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equipment; home electronic appliances; machine tools; personal electronic equipment; and industrial robots. 

“High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-
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“Specific”:  Aircraft; aerospace equipment; submersible repeaters; nuclear reactor control systems; medical equipment or 
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The information in this document is current as of January, 2007. The information is subject to 
change without notice.  For actual design-in, refer to the latest publications of NEC Electronics data 
sheets or data books, etc., for the most up-to-date specifications of NEC Electronics products.  Not 
all products and/or types are available in every country.  Please check with an NEC Electronics sales 
representative for availability and additional information.
No part of this document may be copied or reproduced in any form or by any means without the prior       
written consent of NEC Electronics.  NEC Electronics assumes no responsibility for any errors that may 
appear in this document.
NEC Electronics does not assume any liability for infringement of patents, copyrights or other intellectual 
property rights of third parties by or arising from the use of NEC Electronics products listed in this document 
or any other liability arising from the use of such products.  No license, express, implied or otherwise, is 
granted under any patents, copyrights or other intellectual property rights of NEC Electronics or others.
Descriptions of circuits, software and other related information in this document are provided for illustrative 
purposes in semiconductor product operation and application examples. The incorporation of these 
circuits, software and information in the design of a customer's equipment shall be done under the full 
responsibility of the customer. NEC Electronics assumes no responsibility for any losses incurred by 
customers or third parties arising from the use of these circuits, software and information.
While NEC Electronics endeavors to enhance the quality, reliability and safety of NEC Electronics products, 
customers agree and acknowledge that the possibility of defects thereof cannot be eliminated entirely.  To 
minimize risks of damage to property or injury (including death) to persons arising from defects in NEC 
Electronics products, customers must incorporate sufficient safety measures in their design, such as 
redundancy, fire-containment and anti-failure features.
NEC Electronics products are classified into the following three quality grades: "Standard", "Special" and 
"Specific".  
The "Specific" quality grade applies only to NEC Electronics products developed based on a customer-
designated "quality assurance program" for a specific application.  The recommended applications of an NEC 
Electronics product depend on its quality grade, as indicated below.  Customers must check the quality grade of 
each NEC Electronics product before using it in a particular application. 

The quality grade of NEC Electronics products is "Standard" unless otherwise expressly specified in NEC 
Electronics data sheets or data books, etc.  If customers wish to use NEC Electronics products in applications 
not intended by NEC Electronics, they must contact an NEC Electronics sales representative in advance to 
determine NEC Electronics' willingness to support a given application.

(Note)

•

•

•

•

•

•

M8E  02. 11-1

(1)

(2)

"NEC Electronics" as used in this statement means NEC Electronics Corporation and also includes its 
majority-owned subsidiaries.
"NEC Electronics products" means any product developed or manufactured by or for NEC Electronics (as 
defined above).

Computers, office equipment, communications equipment, test and measurement equipment, audio
and visual equipment, home electronic appliances, machine tools, personal electronic equipment
and industrial robots.
Transportation equipment (automobiles, trains, ships, etc.), traffic control systems, anti-disaster
systems, anti-crime systems, safety equipment and medical equipment (not specifically designed
for life support).
Aircraft, aerospace equipment, submersible repeaters, nuclear reactor control systems, life
support systems and medical equipment for life support, etc.

"Standard":

"Special":

"Specific":
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PREFACE 
 

 

Readers: The PM+ is an integrated development environment platform that enables efficient 

controls of programs running in Windows.   

 This manual is intended for user engineers who wish to develop application systems 

using the PM+ on Windows. 

 

Purpose: This manual explains how to operate PM+ on Windows.   

 For the Windows operations, refer to the function guides provided with the Windows 

OS. 

 

Organization: This manual consists of the following contents: 

 

 • GENERAL 

 • INSTALLATION 

 • STARTING AND EXITING 

 • QUICK TOUR 

 • METHOD OF OPERATION 

 • WINDOW REFERENCE 

 • MESSAGES 

 

How to Read This Manual: It is assumed that the readers of this manual have a general knowledge of 

microcomputers and a basic knowledge of how to operate Windows 98, Windows Me, 

Windows 2000, or Windows XP.  
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Related Documents: When using this manual, also refer to the following documents.   

 Some related documents may be preliminary versions.  Note, however, that whether a 

related document is preliminary is not indicated in this document. 
 

Documents related to 78K0R Microcontroller development tools (User’s Manual) 

 

Document Name Document No. 

Operation U17838E CC78K0R Ver. 1.00 C Compiler 

Language U17837E 

Operation U17836E RA78K0R Ver. 1.00 Assembler Package 

Language U17835E 

SM+ System Simulator Operation U18010E 

PM+ Ver. 6.30 Project Manager This manual 

ID78K0R-QB Ver. 3.20 Integrated Debugger Operation U17839E 
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Documents related to V850 Microcontroller development tools (User’s Manual) 

 

Document Name Document No. 

Operation U17293E 

C Language U17291E 

Assembly Language U17292E 

CA850 Ver. 3.00 C Compiler Package 

Link Directives U17294E 

ID850 Ver. 3.00 Integrated Debugger Operation U17358E 

ID850NW Ver. 3.00, 3.10 Integrated Debugger Operation U17369E 

ID850NWC Ver. 2.51 Integrated Debugger Operation U16525E 

ID850QB Ver. 3.20 Integrated Debugger Operation U17964E 

Operation U17246E SM+ System Simulator 

User Open Interface U17663E 

SM850 Ver. 2.50 System Simulator Operation U16218E 

SM850 Ver. 2.00 or later System Simulator External Part User Open Interface 

Specifications 
U14873E 

Basics U13430E 

Installation U17419E 

Technical U13431E 

RX850 Ver. 3.20 Real-Time OS 

Task Debugger U17420E 

Basics U13773E 

Installation U17421E 

Technical U13772E 

RX850 Pro Ver. 3.20 Real-Time OS 

Task Debugger U17422E 

RD850 Ver. 3.01 Task Debugger U13737E 

AZ850 Ver. 3.30 System Performance Analyzer U17423E 

PG-FP4 Flash Memory Programmer U15260E 

TW850 Ver. 2.00 Performance Analysis Tuning Tool U17241E 

PM+ Ver. 6.30 Project Manager This manual 
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CHAPTER 1   GENERAL

1. 1   Overview
The project manager (PM+) is an integrated development environment platform for NEC Electronics microcontrollers 

(78K0R, 78K0, 78K0S and V850 Microcontrollers).
A series of operations in user program development can be performed from PM+ such as editor startup, builder startup, 

and debugger startup.  

1. 2   Terminology
The terms used for PM+ are defined below.

Figure 1-1 shows the image of the Main window.  

Figure 1-1   Main Window of PM+

Workspace
A "workspace" is the unit which manages the file name of multiple project files. 
PM+ saves the file names of multiple project files into a workspace file (*.prw), and refers to it. 

Project
A "project" is a unit managed by PM+.  It indicates an application system developed under PM+ and its environment.  
PM+ saves the information, such as the source files, target device name, tool options for creating a load module, and 
editor or debugger, to be used for the application system into each project file (*.prj) as "project information" and 
refers to it.  
Build or debug is performed in project units.  Therefore, the project to be built or debugged have to be set as "active 
project" (by selecting the [Project] menu -> [Select Active Project...] ).  

Workspace

Project group
Project
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Project group
Multiple registered projects can be arranged with related projects in a group.  Note that each project to be registered 
in a project group must target a common device (i.e. only one device file can be assigned to a project group).

 IDL file
An IDL file is a file used to save the layer information for PM+ (idea-L information file).

1. 3   Functions and Features
The major functions and features of PM+ are as follows: 

- Managing multiple projects
PM+ can manage multiple project files collectively by using concepts such as workspace and project group.  

- Starting a builder 
PM+ can be used to start tools required for generating application systems (a compiler,structured assembler(only 
78K0 or 78K0S Microcontrollers), assembler, linker, ROM-ization processor necessary for storing programs in 
ROM, and a hex converter). 

- Starting editor 
PM+ can be used to create or modify the source files to be used for a project by the editor function which PM+ pro-
vides. Furthermore, an external editor can also be registered and started form PM+.   

- Starting a debugger 
PM+ can be used to start NEC Electronics debugger or system simulator.  When a correction of the source pro-
gram is issued from the debugger, PM+ displays a specified line of the specified file.  

- Registering and executing external tools 
Other applications the user often uses can be included in the menu of PM+ and started from this menu. 

- Linking with a source management tool 
Version management of the source program in the software development process can be performed more easily by 
linking with a source management tool.  

- Linking with a source analysis tool 
Quality management of the source program in the software development process can be performed more easily by 
linking with a commercial source analysis tool.  

- Correspondence of comments with specification  
PM+ supports a function that is effective in adjustment of specification at the processes of its review (idea proces-
sor function).  This makes it possible to reflect the adjusted contents to a source program as comments.  
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1. 4   Positioning of PM+

Figure 1-2 shows the relationship between the software used for program development and PM+.  

Figure 1-2   Relationship between Software for Program Development and PM+ 
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1. 5   Operating Environments

The following environments are required in order to use PM+.  

[Caution]
The operation of PM+ is not guaranteed in a network environment. Do not use PM+ in a network environment.  

(1)   Host machine 

- CPU: Pentium IITM 400MHz or higher

- Memory: 128 Mbytes or more

- OS: Windows®2000, Windows XP Professional, Windows XP Home Edition

[Caution]
Regardless of which OS is used, higher and the latest Service Pack must be installed.  

(2)   DLL

The following DLL files provided by Microsoft Corp. are required. 

- mfc42.dll V6.0.8665.0 or more (It is provided when PM+ is installed.)

- msvctr.dll V6.1 or more (It is provided when PM+ is installed.)

- ComCtl32.dll V5.81 or more (It is necessary to install in addition to PM+.)

(3)   Related development tools

[78K Microcontrollers]

- Compiler/Assembler:
Compiler:  CC78K0R (Ver.1.00 or later), CC78K0(Ver.4.00 later), CC78K0S(Ver.2.00 later)
Assembler: RA78K0R (Ver.1.00 or later), RA78K0(Ver.4.00 later), RA78K0S(Ver.2.00 later)

- Integrated debugger/System simulator

Integrated debugger: ID78K0R-QB (Ver.3.20 or later)

System simulator: SM+ for 78K0R (Ver.2.20 or later)

- Device File
A device file of target device to be used

- Device Driver Configurator (for 78K Microcontrollers: if necessary)

Applilet®2 (Under development) 

[V850 Microcontrollers]

- Compiler
CA850 (Ver.3.00 or later)

- Integrated debugger/System simulator

Integrated debugger: ID850 (Ver.3.10 or later), ID850NW (Ver.3.10 or later), or ID850QB (Ver.3.10 or later)

System simulator: SM850 (Ver.3.00 or later), or SM+ for V850 (Ver.2.00 or later)

- Device File
A device file of target device to be used

- Performance analysis tuning tool (if necessary) 
TW850 (Ver.2.00 or later)

- Link Directive Generator (if necessary) 
LDG (Ver.1.01 or later)

- eXaminer for system Operation (if necessary) 
XO850 (Ver.3.20 or later)
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1. 6   Files Created/Managed by PM+
The files created and managed by PM+ are as follows.
Refer to the user’s manual of each tool for files created by other tools linked with PM+.

(1)   Workspace file (*.prw)

File in which workspace information is saved.
It is created by selecting the [File] menu -> [New Workspace...], or when an existing project file (*.prj) is opened.
Information such as the project file name registered in the workspace and batch build information is stored in this 
file.

(2)   Project file (*.prj)

File in which project information is saved.
It is created when a project is created (refer to "5. 6. 1  Creating a project file").  Various kinds of information set to 
the project and information such as options set to tools linked with PM+ are saved in this file.

(3)   User environment setting file (*.prk)

File in which information specific to the user, such as window locations and toolbar display information, is saved.
This file is always updated when PM+ is terminated, so this file does not need source management.
If this file is deleted, user-dependant environment settings are cleared.

(4)   Dependency data file (*.sdb)

File in which the dependency with the source file is registered.
Aiming to accelerate the opening of a project, this file is updated when the project is closed. (It is newly created if 
the file does not exist.)

(5)   Function information file (*.fni)

File in which information on the functions included in the source file is registered.
Aiming to accelerate the opening of a project, this file is updated when the project is closed. (It is newly created if 
the file does not exist.)

(6)   Make file (*.mak)

File automatically created at build.
This file is updated during the build after settings such as options have been changed (refer to "5. 6. 10  Exporting 
a make file").

(7)   Log file (*.plg)

File in which the contents of the [OutPut] window are saved.
This file is updated during a build. (It is newly created if the file does not exist.)
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CHAPTER 2   INSTALLATION 

2. 1   Installing PM+ 
PM+ is included with an assembler package (RA78Kx) or a compiler package (CA850).  
When RA78Kx or CA850 are installed, PM+ can be also installed if necessary, as it is supplied in the same package.  
For the details on how to install the assembler package or the compiler package, refer to the user's manual of each tool.  

2. 2   Uninstalling PM+  
To uninstall PM+, start "Add or Remove Programs" ("Add/Remove Programs" in Windows other than Windows XP) on 

the Control Panel of Windows and select the following items.

-  NEC EL PM+ V6.30 

-  NEC EL PM+ V6.30 Documents
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CHAPTER 3   STARTING AND EXITING

3. 1   Starting 
PM+ can be started by either of the following methods.

[When starting PM+ without using parameters]
- Select Windows Start menu -> [Program] -> [NEC Electronics Tools] -> [PM+ V6.30]

- Double-click the existing workspace file (*.prw) (The selected workspace file automatically opens.)

[When starting PM+ using parameters]
- Input the command line as shown below.

[Format]

[Caution]
If a workspace file (*.prw) or project file (*.prj) is specified for the file name, specification of the line number will be 
ignored.

[Example]
pmplus.exe ∆ F:\SRC\CALLTREEVIEW.CPP ∆ -L12

-> "F:\SRC\CALLTREEVIEW.CPP" is loaded to the Edit window and the caret is placed on the 12th line.

pmplus.exe ∆ F:\PRJ\CALLTREE.PRW ∆ -L12 ∆ F:\SRC\CALLTREEVIEW.CPP ∆ -L12
- > "F:\PRJ\CALLTREE.PRW" opens and -L12 is ignored

  "F:\SRC\CALLTREEVIEW.CPP" is loaded to the Edit window and the caret is placed on the 12th line.

[Caution]
Multiple instances of PM+ cannot be started at the same time.  If an attempt is made to start a new PM+ while PM+ is 
already running, the currently running PM+ will be displayed on the forefront.

pmplus.exe ∆ filename1 ∆ -Ln ∆ filename2 ∆ -Ln ∆ filename3 ∆ -Ln             ∆ : space

Line numbers in which the caret is placed 
(n = line number)

File names opened at startup
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The Main window will be displayed after PM+ is started.  

Figure 3-1   Main Window at Starting (When Starting PM+ from Windows Start Menu)

[Caution]
Multiple PM+ cannot be activated.  Therefore, if an attempt is made to start PM+ while PM+ has already run, already-
running PM+ will be displayed on the forefront. 

3. 2   Exiting 
To terminate PM+, select the [File] menu -> [Exit PM+] on the Main window or click the [Close] button.  
For any window that has been edited, a message for confirming whether to save the changes is displayed, then the 

PM+ is terminated. 
Note that PM+ cannot be terminated during build execution. 
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CHAPTER 4   QUICK TOUR

4. 1   Overview
This chapter describes the operation flow from project registration to debugging for first-time users of PM+.

Figure 4-1   Operation Flow until Debugging

Creating Workspace

Setting Options Related to Compilation

Selecting Debugger

Selecting Active Project

Executing Build

Other Settings
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4. 2   Creating Workspace 

The development flow using PM+ begins with the registration of a project.  
In order to register a project, a "workspace" to manage it must be created.  
A workspace can be created using one of the following three methods.  
Refer to the appropriate method in accordance with the environment used.  

(1)   Creating a new workspace 

A new workspace can be created by specifying the necessary project information in order in a wizard format.
[Refer to]: "5. 1. 6  Creating a new workspace"

(2)   Creating a workspace using a project file created by the PM (V3.xx) or PM plus (V5.xx)

In PM+, a workspace can be created by reading a project file or workspace file created by the PM (V3.xx) or PM 
plus (V5.xx).  
[Refer to]: "5. 1. 5  Opening a project file generated by the previous version"

(3)   Creating a workspace using a project file created by a NEC Electronics debugger/simulator

A workspace can be created by using a project file that has been updated the project information for PM+ in a wiz-
ard format.  
[Refer to]: "5. 1. 7  Opening a workspace"

Multiple projects can be registered to one workspace.
[Refer to]: "5. 6. 3  Adding a new project to a workspace"
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4. 3   Setting Options Related to Compilation

Options related to compilation can be set  for each project from the [Tool] menu.  
Refer to the user's manual of the compiler for details of each option.  
To set option individually in source file units, select the appropriate file on the [Project] window and click the right mouse 

button.  When option is set individually, the icon of the source file will change to green on the [Project] window.  

Figure 4-2   Setting Options Related to Compilation

Click the right mouse button after 
selecting the source file (test1.c)

Options are set individually 
per source file (test1.c)

In PM+, individual options related to the compiler can be set for each 
registered source file. 
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4. 4   Selecting Active Project 

In PM+, multiple projects can be registered to one workspace.  
When build is executed, therefore, the project to be built must be pre-specified.  
To specify the active project, select the appropriate project on the [Project] window and click the right mouse button.  

The icon of the project will change from gray to pink when selected as an active project.  
Only an active project is built or debugged.  
[Refer to]: "5. 6. 2  Selecting active project"

Figure 4-3   Selecting Active Project

Click the right mouse button after 
selecting the project (Library). 

The project (Library) is set 
as the active project. 

In PM+, multiple projects can be registered or managed together with 
related projects in a project group.  

Project group name:
Multiple projects can be managed 
(the example shows main, Library). 

Library files, etc. can be registered. 

Specifications, etc. can be freely 
registered.  
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4. 5   Selecting Debugger

Selecting the [Tool] menu -> [Debugger Settings...] displays the [Debugger Settings] dialog box in which the debugger 
to be used can be set.  

In this dialog box, all the NEC Electronics debuggers and simulators that are specified as the tools to be used and their 
versions can be displayed and selected.

After executing build by selecting the [Build] menu -> [Build and Debug], the debugger that is set here starts up automat-
ically and downloads a load module file at the same time to facilitate the debug operation.  

[Refer to]: [Debugger Settings] dialog box, "5. 6. 18  Changing the tools used"

Figure 4-4   Selecting Debugger
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4. 6   Executing Build

selecting the [Build] menu -> [Build and Debug] starts batch processing from build to debug for the active project.  
If build ends correctly, the set debugger starts up automatically and loads the created load module file (if the debugger 

does not have to be started up, execute build by selecting the [Build] menu -> [Build]).  At this time, a make file (*.mak) is 
also created automatically in default condition.  

The messages that are output from the language processing tool during build execution are displayed on the [OutPut] 
window.  At this time, place the caret on the error/warning line that is displayed and double-click the left mouse button to 
open the source file and tag-jump to the relevant error/warning line.  

[Refer to]: "5. 7. 1  Building and debugging"

4. 7   Other Settings
There are many other functions is provided to enable more efficient and smooth execution of the debug operation flow 

using the PM+ platform.  

- Setting the layer rule
[Refer to]: "5. 4. 17  Applying a layer rule"

- Registration of external tools and customization of menu/toolbars
[Refer to]: "5. 8. 5  Registering external tools", "5. 8. 11  Customizing settings"

- Word-based searching in all the source files of the project
[Refer to]: "5. 3. 23  Searching for a character string within a project"

- Setting the tool to be used
[Refer to]: "5. 6. 18  Changing the tools used"
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CHAPTER 5   METHOD OF OPERATION

5. 1   File Management
Operations related to the file handling in PM+ are shown below. 
The operations described in this section are performed using the [File] menu in the Main window.

- Creating a new file

- Opening a existing file

- Inserting a file

- Closing a window

- Opening a project file generated by the previous version

- Creating a new workspace

- Opening a workspace

- Saving a workspace

- Closing a workspace

- Saving a file by overwriting

- Saving a file with a new name

- Saving all files

- Saving all files (Changed files only)

- Saving and closing all files

- Closing all windows

- Closing all windows without saving

- Changing a source file name

- Saving all source files

- Checking printing status

- Printing

- Printing directly

- History of files

- History of workspaces

- Exiting PM+

5. 1. 1   Creating a new file 

Selecting the [File] menu -> [New] opens a new Edit window.  
Up to 64 Edit window can be opened together with the Search result display window and the [OutPut] window.  

5. 1. 2   Opening a existing file

Selecting the [File] menu -> [Open] opens the [Open] dialog box to open a selected file.  

5. 1. 3   Inserting a file 

Selecting the [File] menu -> [Insert file...] opens the [Insert File] dialog box to insert a specified file at the caret position 
in the currently active Edit window.  

The files that can be inserted are "IDL file" and "text file".
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5. 1. 4   Closing a window 

Selecting the [File] menu -> [Close] closes the window being edited.  If the contents of the window has been modified, a 
message for confirming whether to save the changes is displayed.  

Note that if there are any files with read-only having the same name, those files will all be closed.  

5. 1. 5   Opening a project file generated by the previous version 

 Selecting the [File] menu -> [Open Workspace...] opens the [Open Workspace] dialog box to read a project file (*.prj) or  
workspace file (*.prw) that was generated by the previous version, PM (V3.xx) or PM plus (V5.xx).

 At this time, PM+ outputs a message that prompt the user to confirm that PM+ is going to convert the file format into the 
workspace file format of PM+ (V6.xx).  Click the [OK] button; the file format is then automatically converted as follows and 
read.

- Workspace file name (If a project file is read);
"project file name + extension (*.prw)"  

- Project group name (If a project file is read);
"device microcontrollers name" (e.g. V850 Microcontrollers)  

- Project title name (If a project file is read);
If a title setting has been performed with the read file, it remains as its title.  
If no title setting has been performed with the read file, the project file name is set as its title.

- [Select Debugger] information ( Only PM plus (V5.xx));
Deleted

- Version information;
PM+ (V6.xx)

The workspace name can not be renamed.  However, the project group name or the project title name can be renamed 
by clicking the right mouse button on its name in the [Project] window.  

If a project file generated by the other NEC Electronics tools (debugger, etc.) is to be opened, refer to "5. 1. 7  Opening 
a workspace".  

5. 1. 6   Creating a new workspace

Selecting the [File] menu -> [New Workspace...] creates a new workspace.  
To create a new workspace and its project, the [New WorkSpace] wizard is displayed.  
Enter/select the necessary information in each dialog box to be displayed and click the [Next>] button to proceed.  Click-

ing the [Finish] button in the dialog box at the last step ([New WorkSpace - Step 9/9 [Confirmation]] dialog box) causes a 
make file to be created automatically.  refer to "5. 6. 10  Exporting a make file" for details of make file creation.  

5. 1. 7   Opening a workspace 

selecting the [File] menu -> [Open Workspace...] or moving the workspace file using a drag-and-drop operation opens a 
workspace.  

Selecting the [File] menu -> [Open Workspace...] displays the [Open Workspace] dialog box and opens the selected 
workspace file (*.prw) on the [Project] window.  At this time, closes the currently opened workspace file and project file.  If 
a project file (*.prj), rather than a workspace file, is specified, a message is displayed, after which the prw file correspond-
ing to prj is opened.  At this time, the project file (*.prj) of PM (V3.xx) format can also be specified in this dialog box (refer 
to "5. 1. 5  Opening a project file generated by the previous version"). 

If a workspace file is dragged to the main frame, Edit window, Search result display window, [OutPut] window, and 
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[Project] window, opens the workspace file that was dropped.  At this time, closes the currently opened workspace file.  If 
a project file (*.prj), rather than a workspace file, is moved using a drag-and-drop operation, a prw file corresponding to prj 
is opened.

If an attempt is made to open a project file created by another NEC Electronics tool (debugger or simulator), a message 
is displayed, after which the [Project Settings] wizard for updating the project information for PM+ are opened.  

Enter/select the necessary information in each dialog box and click the [Next>] button to proceed.  

5. 1. 8   Saving a workspace 

Selecting the [File] menu -> [Save Workspace] saves the currently opened workspace.  
The information of the opened workspace and the project(s) is saved into the current file. (by overwriting)  

5. 1. 9   Closing a workspace 

Selecting the [File] -> [Close Workspace] closes all the currently opened windows.  At this time, you can select whether 
all the Edit window are to be closed.  After the all windows are closed, "No Workspace" will appear on the [File] tag in the 

[Project] window.  

5. 1. 10   Saving a file by overwriting  

Selecting the [File] menu -> [Save] saves an IDL file or and a source file are saved into the each current file (by overwrit-
ing).  All the current file information including such as the layer information and the location of the caret in the Edit window 
is saved into the IDL file.  

By specifying the [Layer Indent] area ([Tool] menu -> [PM+ Settings...] - [Source File by idl file] tab), the indent by layer 
can be replaced with the Tab code or a single-byte space.  

If the following files are active, the [Save As] dialog box is displayed to specify the name of the file.  

- A newly created Edit window 
A default file name is created based on the contents of the first line in the Edit window.  

- A Search result display window
A default file name is created based on the contents of the first line in the Edit window.  

- An IDL backup file opened by selecting the [Open] menu or the history of the file.  
A default file name is "backup file name.idl".  

- An Edit window in which multiple files were read.  
A default file name is created based on the contents of the first line in the Edit window.  

- A file saved automatically  
A default file name is created based on the contents of the first line in the Edit window.  

- A newly created source file
A default file name is created based on the contents of the first layer line of each file in the Edit window.  

5. 1. 11   Saving a file with a new name

Selecting the [File] menu -> [Save as...] opens the [Save As] dialog box to assign a name to the file being edited and 
save it.  In addition, the indent by the layer and the setting of the Tab can be specified with the [Save Source Files Options] 
dialog box.  
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5. 1. 12   Saving all files 

Selecting the [File] menu -> [Save All] saves all of the files currently open in the Edit window by overwriting.  The con-
tents of the Edit window including those that have not been modified are also saved, however, the contents of the Edit win-
dow, [OutPut] window and Search result display window that have the read-only attribute are not saved.  

Note that [Save All (Changed files Only)] menu item is not displayed in the default condition.  If you wish to make this 
menu item display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 1. 13   Saving all files (Changed files only)

By selecting the [File] menu -> [Save All (Changed files Only)], the contents of all the Edit window currently opened are 
saved by the same file name.  However, the contents of the Edit window including those that have not been modified is not 
saved.  

Note that [Save All (Changed files Only)] menu item is not displayed in the default condition.  If you wish to make this 
menu item display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 1. 14   Saving and closing all files

Selecting the [File] menu -> [Save and Close All] saves all of the files currently open in the Edit window and then closes 
the windows.  The [Project] window and the [OutPut] window are not closed.  

Note that [Save and Close All] menu item is not displayed in the default condition.  If you wish to make this menu item 
display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 1. 15   Closing all windows

Selecting the [File] menu -> [Close All] closes all the Edit window currently open.  If any of the contents have been 
changed, a message for confirming whether the changes are to be saved is displayed.  The [Project] window and the [Out-
Put] window are not closed.  

Note that [Close All] menu item is not displayed in the default condition.  If you wish to make this menu item display, 
specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 1. 16   Closing all windows without saving

Selecting the [File] menu -> [Destroy All] closes all the Edit window currently open without saving.  The [OutPut] window 
and the [Project] window are not closed.  

5. 1. 17   Changing a source file name

Selecting the [File] menu -> [Change Source File Name...] opens the [Change Source File Names] dialog box in which 
the name of the source file can be changed.  

5. 1. 18   Saving all source files 

Selecting the [File] menu -> [Save All Source Files] saves all the source files by overwriting regardless of whether the 
contents are modified or not.  
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5. 1. 19   Checking printing status

Selecting the [File] menu -> [Print Preview] displays the printing status of the active Edit window in the condition set in 
the [Print] dialog box.  

The following functions are supported on the print preview window:  

5. 1. 20   Printing

Selecting the [File] menu -> [Print...] opens the [Print] dialog box to print the contents of the active Edit window.  

5. 1. 21   Printing directly

Selecting the [File] menu -> [Print Direct] prints the contents of the active Edit window without opening the [Print] dialog 
box.  

5. 1. 22   History of files  

The bottom of the [File] menu displays the names of the ten most recently edited/saved files.  Selecting any one of them 
causes the Edit window for that file to open.  

5. 1. 23   History of workspaces

The bottom of the [File] menu displays the names of the ten most recently opened workspace files or project files. 

5. 1. 24   Exiting PM+

To exit the PM+, select the [File] menu -> [Exit PM+] or the [Close] button.  For any window that has been edited, a mes-
sage for confirming whether to save the changes is displayed, then the PM+ is exited.  

Note that PM+ cannot be terminated during build execution. 

[Print] Displays the [Print] dialog box.  

[Next Page] Displays the next screen.   

[Prev Page] Displays the previous screen.  

[One Page/Two Page ] Toggles the display mode between one-page or two-page.  

[Zoom In] Expands the display in two steps.  

[Zoom Out] Reduces the display in two steps.  

[Close] Closes the print preview window.  
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5. 2   Edit Functions
Operations related to editing files in PM+ are shown below. 
The operations described in this section are performed using the [Edit] menu in the Main window.

- Canceling an edit operation

- Canceling an [Undo] operation

- Cutting off character strings

- Copying character strings

- Cutting off character strings (Cut for Append)

- Copying character strings (Copy for Append)

- Copying character strings as a screen image

- Inserting the contents of clipboard

- Inserting the contents of clipboard with specified format

- Deleting character strings

- Deleting a word

- Deleting characters to the end of a word

- Deleting a line

- Deleting character strings to the top of line

- Deleting character strings to the end of line

- Selecting a word at the caret

- Selecting a word to the left of the caret

- Selecting a word to the right of the caret

- Selecting a range to the top of line

- Selecting a range to the end of line

- Selecting entire contents

- Grouping by keyword

- Restoring color of grouping line

- Creating function prototypes

- Inserting a new object

- Setting links for objects

- Object
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5. 2. 1   Canceling an edit operation 

Selecting the [Edit] menu -> [Undo] cancels the effect of an edit operation and restores the previous state.  Up to 1024 
edit operations can be undone.  

[Undo] is effective for the following edit operations:  

- Entry of characters into the Edit window. (The key input is canceled for each one character including the [Tab], 
[Delete], [BackSpace] and [Enter] keys.)  

- [File] -> [Insert file...] 

- [Edit] -> [Cut]

- [Edit] -> [Paste]

- [Edit] -> [Paste Special...]

- [Edit] -> [Delete]

- [Edit] -> [Delete the Line]

- [Edit] -> [Insert New Object...]

- Replacement of a character string using [Find] -> [Replace...] (except [Replace All])

- Copying of lines by dragging of mouse

- Movement of lines by dragging of mouse

- Insertion of a tab character at the beginning of a line

- Deletion of a tab character at the beginning of a line

- [Layer] -> [Promote]

- [Layer] -> [Demote]

5. 2. 2   Canceling an [Undo] operation 

Selecting the [Edit] menu -> [Redo] cancels the effect of an [Undo] operation and restores the previous state.  Up to 
1024 edit operations can be redone.  

[Redo] is effective for the following edit operations:  

- Entry of characters into the Edit window. (The key input is canceled for each one character including the [Tab], 
[Delete], [BackSpace] and [Enter] keys.)  

- [File] -> [Insert file...] 

- [Edit] -> [Cut]

- [Edit] -> [Paste]

- [Edit] -> [Paste Special...]

- [Edit] -> [Delete]

- [Edit] -> [Delete the Line]

- [Edit] -> [Insert New Object...]

- Replacement of a character string using [Find] -> [Replace...] (except [Replace All])

- Copying of lines by dragging of mouse

- Movement of lines by dragging of mouse

- Insertion of a tab character at the beginning of a line

- Deletion of a tab character at the beginning of a line

- [Layer] -> [Promote]

- [Layer] -> [Demote]



CHAPTER 5  METHOD OF OPERATION

User’s Manual  U18416EJ1V0UM 43

5. 2. 3   Cutting off character strings

Selecting the [Edit] menu -> [Cut] sends the character string or lines selected with range selection to the clipboard and 
deletes them from the Edit window.  

If the lines selected with range selection have lower layers, the contents of the lower layer lines will also be sent to the 
clipboard regardless of whether the layers are expanded or collapsed.  

When a character string is cut, the caret position will not be changed.  When lines are cut, the caret will be positioned to 
the beginning of the line following the cut position.  When the last line of a document is cut, the caret will be positioned to 
the end of the new last line.  

5. 2. 4   Copying character strings

Selecting the [Edit] menu -> [Copy] sends the character string or the lines selected with range selection to the clipboard.  
If the lines selected with range selection have lower layers, the contents of the lower layer lines will also be sent to the 

clipboard regardless of whether the layers are expanded or collapsed.  

5. 2. 5   Cutting off character strings (Cut for Append)

Selecting the [Edit] menu -> [Cut for Append] adds the contents of the character strings or the lines selected with range 
selection to the end of the clipboard and deletes them from the Edit window.  This menu item dose not erase the previous 
contents of the clipboard but instead appends the copy portion to the end of the contents of the clipboard.  

If the lines selected with range selection have lower layers, the contents of the lower layer lines will also be sent to the 
clipboard regardless of whether the layers are expanded or collapsed.  

When a character string is cut, the caret position will not be changed.  When lines are cut, the caret will be positioned to 
the beginning of the line following the cut position.  When the last line of a document is cut, the caret will be positioned to 
the end of the new last line.  

Note that [Cut for Append] menu item is not displayed in the default condition.  If you wish to make this menu item dis-
play, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 2. 6   Copying character strings (Copy for Append) 

Selecting the [Edit] menu -> [Copy for Append] adds the contents of the character string or the lines selected with range 
selection to the end of the clipboard.  This menu item dose not erase the previous contents of the clipboard but instead 
appends the copy portion to the end of the contents of the clipboard.  

If the lines selected with range selection have lower layers, the contents of the lower layer lines will also be sent to the 
clipboard regardless of whether the layers are expanded or collapsed.  

Note that [Copy for Append] menu item is not displayed in the default condition.  If you wish to make this menu item dis-
play, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 2. 7   Copying character strings as a screen image 

Selecting the [Edit] menu -> [Image Copy] sends the character string or lines selected with range selection to the clip-
board exactly as they are displayed on the screen (as a screen image).  

When the contents of the lines are sent to the clipboard, no layer information is sent.  Each time the layer is demoted by 
one, a space or Tab code is written.  The code to write can be specified with [Image Copy] on the [Tool] menu -> [PM+ 
Settings...] - [Edit] tab.  Furthermore, the number of the indent characters can be specified with [Indent Characters] on the 
same [Edit] tab.  

If the lines selected with range selection have lower layers, the contents of the lower layer lines that have been col-
lapsed will not be sent to the clipboard.  Note that objects cannot be copied.  
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5. 2. 8   Inserting the contents of clipboard 

Selecting the [Edit] menu -> [Paste] reads the contents of the clipboard and inserts them at the caret position.  At this 
time, the layer information is also inserted.  

When a character string is pasted, the caret will move to the position following the character string in the default condi-
tion.  If, however, [Don't Move Caret as Paste] is selected on the [Edit] tab on the [Option] menu - [PM+ Settings...], the 
caret will not move.  

When lines are pasted, they are inserted to the line above the caret position and the screen is redisplayed without mov-
ing of the caret position.  If, however, the caret is positioned to the top line of the screen or if is not visible on the screen, 
the screen is scrolled and redisplayed so that the caret is positioned to the middle of the screen.  

If you perform [Paste] while performing range selection, the lines selected with range selection will be deleted and the 
contents of the clipboard will be inserted to the position occupied by the lines selected with range selection.  At this time, 
the caret will be positioned to the top of the line following the inserted position.  If, however, the caret is positioned to the 
top line of the screen or if is not visible on the screen, the screen is scrolled and redisplayed so that the caret is positioned 
to the middle of the screen.  

If the first layer line having a lower layer is copied or cut off from the other file and pasted to the first layer of the IDL file 
being edited, the source file name of the copy source is set as is.  If the same source file name exists in the IDL file being 
edited, however, the information of the source file name of the copy source will be deleted.  If an attempt is made to save 
the IDL file being edited in this case, a message prompting you to change the path of the source file name will be dis-
played, then if you will select [Yes] in response to this message, the [Change Source File Names] dialog box will be dis-
played.  In this dialog box, specify the name of the source file to be created from the IDL file being edited.  

5. 2. 9   Inserting the contents of clipboard with specified format

Selecting the [Edit] menu -> [Paste Special...] opens the Paste Special dialog box to select the format in which the con-
tents of the clipboard are to be pasted, and then inserts the contents of the clipboard to the caret position.  In the dialog 
box, the processing depends on MFC (Microsoft® Foundation Class).  

5. 2. 10   Deleting character strings 

Selecting the [Edit] menu -> [Delete] deletes the character string or the lines selected with range selection.  The charac-
ter string or the lines selected with range selection are not sent to the clipboard.  

When a character string is deleted, the caret position will not be changed.  When lines are deleted, the caret will be posi-
tioned to the beginning of the line following the deleted position.  When the last line of a document is deleted, the caret will 
be positioned to the end of the new last line.  

5. 2. 11   Deleting a word

Selecting the [Edit] menu -> [Delete the Word] deletes a single word at the caret position.  The deleted characters are 
not sent to the clipboard.  Refer to the Edit window for definitions of "words".  

Note that [Delete the Word] menu item is not displayed in the default condition.  If you wish to make this menu item dis-
play, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 2. 12   Deleting characters to the end of a word

Selecting the [Edit] menu -> [Delete to End of Word] deletes the portion of the word that is to the right of the caret posi-
tion.  The deleted characters are not sent to the clipboard.  Refer to the Edit window for definitions of "words".  

Note that [Delete to the End of Word] menu item is not displayed in the default condition.  If you wish to make this menu 
item display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  
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5. 2. 13   Deleting a line

Selecting the [Edit] menu -> [Delete the Line] deletes a single line at the caret position.  If multiple lines are selected with 
range selection, [Delete the Line] cannot be selected.  The contents of the deleted line is not sent to the clipboard.  

5. 2. 14   Deleting character strings to the top of line
Selecting the [Edit] menu -> [Delete to the Top of Line] deletes the portion of the line from the caret position to the begin-

ning of the line.  The contents of the deleted line is not sent to the clipboard.  After the portion is deleted, the caret will be 
positioned to the beginning of the line.  

Note that [Delete to the Top of Line] menu item is not displayed in the default condition.  If you wish to make this menu 
item display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 2. 15   Deleting character strings to the end of line
Selecting the [Edit] menu -> [Delete to the End of Line] deletes the portion of the line from the caret position to the end 

of the line.  The contents of the deleted line is not sent to the clipboard.  After the portion is deleted, the caret position will 
not be changed.  

Note that [Delete to the End of Line] menu item is not displayed in the default condition.  If you wish to make this menu 
item display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 2. 16   Selecting a word at the caret 
Selecting the [Edit] menu -> [Select to the Word] selects a word at the caret position.  
Refer to the Edit window for definitions of "words".  
Note that [Select to the Word] menu item is not displayed in the default condition.  If you wish to make this menu item 

display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 2. 17   Selecting a word to the left of the caret
Selecting the [Edit] menu -> [Select to the Top of Word] selects the portion of the word that is to the left of the caret posi-

tion, with range selection. 
Refer to the Edit window for definitions of "words".  
Note that [Select to the Top of Word] menu item is not displayed in the default condition.  If you wish to make this menu 

item display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 2. 18   Selecting a word to the right of the caret
Selecting the [Edit] menu -> [Select to the End of Word] selects the portion of the word that is to the right of the caret 

position, with range selection. 
Refer to the Edit window for definitions of "words".  
Note that [Select to the End of Word] menu item is not displayed in the default condition.  If you wish to make this menu 

item display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 2. 19   Selecting a range to the top of line
Selecting the [Edit] menu -> [Select to the Top of Line] selects the range from the caret position to the beginning of the 

line is selected with range selection.  
Note that [Select to the Top of Line] menu item is not displayed in the default condition.  If you wish to make this menu 

item display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  
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5. 2. 20   Selecting a range to the end of line

Selecting the [Edit] menu -> [Select to the End of Line] selects the range from the caret position to the end of the line 
with range selection.  

Note that [Select to the End of Line] menu item is not displayed in the default condition.  If you wish to make this menu 
item display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 2. 21   Selecting entire contents 

Selecting the [Edit] menu -> [Select All] selects the entire contents of the Edit window.  

5. 2. 22   Grouping by keyword

Selecting the [Edit] menu -> [Grouping be Keyword...] opens the [Grouping by Keyword] dialog box in which the lines 
that contain a specified character string can be collected.  

5. 2. 23   Restoring color of grouping line 

Selecting the [Edit] menu -> [Restore Color of Grouping Lines] restores the color assigned to the lines collected with 
[Grouping by Keyword...].  

5. 2. 24   Creating function prototypes 

Selecting the [Edit] menu -> [Make Function Prototypes...] opens the [Select the way of Function Prototypes] dialog box 
in which a function prototype can be created automatically.  

5. 2. 25   Inserting a new object 

Selecting the [Edit] menu -> [Insert New Object...] opens the Insert Object dialog box to insert a new embedded object.  
In the dialog box, the processing depends on MFC (Microsoft Foundation Class).  

5. 2. 26   Setting links for objects

Selecting the [Edit] menu -> [Link...] opens the Links dialog box to edit link objects, change sources, and cancel links.  In 
the dialog box, the processing depends on MFC (Microsoft Foundation Class).  

5. 2. 27   Object

Selecting the [Edit] menu -> [Object] (the end of the menu list) starts an application and converts a file type for a 
selected object.  

The character strings and functions displayed on this menu item differ depending on the type of the selected object.  



CHAPTER 5  METHOD OF OPERATION

User’s Manual  U18416EJ1V0UM 47

5. 3   Search Functions
Operations related to searching in PM+ are shown below. 
The operations described in this section are performed using the [Search] menu in the Main window.

- Searching for a character string

- Searching for a character string upward

- Searching for a character string downward

- Searching for a word upward

- Searching for a word downward

- Replacing a character string

- Jumping to a specified line

- Jumping to a specified line in a specified source file

- Jumping to a marked line

- Moving the caret to the top of line

- Moving the caret to the end of line

- Moving the caret to the top of file

- Moving the caret to the end of file

- Moving the caret to the index line

- Moving the caret to the top layer

- Moving the caret to the layer line of the same depth upward

- Moving the caret to the layer line of the same depth downward

- Moving the caret to the position before a jump

- Moving the caret to the function definition line

- Searching for matching braces

- Searching for a character string within multiple files

- Replacing a character string within multiple files

- Searching for a character string within a project

- Jumping to a desired line (tag jump)

- Returning from a tag jump

- Continuing a tag jump downward

- Continuing a tag jump upward

- Moving the caret one word to the right

- Moving the caret one word to the left

- Moving the caret up by one line

- Moving the caret down by one line

- Moving the caret one character to the right

- Moving the caret one character to the left

- Making the search character string specification combo box active

5. 3. 1   Searching for a character string 

Selecting the [Find] menu -> [Find...] opens [Find String] dialog box to search for a character string.  
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5. 3. 2   Searching for a character string upward

Selecting the [Find] menu -> [Find Upward] searches for a specified character string in the upward direction (toward the 
beginning of the text).  

If you have not specified a character string to search for, the [Find String] dialog box will be opened.  
If [Don't Stop Finding at Top Line/End Line] is selected on the [Tool] menu -> [PM+ Settings...] - [Find/Replace] tab, a 

message confirming whether to continue the search is output once the search to the top line is completed.  If this check 
box is not selected, it terminates after searching to the top line.  

Note that [Find Upward] menu item is not displayed in the default condition.  If you wish to make this menu item display, 
specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 3. 3   Searching for a character string downward

Selecting the [Find] menu -> [Find Downward] searches for a specified character string in the downward direction 
(toward the end of the text).  

If you have not specified a character string to search for, the [Find String] dialog box will be opened.  
If [Don't Stop Finding at Top Line/End Line] is selected on the [Tool] menu -> [PM+ Settings...] - [Find/Replace] tab, a 

message confirming whether to continue the search is output once the search to the end line is completed.  If this check 
box is not selected, it terminates after searching to the end line.  

Note that [Find Downward] menu item is not displayed in the default condition.  If you wish to make this menu item dis-
play, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 3. 4   Searching for a word upward 

Selecting the [Find] menu -> [Find the Word Upward] searches for the word at the caret position in the upward direction.  
If [Register String for Direct Search as a Candidate of further Finding] is selected on the [Tool] menu -> [PM+ Settings...] 

- [Find/Replace] tab, the word at the caret position will be stored as a search string, and included in the search string his-
tory in the [Find String] dialog box.  

If this check box is not selected, the word will not be stored as a search string.  
Note that [Find the Word Upward] menu item is not displayed in the default condition.  If you wish to make this menu 

item display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 3. 5   Searching for a word downward 

Selecting the [Find] menu -> [Find the Word Downward] searches for the word at the caret position in the downward 
direction.  

If [Register String for Direct Search as a Candidate of further Finding] is selected on the [Tool] menu -> [PM+ Settings...] 
- [Find/Replace] tab, the word at the caret position will be stored as a search string, and included in the search string his-
tory in the [Find String] dialog box.  

If this check box is not selected, the word will not be stored as a search string.  
Note that [Find the Word Downward] menu item is not displayed in the default condition.  If you wish to make this menu 

item display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 3. 6   Replacing a character string 

Selecting the [Find] menu -> [Replace...] opens [Replace String] dialog box to replace a character string.  
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5. 3. 7   Jumping to a specified line
Selecting the [Find] menu -> [To a Specific Line...] opens [Jump to Specified Line] dialog box to jump to a specified des-

tination line number.  

5. 3. 8   Jumping to a specified line in a specified source file
Selecting the [Find] menu -> [To the Specific Line in the Source file...] opens [Jump to Specified Line in the Source file] 

dialog box to jump to a specified destination line number in a specified source file.  
Note that [To the Specific Line in the Source file...] menu item is not displayed in the default condition.  If you wish to 

make this menu item display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 3. 9   Jumping to a marked line
Selecting the [Find] menu -> [Mark Jump...] opens [Mark Jump] dialog box to register the current caret position as a 

mark, or to jump to a marked line.  

5. 3. 10   Moving the caret to the top of line
Selecting the [Find] menu -> [To the Top of Line] moves the caret to the top of the line to which the caret is currently 

positioned.  

5. 3. 11   Moving the caret to the end of line
Selecting the [Find] menu -> [To the End of Line] moves the caret to the end of the line to which the caret is currently 

positioned.  

5. 3. 12   Moving the caret to the top of file
Selecting the [Find] menu -> [To the Top of File] moves the caret to the top of the top line (the top layer line) of a file.  
When [Release Range Selected Before Jump] is selected on the [Tool] menu -> [PM+ Settings...] - [Edit] tab, if range 

selection has been performed, the selected range is released and the caret moves to the top of the top line.  When this 
check box is not selected, if range selection has been performed, the range from the position where range selection 
started to the top line is re-selected.  If, however, a layer higher than that of the line where range selection started exists 
between the range selection start position and the top line, the range up to the line immediately before the line with that 
higher layer is re-selected.  

5. 3. 13   Moving the caret to the end of file
Selecting the [Find] menu -> [To the End of File] moves the caret to the end of the last line of a file.  
When [Release Range Selected Before Jump] is selected on the [Tool] menu -> [PM+ Settings...] - [Edit] tab, if range 

selection has been performed, the selected range is released and the caret moves to the end of the last line.  When this 
check box is not selected, if range selection has been performed, the range from the position where range selection 
started to the last line is re-selected.  If, however, a layer higher than that of the line where range selection started exists 
between the range selection start position and the last line, the range immediately before that higher layer line is re-
selected.  
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5. 3. 14   Moving the caret to the index line

Selecting the [Find] menu -> [To the Index Line] moves the caret to the top of the index line at the current caret position 
(line with a layer higher by one).  

When [Release Range Selected Before Jump] is selected on the [Tool] menu -> [PM+ Settings...] - [Edit] tab, if range 
selection has been performed in the Edit window, the selected range is released and the caret moves to the top of the 
index line.  When this check box is not selected, if range selection has been performed in the Edit window, the range from 
the position where range selection started to the index line is re-selected.  If, however, a layer higher than that of the line 
where the range selection started exists between the range selection start position and the index line, the range up to the 
line immediately before the index line is re-selected because that higher layer cannot be selected by range selection.

5. 3. 15   Moving the caret to the top layer

Selecting the [Find] menu -> [To the Top Layer at caret] moves the caret to the top layer line at the caret position.  
When [Release Range Selected Before Jump] is selected on the [Tool] menu -> [PM+ Settings...] - [Edit] tab, if range 

selection has been performed in the Edit window, the selected range is released and the caret moves to the top layer at 
the caret position.  If, however, a layer higher than that of the line where range selection started exists between the range 
selection start position and the top layer at the caret position, the range immediately before that higher layer line is re-
selected.  

5. 3. 16   Moving the caret to the layer line of the same depth upward

Selecting the [Find] menu -> [Same Layer Line Up] moves the caret to the layer line of the same depth at a position one 
line above the caret (in the upward direction).  

if range selection has been performed in the Edit window, the selected range is released and then the caret moves 
regardless of whether [Release Range Selected Before Jump] is selected on the [Tool] menu -> [PM+ Settings...] - [Edit] 
tab.

Note that [Same Layer Line Up] menu item is not displayed in the default condition.  If you wish to make this menu item 
display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 3. 17   Moving the caret to the layer line of the same depth downward

Selecting the [Find] menu -> [Same Layer Line Down] moves the caret to the layer line of the same depth at a position 
one line below the caret (in the downward direction).  

if range selection has been performed in the Edit window, the selected range is released and then the caret moves 
regardless of whether [Release Range Selected Before Jump] is selected on the [Tool] menu -> [PM+ Settings...] - [Edit] 
tab.

Note that [Same Layer Line Down] menu item is not displayed in the default condition.  If you wish to make this menu 
item display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 3. 18   Moving the caret to the position before a jump

Selecting the [Find] menu -> [Back Jump] moves the caret back to the position immediately before the previous jump.  
This menu item becomes valid if the following jump is performed:  

- [Mark Jump]

- [To the Specific Line...]

- [To the Specific Line in the Source file...]

- [To the Top of File]

- [To the Index Line]
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- [To the Top Layer at caret]

- [To the End of File]

- [To the Function Definition]

- [To the Matching Brace]

- Jump from [Function List...] of the [View] menu

- Jump from [Layer List...] of the [View] menu

- [Some Layer Line Up]

- [Some Layer Line Down]

if range selection has been performed in the Edit window, the selected range is released and then the caret moves 
regardless of whether [Release Range Selected Before Jump] is selected on the [Tool] menu -> [PM+ Settings...] - [Edit] 
tab.

Note that [Back Jump] menu item is not displayed in the default condition.  If you wish to make this menu item display, 
specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 3. 19   Moving the caret to the function definition line

Selecting the [Find] menu -> [To the Function Definition] moves the caret to the definition line of the function name that 
is at the current caret position, or is selected with range selection.  Specification except for a function cannot be per-
formed.  

If a project is opened, it searches for the definition line in all the files registered with the project.  If a project is not 
opened, it searches for the definition line within all the files open in the active Edit window.  

5. 3. 20   Searching for matching braces  

Selecting the [Find] menu -> [To the Matching Brace] searches for the matching brace that at the caret position and 
moves the caret to that brace in the Edit window.  PM+ can search for the following three types of braces: ( ), { }, and [ ].  If 
no matching brace can be found, the caret position does not move.  Any braces in comments are ignored.  

If range selection has been performed in the Edit window, the selected range is released and then the caret moves regard-
less of whether [Release Range Selected Before Jump] is selected on the [Tool] menu -> [PM+ Settings...] - [Edit] tab.

[Example]

The caret position is alternately moved to the matching 
brace by the input of the [Ctrl] + [L] key combination. 

The matching brace:No.1

The matching brace:No.1The matching brace:No.3

The matching brace:No.3 The matching brace:No.2

The matching brace:No.2
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5. 3. 21   Searching for a character string within multiple files 

Selecting the [Find] menu -> [Find in Files...] opens [Find in Files] dialog box to search for a character string within mul-
tiple files in a specified folder.  

5. 3. 22   Replacing a character string within multiple files  

Selecting the [Find] menu -> [Replace in Files...] opens [Replace in Files] dialog box to replace a character string within 
multiple files in a specified folder.  

When [Replace in Files...] is executed, the History of Replace in files window is opened to show the file history message 
of the replacement in files.  The message begins with the search key, replacement character string, file type, and 
searched folder.  The body of the history contains the name of the searched files, number of the lines for which the 
replacement was performed, source file names (where applicable), and the contents of the lines before the replacement.  

Figure 5-1   [History of Replace in files] Window

Table 5-1 shows the messages on the History of Replace in files window.  

Table 5-1   Messages on the History of Replace in files Window 

Massages Description

The folder of xxx is invalid. The specified folder is invalid.  

The extension of xxx is invalid. The extension of the specified file is invalid.  

The System File of xxx is invalid. An attempt was made to replace in a system file.

The Hidden File of xxx is invalid. An attempt was made to replace in a hidden file.

The Read Only File of xxx is invalid. The replacement cannot be performed in the specified file because of a 
read-only attribute.  

The Binary File of xxx is invalid. The replacement cannot be performed in the specified file because of a 
binary file.  

File xxx was Replaced. 
Replaced: xxx/Found: yyy

The replacement and saving were performed in the specified file. 
xxx: the number of the replacement  
yyy: the number of the detection

File xxx was closed. 
Found: xxx

The specified file was closed.  
xxx: the number of the detected search character strings

Displays the search conditions.

Displays the names of search files, numbers of the lines for which 
the replacement was performed, source file names (where applica-
ble), and the contents of the lines before the replacement.

Displays the number of search files.
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5. 3. 23   Searching for a character string within a project

Selecting the [Find] menu -> [Find in Project] searches for a character string to which the caret is positioned, or selected 
with range selection, within all of the source files registered to a project.  

The search result are displayed in the Search result display window to be newly opened.  

- This menu item is effective when a project file is open.  

- In the case of a search for a character string at the caret position, this menu item cannot be selected if the caret is 
positioned to a character other than an alphanumeric character or "_".  In the case of a search for a character string 
selected with range selection, this menu item cannot be selected if lines are selected with range selection.  

- Up to 5,119 characters are displayed as the search results in the format of "file-name (number-of-the-line-on-which-
the-character-string-is found) contents-of-the line-on-which- character-string-is-found".  Note that 5120 or more char-
acter cannot be displayed.  

- The search can be interrupted by pressing the [Esc] key.  

- The search conditions are as specified in the [Find in Files] dialog box.  Of the conditions that can be set in the [Find 
in Files] dialog box, only the following items are effective for [Find in Project].  

- [Match Case]

- [Match Whole Word Only]

- [Show File Names]

5. 3. 24   Jumping to a desired line (tag jump)

If a file name and a line number are displayed on the line to which the caret is positioned, selecting the [Find] menu -> 
[Tag Jump] opens the file and jumps to the desired line.  

This makes it possible to jump from an error message displayed during a build to the corresponding error line in the 
source file.  

- A tag jump can be performed only in the format of "file-name delimiter line-number".  The following four characters 
are handled as delimiters: 

- Single-byte space character 

- Tab character

The using file xxx is skipped. The specified file was skipped because it was under editing.  
When the message whether the search will be performed in a file under 
editing is displayed, the above message is displayed after selecting the 
[No] button.  

The search string was not found into the 
using file xxx.

The search character string was not detected in the specified file under 
editing.  

The processing of using file xxx was 
canceled. 
Found: xxx

Search of the specified file currently being edited was stopped. 
xxx: the number of the detected search character strings

The using file xxx was replaced. 
Replaced: xxx/Found: yyy 

The replacement was performed in the specified file under editing.  
Replaced: the number of the replaced character strings 
xxx: the number of the detected search character strings

The using file xxx was searched. 
Found: xxx

The searching was performed in the specified file under editing.  When 
the searching was performed to the end of the file under editing, this mes-
sage is displayed after selecting the [Find Next] button.  
xxx: the number of the detected search character strings  

Massages Description
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- Parentheses "(" and ")"

- If the file name exceeds 260 single-byte characters, this is regarded as a tag jump format error, and a jump cannot 
be performed.  

- A file name containing any of the following symbols is not regarded as being a file name, and jump cannot be per-
formed.  

/, ;, *, ?, ", <, >, |

- If the line number dose not consist of single-byte digits, the caret will be positioned to the top line of the jump desti-
nation file. 

- If the jump destination line is in a collapsed layer, that layer will be expanded before a jump.  

- If [Select a String between Double (")/Single (') Quotations as Tag Jump] is selected on the [Tool] menu -> [PM+ Set-
tings...] - [Edit] tab, and a character string enclosed in " " or ' ' exists on the line from which a jump is to be per-
formed, PM+ searches for the character string in the jump destination line, and the character string is selected with 
range selection.  If multiple occurrences of the character string are found, the first occurrence is selected with range 
selection.  

- If the jump destination file has already been opened in an Edit window, and range selection has been performed in 
the window, the selected range will be released when a jump is performed.  

- When a tag jump is performed, if the IDL file from which the source file was created cannot be found, a message is 
displayed.  Clicking [OK] button in the message dialog box opens the Select IDL File dialog box, so that the IDL file 
or source file to be opened can be selected.  

5. 3. 25   Returning from a tag jump 

After a tag jump has been performed, selecting the [Find] menu -> [To the Tag File] returns from the tag jump destina-
tion to the window from which the tag jump was performed.  If the corresponding line in the window from which the tag 
jump was performed cannot be found, a jump is performed to the top line of the window from which the tag jump was per-
formed.  

5. 3. 26   Continuing a tag jump downward

Once a tag jump has been performed, selecting the [Find] menu -> [Next Tag Jump] continues the search for the line in 
tag jump format in the window from which the tag jump has been performed, in the downward direction, and performs a 
tag jump to the next occurrence.  On the display, it is not possible to return to the window from which a tag jump is per-
formed.  

5. 3. 27   Continuing a tag jump upward

Once a tag jump has been performed, selecting the [Find] menu -> [Next Tag Jump Upward] continues the search for 
the line in a tag jump format in the window from which the tag jump has been performed, in the upward direction, and per-
forms a tag jump to the next occurrence.   On the display, it is not possible to return to the window from which a tag jump 
is performed.  

Note that [Next Tag Jump Upward] menu item is not displayed in the default condition.  If you wish to make this menu 
item display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  
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5. 3. 28   Moving the caret one word to the right  

Selecting the [Find] menu -> [One Word Right] moves the caret one word to the right.  If the caret is positioned to the 
right end of a line, the caret dose not move.  

The definitions of "words" are as follows:  

- Consecutive single-byte alphanumeric characters and underscores  

- Consecutive characters other than the above (excluding spaces and tabs)

When [Release Range Selected Before Jump] is selected on the [Tool] menu -> [PM+ Settings...] - [Edit] tab, if range 
selection has been performed, the selected range is released and the caret moves one word to the right.  When this check 
box is not selected, if range selection has been performed, the caret moves one word to the right, and the range from the 
position where range selection started to the new caret position is re-selected.  If lines have been selected with range 
selection, nothing is performed.  

Note that [One Word Right] menu item is not displayed in the default condition.  If you wish to make this menu item dis-
play, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 3. 29   Moving the caret one word to the left  

Selecting the [Find] menu -> [One Word Left] moves the caret one word to the left.  If the caret is positioned to the left 
end of a line, the caret dose not move.  

The definitions of "words" are as follows:  

- Consecutive single-byte alphanumeric characters and underscores  

- Consecutive characters other than the above (excluding spaces and tabs)

When [Release Range Selected Before Jump] is selected on the [Tool] menu -> [PM+ Settings...] - [Edit] tab, if range 
selection has been performed in the Edit window, the selected range is released and the caret moves one word to the left.  
When this check box is not selected, if range selection has been performed in the Edit window, the caret moves one word 
to the left, and the range from the position where range selection started to the new caret position is re-selected.  If lines 
have been selected with range selection, nothing is performed.  

Note that [One Word Left] menu item is not displayed in the default condition.  If you wish to make this menu item dis-
play, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 3. 30   Moving the caret up by one line  

Selecting the [Find] menu -> [One Line Up] moves the caret up by one line.  
If range selection has been performed in the Edit window, the selected range is released and the caret moves regard-

less of whether [Release Range Selected Before Jump] is selected on the [Tool] menu -> [PM+ Settings...] - [Edit] tab.  
Note that [One Line Up] menu item is not displayed in the default condition.  If you wish to make this menu item display, 

specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 3. 31   Moving the caret down by one line  

Selecting the [Find] menu -> [One Line Down] moves the caret down by one line.  
If range selection has been performed in the Edit window, the selected range is released and the caret moves regard-

less of whether [Release Range Selected Before Jump] is selected on the [Tool] menu -> [PM+ Settings...] - [Edit] tab.  
Note that [One Line Down] menu item is not displayed in the default condition.  If you wish to make this menu item dis-

play, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  
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5. 3. 32   Moving the caret one character to the right  

Selecting the [Find] menu -> [One Character Right] moves the caret one character to the right.  
If range selection has been performed in the Edit window, the selected range is released and the caret moves regard-

less of whether [Release Range Selected Before Jump] is selected on the [Tool] menu -> [PM+ Settings...] - [Edit] tab.  
Note that [One Character Right] menu item is not displayed in the default condition.  If you wish to make this menu item 

display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 3. 33   Moving the caret one character to the left  

Selecting the [Find] menu -> [One Character Left] moves the caret one character to the left.  
If range selection has been performed in the Edit window, the selected range is released and the caret moves regard-

less of whether [Release Range Selected Before Jump] is selected on the [Tool] menu -> [PM+ Settings...] - [Edit] tab.  
Note that [One Character Left] menu item is not displayed in the default condition.  If you wish to make this menu item 

display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 3. 34   Making the search character string specification combo box active

selecting the [Find] menu -> [Direct Search] makes the Search Character String Specification combo box of the toolbar 
active.  After directly inputting the character string to be searched, press the [Enter] key to search the specified character 
string in the currently active Edit window.  

Note that [Direct Search] menu item is not displayed in the default condition.  If you wish to make this menu item display, 
specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  
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5. 4   Layer Management
Operations related to layers in PM+ are shown below. 
The operations described in this section are performed using the [Layer] menu in the Main window.

- Promoting layers

- Demoting layers

- Expanding or collapsing one of the lower layers

- Expanding one of the lower layers

- Collapsing one of the lower layers

- Expanding all of the lower layers

- Expanding all of the layers

- Collapsing all of the layers

- Expanding a specified number of layers

- Collapsing a specified number of layers

- Displaying the top layer only

- Displaying the first and second layers

- Displaying the first to third layers

- Displaying the first to fourth layers

- Displaying the first to fifth layers

- Collapsing a layer at the caret

- Applying a layer rule

5. 4. 1   Promoting layers 

Selecting the [Layer] menu -> [Promote] promotes the layer of the line to which the caret is positioned or the line 
selected with range selection, by one, as well as the layers of its lower layer lines, if any.  

Figure 5-2   Promoting Layers 

Select the [Layer] menu -> [Promote]. 

If a line without lower layers, the layer mark at the top of the line is changed to the 
"Line with Lower Layer" mark.  The layer mark can be specified with the [Layer 
Mark at Top of Line] area on the [Tool] menu -> [PM Setting...] - [Layer] tab.  
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5. 4. 2   Demoting layers 

Selecting the [Layer] menu -> [Demote] demotes the layer of the line to which the caret is positioned or the line selected 
with range selection, by one, as well as the layers of its lower layer lines, if any.  

Figure 5-3   Demoting Layers 

5. 4. 3   Expanding or collapsing one of the lower layers

Selecting the [Layer] menu -> [Expand/Collapse] expands one of the lower layers of the line to which the caret is posi-
tioned or the line selected with range selection if it is collapsed, and collapses it if expanded.  

When a lower layer is expanded, if not all of the lines with the expanded lower layer can be displayed, the screen will be 
scrolled so that the caret line is positioned to the top of the screen.  

5. 4. 4   Expanding one of the lower layers 

Selecting the [Layer] menu -> [Expand] expands one of the lower layers of the line to which the caret is positioned or the 
line selected with range selection.  

When a lower layer is expanded, if not all of the lines with the expanded lower layer can be displayed, the screen will be 
scrolled so that the caret line is positioned to the top of the screen.  

Note that [Expand] menu item is not displayed in the default condition.  If you wish to make this menu item display, 
specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

Figure 5-4   Expanding One of the Lower Layers

Select the [Layer] menu -> [Demote]. 

If a line with lower layers, the layer mark at the top of the line is changed to the 
"Line with Lower Layer" mark.  The layer mark can be specified with the [Layer 
Mark at Top of Line] area on the [Tool] menu -> [PM Setting...] - [Layer] tab.  

Select the [Layer] menu -> [Expand]. 
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5. 4. 5   Collapsing one of the lower layers 

Selecting the [Layer] menu -> [Collapse] collapses one of the lower layers of the line to which the caret is positioned or 
the line selected with range selection.  

Note that [Collapse] menu item is not displayed in the default condition.  If you wish to make this menu item display, 
specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

Figure 5-5   Collapsing One of the Lower Layers 

5. 4. 6   Expanding all of the lower layers 

Selecting the [Layer] menu -> [Expand All Lower Layers] expands all of the lower layers of the line to which the caret is 
positioned or the line selected with range selection.  

When a lower layer is expanded, if not all of the lines with the expanded lower layer can be displayed, the screen will be 
scrolled so that the caret line is positioned to the top of the screen.  

Figure 5-6   Expanding All of the Lower Layers 

5. 4. 7   Expanding all of the layers

Selecting the [Layer] menu -> [Expand All] expands all of the layers in the active Edit window.  

5. 4. 8   Collapsing all of the layers 

Selecting the [Layer] menu -> [Collapse All] collapses all of the layers in the active Edit window.  If the caret is posi-
tioned to a collapsed layer, it will be moved to the top layer.  

Select the [Layer] menu -> [Collapse]. 

Select the [Layer] menu -> [Expand All Lower Layers]. 
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5. 4. 9   Expanding a specified number of layers 

Selecting the [Layer] menu -> [Expand the Specific Layer...] opens the [Expand to Specified Layer] dialog box to expand 
a specified number of layers.  

A value within the range of 1 to 127 can be specified in this dialog box.  The last setting is displayed in the default con-
dition.  When this value is specified for the first time, 127 is displayed.  

5. 4. 10   Collapsing a specified number of layers

Selecting the [Layer] menu -> [Collapse the Specific Layer...] opens the [Collapse to Specified Layer] dialog box to col-
lapse a specified number of layers.  

A value within the range of 1 to 127 can be specified in this dialog box.  The last setting is displayed in the default con-
dition.  When this value is specified for the first time, 1 is displayed.  

5. 4. 11   Displaying the top layer only

Selecting the [Layer] menu -> [Shown Index 1] collapses lower layers and displays the top layer only.  
If the caret is positioned to a layer other than the top layer, it will be  positioned to the top layer.  
Note that [Show Index 1] menu item is not displayed in the default condition.  If you wish to make this menu item display, 

specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 4. 12   Displaying the first and second layers

Selecting the [Layer] menu -> [Shown Index 2] collapses the third and subsequent layers and displays the first and sec-
ond layers.  

If the caret is positioned to a layer below the second layer, it will be  positioned to the second layer.  
Note that [Show Index 2] menu item is not displayed in the default condition.  If you wish to make this menu item display, 

specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 4. 13   Displaying the first to third layers 

Selecting the [Layer] menu -> [Shown Index 3] collapses the fourth and subsequent layers and displays the first to third 
layers.  

If the caret is positioned to a layer below the third layer, it will be positioned to the third layer.  
Note that [Show Index 3] menu item is not displayed in the default condition.  If you wish to make this menu item display, 

specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 4. 14   Displaying the first to fourth layers  

Selecting the [Layer] menu -> [Shown Index 4] collapses the fifth and subsequent layers and displays the first to fourth 
layers.  

If the caret is positioned to a layer below the fourth layer, it will be positioned to the fourth layer.  
Note that [Show Index 4] menu item is not displayed in the default condition.  If you wish to make this menu item display, 

specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  
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5. 4. 15   Displaying the first to fifth layers  

Selecting the [Layer] menu -> [Shown Index 5] collapses the sixth and subsequent layers and displays the first to fifth 
layers.  

If the caret is positioned to a layer below the fifth layer, it will be  positioned to the fifth layer.  
Note that [Show Index 5] menu item is not displayed in the default condition.  If you wish to make this menu item display, 

specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 4. 16   Collapsing a layer at the caret 

Selecting the [Layer] menu -> [Collapse This Layer] collapses the layer of the line to which the caret positioned.  If the 
caret line has lower layers and these lower layers are expanded, the lower layers will also be collapsed.  

5. 4. 17   Applying a layer rule

Selecting the [Layer] menu -> [Apply Layer Rule...] opens the [Set Layer Rule] dialog box in which a layer rule can be 
applied to the contents of the Edit window.  
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5. 5   Display Functions
Operations related to display in PM+ are shown below. 
The operations described in this section are performed using the [Display] menu in the Main window.

- Displaying a list of functions

- Displaying a list of layers

- Displaying the standard bar

- Displaying the build bar

- Displaying the option bar

- Displaying the external tool bar

- Displaying the status bar

- Displaying the [Project] window

- Displaying the [OutPut] window

- Displaying an object as contents or icon

- Displaying all objects as contents

- Displaying all objects as icons

5. 5. 1   Displaying a list of functions 

Selecting the [View] menu -> [Function List...] opens the [Function List] dialog box to list the functions of the file dis-
played in the active Edit window.  The list of functions can be saved in the TEXT or CSV format with the [Save the Func-
tion List] dialog box.  

5. 5. 2   Displaying a list of layers 

Selecting the [View] menu -> [Layer List...] opens the [Layer List] dialog box to list the layers of the file displayed in the 
active Edit window.  

5. 5. 3   Displaying the standard bar 

Selecting the [View] menu -> [Standard Bar] toggles the standard bar between on and off.  

5. 5. 4   Displaying the build bar 

Selecting the [View] menu -> [Build Bar] toggles the build bar between on and off.  

5. 5. 5   Displaying the option bar 

Selecting the [View] menu -> [Option Bar] toggles the option bar between on and off.  

5. 5. 6   Displaying the external tool bar 

Selecting the [View] menu -> [Ex-tool Bar] toggles the external tool bar between on and off.  
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5. 5. 7   Displaying the status bar 

Selecting the [View] menu -> [Status Bar] toggles the status bar between on and off.  

5. 5. 8   Displaying the [Project] window  

Selecting the [View] menu -> [Project Window] toggles the [Project] window between on and off.  

5. 5. 9   Displaying the [OutPut] window  

Selecting the [View] menu -> [Output Window] toggles the [OutPut] window between on and off.  

5. 5. 10   Displaying an object as contents or icon

Selecting the [View] menu -> [Display Object as Content]/[Display Object as Icon] toggles the display format of an 
embedded object between contents and icon.  

When an object displayed as contents is selected, this menu item is displayed as [Display Object as Icon].  Selecting 
this menu item causes the object to be displayed as an icon.  

When an object displayed as an icon is selected, this menu item is displayed as [Display Object as Content].  Selecting 
this menu item causes the object to be displayed as contents.  

5. 5. 11   Displaying all objects as contents 

selecting the [View] menu -> [Display All Object as Content] displays all the objects in the currently active Edit window 
as contents.  

5. 5. 12   Displaying all objects as icons

selecting the [View] menu -> [Display All Object as Icons] displays all the objects in the currently active Edit window as 
icons.  
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5. 6   Project Management
Operations related to projects in PM+ are shown below. 
The operations described in this section are performed using the [File] menu or [Project] menu in the Main window, or 

the right-click menus on the [Project] window.

- Creating a project file

- Selecting active project

- Adding a new project to a workspace

- Inserting a project into a workspace

- CVS update

- CVS commit

- CVS log

- CVS status

- CVS comparison

- Exporting a make file

- Setting project information

- Adding a source file

- Adding a project-related file

- Adding other files

- Making the active project selection combo box active

- Changing a project group name

- Changing a project title

- Changing the tools used

- Moving a project

5. 6. 1   Creating a project file 

Up to 128 source projects can be registered per workspace.  

[ When registering a project to a new workspace ]
A project file can be created using one of the following three methods. Refer to the appropriate method when creating 
the workspace.  

- Creating a new project file 
A new workspace can be created by specifying the necessary project information in order in a wizard format. 
Refer to: "5. 1. 6  Creating a new workspace"

- Creating a workspace using a project file created by the PM(V3.xx)
In PM+, a workspace can be created by reading a project file created by the PM(V3.xx).  
Refer to: "5. 1. 5  Opening a project file generated by the previous version"

- Creating a workspace using a project file created by an NEC Electronics debugger/simulator
A workspace can be created by using a project file that has been updated the project information for PM+ in a 
wizard format.   
Refer to: "5. 1. 7  Opening a workspace"

[ When registering a project to an existing workspace ]
- Creating a new project file

Refer to: "5. 6. 3  Adding a new project to a workspace" 
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5. 6. 2   Selecting active project 

Selecting the [Project] menu -> [Select Active Project...] displays the [Select Active Project] dialog box in which the 
active project can be selected.  

The active project means the project to be built or debugged.  

5. 6. 3   Adding a new project to a workspace

Selecting the [Project] menu -> [Add New Project...] can be added a new project to a workspace.  
A new project can also be added by selecting a project group on the [Project] window, clicking the right mouse button, 

and selecting [Add New Project...].  
In order to add a new project to the workspace currently open, the [Add New Project] wizard is displayed.  
Enter/select the necessary information in each dialog box and click the [Next>] button to proceed.  Clicking the [Finish] 

button in the dialog box at the last step ([Add New Project - Step 9/9 [Confirmation]] dialog box) causes a make file to be 
created automatically.  Refer to "5. 6. 10  Exporting a make file" for details of make file creation.  

5. 6. 4   Inserting a project into a workspace

Selecting the [Project] menu -> [Insert Project...] opens [Insert Project] dialog box to insert an existing project into the 
project group.  

5. 6. 5   CVS update

Selecting the [Project] menu -> [CVS Update...] allows the CVS update command to be executed for the selected file 
and a file registered in the repository to be acquired.  

The following operations must be performed before executing this menu item.  

- Set the folder that includes cvs.exe using the PATH variable of Windows.  

- Set the repository of CVS.  

- If the CVS server is being used, log onto the server.  

5. 6. 6   CVS commit

Selecting the [Project] menu -> [CVS commit...] executes the CVS commit command for the selected file and reflects 
the file in the repository.  

The following operations must be performed before executing this menu item.  

- Set the folder that includes cvs.exe using the PATH variable of Windows.  

- Set the repository of CVS.  

- If the CVS server is being used, log onto the server.  

5. 6. 7   CVS log

Selecting the [Project] menu -> [CVS Log...] executes the CVS log command for the selected file and displays the log 
contents of the file on the [OutPut] window.  

The following operations must be performed before executing this menu item.  

- Set the folder that includes cvs.exe using the PATH variable of Windows.  

- Set the repository of CVS.  

- If the CVS server is being used, log onto the server.  
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5. 6. 8   CVS status

Selecting the [Project] menu -> [CVS Status...] executes the CVS status command for the selected file and displays the 
status of the file on the [OutPut] window.  

The following operations must be performed before executing this menu item.  

- Set the folder that includes cvs.exe using the PATH variable of Windows.  

- Set the repository of CVS.  

- If the CVS server is being used, log onto the server.  

5. 6. 9   CVS comparison

Selecting the [Project] menu -> [CVS Diff] executes the CVS comparison command for the selected file and compares 
that file with the previous version.  The comparison result is displayed on the [OutPut] window.  

The following operations must be performed before executing this menu item.  

- Set the folder that includes cvs.exe using the PATH variable of Windows.  

- Set the repository of CVS.  

- If the CVS server is being used, log onto the server.  

5. 6. 10   Exporting a make file

Selecting the [Project] menu -> [Export Makefile] creates a make file corresponding to the currently active project.  
When a make file is created, a parameter file dependent on the language product may be created for the language pro-

cessing program.  Therefore the created file will differ depending on the microcontrollers to be used.
The make file is created under the name "Project file name + .mak".  If a make file already exists, it is overwritten.  

5. 6. 11   Setting project information

Selecting the [Project] menu -> [Project Settings...] opens [Project Settings] dialog box ,in which the project information 
can be set.  

Note that the name of project group can not be changed in the [Project Settings] dialog box.  To change the name, 
select the project group name on the [Project] window, click the right mouse button, and use the [Edit Project Group 
Name...] menu that is displayed.  

5. 6. 12   Adding a source file

Selecting the [Project] menu -> [Add Source Files...] displays the [Add Source Files] dialog box in which the source file 
can be added to the active project.  

5. 6. 13   Adding a project-related file

Selecting the [Project] menu -> [Add Project Related Files...] displays the [Add Project Related Files] dialog box in which 
the project-related file can be added to the active project.  

5. 6. 14   Adding other files

Selecting the [Project] menu -> [Add Other Files...] displays the [Add Other Files] dialog box in which any file can be 
added to the active project as other file.  



CHAPTER 5  METHOD OF OPERATION

User’s Manual  U18416EJ1V0UM 67

5. 6. 15   Making the active project selection combo box active

selecting the [Project] menu -> [Direct Select Active Project] makes the Active Project Selection combo box of the 
toolbar active.  Active projects can be switched by selecting a project.  

5. 6. 16   Changing a project group name

To change the project group name, select the project group name on the [Project] window, click the right mouse button, 
and use the [Edit Project Group Name...] menu that is displayed.  

5. 6. 17   Changing a project title

To change the project title, select the project title on the [Project] window, click the right mouse button, and use the [Edit 
Project Title...] menu that is displayed.  

The project title can also be changed with the [Project] menu -> [Project Settings...].  

5. 6. 18   Changing the tools used

To change the tools specified for use in a project included in a project group at once, select the project group name on 
the [Project] window click the right mouse button, and use the [Select Tools...] menu that is displayed.

To change the tools used by an active project, select the project title name on the [Project] window click the right mouse 
button, and use the [Project Settings...] menu that is displayed.

5. 6. 19   Moving a project

To move the project to another project group, follow the procedure shown below on the [Project] window.  

1.   Select the name of the project title to be moved, click the right mouse button, and delete the project using the 
[Delete Project] menu.  

2.   Select the name of the project group to which the project is to be moved, click the right mouse button, and insert 
the deleted project using the [Insert Project...] menu.  
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5. 7   Build Functions
Operations related to build in PM+ are shown below. 
The operations described in this section are performed using the [Build] menu in the Main window.

- Building and debugging

- Rebuilding and debugging

- Compiling

- Building

- Stopping build

- Rebuilding

- Batch building

- Batch rebuilding

- Updating dependency relationship of files

- Cleaning

- Editing

- Debugging

- Downloading multiple load module files

- Selecting build mode

- Setting build options

- Setting batch build

- Making the build mode selection combo box active

5. 7. 1   Building and debugging

Selecting the [Build] menu -> [Build and Debug] executes batch processing from build to debug for the active project.  
If build ends correctly, the debugger starts up automatically and loads the load module file created by build processing.  

However, if a program is under execution on the debugger, an error will occur.  When an error occurs during build, the pro-
cessing stops and the debugger does not start up.  

The messages output from the language processing tools during build are output to a log file.  The log file is created in 
the project folder, under the name "project file name.plg".  

To stop build, select the [Build] menu -> [Stop Build].  

5. 7. 2   Rebuilding and debugging

Selecting the [Build] menu -> [Rebuild and Debug] executes batch processing from rebuild to debug for the active 
project.  With [Build and Debug] menu item, source files are built only when the time stamp is updated after the source 
files and their dependent files have been scanned, whereas with [Rebuild and Debug] menu item, all the source files are 
built unconditionally.  

If rebuild ends correctly, the debugger starts up automatically and loads the load module file created by rebuild process-
ing.  However, if a program is under execution on the debugger, an error will occur.  When an error occurs during rebuild, 
the processing stops and the debugger does not start up.  

The messages output from the language processing tools during build are output to a log file.  The log file is created in 
the project folder, under the name "project file name.plg".  

To stop rebuild, select the [Build] menu -> [Stop Build].  
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5. 7. 3   Compiling 

Selecting the [Build] menu -> [Compile] executes a language tool (assembler, compiler) for the selected file on the 

[Project] window.  "Compile" is a part of "Build", except that object file linking is not executed within "Compile".  Execution 
of "Compile" will also start up the assembler for the assembler source code.  

The messages output form the language processing tools during compilation are output to a log file and displayed on 
the [OutPut] window.  The log file is created in the project folder, under the name "project file name.plg".  

5. 7. 4   Building 

Selecting the [Build] menu -> [Build] starts up a set of language tools (assembler, compiler, and link commands) for the 
active project.  With [Build] menu item, source files are built only when the time stamp is updated after the source files and 
their dependent files have been scanned.  

The make file is created during build in default condition, under the name "project file name.mak".  This make file is 
updated during build by default if options and other settings are changed.  

The messages output form the language processing tools during build are output to a log file and displayed on the [Out-
Put] window.  The log file is created in the project folder, under the name "project file name.plg".  

To stop build, select the [Build] menu -> [Stop Build].  

[Caution] 
In PM(Ver.3.xx), if the [Build] menu item is executed while the debugger is activated, a load module file is downloaded 
automatically, but in PM+, a load module file is not downloaded.  To perform batch processing from build to download, 
use the [Build and Debug] menu item.  

5. 7. 5   Stopping build 

If [Build] menu -> [Stop Build] is selected during build execution, build processing is stopped. If [Build] menu -> [Stop 
Build] is selected during batch build or batch rebuild execution, a question message is displayed and build processing is 
paused.  

5. 7. 6   Rebuilding 

Selecting the [Build] menu -> [Rebuild] starts up a set of language tools (assembler, compiler, and link commands) for 
the active project.  

With [Build] menu item, source files are built only when the time stamp is updated after the source files and their depen-
dent files have been scanned, whereas with [Rebuild] menu item, all the source files are built unconditionally.  

The messages output form the language processing tools during rebuild are output to a log file and displayed on the 

[OutPut] window.  The log file is created in the project folder, under the name "project file name.plg".  
To stop rebuild, select the [Build] menu -> [Stop Build].  

[Caution] 
In PM(Ver.3.xx), if the [Rebuild] menu item is executed while the debugger is activated, a load module file is down-
loaded automatically, but in PM+, a load module file is not downloaded.  To perform batch processing from rebuild to 
download, use the [Rebuild and Debug] menu item.  

5. 7. 7   Batch building

Selecting the [Build] menu -> [Batch Build...] opens [Edit Batch Build Settings] dialog box and executes building of the 
projects specified in the [Edit Batch Build Settings] dialog box from multiple projects registered to the workspace.  
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5. 7. 8   Batch rebuilding

Selecting the [Build] menu -> [Batch Rebuild...] opens [Edit Batch Build Settings] dialog box and executes rebuilding of 
the projects specified in the [Edit Batch Build Settings] dialog box from multiple projects registered to the workspace.  

5. 7. 9   Updating dependency relationship of files 

Selecting the [Build] menu -> [Update dependencies] updates the dependency relationship of the source files and 
include files, and reflects the update contents in the [Project] window.  

[Caution] 
If a change that affects the dependency relationship (change of include file path, etc.) has been made in the compiler 
option settings or assembler option settings, the dependency relationship must be updated.  

5. 7. 10   Cleaning

Selecting the [Build] menu -> [Clean] deletes all the intermediate files and output files generated by building projects.  
The user is not asked for confirmation when these files are deleted.  

5. 7. 11   Editing

Selecting the [Build] menu -> [Edit] enables the file selected on the [Project] window to be opened with the set editor.  
If a file that cannot be edited is selected on the [Project] window, an external editor is opened and the file is edited as a 

new document.  

5. 7. 12   Debugging 

Selecting the [Build] menu -> [Debug] starts up the debugger and downloads a load module file.  During downloading, 
the name of the load module file is displayed on the [OutPut] window.  

At this time, if a program is being executed on the debugger, an error will occur.  Therefore, Select the [Debug] menu 
item after stopping the program.  

5. 7. 13   Downloading multiple load module files

Selecting the [Build] menu -> [Download Some Load Module Files] enables the multiple load module files to be loaded 
onto the debugger.  This menu item become valid only when a project that uses a V850 Microcontrollers device is active.  

The load module files to be loaded are those specified as the debug target files of an active project, or the files in the 
[Debug Target File List] on the [Debugger Settings] dialog box (the [Download the Debug Target Files in the same Project 
Group] check box must be selected).  

When downloading files to the debugger, the names of the downloaded files are displayed on the [OutPut] window.  

[Caution]
This menu item is available only when a project that uses a V850 microcontroller is active.

5. 7. 14   Selecting build mode

Selecting the [Build] menu -> [Select Build Mode...] opens [Build Mode] dialog box in which the build mode can be 
selected, added and deleted.  
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5. 7. 15   Setting build options

Selecting the [Build] menu -> [Build Settings...] opens [Build Settings] dialog box in which the build options can be set.  
The settable items are follows: 

- Options during build  

- Processing to be executed before build 

- Processing to be executed after build 

5. 7. 16   Setting batch build

Selecting the [Build] menu -> [Batch Build Settings...] opens [Build Settings] dialog box in which the project for batch 
build or rebuild can be selected and the build sequence can be set.  

5. 7. 17   Making the build mode selection combo box active

selecting the [Build] menu -> [Direct Build Mode Selection] makes the Build Mode Selection combo box of the toolbar 
active. The build mode can be selected.  
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5. 8   Tool Management
Operations related to tools in PM+ are shown below. 
The operations described in this section are performed using the [Tool] menu in the Main window.

- Setting options for each tool

- Selecting the real-time OS to be used

- Dumping the load module file or the object file

- Selecting and setting the debugger to be used

- Registering external tools

- Starting up external tools

- Comparing files

- Inserting device file

- Setting environment

- Setting font

- Customizing settings

- Recording key operations

- Playing back key operations

- Saving key operations

- Commands corresponding to key operations

- Reading key operations

- Executing macro

- Registering macro

- Executing registered macro

5. 8. 1   Setting options for each tool

The [Tool] menu displays the menu items for setting the tool options executed on PM+.  Refer to the user's manual of 
each tool for the operation of the selected menu.   

5. 8. 2   Selecting the real-time OS to be used

Selecting the [Tool] menu -> [Select RTOS...] opens the [Select RTOS] dialog box and select the real-time OS used by 
the active project.  

[Caution]
This menu item is available only when a real-time OS for the microcontrollers used is installed.  

5. 8. 3   Dumping the load module file or the object file 

Selecting the [Tool] menu -> [dump850] opens the [dump850] dialog box and starts up the dump command "dump850".  
The results are displayed on the Edit window.  

The object to be analyzed are the load module file of the active project specified with the [dump850] dialog box or the 
object file generated from the source files selected on the active Edit window/[Project] window.  If the active Edit window is 
an IDL file, the object file generated from the source file indicated by the caret is analyzed.  

The analyzed results are saved under the file name "project file name.dmp".  If the same file name already exists, the 
previous file is renamed "project file name.dmp.bak".  

The execution of dump850 can be stopped by using the [Esc] key.  In this case, the results are not displayed.  
Refer to the CA850 compiler package user's manual for details on dump850.  
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[Caution]
This menu item is available only when a project that uses a V850 microcontroller is active and the CA850 (Ver.3.10 or 
earlier) is selected as the tool to be used.

5. 8. 4   Selecting and setting the debugger to be used

Selecting the [Tool] menu -> [Debugger Settings...] opens the [Debugger Settings] dialog box.  The debugger to be 
used, the load module files to be downloaded, and other options can be set in this dialog box.  

5. 8. 5   Registering external tools

Selecting the [Tool] menu -> [Register Ex-tool...] opens the [Register External Tool] dialog box in which the external 
tools to be used can be registered.  Up to 10 external tools can be registered.  

The icons of the tools set as external tools are displayed as buttons on the external toolbar.  

5. 8. 6   Starting up external tools

The [Tool] menu includes items for starting up the external tools registered with the [Tool] menu -> [Register Ex-tool...].  
The arguments at startup and the current folder are based on those set in the [Register External Tool] dialog box.  

5. 8. 7   Comparing files

Selecting the [Tool] menu -> [File Compare...] opens the [File Compare] dialog box in which the contents of the selected 

Edit window can be compared.  

5. 8. 8   Inserting device file

Selecting the [Tool] menu -> [Device File Installer...] starts up the device file installer (DFINST).  
If there is no corresponding device file, download the applicable file from the following web site:  

http://www.necel.com/micro/ods/eng/index.html

This download site can also be accessed by selecting the [Help] menu -> [NEC Electronics Microcontrollers Web].  

5. 8. 9   Setting environment

Selecting the [Tool] menu -> [PM+ Settings...] opens [PM+ Settings] dialog box in which the environment of PM+ can be 
set.  The following environment settings are available:

- Options related to workspace  

- External editors 
- File-related items 
- Source files generated by IDL files 
- Window size and position 
- Path-related items 
- Editing-related items 
- Window display 
- Layer-related items 
- Edit window-related items 
- Search/replace-related items 

http://www.necel.com/micro/ods/eng/index.html
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5. 8. 10   Setting font

Selecting the [Tool] menu -> [Font...] opens the [Font] dialog box in which the type and size of the font on the Edit win-
dow can be selected.  

5. 8. 11   Customizing settings 

Selecting the [Tool] menu -> [Customize...] opens [Customize] dialog box in which each setting can be customized.  The 
following settings are available: 

- Shortcut keys assigned to each menu 

- Menu items to be displayed 

- Toolbar items to be displayed 

- Right mouse button menu items and shortcut menu items 

- Highlight display and color for keywords 

5. 8. 12   Recording key operations  

Selecting the [Tool] menu -> [Record the Key Operations/Stop Recording the Key Operations] starts and stops record-
ing of the key operations.  

While key operations are not being recorded, this menu item is [Record the Key Operations], and selecting this menu 
item starts recording of the key operations.  

While key operations are not being recorded, this menu item is [Record the Key Operations], and selecting this menu 
item starts recording of the key operations.  

While key operations are being recorded, "(Recording)" is displayed on the window title.  

5. 8. 13   Playing back key operations 

Selecting the [Tool] menu -> [Play Back] plays back the recorded key operations. If this menu item is selected during 
recording, the recording stops and the operations start to be played back.  

If the previous key operation is read by selecting the [Tool] menu -> [Load the Macro File...], that key operation is played 
back.  

5. 8. 14   Saving key operations  

Selecting the [Tool] menu -> [Save the Key Operations...] opens the [Save the Key Operation] dialog box in which the 
recorded key operations can be saved to a file.  

The extension of the file (macro fle) in which the operations are saved is "*.imc".  

5. 8. 15   Commands corresponding to key operations

When the recorded key operations are saved, the command corresponding to each key operation is described in a 
macro file (.imc).  

The macro file is text file, and can therefore be referenced or modified.  Addition is also possible, in accordance with the 
prescribed format (refer to "APPENDIX B  COMMANDS FOR KEYBOARD MACROS").  
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5. 8. 16   Reading key operations

Selecting the [Tool] menu -> [Load the Macro File...] opens the [Load the Macro File] dialog box in which a key opera-
tion can be read from the specified file (*.imc).  To play back the key operation, select the [Tool] menu -> [Play Back the 
Macro File...] .

5. 8. 17   Executing macro

Selecting the [Tool] menu -> [Play Back the Macro File...] opens the [Play back the Macro File] dialog box in which a key 
operation is read from the specified file (*.imc) and played back.  

5. 8. 18   Registering macro

Selecting the [Tool] menu -> [Register the Macro Files...] opens the [Entry Macro Files] dialog box in which the specified 
file (*.imc) can be registered to a key. 

5. 8. 19   Executing registered macro

Selecting the [Tool] menu -> [Play Back the Register Macro] plays back the macro registered with [Register the Macro 
Files...]. 
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5. 9   Window Management
Operations related to windows in PM+ are shown below. 
The operations described in this section are performed using the [Window] menu in the Main window.

- Arranging windows so they overlap

- Arranging windows horizontally

- Arranging windows vertically

- Splitting a window

- Moving the caret to the other split window

- Activating the next window

- Activating the previous window

- Displaying a list of windows

5. 9. 1   Arranging windows so they overlap

Selecting the [Window] menu -> [Cascade] overlaps all currently displayed windows with one another in such a way that 
their titles are visible (cascading).  

5. 9. 2   Arranging windows horizontally 

Selecting the [Window] menu -> [Tile Horizontally] tiles all currently displayed windows horizontally.  

5. 9. 3   Arranging windows vertically

Selecting the [Window] menu -> [Tile Vertically] tiles all currently displayed windows vertically.  

5. 9. 4   Splitting a window  

Selecting the [Window] menu -> [Split] splits the currently active Edit window into two.  At this time, the editing opera-
tions performed in one part of the window are reflected in the other.  

To split a window, use either of the following: 

- After selecting the [Window] menu -> [Split], specify the split position with mouse.  

- When the mouse cursor is positioned to the top of the vertical scroll bar in the Edit window, the split-enabling cursor 
is displayed, and specify the split position by it .

To return a split window to the previous state, use either of the following: 

- Move the split line toward the top or bottom of the window with mouse.  

- Double-click the left mouse button on the split line.  

5. 9. 5   Moving the caret to the other split window

Selecting the [Window] menu -> [To the Next Split Window] moves the caret from the split window to the other split win-
dow.  
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5. 9. 6   Activating the next window

Selecting the [Window] menu -> [To the Next Window] activating the window following the currently active one, accord-
ing to Z order( window superposition order).  

Note that [To the Next Window] menu item is not displayed in the default condition.  If you wish to make this menu item 
display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 9. 7   Activating the previous window

Selecting the [Window] menu -> [To the Previous Window] activating the window preceding the currently active one, 
according to Z order (window superposition order).  

Note that [To the Previous Window] menu item is not displayed in the default condition.  If you wish to make this menu 
item display, specify it with the [Tool] menu -> [Customize...] - [Menu] tab.  

5. 9. 8   Displaying a list of windows

Selecting the [Window] menu -> [Window List...] opens the [Window List] dialog box to display a list of currently open 
windows.  
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5. 10   Help Functions
Operations related to the help in PM+ are shown below. 
The operations described in this section are performed using the [Help] menu in the Main window.

- Starting up the PM+ help

- Displaying the help of the Main window

- Displaying the help of a current window

- Displaying a list of shortcut keys

- Accessing to NEC Electronics microcontrollers web site

- Starting up a external help 1

- Starting up a external help 2

- Starting up a external help 3

- Displaying the version information about PM+

5. 10. 1   Starting up the PM+ help  

Selecting the [Help] menu -> [PM+ Help] starts up the PM+ help.  

5. 10. 2   Displaying the help of the Main window

Selecting the [Help] menu -> [Main Window] displays the help topic of the Main window.  

5. 10. 3   Displaying the help of a current window

Selecting the [Help] menu -> [Current Window] displays the help topic of the current active window.  

5. 10. 4   Displaying a list of shortcut keys

Selecting the [Help] menu -> [Shortcut List...] opens [Shortcut List] dialog box to list the shortcut keys specified for the 
PM+ menu items.  

5. 10. 5   Accessing to NEC Electronics microcontrollers web site

Selecting the [Help] menu -> [NEC Electronics Microcontrollers Web] accesses the NEC Electronics microcontrollers 
web site.  

http://www.necel.com/micro/index_e.html

5. 10. 6   Starting up a external help 1

Selecting the [Help] menu -> [External HELP 1] starts up the help specified with [External HELP "(1) [Shift]+[F1]"] area 
on the [Tool] menu -> [PM+ Settings...] - [Path] tab.  

5. 10. 7   Starting up a external help 2

Selecting the [Help] menu -> [External HELP 2] starts up the help specified with [External HELP "(2) [Ctrl]+[F1]"] area on 
the [Tool] menu -> [PM+ Settings...] - [Path] tab.  

http://www.necel.com/micro/index_e.html
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5. 10. 8   Starting up a external help 3

Selecting the [Help] menu -> [External HELP 3] starts up the help specified with [External HELP "(3) [Shift]+[Ctrl]+[F1]"] 
area on the [Tool] menu -> [PM+ Settings...] - [Path] tab.  

5. 10. 9   Displaying the version information about PM+

Selecting the [Help] menu -> [About PM+...] displays the version information about PM+.  
When a project file is opened, the version information about NEC Electronics tools and device files that are correspond-

ing to the project is also displayed.  
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CHAPTER 6   WINDOW REFERENCE

6. 1   Window Composition

PM+ has the following windows, wizards and dialog boxes.  

Table 6-1   Window/Wizard/Dialog Box List

Window/Wizard/Dialog Box Name Contents 

Main window This window is the first window to be opened after PM+ is 
started.  To use PM+, start operation from this window.  

[Project] window This window is used to display various information on the 
projects currently opened.  

Edit window This window is used to edit source programs.  

Search result display window This window is used to display the results of search.

[OutPut] window This window is used to display the execution status of the 
make file during build processing.  

[New WorkSpace] wizard This wizard is used to create a new workspace and its project.  

[Add New Project] wizard This wizard is used to add a new project to a workspace.  

[Project Settings] wizard This wizard is used to update the project information for PM+ If 
an attempt is made to open a project file created by another 
NEC Electronics tool (debugger or simulator).  

[Open] dialog box This dialog box is used to open a specified file.  

[Insert File] dialog box This dialog box is used to insert the contents of a specified file 
to the current caret position in the active Edit window. 

[Open Workspace] dialog box This dialog box is used to open a specified workspace file.  

[Save As] dialog box This dialog box is used to save the current active file into a 
specified file.  

[Save Source Files Options] dialog box This dialog box is used to set options when a source file is 
saved. 

[Change Source File Names] dialog box This dialog box is used to change the name of the source file to 
be created from an IDL file being edited to a specified file 
name.  

[Change Selected Source File Name] dialog box This dialog box is used to rename the source file selected in 
the [Change Source File Names] dialog box. 

[Change Selected Source File Names] dialog box This dialog box is used to rename multiple source files 
selected in the [Change Source File Names] dialog box.  

[Set Comment Mark] dialog box This dialog box is used to change a comment mark for a speci-
fied file. 

[Print] dialog box This dialog box is used to print the contents of the window 
being edited. 

[Font] dialog box (Print) This dialog box is used to specify the font and size of the char-
acters to be printed. 

[Set Header/Footer] dialog box This dialog box is used to specify the contents of the header or 
footer to be printed.  
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[Grouping by Keyword] dialog box This dialog box is used to collect lines including a specified 
character string and display the collected results at the top of 
the Edit window.  In the collected results, the search key is dis-
played in the first layer, and the collected lines are displayed in 
the second layer.  

[Select the way of Function Prototypes] dialog 
box

This dialog box is used to automatically generate the prototype 
declaration of a function.  

[Find String] dialog box This dialog box is used to find a character string.

[Replace String] dialog box This dialog box is used to replace a character string. 

[Jump to Specified Line] dialog box This dialog box is used to make a jump to a specified destina-
tion line number in the current file. 

[Jump to Specified Line in the Source file] dialog 
box

This dialog box is used to make a jump to a specified destina-
tion line number in a specified source file.  

[Mark Jump] dialog box This dialog box is used to specify the current caret position as 
a mark or to make a jump to a marked line.  

[Find in Files] dialog box This dialog box is used to search through multiple files in a 
specified folder for a character string.

[Replace in Files] dialog box This dialog box is used to replace a character string in multiple 
files in a specified folder. 

[Expand to Specified Layer] dialog box This dialog box is used to expand specified layers. 

[Collapse to Specified Layer] dialog box This dialog box is used to collapse specified layers. 

[Set Layer Rule] dialog box This dialog box is used to apply a layer rule to the current con-
tents of the Edit window, or set  the layer rule to be applied 
when files are read.  

[Function List] dialog box This dialog box is used to lists the functions of the file dis-
played in the active Edit window.  

[Save the Function List] dialog box This dialog box is used to save the functions displayed in the 
[Function List] dialog box to a file.  

[Layer List] dialog box This dialog box is used to list the layers of the file displayed in 
the active Edit window.  

[Select Active Project] dialog box This dialog box is used to select the active project. 

[Insert Project] dialog box This dialog box is used to insert an existing project into a 
project group. 

[CVS Update] dialog box This dialog box is used to execute the CVS update command 
for the selected file and acquire files registered in the reposi-
tory.  

[CVS Commit] dialog box This dialog box is used to execute the CVS commit command 
for the selected file and reflect the file in the repository.  

[CVS Log] dialog box This dialog box is used to execute the CVS log command for 
the selected file and display the file's log contents in the [Out-
Put] window. 

[CVS Status] dialog box This dialog box is used to execute the CVS status command 
for the selected file and display the file's status in the [OutPut] 
window. 

[Project Settings] dialog box This dialog box is used to set the information on the current 
active project. 

[Add Source Files] dialog box This dialog box is used to add source files to a project.  

[Add Project Related Files] dialog box This dialog box is used to add project-related files to a project. 

Window/Wizard/Dialog Box Name Contents 
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[Add Other Files] dialog box This dialog box is used to add any files to a project as other 
files.  

[Project Group Name] dialog box This dialog box is used to change a project group name. 

[Project Title] dialog box This dialog box is used to change a project title.  

[Tool Version Settings] dialog box This dialog box is used to change the tools to be used by a 
project included in the selected project group at once.

[Tool Version Detail Setting] dialog box This dialog box is used to select the tools to be used and their 
versions.

[Properties] dialog box This dialog box is used to displays the path information and 
read attribute of the selected file.  

[Add New Memo] dialog box This dialog box is used to add a new memo. 

[Startup File] dialog box This dialog box is used to specify a startup file when an exist-
ing file is used as a startup file. 

[Copy Startup File from] dialog box This dialog box is used to specify a startup file to be a copy 
source when an existing file is copied and used as a startup 
file.  

[Startup File to register] dialog box This dialog box is used to specify a startup file to register.  

[Link Directive File] dialog box This dialog box is used to specify a link directive file when an 
existing file is used as a link directive file.  

[Copy Link Directive File from] dialog box This dialog box is used to specify a link directive file to be a 
copy source when an existing file is copied and used as a link 
directive file.  

[Link Directive File to register] dialog box This dialog box is used to specify a link directive file when an 
existing file is used as a link directive file.  

[Select Project] dialog box This dialog box is used to specify the project to be added when 
a source file is dragged to the [Project] window while a work-
space file or project file is open. 

[Edit Batch Build Settings] dialog box This dialog box is used to select the project for batch build or 
rebuild and set the build sequence.

[Build Mode] dialog box This dialog box is used to select, add and delete build modes.  

[Add Build Mode] dialog box This dialog box is used to add a new build mode. 

[Build Settings] dialog box This dialog box is used to set options related to build.  

[Add Command] dialog box This dialog box is used to specify the commands used to exe-
cute any processing required before or after build (copying of 
output files to another folder, etc.).  

[Edit Command] dialog box This dialog box is used to edit commands specified as required 
processing either during build execution, before or after build 
processing. 

[Select RTOS] dialog box This dialog box is used to select the real-time OS used by the 
current active project.

[dump850] dialog box This dialog box is used to activate the dump command, 
dump850.  

[Debugger Settings] dialog box This dialog box is used to set the details of the debugger to be 
used.  

[Register External Tool] dialog box This dialog box is used to register (add), change, and delete 
external tools to be used.  Up to 10 tools can be registered.  
The currently set tools are displayed. 

[Select External Tool] dialog box This dialog box is used to specify a external tool to be used. 

Window/Wizard/Dialog Box Name Contents 
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[File Compare] dialog box This dialog box is used to compare the contents of two Edit 
windows. 

[PM+ Settings] dialog box This dialog box is used to make various environment settings.  

[User Setting] dialog box This dialog box is used to set arbitrary keywords for the smart 
lookup function.  

[Font] dialog box This dialog box is used to select the type and size of charac-
ters to be displayed in the Edit window.  

[Customize] dialog box This dialog box is used to set the options of keyboard, menu, 
toolbar, user menu, keyword.  

[Edit User keyword] dialog box This dialog box is used to edit the keywords defined by the 
user to highlight arbitrary character strings.  

[Edit C Language's reserve words] dialog box This dialog box is used to edit the keywords for highlighting of 
reserved words in C language. 

[Save the Key Operation] dialog box This dialog box is used to save the recorded key operation in a 
file.  

[Load the Macro File] dialog box This dialog box is used to read a saved macro file.  

[Play back the Macro File] dialog box This dialog box is used to read the key operation from a saved 
macro file and execute the macro. 

[Entry Macro Files] dialog box This dialog box is used to register a macro file to a key.  

[Add the Macro file] dialog box This dialog box is used to add a macro file for macro registra-
tion.  

[Change the Macro file] dialog box This dialog box is used to change the stored contents of a 
macro file. 

[Window List] dialog box This dialog box is used to list the widows that are currently 
open. 

[Shortcut List] dialog box This dialog box is used to display a list of the shortcut keys set 
in PM+.  

[About PM+] dialog box This dialog box is used to display the version information about 
PM+.  

Window/Wizard/Dialog Box Name Contents 
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Figure 6-1 shows a screen image when displaying the various windows.  

Figure 6-1   Window Composition of PM+

[Project] window Edit window Search result display window[OutPut] window
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6. 2   Input Rules

This section explains the rules for inputting characters in the windows, or dialog boxes of PM+.

(1)   File names

- File names are composed of a to z, A to Z, 0 to 9, ., _, +, and -.

- File names cannot be prefixed by a period (.), +, or -.

- File names cannot be suffixed by a period (.).

- Uppercase characters and lowercase characters are not distinguished for file names.

- A file name consists of up to 259 characters including the path.

[Caution]
A workspace file name, or a project file name consists of up to 255 characters.

(2)   Path names

- Path names are composed of a to z, A to Z, 0 to 9, ., _, +, -, and one-byte spaces.

- Path names cannot be prefixed by a period (.), +, -, or one-byte space.

- Path names cannot be suffixed by a period (.), or one-byte space.

- Uppercase characters and lowercase characters are not distinguished for path names.

- A path name consists of up to 259 characters.

6. 3   Explanation of Windows/Wizards/Dialog boxes 

This section explains each window/wizard/dialog box of PM+ as follows:  

Window/Wizard/Dialog box name

Briefly explains the function of the window, wizard or dialog box and points to be noted.  
In addition, the screen image of the window or dialog box is illustrated.  Item of related operation are also explained.  

Opening

Explains how to open the window, wizard or dialog box.  
If two of more methods of opening are listed, the window or dialog box can be opened by any of them.  

Explanation of each area

Explains items to be set to or displayed in each area of the window or dialog box.  

Function buttons 

Explains the operation of each button in the window or dialog box.  
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Main window

The Main window is the first window to be opened after PM+ is started.  To use PM+, start operation from this window.  

Figure 6-2   Main Window 

This section describes the following items: 

- Title bar

- Menu bar

- Tool bar

- Window display area

- Status bar

- Drag-and-drop function

Title bar Menu bar Tool bar Window display area

Status bar
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Title bar 

The title bar displays the following information.  

PM+  -  the name of the workspace or the project file ["file name" or "window name"] 

[Caution]
In ["file name"], the name of the file which is opened in the active Edit window is displayed.  
If you wish to make it display with the path, specify it with the [Tool] menu -> [PM+ Settings...] - [View] tab.  

Menu bar

The menu bar consists of the following menus.  

(1)  [File] menu

(2)  [Edit] menu

(3)  [Find] menu

(4)  [Layer] menu

(5)  [View] menu

(6)  [Project] menu

(7)  [Build] menu

(8)  [Tool] menu

(9)  [Window] menu

(10)  [Help] menu

(1)   [File] menu

New Opens a new Edit window newly.  
Up to 64 Edit windows can be opened including the Search result display win-
dows and the [OutPut] windows.  

Open... Loads a existing file and opens the Edit window.  The name of the file loaded is 
displayed on the title of the Edit window.  
Opens the [Open] dialog box.  

Insert file... Inserts a specified file at the caret position in the currently active Edit window.  
Opens the [Insert File] dialog box.  

Close Closes the currently active Edit window or Search result display window.  If 
there are any files with read-only having the same name, those files will be 
closed.  

New Workspace... Opens the wizard to create a workspace newly.  

Open Workspace... Opens a Workspace.  
Opens the [Open Workspace] dialog box.  

Refer to: "5. 1. 7  Opening a workspace"

Save Workspace Saves the contents of the workspace by overwriting.  

Close Workspace Closes the currently open workspace.  

Save Overwrites the file currently being edited.  
Refer to: "5. 1. 10  Saving a file by overwriting"

Save As... Saves the file currently being edited to the file whose name is specified.
Opens the [Save As] dialog box.  
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[Note]
This menu item in the above table is not displayed by default. To display this menu item, customize the settings 
for the [File] menu by selecting the [Tool] menu -> [Customize...] - [Menu] tab.  

(2)   [Edit] menu 

Save All... Overwrites all the files that are currently open in the Edit windows.  The contents 
of the Edit windows including those that have not been modified are saved. 
However, the contents of the Edit windows, [OutPut] windows and Search result 
display windows which have the read-only attribute are not saved. [Note]

Save All (Changed files Only) Overwrites all modified files that are currently open in the Edit windows.  [Note]

Save and Close All Saves all the files that are currently open in the Edit windows and then closes 
the windows.  [Note]

Close All Closes all the Edit windows currently open. [Note]

Destroy All Closes all the Edit windows currently open.  Any changes made to the files will 
not be saved.  The [Project] window and the [OutPut] windows cannot be 
closed.  [Note]

Change Source File Name... Changes the names of the source files that are currently being edited.  
Opens the [Change Source File Names] dialog box.  

Save All Source Files Updates all of the source files that are currently being edited.  

Print Preview Displays the printing status of the window currently being edited.

Print... Prints the contents of the window currently being edited.  
Opens the [Print] dialog box.  

Print Direct Prints the contents of the window currently being edited.  
The [Print] dialog box is not opened. [Note]

Recent File  Displays the name of the ten most recently edited or saved files.  

Recent Workspace Displays the name of the ten most recently opened workspaces.  

Exit PM+ Exits from PM+.  

Undo Cancels the effect of an edit operation to restore the previous state.  
Refer to: "5. 2. 1  Canceling an edit operation"

Redo Cancels the effect of an [Undo] operation.  
Refer to: "5. 2. 2  Canceling an [Undo] operation"

Cut Sends the character string or lines selected with range selection to the 
clipboard and deletes them.  

Copy Sends the character string or lines selected with range selection to the 
clipboard.  

Cut for Append Sends the character string or the lines selected with range selection to the 
clipboard and deletes them.  This command does not erase the previous 
contents of the clipboard but instead appends the cut potion to the end of 
the contents of the clipboard.  [Note]

Copy for Append Sends the character string or the lines selected with range selection to the 
clipboard.  This command does not erase the previous contents of the 
clipboard but instead appends the cut potion to the end of the contents of 
the clipboard.  [Note]

Image Copy Sends the character string or the lines selected with range selection to the 
clipboard exactly as they are displayed on the screen.  

Refer to: "5. 2. 7  Copying character strings as a screen image"

Paste Inserts the contents of the clipboard at the caret position.  
Refer to: "5. 2. 8  Inserting the contents of clipboard"

Paste Special... Inserts the contents of the clipboard by the specified format at the caret 
position.  
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[Note]
This menu item in the above table is not displayed by default. To display this menu item, customize the settings 
for the [Edit] menu by selecting the [Tool] menu -> [Customize...] - [Menu] tab.  

(3)   [Find] menu

Delete Deletes the character string or the lines selected with the range selection.  

Delete the Word Deletes a single word at the caret position.  [Note]

Delete to the End of Word Deletes the portion of the word at the caret position that is to the right of 
the caret position.  [Note]

Delete the Line Deletes a single line at the caret position.  

Deleting to the Top of Line Deletes the portion of the line from the caret position to the beginning of 
the line.  [Note]

Delete to the End of Line Deletes the portion of the line from the caret position to the end of the line.  
[Note]

Select to the Word Selects the word at the caret position with the range selection.  [Note]

Select to the Top of Word Selects the portion of the word at the caret position that is to the left of the 
caret position, with range selection.  [Note]

Select to the End of Word Selects the portion of the word at the caret position that is to the right of 
the caret position, with range selection.  [Note]

Select to the Top of Line Selects the portion of the line from the caret position to the beginning of 
the line with range selection.  [Note]

Select to the End of Line Selects the portion of the line from the caret position to the end of the line 
with range selection.  [Note]

Select All Selects the entire contents of the Edit window.  

Grouping by Keyword... Collects the lines containing a specified character string.  
Opens the [Grouping by Keyword] dialog box.  

Restore Color of Grouping Lines Restores the color assigned to the lines collected with the [Grouping by 
Keyword...].  

Make Function Prototypes... Makes the function prototypes automatically.  
Opens the [Select the way of Function Prototypes] dialog box.  

Insert New Object... Inserts new embedded objects.  
Opens the Insert Object dialog box.  

Link... Edits the linked object and changes the link information.  
Opens the Links dialog box.  

Object Starts an application and converts a file type for a selected object.  

Find... Searches for the specified character string.  
Opens the [Find String] dialog box.  

Find Upward Searches for the specified character string toward the beginning of the file.  
[Note]

Find Downward Searches for the specified character string toward the end of the file.  
[Note]

Find the Word Upward Searches for the word at the caret position toward the beginning of the file.  
[Note]

Find the Word Downward Searches for the word at the caret position toward the end of the file.  
[Note]

Replace... Replaces the specified character string with the replacement character string.  
Opens the [Replace String] dialog box.  

To a Specific Line... Moves the caret position to the specified line.  
Opens the [Jump to Specified Line] dialog box.  
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[Note]
This menu item in the above table is not displayed by default. To display this menu item, customize the settings 
for the [Find] menu by selecting the [Tool] menu -> [Customize...] - [Menu] tab.  

To the Specific Line in the Source File... Moves the caret position to the specified line in the specified source file.  
Opens the [Jump to Specified Line in the Source file] dialog box.   [Note]

Mark Jump... Registers the current caret position as a mark, or moves the caret position 
to the marked line.  
Opens the [Mark Jump] dialog box.  

To the Top of Line Moves the caret position to the top of the line.  

To the End of Line Moves the caret position to the end of the line.  

To the Top of File Moves the caret position to the top of the top line of the file.  

To the End of File Moves the caret position to the end of the last line of the file.  

To the Index Line Moves the caret position to the top of the index line at the current caret 
position.  

To the Top Layer at caret Moves the caret position to the top layer line at the current caret position.  

Same Layer Line Up Moves the caret position to the layer line of the same depth at a position 
one line above the current caret.  [Note]

Same Layer Line Down Moves the caret position to the layer line of the same depth at a position 
one line below the current caret.  [Note]

Back Jump Moves the caret position to the position before the previous jump.  [Note]
Refer to: "5. 3. 18  Moving the caret to the position before a jump"

To the Function Definition Moves the caret position to the definition line for the function.  

To the Matching Brace Searches for the matching brace that at the current caret position and 
moves the caret to that brace.  

Refer to: "5. 3. 20  Searching for matching braces"

Find in Files... Searches for the specified character string within multiple files.  
Opens the [Find in Files] dialog box.  

Replace in Files... Replaces the specified character string within multiple files.  
Opens the [Replace in Files] dialog box.  

Find in Project Searches for the specified character string within multiple files registered 
in the project.  

Refer to: "5. 3. 23  Searching for a character string within a project"

Tag Jump Performs a tag jump.
Refer to: "5. 3. 24  Jumping to a desired line (tag jump)"

To the Tag File Returns from the tag jump destination to the window from which the tag 
jump was made.  

Next Tag Jump Continues the search for the line in tag jump format.  

Next Tag Jump Upward Continues the search for the line in tag jump format upward from a tag 
jump that has been made.  [Note]

One Word Right Moves the caret position rightward by one word.  [Note] 

One Word Left Moves the caret position leftward by one word.  [Note]

One Line Up Moves the caret position upward by one line.  [Note]

One Line Down Moves the caret position downward by one line.  [Note]

One Character Right Moves the caret position rightward by one character.  [Note]

One Character Left Moves the caret position leftward by one character.  [Note]

Direct Search Make the Search Character String Specification combo box of the toolbar 
active.  Searches for the specified character string in the currently active 
Edit window by pressing [Enter] key. [Note]
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(4)   [Layer] menu

[Note]
This menu item in the above table is not displayed by default. To display this menu item, customize the settings 
for the [Layer] menu by selecting the [Tool] menu -> [Customize...] - [Menu] tab.  

Promote Promotes the layer of line to which the current caret positioned or the line selected 
with range selection by one.  

Refer to: "5. 4. 1  Promoting layers"

Demote Demotes the layer of line to which the current caret positioned or the line selected 
with range selection by one.  

Refer to: "5. 4. 2  Demoting layers"

Expand/Collapse Expands/Collapses one of the lower layers of the line to which the current caret is 
positioned or the line selected with range selection.  

Expand Expands one of the lower layers of the line to which the current caret is positioned 
or the line selected with range selection. [Note] 

Refer to: "5. 4. 4  Expanding one of the lower layers"

Collapse Collapses one of the lower layers of the line to which the current caret is posi-
tioned or the line selected with range selection.  [Note] 

Refer to: "5. 4. 5  Collapsing one of the lower layers"

Expand All Lower Layers Expands all of the lower layers of the line to which the current caret is positioned 
or the line selected with range selection.  

Expand All Expands all of the layers in the active Edit window.  

Collapse All Collapses all of the layers in the active Edit window.  

Expand the Specific Layer... Expands a specified number of layers.  
Opens the [Expand to Specified Layer] dialog box.  

Collapse the Specific Layer... Collapses a specified number of layers.  
Opens the [Collapse to Specified Layer] dialog box.  

Show Index 1 Collapses lower layers and displays the top layer only.  [Note] 

Show Index 2 Collapses the third and subsequent layers and displays the first and second lay-
ers.  [Note] 

Show Index 3 Collapses the fourth and subsequent layers and displays the first to third layers.  
[Note] 

Show Index 4 Collapses the fifth and subsequent layers and displays the first to fourth layers.  
[Note] 

Show Index 5 Collapses the sixth and subsequent layers and displays the first to fifth layers.  
[Note] 

Collapse This Layer Collapses the layer of the line to which the current caret is positioned.  

Apply Layer Rule... Applies a layer rule to the current contents of the Edit window.  
Opens the [Set Layer Rule] dialog box.  
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(5)   [View] menu 

(6)   [Project] menu

[Note]
This menu item in the above table is not displayed by default. To display this menu item, customize the settings 
for the [Project] menu by selecting the [Tool] menu -> [Customize...] - [Menu] tab.  

Function List... Lists the functions of the file displayed in the active Edit window.  
Opens the [Function List] dialog box.  

Layer List... Lists the layers of the file displayed in the active Edit window.  
Opens the [Layer List] dialog box.  

Standard Bar Toggles the display of the standard bar between on and off.  

Build Bar Toggles the display of the build bar between on and off.  

Option Bar Toggles the display of the option bar between on and off.  

Ex-tool Bar Toggles the display of the external tool bar between on and off.  

Status Bar Toggles the display of the status bar between on and off.  

Project Window Toggles the display of the [Project] window between on and off.  

Output Window Toggles the display of the [OutPut] window between on and off.  

Display Content/Icon Toggles the display format of an object between contents or icon.  
When an object displayed as icon is selected, this menu item is displayed as 
[Display Object as Content].  
When an object displayed as contents is selected, this menu item is displayed as 
[Display Object as Icon].  

Display All Object as Content Displays all the objects in the currently active Edit window as contents.  

Display All Object as Icon Displays all the objects in the currently active Edit window as icons.  

Select Active Project... Selects the project to be the target for the build processing.  
Opens the [Select Active Project] dialog box.  

Add New Project... Opens the wizard to add a new project into the workspace.

Insert Project ... Inserts an existing project into the workspace.  
Opens the [Insert Project] dialog box.  

CVS Update... Acquires the source files registered in the server when CVS is used.  

CVS Commit... Reflects the contents of the modification of source files into the server when CVS 
is used.  

CVS Log... Displays the log contents of the file when CVS is used.  

CVS Status... Displays the status of the file when CVS is used.  

CVS Diff Displays the difference between the files when CVS is used.  

Export Makefile Creates a make file for the project.  

Project Settings... Sets the project information. 
Opens the [Project Settings] dialog box.  

Add Source Files... Adds source files to an active project.  
Opens the [Add Source Files] dialog box.  

Add Project Related Files... Adds project-related files to an active project.  
Opens the [Add Project Related Files] dialog box.  

Add Other Files... Adds any files to an active project as other files.  
Opens the [Add Other Files] dialog box.  

Direct Select Active Project Make the Active Project Selection combo box of the toolbar active.  Active 
projects can be switched by selecting a project.  [Note] 
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(7)   [Build] menu

[Note]
This menu item in the above table is not displayed by default. To display this menu item, customize the settings 
for the [Build] menu by selecting the [Tool] menu -> [Customize...] - [Menu] tab.  

[Caution] 
If the project file to which no source file is registered is opened, some build-related menu items may be invalid.

Build and Debug Performs the build processing and then starts the debugger.  
Refer to: "5. 7. 1  Building and debugging"

Rebuild and Debug Performs the rebuild processing and then starts the debugger.  
Refer to: "5. 7. 2  Rebuilding and debugging"

Compile Compiles the selected file.  
Refer to: "5. 7. 3  Compiling"

Build Performs the build processing for the active project.  
Refer to: "5. 7. 4  Building"

Stop Build If during build execution, build processing is stopped. If during batch build 
or batch rebuild execution, a question message is displayed and build pro-
cessing is paused.   

Rebuild Performs the rebuild processing for the active project.  
Refer to: "5. 7. 6  Rebuilding"

Batch Build Executes building of the projects specified in the [Edit Batch Build Set-
tings] dialog box from multiple projects registered to the workspace. 

Batch Rebuild Executes rebuilding of the projects specified in the [Edit Batch Build Set-
tings] dialog box from multiple projects registered to the workspace. 

Update dependencies Updates the dependency relationship of the source files and include files.

Clean Deletes the intermediate files and hexadecimal code files that have been 
generated by the build processing.  

Edit Starts the specified editor to open the selected file.  

Debug Starts the debugger.  

Download Some Load Module Files Downloads multiple load module files registered as the same project group 
to the debugger.  

Refer to: "5. 7. 13  Downloading multiple load module files"

Select Build Mode... Specifies the build mode.  
Opens the [Build Mode] dialog box.  

Build Settings... Performs the setting for the build processing.  
Opens the [Build Settings] dialog box.  

Batch Build Settings... Selects the project for batch build or rebuild and sets the build sequence. 
Opens the [Edit Batch Build Settings] dialog box.  

Direct Build Mode Selection Make the Build Mode Selection combo box of the toolbar active.  Build 
mode can be selected.  [Note] 
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(8)   [Tool] menu 

Tool's name Specifies the tool options executed on PM+.  Each name of the menu 
items depends on the tool.  

Select RTOS... Select the real-time OS used.
Opens the [Select RTOS] dialog box.

Refer to: "5. 8. 2  Selecting the real-time OS to be used"

dump850 Executes a dump command. (executes "dump850".)  
Opens the [dump850] dialog box.  

Refer to: "5. 8. 3  Dumping the load module file or the object file"

Debugger Settings... Sets up the debugger to be used and specifies the files to be down-
loaded.  
Opens the [Debugger Settings] dialog box.  

Register Ex-tool... Registers the external tool which is started from PM+.  
Opens the [Register External Tool] dialog box.  

Start up Ex-tool Starts the registered external tool.  The name of this menu item is dis-
played as the designation at the time of registering the external tool.  

File Compare... Compares the selected files.  
Opens the [File Compare] dialog box.  

Device File Installer Starts the device file installer (DFINST).  
Refer to: "5. 8. 8  Inserting device file"

PM+ Settings... Sets up the operating environment for PM+.  
Opens the [PM+ Settings] dialog box.  

Font... Specifies the type and size of the font used in the Edit window.  
Opens the [Font] dialog box.  

Customize... Customizes the menu bar, tool bar and so on.  
Opens the [Customize] dialog box.  

Record the Key Operations
/Stop Recording the Key Operations

Starts and stops recording of the key operations.  

Play Back Plays back the currently recorded key operations. 

Save the Key Operations... Saves the recorded key operations to a macro file.  
Opens the [Save the Key Operation] dialog box.  

Refer to: "5. 8. 15  Commands corresponding to key operations"

Load the Macro File... Loads the macro file to which the key operations have been saved, and 
enables a use of [Play Back] menu item.  
Opens the [Load the Macro File] dialog box.  

Play Back the Macro File... Loads the macro file to which the key operations have been saved, and 
executes the key operations.  
Opens the [Play back the Macro File] dialog box.  

Register the Macro Files... Registers the macro file, and adds to the cascade menu of the [Play 
Back the Register Macro].  
Opens the [Entry Macro Files] dialog box.  

Play Back the Register Macro Executes the macro registered with the [Register the Macro Files...].  
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(9)   [Window] menu

[Note]
This menu item in the above table is not displayed by default. To display this menu item, customize the settings 
for the [Window] menu by selecting the [Tool] menu -> [Customize...] - [Menu] tab.  

(10)   [Help] menu

Cascade Overlaps all the currently open windows with one another in such a way that their 
titles are visible.  

Tile Horizontally Tiles all the currently open windows horizontally.  

Tile Vertically Tiles all the currently open windows vertically.  

Split Splits the currently active Edit window into two.  
Refer to: "5. 9. 4  Splitting a window"

To the Next Split Window Moves the caret from the split screen to which the caret is positioned to column 1 of 
the other split screen.  

To the Next Window Activates the window following the currently active one, according to Z order (win-
dow superposition order).  [Note] 

To the Previous Window Activates the window preceding the currently active one, according to Z order (win-
dow superposition order).  [Note] 

Window List... Displays a list of currently open windows.  
Opens the [Window List] dialog box.  

Open window information Displays the window title of the window currently being edited and makes the 
selected window the top window.  

Tool Help  Displays the help file for each tool. The menu item names differ for 
each tool. When a project is opened, its menu items are added. 

PM+ Help Starts the PM+ help.  

Main Window Starts the PM+ help to display the topic of the Main window.  

Current Window Starts the PM+ help to display the topic of the currently active window.  

Shortcut List... Lists the shortcut keys specified for the PM+ menu items.  
Opens the [Shortcut List] dialog box.  

NEC Electronics Microcontrollers  Web Accesses the NEC microcontrollers web site.  
http://www.necel.com/micro/index_e.html

External HELP 1 Displays the help topic specified in [External HELP (1)] on the [Path] 
tub displayed by selecting the [Tool] -> [PM+ Settings...].  

External HELP 2 Displays the help topic specified in [External HELP (2)] on the [Path] 
tub displayed by selecting the [Tool] -> [PM+ Settings...].  

External HELP 3 Displays the help topic specified in [External HELP (3)] on the [Path] 
tub displayed by selecting the [Tool] -> [PM+ Settings...].  

About PM+... Displays the version information about PM+.  

http://www.necel.com/micro/index_e.html
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Tool bar

The tool bar is a collection of buttons and combo boxes that can execute often-used commands with a single action.  
The kind of tool bar is as follows:  

(1)  Standard bar

(2)  Build bar

(3)  Option bar

(4)  External tool bar

The standard bar and the build bar can be customized with the [Tool] menu -> [Customize...] - [Toolbar] tab.  

(1)   Standard bar

The standard bar consists of the buttons and combo box that are related to the operation or the modification of files.  

Table 6-2 shows the list of items on the standard bar in the default condition.  

Table 6-2   Standard Bar

Item  Function

Lists the names of the files opened.  

Opens a Edit window newly.  
Up to 64 Edit windows can be opened including the Search result display windows and the 
[OutPut] windows.  

Loads a existing file and opens the Edit window.  The name of the file loaded is displayed on 
the title of the Edit window.  
Opens the [Open] dialog box.  

Overwrites the file currently being edited.  

Prints the contents of the window currently being edited.  

Displays the printing status of the window currently being edited.

Sends the character string or lines selected with range selection to the clipboard and deletes 
them.  

Sends the character string or lines selected with range selection to the clipboard.  

Inserts the contents of the clipboard at the caret position.  

Searches for the specified character string within multiple files.  

Specifies a character string to be searched for.  Searches for the specified character string in 
the currently active Edit window by pressing [Enter] key 

Promotes the layer of line to which the current caret positioned or the line selected with 
range selection by one.  

Demotes the layer of line to which the current caret positioned or the line selected with range 
selection by one.  

Expands/Collapses one of the lower layers of the line to which the current caret is positioned 
or the line selected with range selection.  

Expands one of the lower layers of the line to which the current caret is positioned or the line 
selected with range selection.  



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U18416EJ1V0UM 97

(2)   Build bar

The build bar consists of the buttons and combo boxes that are related to the build processing.  

Table 6-3 shows the list of items on the build bar in the default condition.  

Table 6-3   Build Bar

Opens the [Project] window.  Closes the [Project] window when the [Project] window is 
already opened.

Opens the [OutPut] window.  Closes the [OutPut] window when the [OutPut] window is 
already opened.

Starts the PM+ help.  

Item Function

This is the Active Project Selection combo box.  Active projects can be switched by 
selecting a project.  

This is the Active Project Selection combo box.  The following build modes can be 
specified in the default condition.  This specification will be reflected in the [Build] 
menu -> [Select Build Mode...].  

[Debug Build]
Creates the object file with the debug information.  

[Release Build]
Creates the object file without the debug information.  

Compiles the selected file.  

Performs the build processing for a active project.  

Performs the rebuild processing for a active project.  

Performs the build processing and then starts the debugger.  

Stops the current build processing.  

Starts the device file installer.  

Item  Function
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(3)   Option bar

The option bar consists of the buttons that are related to the option settings.  The order of display of the buttons 
depends on the loaded tool.  

[78K Microcontrollers]  

Table 6-4   Option Bar (78K Microcontrollers)  

[V850 Microcontrollers]  

Table 6-5   Option Bar (V850 Microcontrollers)  

(4)   External tool bar

The external tool bar consists of the icons that are registered with the [Tool] menu -> [Register Ex-tool...].  The 
order of display of the icons depends on the order registered with [Register Ex-tool...] menu item.  

Button  Function

Opens the Structured Assembler Options dialog box.  
 (except 78K0R Microcontrollers)

Opens the Assembler Options dialog box.  

Opens the Linker Options dialog box.  

Opens the Object Converter Options dialog box.  

Opens the List Converter Options dialog box.  

Opens the Compiler Options dialog box.  

Button  Function

Opens the Compiler Common Options dialog box.  

Opens the Section File Generator Options dialog box.

Opens the Compiler Options dialog box.  

Opens the Assembler Options dialog box.  

Opens the Linker Options dialog box.  

Opens the ROM processor Options dialog box.

Opens the Hex Converter Options dialog box.  

Opens the Static performance analyzer Options dialog box.  
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Window display area 

This area is displayed various windows.  
For details on the function of each window, refer to the following.  

- [Project] window

- Edit window

- Search result display window

- [OutPut] window

Status bar

The status bar displays brief description of the menu that has been activated by clicking and indicates the other various 
information.

Figure 6-3 shows an image of the status bar.  

Figure 6-3   Status Bar

(1)   Brief description 

Displays the following descriptions.  

- The description of the menu that has been activated by clicking

- The contents of the line corresponding to a tag jump destination

- The name of the source file to be output. (When editing an IDL file)  

Displays "For Help, press F1" in the default condition.

(2)   Character code type

Displays the character code type used for the file currently edited.

(3)   Line feed code type

Displays the line feed code type used for the file currently edited.

(4)   Key input mode

Displays the key input mode.  In the overwrite mode, "OVER" is displayed. 

(5)   Depth of layers

Displays the depth of the layers at the current caret position.  

(6)   Number of columns 

Displays the number of columns at the caret position.

(7)   Number of lines

Displays the number of lines at the current caret position.  

(1) (2) (3) (4) (5) (6) (7)
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 Drag-and-drop function

The following operations are achieved by dropping a file in the main frame.  

- When dropping a workspace file (.prw extension)  
Opens the dropped workspace.  If another workspace is already open, closes that workspace and then opens the 
workspace that was dropped.  
Multiple workspace files cannot be dropped.  A workspace file and project file cannot be dropped together.  

- When dropping a project file (.prj extension)  
Opens the workspace corresponding to the project file that was dropped.  If another workspace is already open, 
closes that workspace and then opens the workspace corresponding to the project file that was dropped.  
Multiple project files cannot be dropped.  A workspace file and project file cannot be dropped together.  

- When dropping a file other than a workspace file or project file
Opens the file that was dropped in the Edit window.  If "Untitled1" exists in the Edit window while the [OutPut] win-
dow is not displayed, "Untitled1" is closed when the file that was dropped is opened.  
Multiple files can be dropped.  
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[Project] window

The [Project] window is used to display various information on the projects currently opened.  

Figure 6-4   [Project] Window

This section describes the following items:  

- Opening

- Explanation of each area

- Drag-and-drop function

Opening

- Select the [View] menu -> [Project Window].  

(1) (2)
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Explanation of each area

(1)   [Files] tab

The [File] tab displays the file information to be managed by a project file.  When there are multiple projects, the 
information is displayed in project units.  
A  file can be added into a project by dragging and dropping the file onto this tab (refer to "Drag-and-drop function").  

Figure 6-5   [Project] Window - [File] Tab

(a)   Project group name
Multiple registered projects can be arranged with related projects in a group.  The project group name can be set 
by the user freely, and up to 127 characters names can be set.
The initial setting for the project group name is made when a workspace is created.  Up to 20 projects can be reg-
istered in one project group.  Register the same device file for multiple registered projects, as they are managed 
as a project group.  
When the mouse cursor is placed on the project group name, the device name used in the projects affiliated with 
that project group is displayed as a pop-up.  

Clicking the right mouse button on the project group name displays the following menus:   

Edit Project Group Name... Opens the [Project Group Name] dialog box.  

Add New Project... Opens a wizard to add a new project into the project.  

Insert Project... Opens the [Insert Project] dialog box.  

Select Tools... Opens the [Tool Version Settings] dialog box. 

Register order Displays the file names in the order in which they were registered.  

Ascending order Displays the file names in the ascending order.  

Fix Window Fixes the location of the [Project] window.  

(a)
(b)
(c)

(d)

(e)

(f)

(g)
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(b)   Project title name 
The project title is displayed.  If a title is not set, the file name without the path and extension is displayed.  The 
project title name can be set by the user freely, and up to 127 characters can be set.   
When the mouse cursor is placed on the project title name, the device name used in the projects is displayed as a pop-up.  

[Meaning of icons]

Clicking the right mouse button on the project title name displays the following menus:   

(c)   Source Files folder
Source files and assembler files registered in the project are grouped here.  The names of the source files regis-
tered to the project are displayed under the Source File folder.   Double-clicking a file name or pressing the 
[Enter] key after selecting a file name opens the file under the set editor (refer to [PM+ Settings] dialog box).  Up 
to 2048 source files can be registered per project.  
When the mouse cursor is placed on the source file folder, "Source Files" is displayed in a pop-up menu.  When 
the mouse cursor is placed on the source file name, the source file name indicated by the mouse cursor is dis-
played as a full path in a pop-up.  

[Meaning of icons]

Project set as the active project (by selecting the [Project] menu -> [Select Active Project...] or right 
mouse button -> [Set as Active Project])

Project not set as active project  

Set as Active Project Makes the selected project active.  

Build Starts the build processing.  

Compiler Options... Opens the Compiler Options dialog box.  

Assembler Options... Opens the Assembler Options dialog box.  

Edit Project Title... Opens the [Project Title] dialog box.  

Project Settings... Opens the [Project Settings] dialog box.  Changes the project title and so on.

Delete Project Deletes a selected project.  

Register order Displays the file names in the order in which they were registered.  

Ascending order Displays the file names in the ascending order.  

Fix Window Fixes the location of the [Project] window.  

Source file to which no compiler or assembler options have been set individually (by clicking the right 
mouse button -> [Special Compiler Options...] or [Special Assembler Options...]) 

Source file to which compiler or assembler options have been set individually

[Note] Only for projects using a real-time OS
Source file created by the configurator and to which no compiler or assembler options have been set 
individually
The name given by the tool DLL of the real-time OS is used as the file name.

[Note] Only for projects using a real-time OS
Source file created by the configurator and to which compiler or assembler options have been set indi-
vidually
The name given by the tool DLL of the real-time OS is used as the file name.

[Note]  Only for projects using Applilet2
Source file created by Applilet2 and to which no compiler or assembler options have been set individually

[Note]  Only for projects using Applilet2
Source file created by Applilet2 and to which compiler or assembler options have been set individually



CHAPTER 6  WINDOW REFERENCE

104 User’s Manual  U18416EJ1V0UM

Clicking the right mouse button on the source file folder or the source file name displays the following menus:   

[When a Source File folder is selected] 

[When a source file name is selected] 

[When an assembler source file is selected] 

[When a structured assembler source file is selected] 
These menu items become valid only when a project that uses  a 78K0 or 78K0S Microcontrollers is active.

[Caution]
The source file added using the [Add Source Files...] menu is added at the end of the source file list.  
The source file order can be changed on the [Source File] tab in the [Project Settings] dialog box.
Source files can also be added by directly dragging the source file into the [Project] window.

Add Source Files... Opens the [Add Source Files] dialog box.  

Compiler Options... Opens the Compiler Options dialog box.  

Assembler Options... Opens the Assembler Options dialog box.  

Add Source Files... Opens the [Add Source Files] dialog box.  

Delete Source File Deletes a selected source file from the project.  

Compile Compiles a selected file.  

Open Opens a selected file under the set editor.  

Special Compiler Options... Opens the Compiler Options dialog box.  
When options are set to a file, the icon of the file displays in green.  

Reset Special Compiler Options Cancels compiler options set to a file.  

Properties... Opens the [Properties] dialog box to display the properties of a selected file.  

Add Source Files... Opens the [Add Source Files] dialog box.  

Delete Source File Deletes a selected source file from the project.  

Compile Compiles a selected file.  

Open Opens a selected file under the set editor.  

Special Assembler Options... Opens the Assembler Options dialog box.  
When options are set to a file, the icon of the file displays in green.  

Reset Special Assembler Options Cancels assembler options set to a file.  

Properties... Opens the [Properties] dialog box to display the properties of a selected file.  

Add Source Files... Opens the [Add Source Files] dialog box.  

Delete Source File Deletes a selected source file from the project.  

Compile Compiles a selected file.  

Open Opens a selected file under the set editor.  

Special Structured Assembler 
Options...

Opens the Structured Assembler Options dialog box.  
When options are set to a file, the icon of the file displays in green.  

Reset Special Structured 
Assembler Options

Cancels structured assembler options set to a file.  

Properties... Opens the [Properties] dialog box to display the properties of a selected file.  
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(d)   Function name
The names of the functions in C language existing in the source files are displayed.  Double-clicking a function 
name or pressing the [Enter] key after selecting a function name displays the function definition line under the set 
editor (refer to [PM+ Settings] dialog box).    
When the mouse cursor is placed on the function file name, the function name indicated by the mouse cursor is 
displayed in a pop-up.  

Clicking the right mouse button on the function file name displays the following menus:   

[Caution]
- The source file added using the [Add Source Files...] menu is added at the end of the source file list.  

The source file order can be changed on the [Source File] tab in the [Project Settings] dialog box.
Source files can also be added by directly dragging the source file into the [Project] window.

- If, after a function name has been changed in the Edit window and the function name is updated in the 
[Project] window, the Edit window change status is undone using the [Undo]/[Redo] menu items, the function 
name is not updated even if the [Project] window is made active. It is updated when build or save is per-
formed.

(e)   Include Files folder
Include files registered in the project are grouped here. Source files that have a dependency relationship with 
include files are also displayed.  Double-clicking a file name or pressing the [Enter] key after selecting a file name 
opens the file under the set editor.  
When the mouse cursor is placed on the include file folder, "Include Files" is displayed in a pop-up menu.  When 
the mouse cursor is placed on the file name, the file name indicated by the mouse cursor is displayed as a full 
path in a pop-up.  

[Meaning of icons]

Add Source Files... Opens the [Add Source Files] dialog box.  

Delete Source File Deletes a selected source file from the project.  

Compile Compiles a selected file.  

Open Opens a selected file under the set editor.  

Special Compiler Options... Opens the Compiler Options dialog box.  

Reset Special Compiler Options Cancels compiler options set to a file.  

Properties... Opens the [Properties] dialog box to display the properties of a selected file.  

File format in other than binary 

[Note] Only for projects using a real-time OS
File created by the configurator
The name given by the tool DLL of the real-time OS is used as the file name.

[Note] Only for projects using Applilet2
File created by the configurator
The name given by the tool DLL of the real-time OS is used as the file name.
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Clicking the right mouse button on the include file folder,  the file name or displays the following menus:   

[When a Include Files folder is selected] 

[When a include file name is selected] 

[When a dependency relationship file name is selected] 

(f)   Project Related Files folder
The related files (link directive files and library files) to build the project are grouped here.  Double-clicking a file 
name or pressing the [Enter] key after selecting a file name opens the file under the set editor. (refer to [PM+ Set-
tings] dialog box).    
When the mouse cursor is placed on the project-related file folder, "Project Related Files" is displayed in a pop-
up menu.  When the mouse cursor is placed on the project-related file name, the project-related file name indi-
cated by the mouse cursor is displayed as a full path in a pop-up.  
In a project that uses a real-time OS, the name of the configuration file used is automatically registered.

[Meaning of icons]

Clicking the right mouse button on the project-related file folder or the project-related file name displays the fol-
lowing menus:   

[When a Project Related Files folder is selected]

Update Dependencies Updates a dependency relationship between source files and include files, and 
reflects the updated contents in the [Project] window.  

Compiler Options... Opens the Compiler Options dialog box.  

Assembler Options... Opens the Assembler Options dialog box.  

Update Dependencies Updates a dependency relationship between source files and include files, and 
reflects the updated contents in the [Project] window.  

Open Opens a selected file under the set editor.  

Compiler Options... Opens the Compiler Options dialog box.  

Assembler Options... Opens the Assembler Options dialog box.  

Properties... Opens the [Properties] dialog box to display the properties of a selected file.  

Update Dependencies Updates a dependency relationship between source files and include files, and 
reflects the updated contents in the [Project] window.  

Open Opens a selected file under the set editor.  

Compiler Options... Opens the Compiler Options dialog box.  

Assembler Options... Opens the Assembler Options dialog box.  

Properties... Opens the [Properties] dialog box to display the properties of a selected file.  

File format in other than binary 

Binary file, such as an object file or library file (cannot be edited)

Add Project Related Files... Opens the [Add Project Related Files] dialog box.  

Compiler Options... Opens the Compiler Options dialog box.  

Assembler Options... Opens the Assembler Options dialog box.  
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[When a project related file name is selected] 

(g)   Other Files folder
The user can register any file freely.  Double-clicking a file name or pressing the [Enter] key after selecting a file 
name starts up un application in accordance with the file association.  Up to 100 other files can be registered per 
project.  
When the mouse cursor is placed on the other file folder, "Other Files" is displayed in a pop-up menu.  When the 
mouse cursor is placed on the other file name, the other file name indicated by the mouse cursor is displayed as 
a full path in a pop-up.  

Clicking the right mouse button on the other file folder or the other file name displays the following menus:   

[When an Other Files folder is selected] 

[When an other file name is selected] 

Add Project Related Files... Opens the [Add Project Related Files] dialog box.  

Delete Project Related Files Deletes a selected file.  

Open Opens a selected file under the set editor.  

Open with Link Directive Generator 
filename

Opens a selected file using the LDG.  
This menu item is valid only when all the following conditions are satisfied.
- A link directive file has been selected.
- The LDG has been installed.
- A project that uses a V850 Microcontrollers device is active.

Compiler Options... Opens the Compiler Options dialog box.  

Assembler Options... Opens the Assembler Options dialog box.  

Properties... Opens the [Properties] dialog box to display the properties of a selected 
file.  

Add Other Files... Opens the [Add Other Files] dialog box.  

Compiler Options... Opens the Compiler Options dialog box.  

Assembler Options... Opens the Assembler Options dialog box.  

Add Other Files... Opens the [Add Other Files] dialog box.  

Deletes Other Files Deletes a selected file from the Other Files folder

Open Starts up an application in accordance with the file association.

Open with Editor Opens a selected file under the set editor.  

Compiler Options... Opens the Compiler Options dialog box.  

Assembler Options... Opens the Assembler Options dialog box.  

Properties... Opens the [Properties] dialog box to display the properties of a selected file.  



CHAPTER 6  WINDOW REFERENCE

108 User’s Manual  U18416EJ1V0UM

(2)   [Memo] tab

The [Memo] tab displays the memo information specified for a workspace. 
Memo information is managed in workspace units. 

Figure 6-6   [Project] Window - [Memo] Tab

The contents of the memo can be added with the right mouse button.  

Add Memo... Opens the [Add New Memo] dialog box.  
Records the contents of the memo with the date and time onto the [Memo] tab

Delete Memo... Deletes a selected memo.  
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 Drag-and-drop function

The following operations are achieved by dropping a file in the [Project] window.  The operation differs depending on 
whether or not the workspace is open.  

[When not opening a workspace]

- When dropping a workspace file (.prw extension)  
Opens the dropped workspace.  
Multiple workspace files cannot be dropped.  A workspace file and project file cannot be dropped together.  

- When dropping a project file (.prj extension)  
Opens the workspace corresponding to the project file that was dropped.  
Multiple project files cannot be dropped.  A workspace file and project file cannot be dropped together.  

- When dropping a file other than a workspace file or project file  
Opens the file that was dropped in the Edit window.  If "Untitled1" exists in the Edit window while the [OutPut] win-
dow is not displayed, "Untitled1" is closed when the file that was dropped is opened.  
Multiple files can be dropped.  

[When opening an empty workspace file]

- When dropping a workspace file (.prw extension)  
Closes the workspace and then opens the workspace that was dropped.  
Multiple workspace files cannot be dropped.  A workspace file and project file cannot be dropped together.  

- When dropping a project file (.prj extension)  
Creates a project group newly and add a project file.  The newly created project group name is the device 
microcontrollers name used in the added project file.  
When multiple project files are dropped, if the dropped project file uses the same device, it is registered to the same 
project group.  If the device microcontrollers is the same but the device name differs, a number is suffixed to the 
project group name.  Such numbers are suffixed from "1".  A workspace file and project file cannot be dropped 
together.  

- When dropping a file other than a workspace file or project file  
Opens the file that was dropped in the Edit window.  If "Untitled1" exists in the Edit window while the [OutPut] win-
dow is not displayed, "Untitled1" is closed when the file that was dropped is opened.  
Multiple files can be dropped.  

- When dropping a workspace file and a file other than the workspace file together
Closes the workspace and then opens the workspace that was dropped.  Opens other files that was dropped in the 

Edit window.  If "Untitled1" exists in the Edit window while the [OutPut] window is not displayed, "Untitled1" is 
closed when the file that was dropped is opened.  

- When dropping a project file and a file other than the project file together
Creates a project group newly and add a project file.  Other dropped file is added as a source file to the added 
project and opened in the Edit window.  
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[When opening a workspace for which project is registered]

When opening a workspace for which project is registered is opened, the operation differs depending on the location 
where the file was dropped.  

Figure 6-7   Position where a File is Dropped in a Workspace for which Project is Registered

- When dropping a workspace file (.prw extension)  
The operation is the same regardless of where the file is dropped.  Closes the workspace and then opens the work-
space that was dropped.  
Multiple workspace files cannot be dropped.  A workspace file and project file cannot be dropped together.  

- When dropping a project file (.prj extension)  
The operation differs depending on where the file was dropped.  
If the project file is dropped at (1) or (2), a project is added to the project group at the drop location.  
If the project file is dropped at (3), a newly project group is created and the file is added.  The newly created project 
group name is the device microcontrollers name used in the added project file.  
Multiple files can be dropped.  A workspace file and project file cannot be dropped together.  

- When dropping a file other than a workspace file or project file  
Operation is performed considering that a source file was added.  The operation differs depending on where the file 
was dropped.  
If the file is dropped at (1), the [Select Project] dialog box is displayed to select the project to which the source file is 
added.  The projects that can be selected are projects affiliated with the project group at the drop location.  
If the file is dropped at (2), the file is added as a source file treating that project as the addition target project since 
there is one project affiliated with the project group at the drop location.  
(If the file is dropped at (3), the [Select Project] dialog box is displayed to select the project to which the source file 
is added.  The projects that can be selected are all projects registered to the workspace.  
Multiple files can be dropped.  

(1)

(2)

(3)
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[Caution]
The source file is added at the end of the source file list. 
The source file order can be changed using the [Source File] tab in the [Project Settings] dialog box.

- When dropping a workspace file and a file other than the workspace file together
Closes the workspace and then opens the workspace that was dropped.  Opens other files that was dropped in the 

Edit window.  If "Untitled1" exists in the Edit window while the [OutPut] window is not displayed, "Untitled1" is 
closed when the file that was dropped is opened.  

- When dropping a project file and a file other than the project file together
The operation differs depending on where the file was dropped.  
(If the file is dropped at (1) or (2), a project is added to the project group at the drop location.  Other dropped file is 
considered that was added as a source file and the [Select Project] dialog box is displayed to select the project to 
which the source file is added.  
If the project file is dropped at (3), a newly project group is created and the file is added.  The newly created project 
group name is the device microcontrollers name used in the added project file.  Other dropped file is considered 
that was added as a source file and the [Select Project] dialog box is displayed to select the project to which the 
source file is added.  The projects that can be selected are all projects registered to the workspace.  

[Caution]
The source file is added at the end of the source file list. 
The source file order can be changed using the [Source File] tab in the [Project Settings] dialog box.
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Edit window

The Edit window is used to edit source programs.  

Figure 6-8   Edit Window

This section describes the following items:  

- Opening

- Character input

- Definitions of words

- Range selection

- Moving lines/layers

- Copying lines/layers

- Operations performed by double-clicking the mouse button

- Operations performed with the right mouse button

- Scrolling

- Smart lookup function

- Drag-and-drop function

- Restrictions on the Edit window

Opening

- Select the [File] menu -> [New].  

- Select the [Build] menu -> [Edit].  

- Select the [File] menu -> [Open...], and specify the file to be open.  

- Double-click a icon of the file on the [Project] window.  
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Character input

When editing files in the Edit window, you must observe the following character input rules:

- If the [Enter] key is used, a new line is inserted following the current line.  If, at this time, the current line does not 
have any lower layer, or if the lower layer has been collapsed, the new line will have the same layer as the current 
line.  If the current line has a lower layer and the layer is expanded, the new line will have the lower layer.  

- When you are selecting a range or moving lines by dragging, character input is ignored.  

- Selecting a line range and then pressing the [Tab] key causes a Tab code to be inserted at the beginning of the 
selected lines.  At this time, the Tab code is also inserted at the lines of layer which has been collapsed.  

- Selecting a line range and then pressing the [Shift] + [Tab] key combination causes the Tab code at the beginning of 
the selected lines to be deleted.  At this time, the Tab code at the lines of layer which has been collapsed is also 
deleted .  

Definitions of words

When handling a word in the Edit window, the definitions of "words" are as follows: 

- Consecutive single-byte alphanumeric characters and underscores.  

- Consecutive characters other than the above (excluding tabs and spaces).  

Range selection

When handling a range selection in the Edit window, you must observe the following range selection rules: 

- A range can be selected by dragging, using the [Shift] + [arrow] key, or by using [Shift] + click.  

- With a single line, a range can be selected in units of characters. (character strings range selection) 

- With multiple lines, a range can be selected between the beginning and end of each line. (lines range selection)  

- If multiple lines with a layer are selected as a range, any lower layers are automatically included in the range.  

- When you select multiple lines toward the beginning of file, if a layer higher than that of the range selection start line 
appears, the range selection cannot be performed any further.  

- When you select multiple lines toward the end of file, if a layer higher than that of the range selection start line 
appears, the range selection cannot be performed any further.  

- When you select multiple lines toward the beginning of file, if you select a line with a expanded lower layer, the lower 
layer is included in the range.

- When you select multiple lines toward the end of file, if you select a line with a expanded lower layer, the lower layer 
is included in the range.

- When you select a range using [Shift] + click, if you cannot select the range up to the click position, the range up to 
the last line where range selection is possible is selected, and the screen is scrolled so that line is visible.  

- Range selection is canceled at the point when an operation that causes the caret to move is performed.  Then the 
caret moves to a new location.  If, however, range selection is canceled by pressing an [arrow] key, the new caret 
position will be as follows:  

[Right arrow] key or [Down arrow] key:
Right end of the selected character string range, end of the last line (toward the end of text) of the selected line 
range

[Left arrow] key or [Up arrow] key: 
Left end of the selected character string range, beginning of the first line (toward the beginning of text) of the 
selected line range

-  While you are selecting a range, pressing the [Esc] key causes the range selection to be canceled.  
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Moving lines/layers

When you drag the mark at the beginning of line, the line(s) is moved with either of the following marks displayed.  

Dragging the mark of a line with a lower layer causes the line and the lower layer to be moved.  Dragging the mark of a 
line to the right or left causes the layer level to be changed.  

Copying lines/layers

When you drag the mark at the beginning of line while holding down the [Ctrl] key, the line(s) is copied with either of the 
following marks displayed.  

Dragging the mark of a line with a lower layer causes the line and the lower layer to be copied.  

Operations performed by double-clicking the mouse button

The operation performed by double-clicking the mouse button can be specified as either of the following, with the [Tool] 
menu -> [PM+ Settings...] - [Edit] tab.  

- Expands a collapsed layer or collapses an expanded layer.  

- Selects a word range.

Operations performed with the right mouse button

When you click the right mouse button in the Edit window, the following menu items are displayed:  
These menu items can be changed with the [Tool] menu -> [Customize...].  

Cut Sends the character string or lines selected with range selection to the clipboard and deletes them.  

Copy Sends the character string or lines selected with range selection to the clipboard.  

Paste Inserts the contents of the clipboard at the caret position.  

Undo Cancels the effect of an edit operation to restore the previous state.  

Redo Cancels the effect of an [Undo] operation.  

Find... Searches for the specified character string.  

Replace... Replaces the specified character string with the replacement character string.  

Expand Expands one of the lower layers.  

Collapse Collapses one of the lower layers.  

Promote Promotes the layer of line by one.  

Demote Demotes the layer of line by one.  



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U18416EJ1V0UM 115

Scrolling

The operation of scrolling can be specified with the [Tool] menu -> [PM+ Settings...] - [Scroll] tab.  Also, the scroll bars 
can be toggled between on and off by specifying with the [Tool] menu -> [PM+ Settings...] - [View] tab.  

Smart lookup function

The smart look-up function helps users input data by displaying a list of function names after just a part of the code is 
written during coding.  

To use the smart lookup function, select the [Smart Look up Function Use] check box on the [Tool] menu -> [PM+ Set-
tings...] - [Edit] tab.  

[Note]
When using a real-time OS, the system call name also is regarded as the target of the smart lookup function using the 
keyword file provided by the real-time OS.  

(1)   List of candidate function names 

The function names that match the specified number of characters are displayed.   Up to 1998 function name char-
acters can be recognized.  The maximum number of user registered function candidates is 64.  
To use this function, select the [Function List display] check box on the [Tool] menu -> [PM+ Settings...] - [Edit] tab.  
And also, the number of characters is specified with the [Display the List at more than xxx character(s)] on the 
same [Edit] tab.  

[Caution]
If there is only one candidate in the function name list, the list is not displayed even by pressing the [Up arrow] 
key and [Down arrow] keys on the keyboard. To hide the list, press the [Esc] key.

(2)   Detailed display of functions

When a "(" is entered, if the character string preceding the "(" matches the name of an existing function, the details 
of the function (type, return values, and arguments) are displayed.

Displays a list of candidate function names 

Displays type, return values, arguments of the function
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(3)   Data creation

When a new file is created and not yet assigned a file name, or when a file is being edited and not yet saved, any 
functions added as a result of editing are reflected in the smart lookup function as data.  
The timing for creating data used by the smart lookup function is as follows:

- When a file is saved.

- When the [Smart Look up Function Use] is selected.

- When a file is saved automatically before a build (only modified files).

- When a workspace is opened.

[Caution]
- A function name cannot be recognized with the compiler control instructions indicated below:  

- When the function name differs according to the value of #ifdef

- When function name extends over 2 lines with "\" 

- When variable declaration is performed between function name and "{"

- In the case of a function name without a return value, such as shown below, the character on the preceding line 
are judged to be the return value. In such a case, declare the function type. 

void

#ifdef ENGLISH

FncEng

#else

FncJapan

#endif

(int Cnt, int Mode)

{  ...

void Function         \
Name

(int Cnt. int Mode)

{   ...

void Function         \
Name

(int Cnt. int Mode)

{   ...

#ifdef ENGLISH

int main( argc, argv[])

int argr;

char* argv[];

{

}

a.def

main(){}
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(4)   Display specifications  

The function name candidate and function details displayed by the smart lookup function differ depending on 
whether the workspace is opened or closed.  

[When editing source file affiliated with workspace, with workspace in opened state]  
The function name candidates are displayed based on the information of the source file affiliated with the work-
space.  If multiple projects exist, the function name candidates are displayed based on the function information of 
all the projects.  

[When editing source file not affiliated with workspace, with workspace in opened state]  
The function name candidates are displayed based on the function information in that Edit window.  The function 
name candidates of the source file affiliated with the workspace are not displayed.  

[When workspace is in closed state]  
The function name candidates are displayed based on the function information in that Edit window.  

 Drag-and-drop function

The following operations are achieved by dropping a file in the Edit window.  

- When dropping a workspace file (.prw extension)  
Opens the dropped workspace.  If another workspace is already open, closes that workspace and then opens the 
workspace that was dropped.  
Multiple workspace files cannot be dropped.  A workspace file and project file cannot be dropped together.  

- When dropping a project file (.prj extension)  
Opens the workspace corresponding to the project file that was dropped.  If another workspace is already open, 
closes that workspace and then opens the workspace corresponding to the project file that was dropped.  
Multiple project files cannot be dropped.  A workspace file and project file cannot be dropped together.  

- When dropping a file other than a workspace file or project file
Opens the file that was dropped in the Edit window.  If "Untitled1" exists in the Edit window while the [OutPut] win-
dow is not displayed, "Untitled1" is closed when the file that was dropped is opened.  
Multiple files can be dropped.  

Restrictions on the Edit window

The following restrictions apply in the Edit window.  

- A maximum of 5,119 characters can be entered per line.  

- The maximum allowable number of layers is 127.  A line for which 128 or more layers is specified is corrected to a 
line with 127 layers.  No message is displayed.  

- The maximum allowable number of lines is 2,097,152.  If an attempt is made to enter more lines, a message is dis-
played.  

- When a file being edited is deleted, a message is displayed.  



CHAPTER 6  WINDOW REFERENCE

118 User’s Manual  U18416EJ1V0UM

Search result display window

The Search result display window displays the result of the search performed by selecting  [Find in Files...] or [Find in 
Project] menu item.  

Figure 6-9   Search Result Display Window

This section describes the following items:  

- Opening

- Explanation of each area

- Search results display area

- Drag-and-drop function

Opening

- Select the [Find] menu -> [Find in Files...]. 

- Select the [Find] menu -> [Find in Project]. 

Explanation of each area

(1)   Title bar

This area displays information "searched-character-string - searched-file-name search-result-file-name".
If this window is newly opened, "Untitledx" (x: number) is displayed for "search-result-file-name".

(2)   Search results display area

This area displays the results of the search.
Up to 5,119 characters are displayed as the search results in the format of "file-name (number-of-the-line-on-which-
the-character-string-is found) contents-of-the line-on-which- character-string-is-found". 
Note that 5120 or more character cannot be displayed.

(1)

(2)
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Operations performed by double-clicking the mouse button

Double-clicking a line without a lower layer will tag-jump to the corresponding place in the Edit window.
Double-clicking a line with a lower layer will follow the setting on the [Tool] menu -> [PM+ Settings...] - [Edit] tab. On the 

[Edit] tab, either of the following can be selected.

- Expands a collapsed layer or collapses an expanded layers.  

- Selects a word.

Drag-and-drop function

The following operations are achieved by dropping a file in the Search result display window.  

- When dropping a workspace file (.prw extension)  
Opens the dropped workspace.  If another workspace is already open, closes that workspace and then opens the 
workspace that was dropped.  
Multiple workspace files cannot be dropped.  A workspace file and project file cannot be dropped together.  

- When dropping a project file (.prj extension)  
Opens the workspace corresponding to the project file that was dropped.  If another workspace is already open, 
closes that workspace and then opens the workspace corresponding to the project file that was dropped.  
Multiple project files cannot be dropped.  A workspace file and project file cannot be dropped together.  

- When dropping a file other than a workspace file or project file
Opens the file that was dropped in the Edit window.  If "Untitled1" exists in the Edit window while the [OutPut] win-
dow is not displayed, "Untitled1" is closed when the file that was dropped is opened.  
Multiple files can be dropped.  
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[OutPut] window

The [OutPut] window displays the execution status of the make file during build processing.  On second and subsequent 
opens, this window re-displays the status when the window was exited previously.  

Regarding the execution status, error lines and warning lines are displayed in red and blue, respectively. 

Figure 6-10   [OutPut] Window

This section describes the following items:  

- Opening

- Explanation of each area

- Tag jump function

- Operations performed with the right mouse button

- Drag-and-drop function

Opening

- Select the menu item that perform build or compile processing from the [Build] menu. 

- [Select the [View] menu -> [Output Window].  

Explanation of each area

(1)   Execution status display area

This area displays the execution status of the make file during build processing.  

Tag jump function

When a caret is placed on an error or warning line in the [OutPut] window, double-clicking the left mouse button will 
make tag jump from the line at the caret position to the corresponding error or warning line.  

When a caret is placed on an error or warning number, pressing the [F1] key will display the help topic for the corre-
sponding error or warning.  

(1)
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Operations performed with the right mouse button

When you click the right mouse button in the [OutPut] window, the following menu items are displayed:  These menu 
items can be modified with [Tool] menu -> [Customize...].  

 Drag-and-drop function

The following operations are achieved by dropping a file in the [OutPut] window.  

- When dropping a workspace file (.prw extension)  
Opens the dropped workspace.  If another workspace is already open, closes that workspace and then opens the 
workspace that was dropped.  
Multiple workspace files cannot be dropped.  A workspace file and project file cannot be dropped together.  

- When dropping a project file (.prj extension)  
Opens the workspace corresponding to the project file that was dropped.  If another workspace is already open, 
closes that workspace and then opens the workspace corresponding to the project file that was dropped.  
Multiple project files cannot be dropped.  A workspace file and project file cannot be dropped together.  

- When dropping a file other than a workspace file or project file
Opens the file that was dropped in the Edit window.  
Multiple files can be dropped.  

Copy Sends the character string or lines selected with range selection to the clipboard.  

Clear Clears the contents of the [OutPut] window.  

Find... Searches for the specified character string.  

Find in Project Searches for the specified character string within the source files and the header files regis-
tered to a project.  

Fix Window Fixes the location of the [OutPut] window.  
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[New WorkSpace] wizard

This wizard is used to create a new workspace and its project.  
This wizard displays the following dialog boxes.  Enter/select the necessary information in each dialog box and click the 

[Next>] button to proceed.  

-  [New WorkSpace - Step 1/9 [Workspace Information]] dialog box

-  [New WorkSpace - Step 2/9 [Select Tools]] dialog box

-  [New WorkSpace - Step 3/9 [Select Real-Time OS]] dialog box

-  [New WorkSpace - Step 4/9 [Startup File]] dialog box

-  [New WorkSpace - Step 5/9 [Register Mode]] dialog box

-  [New WorkSpace - Step 6/9 [LinkDirective File]] dialog box

-  [New WorkSpace - Step 7/9 [Setup Source Files]] dialog box

-  [New WorkSpace - Step 8/9 [Select Debugger]] dialog box

-  [New WorkSpace - Step 9/9 [Confirmation]] dialog box

Figure 6-11   [New WorkSpace] Wizard at Starting

This section describes the following items:  

- Opening

- Wizard flow

- Explanation of each dialog box

Opening

- Select the [File] menu -> [New Workspace...] 
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Wizard flow

The dialog boxes to be displayed differ depending on the selection.  The wizard flow of each selection is shown below:  

Figure 6-12   Wizard Flow for Creating New Workspace

Explanation of each dialog box

The following explains each dialog box displayed in this wizard. 

Step 1/9 (Workspace Information) 

Step 4/9 (Startup File)

Check to "Create Blank Workspace" option Yes

No

Yes

Yes

No

No

Step 2/9 (Select Tools)

Create a library project?

Is a real-time OS specified as the tool used?

Step 3/9 (Select Real-Time OS)

Create a project for V850 Microcontrollers?

Check to "Use the Sample file" option

Step 6/9 (Link Directive File)

Step 5/9 (Register Mode)

Step 7/9 (Setup Source Files)

Create a library project?

Step 8/9 (Select Debugger)

Step 9/9 (Confirmation)

No

Yes

Yes

Yes

No

No
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[New WorkSpace - Step 1/9 [Workspace Information]] dialog box

Specify a workspace file name, a folder position, a project group name, and the device microcontrollers name of the tar-
get device to be used.  

The specification of the item marked with "*" in this dialog box can not be omitted (i.e. the [Next>] button can not be 
selected).  

Figure 6-13   [New WorkSpace - Step 1/9 [Workspace Information]] Dialog Box

(1)   Workspace File Name

Specify the name of the file to save the workspace information.  Up to 255 characters can be specified.  
The file extension is ".prw".  If the extension is omitted, it is automatically set to ".prw".  The file name which 
changed the workspace file extension "prw" to "prj" is assigned as the project file name.  
In addition, if a existing workspace file name is specified, the message dialog box is displayed after the [Next>] but-
ton is clicked, and then the existing workspace file will be renamed as backup file (e.g. test.prw -> test.prw.bak). 
If [Create Blank Workspace] is selected, only a workspace is created.  In this case, [Project Group Name], [Micro-
controllers Name], and [Device Name] become invalid.  

(2)   Folder

Specify the folder in which the workspace file and project file are stored.  
Selecting the [Browse...] button opens the [Browse for Folder] dialog box in which to specify the project folder posi-
tion.  The folder in which PM+.exe exists is default folder.  

(3)   Project Group Name

Specify the name of the project group to be displayed on the [Project] window.  Up to 127 characters can be speci-
fied.  
If the specification of this area is omitted, the name of the project group displayed on the [Project] window is the 
same as the name of the workspace file.  
In addition, the project title of the project newly created by this wizard is assigned the name of the project group 
specified with this area.  If you wish to change a project title, select the [Edit Project Title...] menu by clicking the 
mouse right button on the target project title in the [Project] window.  

(4)

(1)

(2)

(3)

(5)

(6)
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(4)   Microcontrollers Name and Device Name

Select the item to be created and the device file to be used from the drop-down list.  
Clicking the [Device Install] button starts the device file installer to register the new device file.  

(5)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(6)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(7)   Function buttons 

Button  Function

<Back This button is always disabled.  

Next> Opens the next step dialog box. (The next step dialog box to be opened differs depending on 
the selection. Refer to "Figure 6-12  Wizard Flow for Creating New Workspace".)  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[New WorkSpace - Step 2/9 [Select Tools]] dialog box

Specify the tool to be used in this dialog box.

Figure 6-14   [New WorkSpace - Step 2/9 [Select Tools]] Dialog Box

(1)   Tool Set

The combination of tools to be used and their versions is regarded as a tool set, and the tool set name can be 
selected from the drop-down list.  
The existing tool set and recommended tool set ("78Kx Microcontrollers Software Package Vx.xx" in the case of the 
78K Microcontrollers, and "V850 Microcontrollers Software Package Vx.xx" in the case of the V850 
Microcontrollers) are listed on the drop-down list.
If the tool set has been changed in the [Tool Version Detail Setting] dialog box opened by clicking the [Detail Set-
ting...] button, "(Changed)" is appended at the top of the tool set name.  If the tool set name already exists, the indi-
cation appended varies from "(Changed01)" to "(Changed99)".  After "(Changed99)", the tool set name is displayed 
as "UserSet".  

[Remark]
A file is saved as "tool-set-name.extension".  The extension varies depending on the product used, as shown 
below. 

78K0R Microcontrollers (including libraries): t0r
78K0 Microcontrollers (including libraries): tk0
78K0S Microcontrollers (including libraries): t0s
V850 Microcontrollers (including libraries): t85

Button Function

Save Saves the tool set currently selected in [Tool Set].
This button is not available (appears dimmed) if the tool set file is read-only.

Delete Deletes the tool set name selected in [Tool Set] from the list (also deletes the corresponding tool set file).
This button is not available (appears dimmed) if there are no tool set files corresponding to the 
selected tool set or the tool set file is read-only.

(1)

(2)

(3)

(4)
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The file is saved under "NEC Electronics\PM+" in the "Application Data" folder, which is accessible by all users.  
If this folder does not exist, it is automatically created when PM+ is started up (for example, "C:\Documents and 
Settings\All Users\Application Data\NEC Electronics\PM+" in the case of Windows XP).

(2)   Tool Versions

Combinations of tools to be used and their versions are displayed in this area.
When a tool set name is selected on the [Tool Set] drop-down list, the tools included in the tool set and their ver-
sions are displayed. 
The tools included in the default tool set selected on the [Tool Set] drop-down list and their versions are displayed 
by default.
The [Tool Version Detail Setting] dialog box is opened by clicking the [Detail Setting...] button.  Tools to be used 
and their versions can be selected in this dialog box.

(a)  Tool

All the installed tools and tools included in the selected tool set are displayed in this area (tools that have not 
been installed are displayed in gray).  

(b)  Version

The tool versions specified in the selected tool set are displayed in this area.  
However, "Unused" is displayed for a tool whose version is not specified in the tool set.

(c)  Select only Installed Tools

If this check box is selected, tools that have not been installed are excluded from the [Tool Versions] list box 
which corresponds to the tool set selected in the [Tool Set] (default).
 "(Selected01)" is appended to the top of the name of the tool set with which this check box is selected (if the tool 
set  name actually exists, "(Selected0n)" is appended).
This check box cannot be selected (grayed) if there are no dimmed tools (all the listed tools have been installed).

(3)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(4)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(5)   Function buttons 

Button  Function

<Back Returns to the previous wizard step.  

Next> Opens the next step dialog box. (The next step dialog box to be opened differs depending on 
the selection.  Refer to "Figure 6-12  Wizard Flow for Creating New Workspace".)  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[New WorkSpace - Step 3/9 [Select Real-Time OS]] dialog box

Specify whether or not to use NEC Electronics real-time OS.  
This dialog box is displayed only when a real-time OS has been selected as the combination of tools to be used in the 

[New WorkSpace - Step 2/9 [Select Tools]] dialog box.  

Figure 6-15   [New WorkSpace - Step 3/9 [Select Real-Time OS]] Dialog Box 

(1)   RTOS

When using the NEC Electronics real-time OS, select "the name of real-time OS", when not using that, select "Not 
use" from the drop-down list.  
"Not use" and all the names of the real-time OSs for the NEC Electronics V850 Microcontrollers that have been 
specified in the [New WorkSpace - Step 2/9 [Select Tools]] dialog box are displayed on the drop-down list. 
If the name of the real-time OS to be used is selected, the [RTOS Settings...] button becomes valid, and clicking 
this button opens the dialog box for setting the selected real-time OS in detail.  Refer to the user's manual of the 
real-time OS for details on the setting.  

(2)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(3)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(1)

(2)

(3)
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(4)   Function buttons 

Button  Function

<Back Returns to the previous wizard step.  

Next> Opens the next step dialog box. (The next step dialog box to be opened differs depending on 
the selection.  Refer to "Figure 6-12  Wizard Flow for Creating New Workspace".)  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[New WorkSpace - Step 4/9 [Startup File]] dialog box 

Specify a startup file.  
This dialog box is displayed only when "V850 Microcontrollers" has been specified as the microcontrollers name in the 

[New WorkSpace - Step 1/9 [Workspace Information]] dialog box.  

Figure 6-16   [New WorkSpace - Step 4/9 [Startup File]] Dialog Box 

(1)   Startup file specification area

(a)  Copy and Use the Sample file

If this option button is selected, the startup file of the sample that corresponds to the register mode set in the next 
wizard step is copied to the project folder and registered to the project-related files.  The name of the startup file 
to be registered is displayed in [The Startup File Name to register] edit box as an absolute path.  
The startup file name to be registered can be changed by clicking the [File Name...] button, or by directly inputting 
the name in the [The Startup File Name to register] edit box using the keyboard. 
If real-time OS is selected for use in the previous wizard step ([New WorkSpace - Step 3/9 [Select Real-Time 
OS]] dialog box), this option button cannot be selected.  

(b)  Use the Existing file

When an existing startup file is used, select this option button.  
If [Browse...] button is clicked, the [Startup File] dialog box is opened to select the any startup file.  The name of 
the startup file to be registered is displayed in [The Startup File Name to register] edit box as an absolute path.  
The startup file name to be registered can be changed by directly inputting the name in the [The Startup File 
Name to register] edit box using the keyboard. 
If this option button is selected, the [File Name...] button cannot be selected.  

(c)  Copy and Use the Existing file

When an existing startup file is copied and used, select this option button.  Specify the startup file name to be the 
copy source and the startup file name to be the copy destination.  
If [Browse...] button is clicked, the [Copy Startup File from] dialog box is opened to select the any startup file.  The 
name of the startup file to be the copy source is displayed in [Copy from] edit box as an absolute path.  Alterna-
tively, the file name to be specified can also be input in the [Copy from] edit box either as an absolute path or a 

(1)

(2)

(3)

(4)
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relative path using the keyboard.  
The startup file name to be registered can be changed by clicking the [File Name...] button, or by directly inputting 
the name in [The Startup File Name to register] edit box using the keyboard. 

(d)  Do Not specify now

When no startup file is specified now, select this option button.  
In this case, a startup file can be specified by selecting the project-related file folder on the [Project] window and 
then selecting [Add Project Related files...] using the right mouse button, or selecting the [Tool] menu -> [Linker 
Options...].  

(2)   The Startup File Name to register

Specify the name of the startup file to be registered.  
If [File Name...] button is clicked, the [Startup File to register] dialog box is opened to select the any startup file.  
Alternatively, the file name to be specified can also be input in this edit box either as an absolute path or a relative 
path using the keyboard.  

(3)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(4)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(5)   Function buttons 

[Caution]
If after selecting "Do Not specify now" for the startup file and registering the source file in the [New WorkSpace - Step 
7/9 [Setup Source Files]] dialog box, and then returning to this dialog box and specifying the source file registered in 
the [New WorkSpace - Step 7/9 [Setup Source Files]] dialog box as the startup file, and ending the wizard as is, the 
following linker option setting message is displayed, and the startup file is registered to both the source file and 
project-related files.  

"Startup file specification is illegal."  

Delete the startup file registered to the source file. 

Button  Function

<Back Returns to the previous wizard step.  

Next> Opens the next step dialog box. (The next step dialog box to be opened differs depending on 
the selection.  Refer to "Figure 6-12  Wizard Flow for Creating New Workspace".)  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[New WorkSpace - Step 5/9 [Register Mode]] dialog box 

Specify the register mode option for the compiler.  The sample file of the startup file corresponding to the register mode 
which is selected in this dialog box is copied to the project folder, and registered to the project-related files.  

This dialog box is displayed only when "V850 Microcontrollers" has been specified as the microcontrollers name in the 

[New WorkSpace - Step 1/9 [Workspace Information]] dialog box and [Copy and Use the Sample file] has been selected in 
the previous wizard step ([New WorkSpace - Step 4/9 [Startup File]] dialog box).  

Figure 6-17   [New WorkSpace - Step 5/9 [Register Mode]] Dialog Box 

(1)   Register mode specification area

(a)  22-Register Mode

The startup file is determined as the 22-register mode.  

(b)  26-Register Mode

The startup file is determined as the 26-register mode.  

(c)  32-Register Mode

The startup file is determined as the 32-register mode.  

(2)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(3)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(1)

(2)

(3)
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(4)   Function buttons 

[Caution] 
If the register mode of the compiler option is changed after a new workspace is created, the quasi directive indicat-
ing the register mode in the startup file may indicate a different mode from the register mode of the other source 
files.  Therefore, execute the relevant processing/measure from those shown below:  

- Modify the quasi directive that indicates the register mode in the startup file as follows: 

*) In 22-register mode 

*) In 26-register mode 

*) In 32-register mode 
Deletes ".option   reg_mode " line.  

- Ignore the following warning displayed at linking.  

Id850:  W4608:  input file have different register modes,  use "-rc" option for more information.

Button  Function

<Back Returns to the previous wizard step.  

Next> Opens the next step dialog box. (The next step dialog box to be opened differs depending on 
the selection.)  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  

#------------------------------
#    register  mode
#------------------------------
      .option   reg_mode  5 5

#------------------------------
#    register  mode
#------------------------------
      .option   reg_mode  7 7
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[New WorkSpace - Step 6/9 [LinkDirective File]] dialog box 

Specify a link directive file.  The specified link directive file is registered to the project-related files.  
This dialog box is displayed only when "V850 Microcontrollers" has been specified as the microcontrollers name in the 

[New WorkSpace - Step 1/9 [Workspace Information]] dialog box.  

Figure 6-18   [New WorkSpace - Step 6/9 [LinkDirective File]] Dialog Box 

(1)   Link directive file specification area

(a)  Create and Use the Sample file

If this option button is selected, a sample link directive file is created in the project folder in accordance with the 
selection in [Memory Usage] area and the selection of the OS in the [New WorkSpace - Step 3/9 [Select Real-
Time OS]] dialog box.  The link directive file is created under the name "project file name.dir" and registered to 
the project-related files automatically.  

- Memory Usage

The link directive file that is created is registered to the project-related files automatically.  The name of the link 
directive file to be registered is displayed in The Link Directive File Name to register edit box as an absolute path.  
The link directive file name to be registered can be changed by clicking the [File Name...] button, or by directly 
inputting the name in the "The Link Directive File Name to register" edit box using the keyboard.  
Refer to "APPENDIX A  SAMPLE LINK DIRECTIVE FILE" for the detail of the link directive file to be created.  

[Caution] 
The link directive file that is created must be customized in accordance with the target specification or user-
defined sections.  

Use Internal memory only The external ROM is mapped to the internal ROM area when the compiler is 
used in ROMless mode.

Use External memory The TEXT sections are mapped to the internal memory, and the DATA sections 
to the external memory.

(1)

(2)

(3)

(4)
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(b)  Use the Existing file

When an existing link directive file is used, select this option button.  
If [Browse...] button is clicked, the [Link Directive File] dialog box is opened to select the any startup file.  The 
name of the link directive file to be registered is displayed in [The Link Directive File Name to register ]edit box as 
an absolute path.  
The link directive file name to be registered can be changed by directly inputting the name in the [The Link Direc-
tive File Name to register] edit box using the keyboard.
If this option button is selected, the [File Name...] button cannot be selected.  

(c)  Copy and Use the Existing file

When an existing link directive file is copied and used, select this option button.  Specify the link directive file 
name to be the copy source and the link directive file name to be the copy destination.  
If [Browse...] button is clicked, the [Copy Link Directive File from] dialog box is opened to select the any startup 
file.  The name of the link directive file to be the copy source is displayed in [Copy from] edit box as an absolute 
path.  Alternatively, the file name to be specified can also be input in the [Copy from] edit box either as an abso-
lute path or a relative path using the keyboard.  
The link directive file name to be registered can be changed by clicking the [File Name...] button, or by directly 
inputting the name in [The Link Directive File Name to register] edit box using the keyboard.

(d)  Do Not specify now

When no link directive file is specified, select this option button.  
A link directive file can be specified by selecting a project-related file folder on the [Project] window and then 
selecting [Add Project Related files...] using the right mouse button, or selecting the [Tool] menu -> [Linker 
Options...] after exiting the wizard.  

(2)   The Link Directive File Name to register 

Specify the name of the link directive file to be registered.  
If [File Name...] button is clicked, the [Link Directive File to register] dialog box is opened to select the any startup 
file.  Alternatively, the file name to be specified can also be input in this edit box either as an absolute path or a rel-
ative path using the keyboard.  

(3)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(4)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(5)   Function buttons 

Button  Function

<Back Returns to the previous wizard step.  

Next> Opens the next step dialog box. (The next step dialog box to be opened differs depending on 
the selection.)  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[New WorkSpace - Step 7/9 [Setup Source Files]] dialog box 

Specify the name of the source file to be registered into the project.  

Figure 6-19   [New WorkSpace - Step 7/9 [Setup Source Files]] Dialog Box 

(1)   Source File Name

The names of the source files to be registered into the project are displayed in the source file list box.  
The source files are registered to the project file in the order currently shown in this list box.  In addition, the build 
processing are performed in the registered order.  

[Cautions]
- If the compiler and assembler are not installed, source file addition is not possible. 

- If, after a source file is added, the microcontrollers name is changed by returning to the [New WorkSpace - 
Step 1/9 [Workspace Information]] dialog box, files among the previously added file other than those with 
extensions corresponding to the microcontrollers after the change are also displayed in the source file list box. 
In this case, delete these source files. 

Button  Function

Add... Opens the [Add Source Files] dialog box to specify the source code files to be registered to the 
project.  Up to 2048 source files can be registered per project.  The extension of source code file 
differs depending on the microcontrollers name registered to the project.  

Remove Removes the selected file from the source file list box.  By selecting a file name while holding 
down the [Shift] or [Ctrl] key, multiple source file names can be selected at once.  The names of 
the removed files are not registered to the project.  
If no source file is selected or listed in the source file list box, this button can not be selected.  

Remove All Removes all the source files from the source file list box.  The names of the removed files are not 
registered to the project.  
If no source file is selected or listed in the source file list box, this button can not be selected.  

Up Moves the selected file up within the source file list box.  

Down Moves the selected file down within the source file list box.  

(1)

(2)

(3)
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- It is possible to proceed to the next step by clicking the [Next>] button even if no source files are specified in 
this dialog box.  In this case, source files can be registered into the project by specifying with the [Project Set-
tings] dialog box or dragging and dropping the source files to be registered onto the [Project] window.  

(2)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(3)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(4)   Function buttons 

Button  Function

<Back Returns to the previous wizard step.  

Next> Opens the next step dialog box. (The next step dialog box to be opened differs depending on 
the selection.   Refer to "Figure 6-12  Wizard Flow for Creating New Workspace".)  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[New WorkSpace - Step 8/9 [Select Debugger]] dialog box 

Select the debugger which debug the project to be created newly. 
The specification of the item marked with "*" in this dialog box can not be omitted (i.e. the [Next>] button can not be 

selected).  The debugger specified with this dialog box can be changed after exiting this wizard.  

Figure 6-20   [New WorkSpace - Step 8/9 [Select Debugger]] Dialog Box 

(1)   Debugger

Select the debugger to be used from the drop-down list.  All the NEC Electronics debuggers that have been 
installed are displayed in the drop-down list together with the corresponding microcontrollers name.  
When a debugger is selected from this list, the file name of the debugger is displayed in the [File Name] text box 
and the selected debugger will start up automatically when a debug operation is executed.  
If you wish to change the debugger to be used after exiting the wizard, select the [Tool] menu -> [Debugger Set-
ting...].  

(2)   File name

The file name of the debugger to be used for debugging is displayed.  When the debugger is selected by the 
[Debugger] drop-down list, that file name is displayed with the path automatically.  
This text box cannot be edited. 

(3)   Option

Specify the options for when starting up the debugger.  
If this specification is omitted, no option is specified for starting up the debugger. 

(4)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(5)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(2)

(1)

(3)

(4)

(5)
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(6)   Function buttons 

Button  Function

<Back Returns to the previous wizard step.  

Next> Opens the last step dialog box.  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[New WorkSpace - Step 9/9 [Confirmation]] dialog box 

The contents of the specification are confirmed and the wizard for creating a new workspace is terminated.  

Figure 6-21   [New WorkSpace - Step 9/9 [Confirmation]] Dialog Box 

(1)   Confirmation area 

The various information specified with this wizard for creating a new workspace is displayed.  
If the contents shown in this dialog box are correct, click the [Finish] button to terminate this wizard.  Then PM+ 
generates a new workspace file and a project file belonging to that workspace, according to the information dis-
played.  
Also generates a make file (project-file-name.mak) automatically.

(2)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(3)   Function buttons 

Button  Function

<Back Returns to the previous wizard step.  

Finish Terminates this wizard for creating a new workspace, and generates a new workspace file and 
a project file belonging to that workspace, according to the displayed information.  
Also generates a make file (project-file-name.mak) automatically.

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  

(1)

(2)
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[Add New Project] wizard

This wizard is used to add a new project to a workspace.  
This wizard displays the following dialog boxes.  Enter/select the necessary information in each dialog box and click the 

[Next>] button to proceed.  

- [Add New Project - Step 1/9 [Project Information] ]dialog box

- [Add New Project - Step 2/9 [Select Tools]] dialog box

- [Add New Project - Step 3/9 [Select Real-Time OS] ]dialog box

- [Add New Project - Step 4/9 [Startup File]] dialog box

- [Add New Project - Step 5/9 [Register Mode]] dialog box

- [Add New Project - Step 6/9 [LinkDirective File]] dialog box

- [Add New Project - Step 7/9 [Setup Source Files]] dialog box

- [Add New Project - Step 8/9 [Select Debugger]] dialog box

- [Add New Project - Step 9/9 [Confirmation]] dialog box

Figure 6-22   [Add New Project] Wizard at Starting

This section describes the following items:  

- Opening

- Wizard flow

- Explanation of each dialog box

Opening

- Select the [Project] menu -> [Add New Project...]  

- Click the right mouse button at a project group on the [Project] window, and select the  [Add New Project...]. 
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Wizard flow

The dialog boxes to be displayed differ depending on the selection.  The wizard flow of each selection is shown below:  

Figure 6-23   Wizard Flow for Add New Project 

Explanation of each dialog box

The following explains each dialog box displayed in this wizard. 

Step 1/9 (Project Information) 

Step 4/9 (Startup File)

No

Yes

Yes

No

No

Step 2/9 (Select Tools)

Create a library project?

Is a real-time OS specified as the tool used?

Step 3/9 (Select Real-Time OS)

Create a project for V850 Microcontrollers?

Check to [Use the Sample file] option

Step 6/9 (Link Directive File)

Step 5/9 (Register Mode)

Step 7/9 (Setup Source Files)

Create a library project?

Step 8/9 (Select Debugger)

Step 9/9 (Confirmation)

No

Yes

Yes

Yes

No
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[Add New Project - Step 1/9 [Project Information] ]dialog box

Specify a project group name, a project file name, a project folder position, a project title and the device microcontrollers 
name of the target device to be used.  

The specification of the item marked with "*" in this dialog box can not be omitted (i.e. the [Next>] button can not be 
selected).  

Figure 6-24   [Add New Project - Step 1/9 [Project Information]] Dialog Box

(1)   Workspace File Name

The file name of the workspace currently open is displayed with an absolute path.  

(2)   Project Group Name

Specify the name of the project group to be displayed on the [Project] window.  Up to 127 characters can be speci-
fied.  
To insert a project in an existing group, select the relevant group name from the drop-down list.  
If this specification is omitted, the name of the project group displayed on the [Project] window will be set as 
[Workspace File Name] without the path and extension.  

(3)   Project File Name

Specify the name of the file to save the project information of the newly added project.  Up to 255 characters can be 
specified. 
The extension of the file is "prj", which is appended automatically when the extension is omitted.  In addition, if an 
existing project file name is specified, the existing project file will be renamed as backup file (e.g. test.prj -> 
test.prj.bak) after the [Next>] button is clicked.  Then the message dialog box whether to create a new project file 
will be displayed.  

(4)   Project Folder

Specify the folder to save the project file of the newly added project.  
Selecting the [Browse...] button opens the Browse for Folder dialog box in which to specify the project folder posi-
tion.  

(1)

(2)

(3)

(4)

(5)

(6)

(8)

(7)
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(5)   Project Title

Specify the project title to be displayed in the [Project] window.  Up to 127 characters can be specified.  
If this specification is omitted, the project title will be set as the project file name without the path and extension.  

(6)   Microcontrollers Name and Device Name

Select the item to be created and the device file to be used from the drop-down list. 
If an existing project group name is displayed in [Project Group Name], the microcontroller name and device name 
that are set to the project are fixed (shaded).
If the device file for the device to be used has not been installed, the following message will be displayed under the 
device name displayed.

"The device file that has been selected is not registered."

When this message is displayed, clicking the [Device Install] button starts the device file installer to register the new 
device file.

(7)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(8)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(9)   Function buttons 

Button  Function

<Back This button is always disabled. 

Next> Opens the next step dialog box. (The next step dialog box to be opened differs depending on 
the selection.  Refer to "Figure 6-23  Wizard Flow for Add New Project".)  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[Add New Project - Step 2/9 [Select Tools]] dialog box

Specify the tool to be used in this dialog box.

Figure 6-25   [Add New Project - Step 2/9 [Select Tools]] Dialog Box

(1)   Tool Set

The combination of tools to be used and their versions is regarded as a tool set, and the tool set name can be 
selected from the drop-down list.  
The existing tool set and recommended tool set ("78Kx Microcontrollers Software Package Vx.xx" in the case of the 
78K Microcontrollers, and "V850 Microcontrollers Software Package Vx.xx" in the case of the V850 
Microcontrollers) are listed on the drop-down list.
If the tool set has been changed in the [Tool Version Detail Setting] dialog box opened by clicking the [Detail Set-
ting...] button, "(Changed)" is appended at the top of the tool set name.  If the tool set name already exists, the indi-
cation appended varies from "(Changed01)" to "(Changed99)".  After "(Changed99)", the tool set name is displayed 
as "UserSet".  

[Remark]
A file is saved as "tool-set-name.extension".  The extension varies depending on the product used, as shown 
below. 

78K0R Microcontrollers (including libraries): t0r
78K0 Microcontrollers (including libraries): tk0
78K0S Microcontrollers (including libraries): t0s
V850 Microcontrollers (including libraries): t85

Button Function

Save Saves the tool set currently selected in [Tool Set].
This button is not available (appears dimmed) if the tool set file is read-only.

Delete Deletes the tool set name selected in [Tool Set] from the list (also deletes the corresponding tool set file).
This button is not available (appears dimmed) if there are no tool set files corresponding to the 
selected tool set or the tool set file is read-only.

(1)

(2)

(4)

(3)
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The file is saved under "NEC Electronics\PM+" in the "Application Data" folder, which is accessible by all users.  
If this folder does not exist, it is automatically created when PM+ is started up (for example, "C:\Documents and 
Settings\All Users\Application Data\NEC Electronics\PM+" in the case of Windows XP).

(2)   Tool Versions

Combinations of tools to be used and their versions are displayed in this area.
When a tool set name is selected on the [Tool Set] drop-down list, the tools included in the tool set and their ver-
sions are displayed. 
The tools included in the default tool set selected on the [Tool Set] drop-down list and their versions are displayed 
by default.
The [Tool Version Detail Setting] dialog box is opened by clicking the [Detail Setting...] button.  Tools to be used 
and their versions can be selected in this dialog box.

(a)  Tool

All the installed tools and tools included in the selected tool set are displayed in this area (tools that have not 
been installed are displayed in gray).  

(b)  Version

The tool versions specified in the selected tool set are displayed in this area.  
However, "Unused" is displayed for a tool whose version is not specified in the tool set.

(c)  Select only Installed Tools

If this check box is selected, tools that have not been installed are excluded from the [Tool Versions] list box 
which corresponds to the tool set selected in the [Tool Set] (default).
 "(Selected01)" is appended to the top of the name of the tool set with which this check box is selected (if the tool 
set  name actually exists, "(Selected0n)" is appended).
This check box cannot be selected (grayed) if there are no dimmed tools (all the listed tools have been installed).

(3)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(4)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(5)   Function buttons 

Button  Function

<Back Returns to the previous wizard step.  

Next> Opens the next step dialog box. (The next step dialog box to be opened differs depending on 
the selection.  Refer to "Figure 6-23  Wizard Flow for Add New Project".)  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[Add New Project - Step 3/9 [Select Real-Time OS] ]dialog box

Specify whether or not to use NEC Electronics real-time OS.  
This dialog box is displayed only when a real-time OS has been selected as the combination of tools to be used in the 

[Add New Project - Step 2/9 [Select Tools]] dialog box.    

Figure 6-26   [Add New Project - Step 3/9 [Select Real-Time OS]] Dialog Box

(1)   RTOS

When using the NEC Electronics real-time OS, select "the name of real-time OS", when not using that, select "Not 
use" from the drop-down list.  
"Not use" and all the names of the real-time OSs for the NEC Electronics V850 Microcontrollers that have been 
specified in the [Add New Project - Step 2/9 [Select Tools]] dialog box are displayed on the drop-down list. 
If the name of the real-time OS to be used is selected, the [RTOS Settings...] button becomes valid, and clicking 
this button opens the dialog box for setting the selected real-time OS in detail.  Refer to the user's manual of the 
real-time OS for details on the setting.  

(2)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(3)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(1)

(3)

(2)
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(4)   Function buttons 

Button  Function

<Back Returns to the previous wizard step.  

Next> Opens the next step dialog box. (The next step dialog box to be opened differs depending on 
the selection.  Refer to "Figure 6-23  Wizard Flow for Add New Project".)  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[Add New Project - Step 4/9 [Startup File]] dialog box

Specify the startup file to be used by a option button.  
This dialog box is displayed only when "V850 Microcontrollers" has been specified as the microcontrollers name in the 

[Add New Project - Step 1/9 [Project Information] ]dialog box.  

Figure 6-27   [Add New Project - Step 4/9 [Startup File]] Dialog Box

(1)   Startup file specification area

(a)  Copy and Use the Sample file

If this option button is selected, the startup file of the sample that corresponds to the register mode set in the next 
wizard step is copied to the project folder and registered to the project-related files.  The name of the startup file 
to be registered is displayed in [The Startup File Name to register] edit box as an absolute path.  
The startup file name to be registered can be changed by clicking the [File Name...] button, or by directly inputting 
the name in the [The Startup File Name to register] edit box using the keyboard. 
If real-time OS is selected for use in the previous wizard step ([Add New Project - Step 3/9 [Select Real-Time OS] 
]dialog box), this option button cannot be selected.  

(b)  Use the Existing file

When an existing startup file is used, select this option button.  
If [Browse...] button is clicked, the [Startup File] dialog box is opened to select the any startup file.  The name of 
the startup file to be registered is displayed in [The Startup File Name to register] edit box as an absolute path.  
The startup file name to be registered can be changed by directly inputting the name in the [The Startup File 
Name to register] edit box using the keyboard. 
If this option button is selected, the [File Name...] button cannot be selected.  

(c)  Copy and Use the Existing file

When an existing startup file is copied and used, select this option button.  Specify the startup file name to be the 
copy source and the startup file name to be the copy destination.  
If [Browse...] button is clicked, the [Copy Startup File from] dialog box is opened to select the any startup file.  The 
name of the startup file to be the copy source is displayed in [Copy from] edit box as an absolute path.  Alterna-
tively, the file name to be specified can also be input in the [Copy from] edit box either as an absolute path or a 

(1)

(2)

(4)

(3)
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relative path using the keyboard.  
The startup file name to be registered can be changed by clicking the [File Name...] button, or by directly inputting 
the name in [The Startup File Name to register] edit box using the keyboard. 

(d)  Do Not specify now

When no startup file is specified now, select this option button.  
In this case, a startup file can be specified by selecting the project-related file folder on the [Project] window and 
then selecting [Add Project Related files...] using the right mouse button, or selecting the [Tool] menu -> [Linker 
Options...].  

(2)   The Startup File Name to register 

Specify the name of the startup file to be registered.  
If [File Name...] button is clicked, the [Startup File to register] dialog box is opened to select the any startup file.  
Alternatively, the file name to be specified can also be input in The Startup File Name to register edit box edit box 
either as an absolute path or a relative path using the keyboard.  

(3)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(4)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(5)   Function buttons 

[Caution]
If after selecting "Do Not specify now" for the startup file and registering the source file in the [Add New Project - Step 
7/9 [Setup Source Files]] dialog box, and then returning to this dialog box and specifying the source file registered in 
the [Add New Project - Step 7/9 [Setup Source Files]] dialog box as the startup file, and ending the wizard as is, the 
following linker option setting message is displayed, and the startup file is registered to both the source file and 
project-related files.  

"Startup file specification is illegal."  

Delete the startup file registered to the source file. 

Button  Function

<Back Returns to the previous wizard step.  

Next> Opens the next step dialog box. (The next step dialog box to be opened differs depending on 
the selection.  Refer to "Figure 6-23  Wizard Flow for Add New Project".)  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[Add New Project - Step 5/9 [Register Mode]] dialog box

Specify the register mode option for the compiler.  The sample file of the startup file corresponding to the register mode 
which is selected in this dialog box is copied to the project folder, and registered to the project-related files.  

This dialog box is displayed only when "V850 Microcontrollers" has been specified as the microcontrollers name in the 

[Add New Project - Step 1/9 [Project Information] ]dialog box and [Copy and Use the Sample file] has been selected in the 
previous wizard step ([Add New Project - Step 4/9 [Startup File]] dialog box).  

Figure 6-28   [Add New Project - Step 5/9 [Register Mode]] Dialog Box

(1)   Register mode specification area

(a)  22-Register Mode

The startup file is determined as the 22-register mode.  

(b)  26-Register Mode

The startup file is determined as the 26-register mode.  

(c)  32-Register Mode

The startup file is determined as the 32-register mode.  

(2)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(3)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(1)
(3)

(2)
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(4)   Function buttons 

[Caution] 
If the register mode of the compiler option is changed after a new workspace is created, the quasi directive indicat-
ing the register mode in the startup file may indicate a different mode from the register mode of the other source 
files.  Therefore, execute the relevant processing/measure from those shown below:  

- Modify the quasi directive that indicates the register mode in the startup file as follows: 

*) In 22-register mode 

*) In 26-register mode 

*) In 32-register mode 
Deletes ".option   reg_mode " line.  

- Ignore the following warning displayed at linking.  

Id850:  W4608:  input file have different register modes,  use "-rc" option for more information.

Button  Function

<Back Returns to the previous wizard step.  

Next> Opens the next step dialog box. (The next step dialog box to be opened differs depending on 
the selection.)  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  

#------------------------------
#    register  mode
#------------------------------
      .option   reg_mode  5 5

#------------------------------
#    register  mode
#------------------------------
      .option   reg_mode  7 7
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[Add New Project - Step 6/9 [LinkDirective File]] dialog box

Specify a link directive file.  The specified link directive file is registered to the project-related files.  
This dialog box is displayed only when "V850 Microcontrollers" has been specified as the microcontrollers name in the 

[Add New Project - Step 1/9 [Project Information] ]dialog box.  

Figure 6-29   [Add New Project - Step 6/9 [LinkDirective File]] Dialog Box

(1)   Link directive file specification area

(a)  Create and Use the Sample file

If this option button is selected, a sample link directive file is created in the project folder in accordance with the 
selection in [Memory Usage] area and the selection of the OS in the [Add New Project - Step 3/9 [Select Real-
Time OS] ]dialog box.  The link directive file is created under the name "project file name.dir" and registered to 
the project-related files automatically.  

- Memory Usage

The link directive file that is created is registered to the project-related files automatically.  The name of the link 
directive file to be registered is displayed in The Link Directive File Name to register edit box as an absolute path.  
The link directive file name to be registered can be changed by clicking the [File Name...] button, or by directly 
inputting the name in the "The Link Directive File Name to register" edit box using the keyboard.  
Refer to "APPENDIX A  SAMPLE LINK DIRECTIVE FILE" for the detail of the link directive file to be created.  

[Caution] 
The link directive file that is created must be customized in accordance with the target specification or user-
defined sections.  

Use Internal memory only The external ROM is mapped to the internal ROM area when the compiler is 
used in ROMless mode.

Use External memory The TEXT sections are mapped to the internal memory, and the DATA sections 
to the external memory.

(1)

(2)

(4)

(3)
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(b)  Use the Existing file

When an existing link directive file is used, select this option button.  
If [Browse...] button is clicked, the [Link Directive File] dialog box is opened to select the any startup file.  The 
name of the link directive file to be registered is displayed in [The Link Directive File Name to register ]edit box as 
an absolute path.  
The link directive file name to be registered can be changed by directly inputting the name in the [The Link Direc-
tive File Name to register] edit box using the keyboard.
If this option button is selected, the [File Name...] button cannot be selected.  

(c)  Copy and Use the Existing file

When an existing link directive file is copied and used, select this option button.  Specify the link directive file 
name to be the copy source and the link directive file name to be the copy destination.  
If [Browse...] button is clicked, the [Copy Link Directive File from] dialog box is opened to select the any startup 
file.  The name of the link directive file to be the copy source is displayed in [Copy from] edit box as an absolute 
path.  Alternatively, the file name to be specified can also be input in the [Copy from] edit box either as an abso-
lute path or a relative path using the keyboard.  
The link directive file name to be registered can be changed by clicking the [File Name...] button, or by directly 
inputting the name in [The Link Directive File Name to register] edit box using the keyboard.

(d)  Do Not specify now

When no link directive file is specified, select this option button.  
A link directive file can be specified by selecting a project-related file folder on the [Project] window and then 
selecting [Add Project Related files...] using the right mouse button, or selecting the [Tool] menu -> [Linker 
Options...] after exiting the wizard.  

(2)   The Link Directive File Name to register

Specify the name of the link directive file to be registered.  
If [File Name...] button is clicked, the [Link Directive File to register] dialog box is opened to select the any startup 
file.  Alternatively, the file name to be specified can also be input in The Link Directive File Name to register edit box 
edit box either as an absolute path or a relative path using the keyboard.  

(3)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(4)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(5)   Function buttons 

Button  Function

<Back Returns to the previous wizard step.  

Next> Opens the next step dialog box. (The next step dialog box to be opened differs depending on 
the selection.)  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[Add New Project - Step 7/9 [Setup Source Files]] dialog box

Specify the name of the source file to be registered into the project.  

Figure 6-30   [Add New Project - Step 7/9 [Setup Source Files]] Dialog Box

(1)   Source File Name

The names of the source files to be registered into the project are displayed in the source file list box.  
The source files are registered to the project file in the order currently shown in this list box.  In addition, the build 
processing are performed in the registered order.  

Button  Function

Add... Opens the [Add Source Files] dialog box to specify the source code files to be registered to 
the project.  Up to 2048 source files can be registered per project.  The extension of source 
code file differs depending on the microcontrollers name registered to the project.  

Remove Removes the selected file from the source file list box.  By selecting a file name while holding 
down the [Shift] or [Ctrl] key, multiple source file names can be selected at once.  The names 
of the removed files are not registered to the project.  
If no source file is selected or listed in the source file list box, this button can not be selected.  

Remove All Removes all the source files from the source file list box.  The names of the removed files 
are not registered to the project.  
If no source file is selected or listed in the source file list box, this button can not be selected.  

Up Moves the selected file up within the source file list box.  

Down Moves the selected file down within the source file list box.  

(1)

(3)

(2)
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[Cautions]
- If the compiler and assembler are not installed, source file addition is not possible. 

- If, after a source file is added, the microcontrollers name is changed by returning to the [Add New Project - 
Step 1/9 [Project Information] ]dialog box, files among the previously added file other than those with exten-
sions corresponding to the microcontrollers after the change are also displayed in the source file list box. In 
this case, delete these source files. 

- It is possible to proceed to the next step by clicking the [Next>] button even if no source files are specified in 
this dialog box.  In this case, source files can be registered into the project by specifying with the [Project Set-
tings] dialog box or dragging and dropping the source files to be registered onto the [Project] window.  

(2)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(3)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(4)   Function buttons 

Button  Function

<Back Returns to the previous wizard step.  

Next> Opens the next step dialog box. (The next step dialog box to be opened differs depending on 
the selection.  Refer to "Figure 6-23  Wizard Flow for Add New Project".)  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[Add New Project - Step 8/9 [Select Debugger]] dialog box

Select the debugger which debug the project to be created newly. 
The specification of the item marked with "*" in this dialog box can not be omitted (i.e. the [Next>] button can not be 

selected).  The debugger specified with this dialog box can be changed after exiting this wizard.  

Figure 6-31   [Add New Project - Step 8/9 [Select Debugger]] Dialog Box

(1)   Debugger

Select the debugger to be used from the drop-down list.  All the NEC Electronics debuggers that have been 
installed are displayed in the drop-down list together with the corresponding microcontrollers name.  
When a debugger is selected from this list, the file name of the debugger is displayed in the [File Name] text box 
and the selected debugger will start up automatically when a debug operation is executed.  
If you wish to change the debugger to be used after exiting the wizard, select the [Tool] menu -> [Debugger Set-
ting...].  

(2)   File name

The file name of the debugger to be used for debugging is displayed.  When the debugger is selected by the 
[Debugger] drop-down list, that file name is displayed with the path automatically.  
This text box cannot be edited. 

(3)   Option

Specify the options for when starting up the debugger.  
If this specification is omitted, no option is specified for starting up the debugger. 

(4)   Message area

The function of the dialog box and applicable cautions are described in this area.  

(5)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(2)

(1)

(3)

(5)

(4)
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(6)   Function buttons 

Button  Function

<Back Returns to the previous wizard step.  

Next> Opens the next step dialog box. (The next step dialog box to be opened differs depending on 
the selection.)  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[Add New Project - Step 9/9 [Confirmation]] dialog box

The contents of the setting are confirmed and the wizard for creating a new project is terminated.  

Figure 6-32   [Add New Project - Step 9/9 [Confirmation]] Dialog Box

(1)   Confirmation area 

The information set by this wizard for creating a new project is displayed here.  
If there are no errors in settings, click the [Finish] button to terminate this wizard.  The workspace and the project 
file belonging to that workspace will then be created in accordance with the displayed information.  
Also generates a make file (project-file-name.mak) automatically.

(2)   Current position area 

The whole flow of the wizard is displayed in this area.  ">>" mark signifies the position of the current dialog box.  
If the flow changes according to the selection of information, the steps to be skipped are displayed in gray.  

(3)   Function buttons 

Button  Function

<Back Returns to the previous wizard step.  

Finish Terminates this wizard for creating a new workspace, and generates a new workspace file and 
a project file belonging to that workspace, according to the displayed information.  
Also generates a make file (project-file-name.mak) automatically.

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  

(1)

(2)
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[Project Settings] wizard

This wizard is used to update the project information for PM+ If an attempt is made to open a project file created by 
another NEC Electronics tool (debugger or simulator).  

This wizard displays the following dialog boxes.  Enter/select the necessary information in each dialog box and click the 
[Next>] button to proceed.  

-  [Project Settings - Step 1/3 [Project Information]] dialog box

-  [Project Settings - Step 2/3 [Select Tools]] dialog box

-  [Project Settings - Step 3/3 [Setup Source Files]] dialog box

Figure 6-33   [Project Settings] Wizard at Starting

This section describes the following items:  

- Opening

- Explanation of each dialog box

Opening

- Select the [File] menu -> [Open Workspace...]

Explanation of each dialog box

The following explains each dialog box displayed in this wizard. 
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[Project Settings - Step 1/3 [Project Information]] dialog box

Confirms the project information and modify the project title and the device microcontrollers name of the target device to 
be used.  

Figure 6-34   [Project Settings - Step 1/3 [Project Information]] Dialog Box

(1)   Information display area

(a)  Project File Name

The name of the project file is displayed.  

(b)  Folder

The project folder specified in the project file is displayed.  

(c)  Workspace File Name

The name of the workspace file to which the project belongs is displayed with an absolute path.  
The file name is automatically determined as project file name + extension (*.prw).  

(d)  Project Group

The name of the project group to which the project belongs is displayed.  
If you wish to change the name of the project group, after this wizard terminates, click the name of that project 
group with the right mouse button in the [Project] window and select the [Edit Project Group Name...] menu.  

(2)   Project Title

The project title to be displayed in the [Project] window is displayed.  
If the project title is modified here, the modification is reflected in the [Project] window.  
Up to 127 characters can be entered for a project title.  

(1)

(2)

(3)
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(3)   Microcontrollers Name and Device Name

The microcontrollers and device name of the target device to be used are displayed.  
They can be changed by selecting from the drop-down lists.
If the device file for the device to be used has not been installed, the following message will be displayed under the 
device name displayed.

"The device file that has been selected is not registered."

When this message is displayed, clicking the [Device Install] button starts the device file installer to register the new 
device file.
If multiple projects are registered into the project group, or if the debugger/simulator is running, these drop-down 
lists are invalid.  

(4)   Function buttons 

Button  Function

<Back This button is always disabled.  

Next> Opens the next wizard.  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[Project Settings - Step 2/3 [Select Tools]] dialog box

Specify the tool to be used in this dialog box.

Figure 6-35   [Project Settings - Step 2/3 [Select Tools]] Dialog Box

(1)   Tool Set

The combination of tools to be used and their versions is regarded as a tool set, and the tool set name can be 
selected from the drop-down list.  
The existing tool set and recommended tool set ("78Kx Microcontrollers Software Package Vx.xx" in the case of the 
78K Microcontrollers, and "V850 Microcontrollers Software Package Vx.xx" in the case of the V850 
Microcontrollers) are listed on the drop-down list.
If the tool set has been changed in the [Tool Version Detail Setting] dialog box opened by clicking the [Detail Set-
ting...] button, "(Changed)" is appended at the top of the tool set name.  If the tool set name already exists, the indi-
cation appended varies from "(Changed01)" to "(Changed99)".  After "(Changed99)", the tool set name is displayed 
as "UserSet".  

[Remark]
A file is saved as "tool-set-name.extension".  The extension varies depending on the product used, as shown 
below. 

78K0R Microcontrollers (including libraries): t0r
78K0 Microcontrollers (including libraries): tk0
78K0S Microcontrollers (including libraries): t0s
V850 Microcontrollers (including libraries): t85

The file is saved under "NEC Electronics\PM+" in the "Application Data" folder, which is accessible by all users.  

Button Function

Save Saves the tool set currently selected in [Tool Set].
This button is not available (appears dimmed) if the tool set file is read-only.

Delete Deletes the tool set name selected in [Tool Set] from the list (also deletes the corresponding tool set 
file).
This button is not available (appears dimmed) if there are no tool set files corresponding to the 
selected tool set or the tool set file is read-only.

(1)

(2)
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If this folder does not exist, it is automatically created when PM+ is started up (for example, "C:\Documents and 
Settings\All Users\Application Data\NEC Electronics\PM+" in the case of Windows XP).

(2)   Tool versions

Combinations of tools to be used and their versions are displayed in this area.
When a tool set name is selected in the [Tool Set] drop-down list, the tools included in the tool set and their ver-
sions are displayed.
 The tools specified in the [Tool Set] drop-down list and their versions are displayed by default.
The [Tool Version Detail Setting] dialog box is opened by double-clicking this area or by clicking the [Detail Set-
ting...] button.  Tools to be used and their versions can be selected in this dialog box.

(a)  Tool

All the installed tools and tools included in the selected tool set are displayed in this area (tools that have not 
been installed are displayed in gray).  

(b)  Version

The tool versions specified in the selected tool set are displayed in this area.  
However, "Unused" is displayed for a tool whose version is not specified in the tool set.

(c)  Select only Installed Tools

If this check box is selected, tools that have not been installed are excluded from the [Tool Versions] list box 
which corresponds to the tool set selected in the [Tool Set] (default).
 "(Selected01)" is appended to the top of the name of the tool set with which this check box is selected (if the tool 
set  name actually exists, "(Selected0n)" is appended).
This check box cannot be selected (grayed) if there are no dimmed tools (all the listed tools have been installed).

(3)   Function buttons 

Button  Function

<Back Returns to the previous wizard step.  

Next> Opens the next wizard.  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[Project Settings - Step 3/3 [Setup Source Files]] dialog box

Specifies the source file information on the project.  

Figure 6-36   [Project Settings - Step 3/3 [Setup Source Files]] Dialog Box

(1)   Source Files

The names of the source files specified by the project file are displayed in the order the build processing with the 
relative path on the basis of the project folder.  
Up to 2048 source files can be registered.  

[Cautions] 
- If the compiler and assembler are not installed, source file addition is not possible. 

- Make is assembled/compiled in accordance with the program type, in the order the files are displayed in the 
list of source files.  The path of project folder is being used for the path name of the source file when execut-
ing make.  
The order of linkage depends on the linker of the microcontrollers to be used.  

Button  Function

Add... Opens [Add Source Files] dialog box to add the source file to the project.  

Remove Removes the selected source file from the list.  

Remove All Removes all the source files from the list.  

Up Moves the selected source file up within the list.  

Down Moves the selected source file down within the list.  

(1)
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(2)   Function buttons 

Button  Function

<Back Returns to the previous wizard step.  

Finish Terminates this wizard for creating a new workspace, and generates a new workspace file and 
a project file belonging to that workspace, according to the displayed information.  

Cancel Stops the operation for creating a new workspace file, and returns to its previous status (in 
which the previously read workspace file is available for use).  

Help Opens the help for this dialog box.  
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[Open] dialog box

This dialog box is used to open a specified file.  
Multiple files being edited can be opened in a read-only attribute.  
When closing files, if there are multiple files opened in the read-only status whose names are the same, all of these files 

are closed.  

Figure 6-37   [Open] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [File] menu -> [Open].  

Explanation of each area

(1)   Look in

Select the drive or folder in which the specified file exists from the drop-down list.  

The files existing in the specified location are displayed in area below.

(2)   File name and Files of type

(a)   File name 
Specify the name of the file to be opened.  
The file name can be directly entered in the text box or can be selected from the list above.

(1)

(2)

(3)

(4)

(5)
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(b)   Files of type
Select the type of the specified file from the drop-down list.  The following types are displayed in the default con-
dition.  

[When opening a workspace file]

- Source Files
[Caution] 

The source file extension corresponding to the currently active project is displayed.  

- Include Files (*.h,*.inc)

- idl Files (*.idl)

- Text Files (*.txt)

- All Files (*.*)

[When not opening a workspace file]

- Source Files (*.c,*.cpp,*.asm,*.s)

- Include Files (*.h,*.inc)

- idl Files (*.idl)

- Text Files (*.txt)

- All Files (*.*)

If a file whose extension is "*.bkl" is selected, it is identified as a backup file.  File types (user-specified extension, 
etc.) can be added with the [Tool] menu -> [Customize...]. 

(3)   Open as read-only

The specified file is opened as a read-only attribute.  

This check box is not selected in the default condition.  

(4)   Apply Layer Rule

The specified file is read applying a specified layer rule.  

This check box is not selected in the default condition, however, if [Apply Layer Rule in Opening File(s)] is selected 
on the [File] tab in the [PM+ Settings] dialog box, this check box is selected automatically and dimmed.

The [Layer Rule...] button can only be valid when [Apply Layer Rule] check box is selected.  Refer to the [Set Layer 
Rule] dialog box for details on the layer rule.  

[Example]

- Opening a file without checking the check box
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- Opening a file with checking the check box

(5)   Gather Files into an Edit Window  

Multiple specified files are read into one Edit window.  

When this check box is selected, [Open as read-only] check box becomes invalid.  

Function buttons 

Button  Function

Open Opens the specified file.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

Layer Rule... Opens the [Set Layer Rule] dialog box to set the layer rule to be applied when reading a file.
This button is available only when the [Apply Layer Rule] check box is selected.
This button is unavailable when the [Enable All Layer Rule’s Options] check box is selected 
on the [File] tab in the [PM+ Settings] dialog box. 
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[Insert File] dialog box

This dialog box is used to insert the contents of a specified file to the active Edit window.  
The contents of the file  will be inserted in the line immediately above the line where the caret is placed.
The caret position does not change after the file insertion. (If the caret is placed in the middle of a line, however, the 

caret will move to the beginning of the line).
The files that can be inserted are as follows: 

- IDL file

- Text file

Figure 6-38   [Insert File] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [File] menu -> [Insert file...].

Explanation of each area

(1)   Look in

Select the drive or folder in which the specified file exists from the drop-down list.  

The files existing in the specified location are displayed in area below.

(1)

(2)

(3)
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(2)   File name and Files of type

(a)   File name 
Specify the name of the file to be opened.  
The file name can be directly entered in the text box or can be selected from the list above.

(b)   Files of type
Select the type of the specified file from the drop-down list.  The following types are displayed in the default con-
dition.  

[When opening a workspace file]

- Source Files
[Caution] 

The source file extension corresponding to the currently active project is displayed.  

- Include Files (*.h,*.inc)

- idl Files (*.idl)

- Text Files (*.txt)

- All Files (*.*)

[When not opening a workspace file]

- Source Files (*.c,*.cpp,*.asm,*.s)

- Include Files (*.h,*.inc)

- idl Files (*.idl)

- Text Files (*.txt)

- All Files (*.*)

File types (user-specified extension, etc.) can be added with the [Tool] menu -> [Customize...]. 

(3)   Apply Layer Rule

The specified file is inserted applying a specified layer rule.  

This check box is not selected in the default condition, however, if [Apply Layer Rule in Opening File(s)] is selected 
on the [File] tab in the [PM+ Settings] dialog box, this check box is selected automatically and dimmed.  

The [Layer Rule...] button can only be valid when [Apply Layer Rule] check box is selected.  

[Example]

- Opening a file without checking the check box
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- Opening a file with checking the check box

Function buttons 

Button  Function

Open Inserts the contents of the specified file.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

Layer Rule... Opens the [Set Layer Rule] dialog box to set the layer rule to be applied when reading a file.
This button is available only when the [Apply Layer Rule] check box is selected.
This button is unavailable when the [Enable All Layer Rule’s Options] check box is selected 
on the [File] tab in the [PM+ Settings] dialog box. 
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[Open Workspace] dialog box

This dialog box is used to open a specified workspace file.  
If a workspace file or a project file is already opened, a workspace to be opened is displayed after the workspace file or 

the project file is closed.  
If a project file created with PM (Ver.3.xx) or PM plus (Ver.5.xx) is specified, a message will be displayed, and the file is 

converted into a workspace file then opened (refer to "5. 1. 5  Opening a project file generated by the previous version").
If an attempt is made to open a project file created with another NEC Electronics tool (such as a debugger or simulator), 

the [Project Settings] wizard will be displayed and update its project information for compatibility with PM+.

Figure 6-39   [Open Workspace] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [File] menu -> [Open Workspace...].  

Explanation of each area

(1)   Look in

Select the drive or folder in which the specified file exists from the drop-down list.  The files existing in the specified 
location are displayed in area below.

(2)   File name and Files of type

(a)   File name 
Specify the name of the file to be opened.  Up to 255 characters can be entered.  
The file name can be directly entered in the text box or can be selected from the list above.

(1)

(2)
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(b)   Files of type
Select the type of the specified file from the drop-down list.  The following types are displayed in the default con-
dition.  

- Workspace File (*.prw)

- Project File (*.prj)

- All Files (*.*)

Function buttons 

Button  Function

Open Opens the specified file.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U18416EJ1V0UM 175

[Save As] dialog box

This dialog box is used to save the current active file into a specified file.  

Figure 6-40   [Save As] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [File] menu -> [Save As...].  

Explanation of each area

(1)   Save in

Select the drive or folder in which the file is to be saved from the drop-down list.  The files existing in the specified 
location are displayed in area below.

(2)   File name and Save as type

(a)   File name 
Specify the name of the file to be saved.  
If the file has no name, a file name created based on the contents of the first line is displayed.  If the first line has 
no characters, the file name is displayed as "Untitled".  
The file name can be directly entered in the text box or can be selected from the list above

(2)

(1)

(3)

(4)
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(b)   Save as type
Select the type of the specified file from the drop-down list.  The following types are displayed in the default con-
dition.  

- Source Files (*.c,*.c2s,*.s)

- Include Files (*.h,*.inc)

- idl Files (*.idl)

- Text Files (*.txt)

- All Files (*.*)

(3)   Create the Source Files

This check box is available only when the  file to be saved is an IDL file.  
If this check box is selected, a source file is also created.  In this case, the [Change Source File Name...] and 
[Source File Name Option...] buttons become valid. 
If this check box is not selected, only the IDL file is saved, and no source file is created.  In this case, the [Change 
Source File Name...] and [Source File Name Option...] buttons become invalid. 
Note that if the Search result display window is active, this check box is always invalid.  

(4)   CR Code

This setting is valid when a file is saved in text file format.  If a text file that has already been read is specified, the 
linefeed  code when the file was read is displayed.  

The linefeed code that can be saved are as follows:  

Function buttons 

Code Description

MS-Windows [CR+LF]: Linefeed code has 2 bytes  CR code and LF code.

UNIX OS [LF]: Linefeed code: LF code

Mac OS [CR]: Linefeed code: CR code

Button  Function

Save Saves the file with the specified name.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

Change Source File Name... Opens the [Change Source File Names] dialog box in which the source file 
name and the comment mark can be changed.  

Source File Name Option... Opens the [Save Source Files Options] dialog box in which the options for the 
source file to be created can be set.  
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[Save Source Files Options] dialog box

This dialog box is used to set options when a source file is saved.  
The settings made in this dialog box have the same meaning as the settings made on the [Source File by idl file] tab in 

the [PM+ Settings] dialog box.  The default settings correspond to the settings in the [PM+ Settings] dialog box.  The set-
tings here are also reflected in the [PM+ Settings] dialog box.  

Figure 6-41   [Save Source Files Options] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [File] menu -> [Save As...],  and click the [Source File Name Option...] button.  

Explanation of each area

(1)   Layer Indent  

This area specifies whether an indent for a layer is replaced with a specified character when a source file is saved.  

(a)   No Replace
The indent of layers is not replaced.

(b)   Replace Tab
The indent of one layer is replaced with one Tab code. 

(c)   Replace Space
The indent of one layer is replaced with the number of space codes specified with [Indent Tab Characters] on the 
[View] tab in the [PM+ Settings] dialog box.  

(d)   Not Replace Layer 
The indents to the specified layer are not replaced with Tab or space codes.  
If "2" is specified, the lines of the first and second layers are not replaced with Tab codes, but the lines of the third 
and subsequent layers are replaced with Tab codes. 

(2)

(1)
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(2)   Convert Tabs to Space in Saving a Source File

If this check box is selected, Tab codes are replaced with the number of space codes specified with [Indent Tab 
Characters] on the [View] tab in the [PM+ Settings] dialog box.  A two-byte space is replaced with two one-byte 
space codes.

Function buttons 

Button  Function

OK Saves the file with the specified options.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Change Source File Names] dialog box

This dialog box is used to change the name of the source file to be created from an IDL file being edited to a specified 
file name.  

Figure 6-42   [Change Source File Names] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [File] menu -> [Change Source File Name...].  

- Select the [File] menu -> [Save As...],  and click the [Change Source File Name...] button.  

Explanation of each area

(1)   Source File Names

(a)   Source File
After selecting a source file name, inline editing can be performed by clicking the left mouse button.  Up to 259 
characters can be specified.  Moreover, after selecting a source file name, double-clicking it or clicking the 
[Change File Names...] button opens the [Change Selected Source File Name] dialog box.  
At this time, if multiple source file names are selected, the [Change Selected Source File Names] dialog box is 
opened.  
If the name of the source file has not been set, the contents of the first layer line, which corresponds to the first 
line of the source file, will be the source file name.  If there are any other source files with the same name, that 
name suffixed by a 4-digt number is displayed as the source file name.  
If the first layer line contains no characters, a 4-digt number + extension will be the source file name.  The exten-
sion will be "c" if there are any C language comments (/**/, //) between the first and 300th lines, or "asm" if there 
are no comments.

(2)

(1)

(3)
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(b)   Title
The contents of the first layer line, which corresponds to the first line of the source file, are extracted and dis-
played. 

(2)   Not Divide the Source File

If this check box is selected, the source file is not divided.  The entire file is saved as a single source file.  
If the check box is cleared then selected again, the previous file name for the file not to be divided is displayed.  
Note that when the Edit window is closed, the name becomes invalid.  
This check box is not selected in the default condition.  

(3)   Remove the Source File before renamed

If this check box is selected, the file with original name is deleted when the source file name is changed.
This check box is not selected in the default condition.  

Function buttons 

Button  Function

OK Changes the IDL file name to the specified file name.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

Change File Names... Opens the [Change Selected Source File Name] dialog box, when a single source file 
name is selected.  
Opens the [Change Selected Source File Names] dialog box, when multiple file names 
are selected.  

Select All Selects all files listed in [Source File Names]. 
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[Change Selected Source File Name] dialog box

This dialog box is used to rename the source file selected in the [Change Source File Names] dialog box.  

Figure 6-43   [Change Selected Source File Name] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select [Change File Names...] with a single source file name selected in the [Change Source File Names] dialog box.  

Explanation of each area

(1)   File Name

Specify the newly set file name.  Up to 259 characters can be specified.  

The file name selected in the [Change Source File Names] dialog box is displayed in the default condition.  

(2)   Folder 

The current folder is displayed.  

Clicking the [...] button opens the dialog box to select the folder.  

(3)   Comment Mark

Select a comment mark from the option buttons.  
If the contents of the Edit window is a C source, /* */ is selected by default.  Otherwise, a semicolon (;) is selected 
by default.
Selecting the [Original Mark] or clicking the [Setting...] button opens the [Set Comment Mark] dialog box in which a 
desired comment mark can be specified.  

(2)

(1)

(3)
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Function buttons 

Button  Function

OK Changes the IDL file name to the specified file name.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

Setting... Opens the [Set Comment Mark] dialog box in which the comment mark for the specified file 
can be changed.  
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[Change Selected Source File Names] dialog box

This dialog box is used to rename multiple source files selected in the [Change Source File Names] dialog box.  

Figure 6-44   [Change Selected Source File Names] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select [Change File Names...] with multiple source file names selected in the [Change Source File Names] dialog 
box.  

Explanation of each area

(1)   Extension

If all the selected files have the same extension, the extension is displayed.  If the files have different extensions, 
this area is left blank.  

(2)   Folder 

If all the selected files are saved in the same folder, the folder is displayed.  If the files have different settings, this 
area is left blank.  

Clicking the [...] button opens the dialog box to select the folder.  

(3)   Comment Mark

Select a comment mark from the option buttons.  
If all the selected files have the same comment marks, the current comment mark is selected.  Otherwise, nothing 
is selected by default.  
Selecting the [Original Mark] or clicking the [Setting...] button opens the [Set Comment Mark] dialog box in which a 
desired comment mark can be specified.  

(2)

(1)

(3)
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Function buttons 

Button  Function

OK Changes the IDL file name to the specified file name.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

Setting... Opens the [Set Comment Mark] dialog box in which the comment mark for the specified file 
can be changed.  
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[Set Comment Mark] dialog box

This dialog box is used to change a comment mark for a specified file.  

Figure 6-45   [Set Comment Mark] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Original Mark] or [Setting...] button in the [Change Selected Source File Name] dialog box.

- Select the [Original Mark] or [Setting...] button in the [Change Selected Source File Names] dialog box.

Explanation of each area

(1)   Comment 

Specify the symbol to be used as a comment mark, as well as %s.  

Function buttons 

Button  Function

OK Enables the specified comment mark. This button is invalid until a character is entered in 
[Comment].  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

(1)
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[Print] dialog box

This dialog box is used to print the contents of the window being edited.  

Figure 6-46   [Print] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [File] menu -> [Print...].  

- Select the [Print] button on the [File] menu -> [Print Preview]. 

Explanation of each area

(1)   Printer

(a)   Name
Select the printer to be used from the drop-down list.
The name of the printer specified as the default printer is displayed by default. 
Clicking the [Properties] button can change the printer settings.  

(2)

(1)

(3)

(5)

(4)

(6)
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(2)   Print Range

(a)   All
Prints all of the contents of the window.

(b)   Selection
Prints the selected portion in the window. 

(c)   Caret Line and Lower Layer
Prints a line and subsequent lower layer lines, at the caret position.  

(3)   Layer

(a)   Print with Indentation
Prints lower layers with indent aligning a first line of the selected range with the left end.  The number of space 
characters for the indent is specified with [Indent Characters] on the [Tool] menu -> [PM Settings...] - [Layer] tab. 

(b)   Print Layer Marks
Prints specified layer marks as well. 

(c)   Print Collapse Layers
Prints currently collapsed layers as well.

(d)   Insert New Page Code at every 1st Layers
Prints the contents, Inserting a new page code for each first layer.

(e)   Print Until x Layer [1-127]
Prints the contents for up to the specified layer.

(4)   Line Number

(a)   Print Line Numbers
Prints line numbers at the left end. 

(b)   Renumber Line Numbers in every 1st Layer
Renumbers lines from 1 for each layer-1 line. 

(5)   Font

The currently set  font type and font size are displayed.  
Clicking the [Change Font...] button opens the [Font] dialog box (Print) in which a desired font type can be speci-
fied. 

(6)   Other

(a)   Enable multiple lines print
Enables multi-line printing.

(b)   Print Header/Footer
Prints the headers or footers. 

(c)   [Header/Footer...] button
Opens the [Set Header/Footer] dialog box in which the contents of the header and footer can be specified.  When 
the [Print Header/Footer] check box is not selected, this button becomes invalid.  
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Function buttons 

Button  Function

Preview Opens the Print Preview window.  

OK Starts printing.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Font] dialog box (Print)

This dialog box is used to specify the font and size of the characters to be printed.  

Figure 6-47   [Font] Dialog Box (Print)

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Change Font...] button in the [Print] dialog box.  

Explanation of each area

(1)   Font  and Size 

(a)   Font
Displays the font type under currently set.  Select a desired font type by the scroll bar. 

(b)   Size
Displays the font size under currently set.  Select a desired font size by the scroll bar.

(2)   Sample

Displays sample characters in the selected font and size. 

(2)

(1)
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Function buttons 

Button  Function

OK Enables the specified font and size. 

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Set Header/Footer] dialog box

This dialog box is used to specify the contents of the header or footer to be printed.  

Figure 6-48   [Set Header/Footer] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Header/Footer...] button in the [Print] dialog box.  

(2)

(1)
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Explanation of each area

(1)   Header

(a)   Header 
Specify the contents to be printed as headers, by clicking any of the following buttons.  When a button is clicked, 
the corresponding characters are entered in the text box. 

(b)   Position
Specify the position at which the contents of the header. 

(c)   Draw a Line Below Header
Draws a line below the contents of headers. 

(d)   Draw a Filename and Path
Prints a file name with the path name if the file name is printed in the header. 

(e)   Draw a Source Filename and Path
Prints a source file name with the path name if the source file name is printed in the header. 

(f)   Header Font 
Displays the font type and font size under currently set in the header.  
Clicking the [Change Header Font...] button opens the [Font] dialog box (Print) in which a desired font type can 
be specified.

(2)   Footer 

(a)   Footer  
Specify the contents to be printed as footers, by clicking any of the following buttons.  When a button is clicked, 
the corresponding characters are entered in the text box. 

(b)   Position
Specify the position at which the contents of the footer.  

Button Function

Page number (%p)

Date (%d)

Time (%t)

Time (%t)

Source file name (%s)

Button Function

Page number (%p)

Date (%d)

Time (%t)

Time (%t)

Source file name (%s)
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(c)   Draw a Line Below Footer
Draws a line below the contents of footers.

(d)   Draw a Filename and Path
Prints a file name with the path name if the file name is printed in the footer. 

(e)   Draw a Source Filename and Path
Prints a source file name with the path name if the source file name is printed in the footer. 

(f)   Footer Font 
Displays the font type and font size under currently set in the footer.  
Clicking the [Change Header Font...] button opens the [Font] dialog box (Print) in which a desired font type can 
be specified.

Function buttons 

Button  Function

OK Enables the specified items.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Grouping by Keyword] dialog box

This dialog box is used to collect lines including a specified character string and display the collected results at the top 
of the Edit window.  In the collected results, the search key is displayed in the first layer, and the collected lines are dis-
played in the second layer.  

The collected lines also remain in their original positions unless [Delete] is selected in [After Grouping].

Figure 6-49   [Grouping by Keyword] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

- Cautions

Opening

- Select the [Edit] menu -> [Grouping by Keyword...].

Explanation of each area

(1)   Find What 

Specify a character string to be used as a keyword of grouping.  Multiple character strings can be specified by plac-
ing a semicolon (;) between the character strings.  
The word at the caret position is displayed by default.  If there is no corresponding word, the character string used 
last for grouping is displayed.  If grouping is being performed for the first time, this area is left blank.  
Up to ten of the latest search keys are stored.  

(2)   Conditions

(a)   AND Search
Collects lines having all the character strings specified in [Find What]. 

(b)   OR Search
Collects lines having any of the character strings (default). 

(1)

(2)

(5)

(4)

(6)

(3)

(7)
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(3)   Paragraph 

(a)   Yes
Collects lines in units of paragraph.  If a collected line has a lower layer, the line is collected with the lower layer 
included as is. 

(b)   No
Collects lines including the specified character string regardless of the paragraph (default). 
The definitions of "paragraph" are as follows:  

(4)   After Grouping

(a)   Change Color
Displays the collected lines in blue (default). 

(b)   Delete
Deletes the collected lines from the original positions.  
If [Yes] is selected in [Paragraph], the lines cannot be deleted. 

(c)   Do Nothing
Performs no processing on the collected lines.  

(5)   Match Case

Collects lines including a character string that matches both the search key in [Find What] and the case of the char-
acters in the search key.  

(6)   Restore Color of Grouping Lines Already

Collects lines in the original color, which was changed by the previous grouping (default).  

(7)   Change Color of Grouped Lines Only

Collects no lines and instead only changes the color of the lines including the search key specified in [Find What].  If 
this check box is selected, the setting made in [After Grouping] is disabled.
By default, this check box is not selected.  

Function buttons 

Beginning of a paragraph : Line preceded by a blank or a higher layer.

End of a paragraph : Line followed by a blank or a higher layer.

Button  Function

Grouping to The Top Collects lines including the search key and displays the collected lines at the top of the 
searched Edit window in the order in which the lines are found.  

Grouping to Other Collects lines including the search key and displays the collected lines at the top of a new 
Edit window in the order in which the lines are found.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  



CHAPTER 6  WINDOW REFERENCE

196 User’s Manual  U18416EJ1V0UM

Cautions

- If [Grouping to Other] is selected, the new window is titled "Grouping- search-key UntitledX(Changed)."  

- The settings of the check boxes and option buttons are stored and displayed when the next grouping is performed.  

- Collected lines cannot be deleted from a read-only file. If [Change Color of Grouped Lines Only] is selected, the 
[Grouping to The Top] button can be selected.  

- If lines are collected from a read-only file by selecting [Grouping to Other], [Delete] key cannot be selected in the 
new window of the collected results.  
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[Select the way of Function Prototypes] dialog box

This dialog box is used to automatically generate the prototype declaration of a function.  

Figure 6-50   [Select the way of Function Prototypes] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

- Cautions

Opening

- Select the [Edit] menu -> [Make Function Prototypes...].  

Explanation of each area

(1)   Generation method selection area

Select a generation method from the following option buttons.  
The selectable buttons depend on the file type.  

(a)   Add Function Prototypes of index1(Source file) at caret position to top of the Index1(Source file).
Adds the function defined in the first layer (Source file) at the caret position in the Edit window as a prototype dec-
laration, at the top of the layer.  

(b)   Add Function Prototypes of each Index1(Source files) to the top of each Index1(Source file).  
Adds the function defined in each first layer (Source file) in the Edit window as a prototype declaration, at the top 
of the layer.  No addition is made to a read-only file.  

(c)   Add Function Prototypes to the top of file. 
Adds a function defined in the Edit window as a prototype declaration, to the top of the file.  

(d)   Make new windows of Function Prototypes.
Creates a function defined in the Edit window as a prototype declaration, to a new window.  

(1)
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(e)   Make header file of Function Prototypes. 
Creates a new first layer (header file) at the top of the IDL file being edited and creates a function defined in the 
IDL file being edited as a prototype declaration.  This IDL file must be that which has a source file and divides the 
source file in units of first layers.  The header file name to be created can be directly input in [Header file Name] 
or can be specified in the Select Include File dialog box, displayed by selecting the [...] button.  The default 
include file extension is ".h".  

- Insert the include sentence to the each source file
This option is enabled if [Make header file of Function Prototypes.] is selected.  When a header file is newly 
created, the "include statement + set header file name" is added to the top of each first layer (source file).  

Function buttons 

Cautions

- In the following cases, a prototype declaration may not be created correctly.  

- If a created prototype declaration is copied and pasted, the pasted prototype declaration is not updated.  

- If the prototype declaration created in the first layer is brought to a lower layer, the prototype declaration created 
initially becomes a different declaration.  

- When a prototype declaration is created, undo buffer is cleared.  Therefore, the original state cannot be restored.  

- A function name cannot be recognized with the control instructions indicated below:

- When the function name differs according to the value of #ifdef

- When function name extends over 2 lines with "\" 

Button  Function

OK Generates the prototype declaration of a function in the specified way.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

void

#ifdef ENGLISH

FncEng

#else

FncJapan

#endif

(int Cnt, int Mode)

{  ...

void Function         \
Name

(int Cnt. int Mode)

{   ...
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- When variable declaration is performed between function name and "{"

- In the case of a function name without a return value, such as shown below, the character on the preceding line are 
judged to be the return value. In such a case, declare the function type. 

#ifdef ENGLISH

int main( argc, argv[])

int argr;

char* argv[];

{

}

a.def

main(){}
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[Find String] dialog box

This dialog box is used to find a character string.
The search is performed also to the lines in lower layers which are not expanded, and if a search key is found in the 

lower layer, the layer is expanded to show the character string.  

Figure 6-51   [Find String] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

- Cautions

Opening

- Select the [Find] menu -> [Find...]. 

- Select the [Find...] button on the tool bar.

Explanation of each area

(1)   Find What

This area specifies a search key.  
A word at the caret position is displayed as the search key by default.  If there is no corresponding word, the char-
acter string used last for searching is displayed.  If there is no previously search key, this area is left blank.  
Up to ten of the latest search keys are stored.  If there are over ten search keys, the oldest one will be deleted.  
The search keys can be saved into an IDL file by checking [Memorize Find What in ideal-L File] check box on the 
[Tool] menu -> [PM+ Settings...] - [Find/Replace] tab.  The setting of the search key(s) can be changed by checking 
[Show String You Selected or Word of Caret Position to Find What] check box on the same tab.  

(3)

(1)

(2)
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(2)   Direction

Specify a search direction.

(a)   Up
Starts an upward search toward the top of the file from the second character to the rightmost one of the character 
string in the range selection or from the end of the lines in the range selection.

(b)   Down
Starts a downward search toward the end of the file from the second character to the leftmost one of the charac-
ter string in the range selection or from the beginning of the lines in the range selection (default).  

(3)   Search options area

(a)   Find from Top/End of Line
The search does not start from the caret position.  If [Up] is selected, the search starts from the last line. 
 If [Down] is selected, the search starts from the first line.  

(b)   Display Mini Dialog
If this check box is selected, the dialog box turns into a mini dialog box when the [Find Next] button is next 
selected (default).  

Figure 6-52 shows an image of the Find String dialog box (mini).  

Figure 6-52   [Find String] Dialog Box (Mini)

(c)   Match Whole Word Only
If this box is selected, a whole word match for the search key is searched for.  

(d)   Match Case
If this box is selected, a character string that matches both the search key in [Find What] and the case of the 
characters in the search key is searched for (default).  

(e)   Regular Expression
If this box is selected, regular expressions are supported in global searching. 
The following regular expressions are supported:

Button  Function

Down Continues a downward search for a character string matching the specified search key.

Up Continues an upward search for a character string matching the specified search key.

Details Displays the normal Find String dialog box in which the search conditions can be changed.  

Cancel Close this dialog box.  

Help Opens the help for this dialog box.  

Expression Description

Character Represents the character itself.

XY X and Y appear in the stated order. (concatenation)

X|Y X or Y appears. (selection)

X* X appears zero or more times.

(X) Same as X

(X)+ X appears one or more times.
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- Meta-characters *, |, (, ), and + have special meanings.  If any of those characters need to be searched, \ 
must be used.  If character \ needs to be searched, \\ must be specified.  
Other special characters are specified as follows:

- In regular expressions, repetition, concatenation, and selection are assigned decreasing priorities, in the 
stated order.  The priority can be adjusted by enclosing the corresponding part in parentheses,( and ).

[How to use regular expressions] 
- A character is a regular expression that indicates the character itself (except meta-characters).

E.g.: "a" is a regular expression indicating that the character "a" will appear.  

- Connection
XY, in which the regular expressions X and Y are described in order, is a regular expression indicating that X 
and Y will appear in that order. 
E.g.: abc is a regular expression indicating that characters a, b, and c will appear in that order.  

- Selection 
X|Y, in which "|" is described between X and Y, is a regular expression indicating that either X or Y will 
appear. 
E.g.: a|b|c is a regular expression indicating that one of the characters a, b or c will appear.

- Repetition
X*, in which "*" is described just after a regular expression X, is a regular expression indicating that X will 
appear repeatedly 0 times or more.  
E.g.: a* is a regular expression indicating that "a" will appear repeatedly 0 times or more. 

 (a, aa, aaa, aaaa, ...Null character strings will appear.)
X+, in which "+" is described just after a regular expression X, is a regular expression indicating that X will 
appear repeatedly once or more. 
E.g.: a+ is a regular expression indicating that "a" will appear repeatedly once or more. 

 (a, aa, aaa, aaaa, ...Null character strings are not included.)

a* means that "a" will appear repeatedly 0 times or more, while aa* means that "a" will appear repeatedly 
once or more and null character strings are not permitted, which is the same operation as the description of 
a+.  

- To indicate the repetition of ab, namely ab, abab, ababab... (ab)* must be specified, not ab* (Since repetition 
has a higher priority than connection, use parentheses to change the priority.)

- The regular expression indicating that the first character is a or b, the second is c, and the third is x or y is 
(a|b) c (x|y) (Since connection has a higher priority than selection, use parentheses to change the priority).  If 
parentheses are omitted, one of a, bcx, or y is searched.  

- The regular expression indicating that one of the characters enclosed in "[" and "]" will appear is not sup-
ported.  It can be described using "selection" as follows: 

E.g.: [abc] -> (a|b|c) This means that one of a, b or c will appear.  

(f)   This Source File Only
If this box is selected, only the source file to which the caret is currently positioned is searched.  

Tab character \t -

Beginning of line ^ Valid only when specified at the beginning of a character string.  Otherwise, 
character ^ itself is searched for.

End of line $ Valid only when specified at the beginning of a character string.  Otherwise, 
character $ itself is searched for.
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Function buttons 

Cautions

- When the [Esc] key is pressed, the search is aborted.  

- The settings of the check boxes and option buttons are stored and displayed at the next search.  

- If a search cannot find any match for the search key, the operator is notified by the issue of a message or beep, 
depending on the setting of [Warning for Find/Replace] on the [Tool] menu -> [PM Settings...] - [Find/Replace] tab.  

Button  Function

Find Next Searches for a match for the search key.  
If [Display Mini Dialog] is selected, the dialog box turns into a mini dialog box.

Cancel Does not enable the settings, and closes this dialog box.  

help Opens the help for this dialog box.  
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[Replace String] dialog box

This dialog box is used to replace a character string.  

Figure 6-53   [Replace String] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

- Cautions

Opening

- Select the [Find] menu -> [Replace...]. 

- Select the [Replace...] button on the too bar.  

Explanation of each area

(1)   Character strings specification area

(a)   Find What 
This area specifies the character string to be replaced.  
A word at the caret position is displayed as the search key by default.  If there is no corresponding word, the 
character string used last for searching is displayed.  If there is no previously search key, this area is left blank.  
Up to the ten most recently specified character strings to be replaced are stored.  If there are over ten character 
strings, the oldest one will be deleted.  
The character strings to be replaced can be saved into an IDL file by checking [Memorize Find What in ideal-L 
File] check box on the [Tool] menu -> [PM+ Settings...] - [Find/Replace] tab.  The setting of the character string to 
be replaced can be changed by checking [Show String You Selected or Word of Caret Position to Find What] 
check box on the same tab.  

(1)

(2)
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(b)   Replace With 
This area specifies a replacement character string.  
The last-specified replacement character string is displayed by default.  If no replacement has been made, this 
area is left blank.  
A replacement character string can be saved into an IDL file by checking [Memorize Find What in ideal-L File] 
check box on the [Tool] menu -> [PM+ Settings...] - [Find/Replace] tab.  The setting of a replacement character 
string can be changed by checking [Show String You Selected or Word of Caret Position to Replace With] check 
box on the same tab.  

(2)   Replacement options area 

(a)   Match Whole Word Only
If this box is selected, a whole word match for the search key is searched for.  

(b)   Match Case
If this box is selected, a character string that matches both the search key in [Find What] and the case of the 
characters in the search key is searched for (default).  

(c)   Regular Expression
If this box is selected, regular expressions are supported in the replacement.  
The following regular expressions are supported:

- Meta-characters *, |, (, ), and + have special meanings.  If any of those characters need to be searched, \ 
must be used.  If character \ needs to be searched, \\ must be specified.  
Other special characters are specified as follows:

- In regular expressions, repetition, concatenation, and selection are assigned decreasing priorities, in the 
stated order.  The priority can be adjusted by enclosing the corresponding part in parentheses,( and ).

[How to use regular expressions] 
- A character is a regular expression that indicates the character itself (except meta-characters).

E.g.: "a" is a regular expression indicating that the character "a" will appear.  

- Connection
XY, in which the regular expressions X and Y are described in order, is a regular expression indicating that X 
and Y will appear in that order.  
E.g.: abc is a regular expression indicating that characters a, b, and c will appear in that order.  

Expression Description

Character Represents the character itself.

XY X and Y appear in the stated order. (concatenation)

X|Y X or Y appears. (selection)

X* X appears zero or more times.

(X) Same as X

(X)+ X appears one or more times.

Tab character \t -

Beginning of line ^ Valid only when specified at the beginning of a character string.  Otherwise, 
character ^ itself is searched for.

End of line $ Valid only when specified at the beginning of a character string.  Otherwise, 
character $ itself is searched for.
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- Selection 
X|Y, in which "|" is described between X and Y, is a regular expression indicating that either X or Y will 
appear. 
E.g.: a|b|c is a regular expression indicating that one of the characters a, b or c will appear.

- Repetition
X*, in which "*" is described just after a regular expression X, is a regular expression indicating that X will 
appear repeatedly 0 times or more.  
E.g.: a* is a regular expression indicating that "a" will appear repeatedly 0 times or more. 

 (a, aa, aaa, aaaa, ...Null character strings will appear.)

X+, in which "+" is described just after a regular expression X, is a regular expression indicating that X will 
appear repeatedly once or more.  
E.g.: a+ is a regular expression indicating that "a" will appear repeatedly once or more.  

 (a, aa, aaa, aaaa, ...Null character strings are not included.)

a* means that "a" will appear repeatedly 0 times or more, while aa* means that "a" will appear repeatedly 
once or more and null character strings are not permitted, which is the same operation as the description of 
a+.  

- To indicate the repetition of ab, namely ab, abab, ababab... (ab)* must be specified, not ab* (Since repetition 
has a higher priority than connection, use parentheses to change the priority.)

- The regular expression indicating that the first character is a or b, the second is c, and the third is x or y is 
(a|b) c (x|y) (Since connection has a higher priority than selection, use parentheses to change the priority).  If 
parentheses are omitted, one of a, bcx, or y is searched.  

- The regular expression indicating that one of the characters enclosed in "[" and "] " will appear is not sup-
ported.  It can be described using "selection" as follows: 

E.g.: [abc] -> (a|b|c) This means that one of a, b or c will appear.  

(d)   Display Mini Dialog
If this check box is selected, the dialog box turns into a mini dialog box when the [Find Next] button is next 
selected (default).  

Figure 6-54 shows an image of the Replace String dialog box (mini).  

Figure 6-54   [Replace String] Dialog Box (Mini)

Button  Function

Down Continues the downward search for a character string matching the specified search key.  

Up Continues the upward search for a character string matching the specified search key.  

Replace+Down Replaces the found characters string then continues the downward search.  

Replace All Searches for matches, from the current caret position or the end of the specified edit 
range toward the end of the text, and replaces all the character strings that match the 
search key.  

Details Displays the normal Replace String dialog box in which the search conditions can be 
changed.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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(e)   Replace All from Top of Line
If this box is selected, the replacement starts from the first line, regardless of the position of the caret.  

(f)   This Source File Only
If this box is selected, only the source file to which the caret is currently positioned is searched.  

Function buttons 

Cautions

- When the [Esc] key is pressed, the search is aborted.  

- The settings of the check boxes and option buttons are stored and displayed at the next replacement.  

- If the replacement ends without finding any match for the character string to be replaced,  the operator is notified by 
the issue of a message or beep, depending on the setting of [Warning for Find/Replace] on the [Tool] menu -> [PM 
Settings...] - [Find/Replace] tab.  

Button  Function

Find Next Searches for a match for the search key.  

Replace Replaces the character string and continues searching for another match for the search key.  
If a read-only file is active, this button cannot be selected.  

Replace All Performs a search from the current caret position, and replaces all the character strings that 
match the search key without confirming.  
If a read-only file is active, this button cannot be selected.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Jump to Specified Line] dialog box

This dialog box is used to make a jump to a specified destination line number in the current file.  

Figure 6-55   [Jump to Specified Line] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Find] menu -> [To a Specific Line...]. 

- Select the [To a Specific Line...] button on the tool bar. 

Explanation of each area

(1)   Line No.

Specify a destination line number.  A jump to the specified line is performed by clicking the [OK] button.  

(2)   Valid

The valid range is from the first line to the last line on the display.  

[Note]
If there is a range selection in the Edit window, the operation is as follows according to the status of [Release Range 
Selected Before Jump] check box on the [Tool] menu -> [PM+ Settings...] - [Edit] tab.  

[Selected]
The range selection is released and the caret is moved to the top of the specified line.  

[Not selected]
The range selection will cover from the start position to the specified line.  If, however, a layer higher than that of the 
line at which the range selection starts appears between the start position and the specified line, the range selec-
tion will cover until just before the higher layer line.  

(1)

(2)
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Function buttons 

Button  Function

OK Makes a jump to the specified line.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Jump to Specified Line in the Source file] dialog box

This dialog box is used to make a jump to a specified destination line number in a specified source file.  

Figure 6-56   [Jump to Specified Line in the Source file] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Find] menu -> [To a Specific Line in the Source file...]. 

Explanation of each area

(1)   File name 

Specify a destination file name.  
If the active window has source files, the drop-down list sequentially lists the source file names.  If the active win-
dow does not have a source file (a text file, etc.), the drop-down list displays only the file name.  

(2)   Line No. 

Specify a destination line number.  
If a value exceeding the highest line number of the file is specified, a jump is made to the last line.  

(3)   Display with Path

If this check box is selected, displays the file name with the path.  This check box is not selected in the default con-
dition.  

Function buttons 

Button  Function

OK Makes a jump to the specified line.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

(1)

(3)

(2)
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[Mark Jump] dialog box

This dialog box is used to specify the current caret position as a mark or to make a jump to a marked line.  

Figure 6-57   [Mark Jump] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

- Cautions

Opening

- Select the [Find] menu -> [Mark Jump...]. 

Explanation of each area

(1)   MarkName 

Sets the mark names.  The contents of that line at the caret position are displayed by default.  
The mark name can be set by the user freely, and up to 5,119 characters can be set.  Moreover, uppercase charac-
ters and lowercase characters are distinguished for the mark name.  
Clicking the [Add] button, register a mark.  Up to 20 marks can be registered.  Note that the same name cannot be 
set more than once.  

(2)   MarkList

Selects the marks.  
If a mark is registered, the registered mark name is displayed.  When the mark name is selected, the selected mark 
name is displayed in the Mark Name edit box.  

(2)

(1)

(3)
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- Selecting mark and jumping
Clicking the [Jump] button after selecting a mark, or double-clicking a mark makes a jump to the mark position 
in the window being edited.  

- Selecting mark and deleting
Clicking the [Remove] button or the [Delete] key after selecting a mark, deletes the selected mark.  Multiple 
marks can be added.  

(3)   FileName and Line

The file name registered for the mark displayed in the Mark Name edit box and the contents of that line are dis-
played.  

Function buttons 

Cautions

- In the following cases, the mark is deleted from the list in this dialog box.  

- If the registered mark line has disappeared (due to [Cut] or [Delete] menu item, etc.)  

- When the untitled Edit window is closed without saving, while there is a mark added in the untitled Edit window.  

- When build or compile is executed and the contents of the [OutPut] window are updated, after a mark has been 
set in the [OutPut] window.  When the [OutPut] window is closed.  

- The way to release the range selection when a jump is made differs depending on the status of [Release Range 
Selected Before Jump] on the [Edit] tab in the [PM+ Settings] dialog box.  

Button  Function

Jump Clicking the [Jump] button after selecting a mark makes a jump to the mark position in the 
window being edited.  

Add Clicking the [Add] button after setting the mark names in the Mark Name edit box, register a 
mark.  

Remove Deletes a selected mark.  A mark can also be deleted with [Delete] key.

Close Does not enable the specified items, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Find in Files] dialog box

This dialog box is used to search through multiple files in a specified folder for a character string.

Figure 6-58   [Find in Files] Dialog Box

Figure 6-59   [Find in Files] Dialog Box (Details)

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

- Cautions

Opening

- Select the [Find] menu -> [Find in Files...]. 

- Select the [Find in Files] button on the tool bar. 

(1)

(2)

(3)

(4)

(1)

(2)

(3)

(5)

(4)
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Explanation of each area

(1)   Find What 

This area specifies the character string to be searched for.  
A word at the caret position is displayed as the search key by default.  If there is no corresponding word, the char-
acter string used last for searching is displayed.  If there is no previously search key, this area is left blank.  
Up to ten of the latest search keys are stored.  If there are over ten character strings, the oldest one will be deleted.  
The setting of the search key(s) can be changed by the status of [Show String You Selected or Word of Caret Posi-
tion to Find What] on the [Tool] menu -> [PM+ Settings...] - [Edit] tab.  

(2)   Of Type 

This area specifies the name of the file to be searched  
The wild card can also be used for file names.  Multiple file names can be specified by separating them with a semi-
colon ";".  
Up to 10 file names can be stored.  

(3)   Folder

This area specifies the folder to be searched.  
A desired folder can be directly input or can be changed by clicking the [...] button to open the Select Folder dialog 
box.  

Figure 6-60 shows an image of the Select Folder dialog box.  

Figure 6-60   [Select Folder] Dialog Box

After selecting a folder in this dialog box, clicking the [OK] button can be specify the folder.  If the [Cancel] button is 
clicked, a folder cannot be selected.  

(4)   Search options area

(a)   Search Active Window Only
If this button is selected, only the file being edited is searched (default).  
Accordingly, [Of Type], [Folder], and [Look in Subfolders] are disabled.  

(b)   Look in Subfolders
If this button is selected, the subfolders of the specified folder are also searched through.  
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(c)   Regular Expression (only details)
If this box is selected, regular expressions are supported in global searching. 

- Meta-characters *, |, (, ), and + have special meanings.  If any of those characters need to be searched, \ 
must be used.  If character \ needs to be searched, \\ must be specified.  
Other special characters are specified as follows:

- In regular expressions, repetition, concatenation, and selection are assigned decreasing priorities, in the 
stated order.  The priority can be adjusted by enclosing the corresponding part in parentheses,( and ).

[How to use regular expressions] 
- A character is a regular expression that indicates the character itself (except meta-characters).

E.g.: "a" is a regular expression indicating that the character "a" will appear.  

- Connection
XY, in which the regular expressions X and Y are described in order, is a regular expression indicating that X 
and Y will appear in that order. 
E.g.: abc is a regular expression indicating that characters a, b, and c will appear in that order.  

- Selection 
X|Y, in which "|" is described between X and Y, is a regular expression indicating that either X or Y will 
appear.  
E.g.: a|b|c is a regular expression indicating that one of the characters a, b or c will appear.

- Repetition
X*, in which "*" is described just after a regular expression X, is a regular expression indicating that X will 
appear repeatedly 0 times or more. 
E.g.: a* is a regular expression indicating that "a" will appear repeatedly 0 times or more.  

 (a, aa, aaa, aaaa, ...Null character strings will appear.)

X+, in which "+" is described just after a regular expression X, is a regular expression indicating that X will 
appear repeatedly once or more.  
E.g.: a+ is a regular expression indicating that "a" will appear repeatedly once or more. 

 (a, aa, aaa, aaaa, ...Null character strings are not included.)

a* means that "a" will appear repeatedly 0 times or more, while aa* means that "a" will appear repeatedly 
once or more and null character strings are not permitted, which is the same operation as the description of 
a+.  

Expression Description

Character Represents the character itself.

XY X and Y appear in the stated order. (concatenation)

X|Y X or Y appears. (selection)

X* X appears zero or more times.

(X) Same as X

(X)+ X appears one or more times.

Tab character \t -

Beginning of line ^ Valid only when specified at the beginning of a character string.  Otherwise, 
character ^ itself is searched for.

End of line $ Valid only when specified at the beginning of a character string.  Otherwise, 
character $ itself is searched for.



CHAPTER 6  WINDOW REFERENCE

216 User’s Manual  U18416EJ1V0UM

- To indicate the repetition of ab, namely ab, abab, ababab... (ab)* must be specified, not ab* (Since repetition 
has a higher priority than connection, use parentheses to change the priority.)

- The regular expression indicating that the first character is a or b, the second is c, and the third is x or y is 
(a|b) c (x|y) (Since connection has a higher priority than selection, use parentheses to change the priority).  If 
parentheses are omitted, one of a, bcx, or y is searched.  

- The regular expression indicating that one of the characters enclosed in "[" and "] " will appear is not sup-
ported.  It can be described using "selection" as follows: 

E.g.: [abc] -> (a|b|c) This means that one of a, b or c will appear.  

(d)   Display the Source File Names in the case of IDL file (only details)
If this button is selected, the source file name is also displayed for an IDL file (default).  

(e)   Match Case
If this box is selected, a character string that matches both the search key in [Find What] and the case of the 
characters in the search key is searched for (default).  

(f)   Match Whole Word Only (only details)
If this box is selected, a whole word match for the search key is searched for.  

(5)   Show File Names (only details)

(a)   Show All File Names with Layer
Displays the names of all searched files  in the Search result display window.  

(b)   Show File Name was found string with Layer
Displays only the names of files in which a match for the search key was found in the Search result display win-
dow, with layer (default).  

(c)   Show File Name was found string without Layer
Displays only the names of files in which a match for the search key was found in the Search result display win-
dow, without layer.  

Function buttons 

Cautions

- The search results are displayed under "File name (searched line number): contents of searched line", up to 5,119 
characters (the lines after the 5120th character are not displayed).  

Button  Function

Find Searches for a character string that matches the search key.  
Opens the Search result display window to display the search results.  

Cancel Does not enable the settings, and closes this dialog box.  

Details>>
Details<<

Updates the Find in Files dialog box and displays the detailed version.  If this button is 
clicked while this dialog box is the detailed version, the dialog box changes back to the origi-
nal Find in Files dialog box.  

Help Opens the help for this dialog box.  
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[Replace in Files] dialog box

This dialog box is used to replace a character string in multiple files in a specified folder.  
When the replacement in files is performed, the [History of Replace in files] window is opened to display the search key, 

replacement character string, file type, and searched folder.  The contents of the history contains the names of search 
files, numbers of the lines for which the replacement was performed, and the information of the lines before the replace-
ment.  

While a file is being searched/replaced, the name of the file currently being searched is displayed in the lower part of the 
dialog box.  

Figure 6-61   [Replace in Files] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Search/replacement result

- Function buttons

- Cautions

Opening

- Select the [Find] menu -> [Replace in Files...]. 

Explanation of each area

(1)   Character strings specification area

(a)   Find What
This area specifies the character string to be replaced.  
A word at the caret position is displayed as the search key by default.  If there is no corresponding word, the 
character string used last for searching is displayed.  If there is no previously search key, this area is left blank.  
The setting of the search key(s) can be changed by the status of [Show String You Selected or Word of Caret 
Position to Find What] on the [Tool] menu -> [PM+ Settings...] - [Edit] tab.  

(1)

(2)

(3)
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(b)   Replace With
This area specifies a replacement character string.  
The last-specified replacement character string is displayed by default.  If no replacement has been made, this 
area is left blank.  
The setting of the search key(s) can be changed by the status of [Show String You Selected or Word of Caret 
Position to Replace With] on the [Tool] menu -> [PM+ Settings...] - [Edit] tab.  

(2)   Files specification area

(a)   Of Type
This area specifies the name of the file to be searched  
The wild card can also be used for file names, but not for the extensions.  Note that files with the following exten-
sions cannot be specified:

.exe, .com, .dll, .ocx, .hlp, .fnc, .lib, .ilb, .bkl, .bkm, .idm, .bak, .dat, .cab, .sys, .ini, .vxd, .inf, .lzh, .zip, .sdb,  .plg, 

.xrf, .prn,  $~$

Multiple file names can be specified by separating them with a semicolon (;).  However, a file with "idl" extension 
cannot be specified in multiple.  

(b)   Folder 
This area specifies the folder to be searched.  
A desired folder can be directly input or can be changed by clicking the [...] button to open the Select Folder dia-
log box.  
After selecting a folder in this dialog box, clicking the [OK] button can be specify the folder.  If the [Cancel] button 
is clicked, a folder cannot be selected.  

(3)   Replacement options area 

(a)   Look in Subfolders
If this button is selected, the subfolders of the specified folder are also searched through.  This setting is linked 
with the setting made in the [Find in Files] dialog box.  

(b)   Match Whole Word Only
If this box is selected, a whole word match for the search key is searched for.  This setting is linked with the set-
ting made in the [Find in Files] dialog box.  

(c)   Display Message every Source File, in the case of IDL file
If this box is selected, if the replacement target file is an IDL file used to create a source file, the name of the 
source file in which the search key was found is displayed as the message Q2205.  
Clicking the [Yes] button performs search/replacement for the displayed source file.
Clicking the [No] button makes search/replacement skip from the displayed source file to the next source file.  A 
read-only source file line is not replaced, in this case, the message box will not appear and the search will skip to 
the next source file.  

(d)   Match Case
If this box is selected, a character string that matches both the search key in [Find What] and the case of the 
characters in the search key is searched for (default).  This setting is linked with the setting made in the [Find in 
Files] dialog box.  

(e)   Regular Expression
If this box is selected, regular expressions are supported in global searching. 

Expression Description

Character Represents the character itself.

XY X and Y appear in the stated order. (concatenation)

X|Y X or Y appears. (selection)
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- Meta-characters *, |, (, ), and + have special meanings.  If any of those characters need to be searched, \ 
must be used.  If character \ needs to be searched, \\ must be specified.  
Other special characters are specified as follows:

- In regular expressions, repetition, concatenation, and selection are assigned decreasing priorities, in the 
stated order.  The priority can be adjusted by enclosing the corresponding part in parentheses,( and ).

[How to use regular expressions] 
- A character is a regular expression that indicates the character itself (except meta-characters).

E.g.: "a" is a regular expression indicating that the character "a" will appear.  

- Connection
XY, in which the regular expressions X and Y are described in order, is a regular expression indicating that X 
and Y will appear in that order.  
E.g.: abc is a regular expression indicating that characters a, b, and c will appear in that order.  

- Selection
X|Y, in which "|" is described between X and Y, is a regular expression indicating that either X or Y will 
appear.  
E.g.: a|b|c is a regular expression indicating that one of the characters a, b or c will appear.

- Repetition
X*, in which "*" is described just after a regular expression X, is a regular expression indicating that X will 
appear repeatedly 0 times or more.  
E.g.: a* is a regular expression indicating that "a" will appear repeatedly 0 times or more.  

 (a, aa, aaa, aaaa, ...Null character strings will appear.)

X+, in which "+" is described just after a regular expression X, is a regular expression indicating that X will 
appear repeatedly once or more. 
E.g.: a+ is a regular expression indicating that "a" will appear repeatedly once or more.  

 (a, aa, aaa, aaaa, ...Null character strings are not included.)

a* means that "a" will appear repeatedly 0 times or more, while aa* means that "a" will appear repeatedly once 
or more and null character strings are not permitted, which is the same operation as the description of a+.  

- To indicate the repetition of ab, namely ab, abab, ababab... (ab)* must be specified, not ab* (Since repetition 
has a higher priority than connection, use parentheses to change the priority.)

- The regular expression indicating that the first character is a or b, the second is c, and the third is x or y is 
(a|b) c (x|y) (Since connection has a higher priority than selection, use parentheses to change the priority).  If 
parentheses are omitted, one of a, bcx, or y is searched.  

X* X appears zero or more times.

(X) Same as X

(X)+ X appears one or more times.

Tab character \t -

Beginning of line ^ Valid only when specified at the beginning of a character string.  Otherwise, 
character ^ itself is searched for.

End of line $ Valid only when specified at the beginning of a character string.  Otherwise, 
character $ itself is searched for.

Expression Description
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- The regular expression indicating that one of the characters enclosed in "[" and "] " will appear is not sup-
ported.  It can be described using "selection" as follows: 

E.g.: [abc] -> (a|b|c) This means that one of a, b or c will appear.  

Search/replacement result 

When searching or replacing in a file ends, the following [History of Replace in files] window will be opened to show the 
file history message of the replacement in files.  The message begins with the search key, replacement character string, 
file type, and searched folder.  The body of the history contains the name of the searched files, number of the lines for 
which the replacement was performed, source file names (where applicable), and the contents of the lines before the 
replacement.  

Figure 6-62   [History of Replace in files] Window

Table 6-6 shows the messages on the History of Replace in files window.  

Table 6-6   Messages on the History of Replace in files Window 

Massages Description

The folder of xxx is invalid. The specified folder is invalid.  

The extension of xxx is invalid. The extension of the specified file is invalid.  

The System File of xxx is invalid. An attempt was made to replace in a system file.

The Hidden File of xxx is invalid. An attempt was made to replace in a hidden file.

The Read Only File of xxx is invalid. The replacement cannot be performed in the specified file because of a 
read-only attribute.  

The Binary File of xxx is invalid. The replacement cannot be performed in the specified file because of a 
binary file.  

File xxx was Replaced. 
Replaced: xxx/Found: yyy

The replacement and saving were performed in the specified file. 
xxx: the number of the replacement  
yyy: the number of the detection

File xxx was closed. 
Found: xxx

The specified file was closed.  
xxx: the number of the detected search character strings

Displays the search conditions.

Displays the names of search files, numbers of the lines for which 
the replacement was performed, source file names (where applica-
ble), and the contents of the lines before the replacement.

Displays the number of search files.



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U18416EJ1V0UM 221

Function buttons 

Cautions

- If [Find Next] or [Replace] is selected, the file in which a match for the search key is found is displayed in the Edit 
window, and a range selection is assigned to the corresponding character string.  By selecting a button in this state, 
the replacement is skipped, continued, or stopped.  

- If a character string is replaced in a file, a backup file is created in the same folder.  The extension of the backup file 
is as specified in [Extension of Backup File] on the [Tool] menu -> [PM+ Settings...] - [File] tab.  The backup file is 
always created, regardless of whether [Make a Backup File] is selected or not.  

- In a search through a file being edited, a message confirming the replacement is displayed.  If the [Yes] button is 
selected, the replacement is performed for the file being edited.  Meanwhile, the file is not saved.  

- If the contents of an IDL file are replaced and saved, the corresponding source file is saved with the same contents.  

- A read-only source file line is not replaced.  The read-only source file is skipped, and the next source file is 
searched.  

The using file xxx is skipped. The specified file was skipped because it was under editing.  
When the message whether the search will be performed in a file under 
editing is displayed, the above message is displayed after selecting the [No] 
button.  

The search string was not found into 
the using file xxx.

The search character string was not detected in the specified file under edit-
ing.  

The processing of using file xxx was 
canceled. 
Found: xxx

Search of the specified file currently being edited was stopped. 
xxx: the number of the detected search character strings

The using file xxx was replaced. 
Replaced: xxx/Found: yyy 

The replacement was performed in the specified file under editing.  
xxx: the number of the replacement  
yyy: the number of the detection

The using file xxx was searched. 
Found: xxx

The searching was performed in the specified file under editing.  When the 
searching was performed to the end of the file under editing, this message 
is displayed after selecting the [Find Next] button.  
xxx: the number of the detected search character strings  

Button  Function

Find Next Performs a search until a match for the search key is found.  During the search, this button is 
grayed.  

Replace Replaces the found character string and continues the search.  During the search, this button is 
grayed.  

Replace This File Replaces all matches for the search key following that in the range selection.  No confirmation 
message is displayed.  After the replacement in the current file ends, the next file is searched.  

Replace All A message notifying the risk of the replacement in files is displayed first.  
If the [Yes] button is selected, replaces all matches for the search key following that in the range 
selection.  

Close Closes the dialog box.  During a file search or replacement, this button displays "Cancel".  

Cancel Stops the search or replacement.  When the search stops, this button displays "Close".  

Help Opens the help for this dialog box.  

Massages Description
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- The following files are not searched: 

- Read-only, system, and hidden files

- Binary file (Contains NULL.)

- File with an inhibited extension (refer to "(a)  Of Type")

- File that cannot be opened in the write mode

- The following folders are not searched:

- Windows folder and its subfolders
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[Expand to Specified Layer] dialog box

This dialog box is used to expand specified layers.  

Figure 6-63   [Expand to Specified Layer] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

- Cautions

Opening

- Select the [Layer] menu -> [Expand the Specific Layer].  

Explanation of each area

(1)   Specify The Layer 

Specify the number of layers to be expanded.  A value within the range of 1 to 127 can be specified.  The last set-
ting is displayed by default.  When this value is specified for the first time, 127 is displayed.  

(2)   Expand Caret Line Only

When this check box is selected, only the layers lower than the line at the caret position are expanded.  
When this check box is not selected, all of the specified lower layers are expanded (default).  

Function buttons 

Button  Function

OK Expands the specified number of layers.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

(1)

(2)
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Cautions

- If a layer higher than the one specified is already expanded, there is no change.  If, however, [Collapse Deeper 
Layer than Specified Layer as Expand Specified Layer Command] is selected on the [Tool] menu -> [PM+ Set-
tings...] - [Layer] tab, the layer lower than the one specified are collapsed.  

- If the current caret position is lower than the specified layer, the updated caret position will differ depending on the 
following settings:

A: [Expand Caret Line Only] check box (which is in this dialog box.)
B: [Collapse Deeper Layer than Specified Layer as Expand Specified Layer Command] check box (which is on the 

[Tool] menu -> [PM+ Settings...] - [Layer] tab.)

A B The Position of the Caret

OFF OFF Moves to the index line of the specified layer that includes the current caret.  

OFF ON Moves to the index line of the specified layer that includes the current caret.  The layers 
lower than the one specified are collapsed.  

ON OFF Moves to the index line of the specified layer that includes the current caret.  

ON ON Not moves.  The layers lower than the caret position are collapsed.  
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[Collapse to Specified Layer] dialog box

This dialog box is used to collapse specified layers.  

Figure 6-64   [Collapse to Specified Layer] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Layer] menu -> [Collapse the Specific Layer...].  

Explanation of each area

(1)   Specify The Layer 

Specify the number of layers to be collapsed.  A value within the range of 1 to 127 can be specified.  The last set-
ting is displayed by default.  When this value is specified for the first time, 1 is displayed.  

(2)   Collapse Caret Line Only

When this check box is selected, only the layers lower than the line at the caret position are collapsed.  When this 
check box is not selected, all of the specified lower layers are expanded (default).  

Function buttons 

Button  Function

OK Collapses the specified number of layers.  
If a layer higher than the one specified is already collapsed, there is no change.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

(1)

(2)
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[Set Layer Rule] dialog box

This dialog box is used to apply a layer rule to the current contents of the Edit window, or set  the layer rule to be applied 
when files are read.  By default, all check boxes are selected.  

Figure 6-65   [Set Layer Rule] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

- Cautions

Opening

- Select the [Layer] menu -> [Apply Layer Rule...].  

- Click the [Layer Rule...] button in the [Open] dialog box.  

- Click the [Layer Rule...] button in the [Insert File] dialog box.  

Explanation of each area

(1)   Apply Layer Rule

Select the coding to be subjected to the layer rule. By default, all check boxes are selected.  The layer rule for each 
item is follows:  

(a)   if
For an if statement or else if statement, the lines from that following ")" of if to "}" are indented.  If "}" is followed by 
a source coding, the lines up to that preceding "}" are indented.  

(b)   switch
The contents of a switch statement are indented.

(1)

(3)

(2)



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U18416EJ1V0UM 227

(c)   case, default
The lines after a case statement are indented up to the next case statement or default statement.  default state-
ment, the lines up to that preceding "}" are indented.

(d)   for
The lines from that following ")" of a for statement to "}" are indented.

(e)   while
The lines from that following ")" of a while statement to "}" are indented.

(f)   do while
The lines from that following a do statement to the last line of the while statement are indented.  

(g)   const
The lines following a const statement are indented.

(h)   struct
The lines following a struct statement are indented.  

(i)   Function
The lines from that following a function definition line to the end of the function are indented.  

(j)   PreProcessor
The lines from that following a preprocessor instruction to that preceding the next preprocessor instruction or to 
that preceding #endif are indented. 
However, #elseif is not hierarchically organized.  Use #elif . 

(2)   Preview

This area displays samples of how the items currently selected by [Apply Layer Rule] are subjected to the layer 
rule.  

(3)   Apply Layer Rule only the Range You Selected

This check box is displayed only if this dialog box is opened by selection the [Layer] menu -> [Apply Layer Rule...].  
This check box becomes valid when the [Apply Layer Rule...] menu item is performed with a range selection in the 

Edit window.  If this check box is selected, the layer rule is applied to the specified range only.  

Function buttons 

Button  Function

OK Applies the layer rule to the current contents of the Edit window.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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Cautions

- When the layer rule is applied, the undo buffer is cleared.  This means that the status existing prior to applying the 
layer rule cannot be restored.  

- If [Apply Layer Rule only to the Range You Selected] check box is selected, the following caution is required:  

- If the range selection does not extend from "{" following an instruction to "}", the layer rule is not applied.  

- If the range selection does not cover the switch statement corresponding to a case or default statement, the layer 
rule is not applied.  

- If the range selection does not extend to the breakpoint of a case or default statement, the layer rule is not applied.  

1:void SetStatus( int State)

2:{

3:    if( State > 0x50 ){

4:        m_nState = State;

5:   }

6:   else if( 

7:           State != OFF )

8:   {

9:        m_nState = OFF;

10:   }else{

11:       m_nState = NULL;

12:   }

13:}

Because the '}' in the fifth line is not included in 
the range selection, the layer rule is not applied.  

Because the switch statement in the third line 
is not included in the range selection, the 
layer rule is not applied.  

1:void SetStatus( int State)

2:{

3:    switch(State){

4:        case 0x50 :

5:           m_nState = State;

6:           break;

7:       case OFF :

8:           m_nState = OFF;

9:

10:        default:

11:          m_nState = NULL;

12:  }

13:}

The case statement in the fourth line is applied 
to the layer rule, but the case statement in the 
seventh line is not applied to the layer rule.

1:void SetStatus( int State)

2:{

3:    switch(State){

4:        case 0x50 :

5:           m_nState = State;

6:            break;

7:       case OFF :

8:           m_nState = OFF;

9:

10:        default:

11:          m_nState = NULL;

12:   }

13:}
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[Function List] dialog box

This dialog box is used to lists the functions of the file displayed in the active Edit window.  If multiple Edit windows are 
open, the function list is updated when any position in the Function List dialog box is clicked after updating the active win-
dow.  

Figure 6-66   [Function List] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Cautions

Opening

- Select the [View] menu -> [Function List...].  

(1)

(2)
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Explanation of each area

(1)   Buttons

(2)   Function

This area displays a list of the functions of the file displayed in the active Edit window.  
If this dialog box is opened or made active with a range selection placed on the character string of a function name 
in the Edit window,  the specified function name is selected.  
Double-clicking the left mouse button or clicking the jump button after selecting a function name in [Function] area 
jumps to the function definition line in the Edit window.  
Note that because this area lists the functions in the active Edit window, when multiple Edit windows are open, the 
contents of the function list will be update each time the window focus is moved.  

Cautions

- The function name is not recognized because the function name differs according to the value of #ifdef.  

- The function name is not recognized because the function name covers two lines due to "\".  

Button  Function

Jumps to the function definition line in the Edit window when a function is selected in [Func-
tion] area.  This is the same as double-clicking a function name.  
This button is invalid if a function name is not selected in [Function] area.  

Displays, in the ascending order, the functions of each source file displayed in the order in 
which they have been searched from the beginning of the Edit window.  If the functions are 
displayed in the ascending order, they are displayed in the order in which they have been 
searched.  By default, they are displayed in the order in which they have been searched.  

Displays the [Save the Function List] dialog box and a function list can be saved into a file.  

Closes this dialog box. 

Opens the help for this dialog box.  

void

#ifdef ENGLISH

FncEng

#else

FncJapan

#endif

(int Cnt, int Mode)

{  ...

void Function         \
Name

(int Cnt. int Mode)

{   ...
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- The function name is not recognized because variable declaration is performed between function name and '{'.

#ifdef ENGLISH

int main( argc, argv[])

int argr;

char* argv[];

{

}
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[Save the Function List] dialog box

This dialog box is used to save the functions displayed in the [Function List] dialog box to a file.  

Figure 6-67   [Save the Function List] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [Save] button in the [Function List] dialog box. 

Explanation of each area

(1)   Save in

Specify the folder in which the file is saved.  By default, the current folder is displayed.  

(2)   File name and Save as type

(a)   File name
Specify the name of the file to be saved.  Directly enter the file name in the text box.  Alternatively, select the file 
name from the list.  Note that the extension cannot be changed to other than ".txt" or ".csv".  

(b)   Save as type
Specify the type (extension) of the file to be saved.  
Select the file type from the drop-down list.  From this drop-down list, "Function List Tag File(*.txt)" or "Function 
List Csv File(*.csv)" can be selected.  
If "Function List Tag File" is selected, the function list is saved to a file of tag jump format.  
If "Function List Csv File" is selected, the function list is saved to a CSV file.  CSV file can be read by spreadsheet 
software.  

(1)

(2)
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By default, "Function List Tag File" is selected.  

Function buttons 

Button  Function

Save Saves the function list to the specified file.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

[ CSV File ]

The names of files defined in the functions  (Defined line number): Function name

The names of files defined in the functions,  Defined line number,  Function name

[ Tag File ]

C:\PM_test\test1.c(19): main
C:\PM_test\test1.c(37): Func1
C:\PM_test\test1.c(76): Func2
C:\PM_test\test1.c(91): Func3

FileName,Line,Function Name
C:\PM_test\test1.c,19,main
C:\PM_test\test1.c,37,Func1
C:\PM_test\test1.c,76,Func2
C:\PM_test\test1.c,91,Func3
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[Layer List] dialog box

This dialog box is used to list the layers of the file displayed in the active Edit window.  

Figure 6-68   [Layer List] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [View] menu -> [Layer List...].  

Explanation of each area

(1)   Layer 

The list indicates the text and line number with lower layers.  If the first layer has a file name, the file name is dis-
played as well.  
Clicking "+" displays a list of the layers lower than the line.  Clicking "-" hides the list.  
Double-clicking a layer or clicking the [Jump] button with a layer selected makes a jump to the selected layer in the 

Edit window.  

Function buttons 

Button  Function

Jump Jumps to the layer selected in [Layer]. 

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

(1)
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[Select Active Project] dialog box 

This dialog box is used to select the active project.  

Figure 6-69   [Select Active Project] Dialog Box 

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Project] menu -> [Select Active Project...].  

Explanation of each area

(1)   Select Project 

This area displays the currently selected project name.  
To change the active project, select from the drop-down list, in which all the currently registered project name are 
displayed.  

Function buttons 

Button  Function

OK Makes the selected project active.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

(1)
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[Insert Project] dialog box

This dialog box is used to insert an existing project into a project group.  
The project added here will be the active project.  

Figure 6-70   [Insert Project] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Project] menu -> [Insert Project...].  

- Select the right mouse button menu -> [Insert Project...] with a project group name selected in the [Project] window.  

Explanation of each area

(1)   Look in

Select the drive or folder that includes the project file to be inserted from the drop-down list.  

(2)   File name and Files of type

Specify the name of the project file to be inserted.  The project file extension is "prj".  Files with any other exten-
sions cannot be specified.  

(3)   Project Group Name 

Select the project group name to which the project is added.  Up to 20 projects can be registered per project group.  
If a new project group is added, enter the group name in the combo box directly.  

(1)

(3)

(2)
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Function buttons 

Button  Function

Open Inserts the selected project group into the workspace.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[CVS Update] dialog box

This dialog box is used to execute the CVS update command for the selected file and acquire files registered in the 
repository.  

The result is displayed on the [OutPut] window.  

Figure 6-71   [CVS Update] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

- Cautions

Opening

- Select the [Project] menu -> [CVS Update...].  

Explanation of each area

(1)   File 

The name of the file for which the command is to be executed is displayed.  
The file is determined as follows:

[If the [Project] window is active]
Selected source file name, function name, include file name, project related file name, or other file name

[If the Edit window is active]
File name on the Edit window, or name of generated file at the caret position if idl file

(2)   Command

The command to be executed is displayed.  %f indicates the name of a file currently selected for command execu-
tion.  
Command options can be added here to set detailed options related to CVS.  The added command options are 
executed when the CVS command is executed.  
Up to 10 executed commands are stored and can be selected from the drop-down list.  

(1)

(2)
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Function buttons 

Cautions

The following operations must be performed before executing this menu item.  

- Set the folder that includes cvs.exe using the PATH variable of OS.  

- Set the repository of CVS.  

- If the CVS server is being used, log onto the server.  

Button  Function

OK Executes the specified command.  
The result is displayed on the [OutPut] window.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[CVS Commit] dialog box

This dialog box is used to execute the CVS commit command for the selected file and reflect the file in the repository.  
The result is displayed on the [OutPut] window.  

Figure 6-72   [CVS Commit] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

- Cautions

Opening

- Select the [Project] menu -> [CVS Commit...].  

Explanation of each area

(1)   Commit File 

The name of the file for which the command is to be executed is displayed.  
The file is determined as follows:

[If the [Project] window is active]
Selected source file name, function name, include file name, project related file name, or other file name

[If the Edit window is active]
File name on the Edit window, or name of generated file at the caret position if idl file

(2)   Log Message 

Enter the log message to be added when commit is executed.  

(1)

(3)

(2)
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(3)   Command 

The command to be executed is displayed.  %f indicates the name of a file currently selected for command execu-
tion.  
Command options can be added here to set detailed options related to CVS.  The added command options are 
executed when the CVS command is executed.  
Up to 10 executed commands are stored and can be selected from the drop-down list.  

Function buttons 

Cautions

The following operations must be performed before executing this menu item.  

- Set the folder that includes cvs.exe using the PATH variable of OS.  

- Set the repository of CVS.  

- If the CVS server is being used, log onto the server.  

Button  Function

OK Executes the specified command.  
The result is displayed on the [OutPut] window.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[CVS Log] dialog box

This dialog box is used to execute the CVS log command for the selected file and display the file's log contents in the 

[OutPut] window. 

Figure 6-73   [CVS Log] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

- Cautions

Opening

- Select the [Project] menu -> [CVS Log...].  

Explanation of each area

(1)   File 

The name of the file for which the command is to be executed is displayed.  
The file is determined as follows:

[If the [Project] window is active]
Selected source file name, function name, include file name, project related file name, or other file name

[If the Edit window is active]
File name on the Edit window, or name of generated file at the caret position if idl file

(2)   Command 

The command to be executed is displayed.  %f indicates the name of a file currently selected for command execu-
tion.  
Command options can be added here to set detailed options related to CVS.  The added command options are 
executed when the CVS command is executed.  
Up to 10 executed commands are stored and can be selected from the drop-down list.  

(1)

(2)
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Function buttons 

Cautions

The following operations must be performed before executing this menu item.  

- Set the folder that includes cvs.exe using the PATH variable of OS.  

- Set the repository of CVS.  

- If the CVS server is being used, log onto the server.  

Button  Function

OK Executes the specified command.  
The result is displayed on the [OutPut] window.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[CVS Status] dialog box

This dialog box is used to execute the CVS status command for the selected file and display the file's status in the [Out-
Put] window. 

Figure 6-74   [CVS Status] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

- Cautions

Opening

- Select the [Project] menu -> [CVS Status...].  

Explanation of each area

(1)   File 

The name of the file for which the command is to be executed is displayed.  
The order of files to be executed is determined as follows:

[If the [Project] window is active]
Selected source file name -> function name -> include file name -> project related file name, -> other file name

[If the Edit window is active]
File name on the Edit window, or name of generated file at the caret position if idl file

(2)   Command 

The command to be executed is displayed.  %f indicates the name of a file currently selected for command execu-
tion.  
Command options can be added here to set detailed options related to CVS.  The added command options are 
executed when the CVS command is executed.  
Up to 10 executed commands are stored and can be selected from the drop-down list.  

(1)

(2)
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Function buttons 

Cautions

The following operations must be performed before executing this menu item.  

- Set the folder that includes cvs.exe using the PATH variable of OS.  

- Set the repository of CVS.  

- If the CVS server is being used, log onto the server.  

Button  Function

OK Executes the specified command.  
The result is displayed on the [OutPut] window.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Project Settings] dialog box

This dialog box is used to set the information on the current active project.  The information is set on the following tabs.  

(1)  [Project Information] tab

(2)  [Source File ] tab

(3)  [Tool Version Settings] tab

Figure 6-75   [Project Settings] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each tab

- Function buttons

- Cautions

Opening

- Select the [Project] menu -> [Project Settings...].  

- Select the right mouse button menu -> [Project Settings...] with a project name selected in the [Project] window.  

(1) (2) (3)
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Explanation of each tab

(1)   [Project Information] tab

This tab displays the information on the current active project and changes the project title or the device name.

Figure 6-76   [Project Settings] Dialog Box - [Project Information] Tab

(a)   Information display area

- Project File Name
The project file name of the active project is displayed.  

- Folder
The project folder specified with the project file is displayed.  

- Workspace File Name
The name of the workspace file to which the active project belongs is displayed with an absolute path.  

- Project Group
The name of the project group to which the active project belongs is displayed.  If you wish to change the 
name of the project group, click the right mouse button on the project group name in the [Project] window 
and select the [Edit Project Group Name...] menu.  

(b)   Project Title
The project title to be displayed in the [Project] window is displayed.  
When the project title is modified here, that modification is reflected in the [Project] window.  
Up to 127 characters can be entered for project title.  

(c)   Microcontrollers Name and Device Name
The microcontrollers and device name of the target device to be used are displayed.  
They can be changed by selecting from the drop-down lists.
If the device file for the device to be used has not been installed, the following message will be displayed under 
the device name displayed.

"The device file that has been selected is not registered."

When this message is displayed, clicking the [Device Install] button starts the device file installer to register the 
new device file.
If multiple projects are registered into the project group, or if the debugger/simulator is running, these drop-down 
lists are invalid.  

(a)

(b)

(c)
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(2)   [Source File ] tab

This tab specifies the source file information on the current active project.

Figure 6-77   [Project Settings] Dialog Box - [Source File] Tab

(a)   Source Files 
This area displays the names of the source files set in the active project in build order, including the relative path 
starting from the project folder.
Up to 2048 source files can be registered.  

[Cautions] 
- If the compiler and assembler are not installed, source file addition is not possible. 

- Executing make assembles/compiles the source files in the order displayed in the source file list, in accor-
dance with the program type.  The path of the project folder is used for the path name of a source file during 
make.  In addition, the linking order depends on the linker of the microcontrollers used. 

Button  Function

Add... Opens [Add Source Files] dialog box to add the source file to the project.  

Remove Removes the selected source file from the list.  

Remove All Removes all the source files from the list.  

Up Moves the selected source file up within the list.  

Down Moves the selected source file down within the list.  

OK Sets the project information on the currently active project.  

Cancel Does not enable the specified items, and closes this dialog box.  

Help Opens the help for this dialog box.  

(a)
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(3)   [Tool Version Settings] tab

This tab specifies the tools used for the current active project.

Figure 6-78   [Project Settings] Dialog Box - [Tool Version Settings] Tab

(a)   Tool Set
The combination of tools to be used and their versions is regarded as a tool set, and the tool set name can be 
selected from the drop-down list.  
The existing tool set and recommended tool set ("78Kx Microcontrollers Software Package Vx.xx" in the case of 
the 78K Microcontrollers, and "V850 Microcontrollers Software Package Vx.xx" in the case of the V850 
Microcontrollers) are listed on the drop-down list.  The name of the tool set specified for use in the current active 
project is displayed by default.
If the tool set has been changed in the [Tool Version Detail Setting] dialog box opened by clicking the [Detail Set-
ting...] button, "(Changed)" is appended at the top of the tool set name.  If the tool set name already exists, the 
indication appended varies from "(Changed01)" to "(Changed99)".  After "(Changed99)", the tool set name is dis-
played as "UserSet".  

[Remark]
A file is saved as "tool-set-name.extension".  The extension varies depending on the product used, as shown 
below. 

78K0R Microcontrollers (including libraries): t0r
78K0 Microcontrollers (including libraries): tk0
78K0S Microcontrollers (including libraries): t0s
V850 Microcontrollers (including libraries): t85

The file is saved under "NEC Electronics\PM+" in the "Application Data" folder, which is accessible by all 
users.  If this folder does not exist, it is automatically created when PM+ is started up (for example, "C:\Docu-
ments and Settings\All Users\Application Data\NEC Electronics\PM+" in the case of Windows XP).

Button Function

Save Saves the tool set currently selected in [Tool Set].
This button is not available (appears dimmed) if the tool set file is read-only.

Delete Deletes the tool set name selected in [Tool Set] from the list (also deletes the corresponding tool set 
file).
This button is not available (appears dimmed) if there are no tool set files corresponding to the 
selected tool set or the tool set file is read-only.

(c)

(b)

(a)
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(b)   Tool Versions
Combinations of tools to be used and their versions are displayed in this area.
When a tool set name is selected on the Tool Set drop-down list, the tools included in the tool set and their ver-
sions are displayed. 
If you wish to change tools to be used and their versions , click the [Detail Setting...] button to open the [Tool Ver-
sion Detail Setting] dialog box.  
The tools used by the active project and their versions are displayed by default.

- Tool
All the installed tools and tools included in the selected tool set (including tools that have not been installed) 
are displayed in this area. 
However, tools that have not been installed are dimmed.

- Version
The tool versions specified in the selected tool set are displayed in this area.
However, tools that have not been installed are dimmed, and "Unused" is displayed for a tool whose version 
is not specified in the tool set.

- Select only Installed Tools
If this check box is selected, tools that have not been installed are excluded from the [Tool Versions] which 
corresponds to the tool set selected in the [Tool Set].
"(Selected01)" is appended to the top of the name of the tool set with which this check box is selected (if the 
tool set name actually exists, "(Selected nn)" is appended).
This check box cannot be selected (grayed) if there are no dimmed tools (all the listed tools have been 
installed).  This check box is not selected in the default condition. 

(c)   Brief description area
A message is displayed when a dimmed item is displayed in the Tool Versions area.

Function buttons 

Cautions

- To transfer a project group, select a project title in the [Project] window, delete the registered project by clicking the 
right mouse button and executing [Delete Project], and then transfer the project to the new location by executing 
[Insert Project...] from the [Project] menu.  

Button  Function

OK Sets the project information on the currently active project.  

Cancel Closes this dialog box. 

Help Opens the help for this dialog box.  
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[Add Source Files] dialog box

This dialog box is used to add source files to a project.  

Figure 6-79   [Add Source Files] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Project] menu -> [Add Source Files...].  

- Select the [Project] menu -> [Project Settings...] - [Source File] tab.  

- Click the [Add...] button on the [New WorkSpace - Step 1/9 [Workspace Information]] dialog box.  

- Select the right mouse button menu -> [Add Source Files...] in the [Project] window.  

Explanation of each area

(1)   Look in

Select the drive or folder that includes the source files to be inserted from the drop-down list.  

(2)   File name and Files of type

Specify the name of the source file to be inserted.  Up to 256 characters can be specified.  The source file exten-
sion depends on the microcontrollers name registered in the project.  
If a list file in which source file names are described is specified for the file name (*.lst, *.csv), the source files 
described in the list file are added to the project.  A list file is a text file with a file name described on each line (*.lst), 
or a CSV file (*.csv).  

(1)

(2)
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Function buttons 

Button  Function

Open Adds the specified source files to the project.  Multiple source files can be added.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

Add Files from Folder... Opens the Brows for Folder dialog box from which the source files to be added are spec-
ified in the folder unit.  All of the source files in the selected folder are added to the 
project.  
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[Add Project Related Files] dialog box

This dialog box is used to add project-related files to a project.  

Figure 6-80   [Add Project Related Files] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Project] menu -> [Add Project Related Files...].  

- Select the right mouse button menu -> [Add Project Related Files...] with the Project Related Files folder selected in 
the [Project] window.  

Explanation of each area

(1)   Look in

Select the drive or folder that includes the project-related files to be added from the drop-down list.  

(2)   File name and Files of type

Specify the name of the project-related files to be added.  Up to 259 characters can be specified.  
A list of the file types that can be added are displayed in the drop-down list.  The contents of [Open as] change 
according to this selection.  

(3)   Open As

Select the application of the file to be added from the drop-down list.  The contents of [Files of type] change accord-
ing to this selection.  

(1)

(3)

(2)



CHAPTER 6  WINDOW REFERENCE

254 User’s Manual  U18416EJ1V0UM

Function buttons 

Button  Function

Open Adds the specified files to the Project Related Files folder.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Add Other Files] dialog box

This dialog box is used to add any files to a project as other files.  

Figure 6-81   [Add Other Files] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Project] menu -> [Add Other Files...].  

- Select the right mouse button menu -> [Add Other Files...] with the Other Files folder/any file selected in the [Project] 
window.  

Explanation of each area

(1)   Look in 

Select the drive or folder that includes any files to be added from the drop-down list.  Multiple files can be added.  

(2)   File name and Files of type

Specify the name of the any files to be added.  Up to 259 characters can be specified.  
The extension of the file is "*.doc", "*.xls" or "*.*".  

Function buttons 

Button  Function

Open Adds the specified files to the Other Files folder.  

Cancel Does not enable the settings, and closes this dialog box.  

(1)

(2)
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[Project Group Name] dialog box

This dialog box is used to change a project group name.  

Figure 6-82   [Project Group Name] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the right mouse button menu -> [Edit Project Group Name...] with a project group name selected in the 

[Project] window.  

Explanation of each area

(1)   Old Project Group 

The name of the project group currently selected in the [Project] window is displayed.  

(2)   New Project Group 

Specify the newly set project group name directly in this area.  Up to 127 characters can be entered.  

Function buttons 

Button  Function

OK Changes to the specified project group name.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

(1)

(2)
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[Project Title] dialog box

This dialog box is used to change a project title.  

Figure 6-83   [Project Title] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the right mouse button menu -> [Edit Project Title...] with a project title selected in the [Project] window.  

Explanation of each area

(1)   Old Project Title 

The name of the project title currently selected in the [Project] window is displayed.  

(2)   New Project Title 

Specify the newly set project title directly in this area.  Up to 127 characters can be entered.  

Function buttons 

Button  Function

OK Changes to the specified project title.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

(1)

(2)
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[Tool Version Settings] dialog box

This dialog box is used to change the tools to be used by a project included in the selected project group at once.

Figure 6-84   [Tool Version Settings] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the right mouse button menu -> [Select Tools...] with a project group name selected in the [Project] window. 

Explanation of each area

(1)   Tool Set

The combination of tools to be used and their versions is regarded as a tool set, and the tool set name can be 
selected from the drop-down list.  
The existing tool set and recommended tool set ("78Kx Microcontrollers Software Package Vx.xx" in the case of the 
78K Microcontrollers, and "V850 Microcontrollers Software Package Vx.xx" in the case of the V850 
Microcontrollers) are listed on the drop-down list.
If the tool set has been changed in the [Tool Version Detail Setting] dialog box opened by clicking the [Detail Set-
ting...] button, "(Changed)" is appended at the top of the tool set name.  If the tool set name already exists, the indi-
cation appended varies from "(Changed01)" to "(Changed99)".  After "(Changed99)", the tool set name is displayed 
as "UserSet".  

(2)

(1)

(3)
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[Remark]
A file is saved as "tool-set-name.extension".  The extension varies depending on the product used, as shown 
below. 

78K0R Microcontrollers (including libraries): t0r
78K0 Microcontrollers (including libraries): tk0
78K0S Microcontrollers (including libraries): t0s
V850 Microcontrollers (including libraries): t85

The file is saved under "NEC Electronics\PM+" in the "Application Data" folder, which is accessible by all users.  
If this folder does not exist, it is automatically created when PM+ is started up (for example, "C:\Documents and 
Settings\All Users\Application Data\NEC Electronics\PM+" in the case of Windows XP).

(2)   Tool Versions

Combinations of the tools in the tool set specified in the Tool Set area and their versions are listed.
When a tool set name is selected on the Tool Set drop-down list, the tools included in the tool set and their versions 
are displayed. 
The tools included in the default tool set selected on the Tool Set drop-down list and their versions are displayed by 
default.
The [Tool Version Detail Setting] dialog box is opened by clicking the [Detail Setting...] button.  Tools to be used 
and their versions can be selected in this dialog box.

(a)   Tool
All the installed tools and tools included in the selected tool set (including tools that have not been installed) are 
displayed in this area. 
However, tools that have not been installed are dimmed.

(b)   Version
The tool versions specified in the selected tool set are displayed in this area.
However, tools that have not been installed are dimmed, and "Unused" is displayed for a tool whose version is 
not specified in the tool set.

(c)   Select only Installed Tools
If this check box is selected, tools that have not been installed are excluded from the [Tool Versions] which corre-
sponds to the tool set selected in the [Tool Set].
"(Selected01)" is appended to the top of the name of the tool set with which this check box is selected (if the tool 
set name actually exists, "(Selected nn)" is appended).
This check box cannot be selected (grayed) if there are no dimmed tools (all the listed tools have been installed).
This check box is not selected in the default condition. 

(3)   Brief description area

A message is displayed when a dimmed item is displayed in the Tool Versions area.

Button Function

Save Saves the tool set currently selected in [Tool Set].
This button is not available (appears dimmed) if the tool set file is read-only.

Delete Deletes the tool set name selected in [Tool Set] from the list (also deletes the corresponding tool set file).
This button is not available (appears dimmed) if there are no tool set files corresponding to the 
selected tool set or the tool set file is read-only.
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Function buttons

Button Function

OK Changes the tools to be used by a project included in the selected project group at once.

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Tool Version Detail Setting] dialog box

This dialog box is used to select the tools to be used and their versions.

Figure 6-85   [Tool Version Detail Setting] dialog box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [Detail Setting...] button on the [Project Settings] dialog box  - [Tool Version Settings] tab.  

- Click the [Detail Setting...] button or double-click the [Tool Versions] area on the [Tool Version Settings] dialog box.  

- Click the [Detail Setting...] button on the [New WorkSpace - Step 2/9 [Select Tools]] dialog box. 

- Click the [Detail Setting...] button on the [Add New Project - Step 2/9 [Select Tools]] dialog box. 

Explanation of each area

(1)   Tool name area

Displays the names of the installed tools.
If the tool name is too long to fit in the field, the name is displayed left-aligned.  Pointing to the character string with 
the pointer causes the character string to pop up.

(2)

(1)

(3)
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(2)   Version selection area

Selects the version of the tool to be used.  
The version specified in the [Tool Version Settings] dialog box is selected by default.  
The version specified in the [Tool Version Settings] dialog box is highlighted, or "Unused" is highlighted if the prod-
uct with that version has not been installed.  
In addition, the version of the product included in the recommended tool set is highlighted by a background color.  
Multiple versions cannot be selected, nor can the version be left unselected.

(3)   Brief description area

Indicates which tool set the background color highlighting the version in the version selection area corresponds to.

Function buttons

Button Function

OK Reflects the modified contents in the [Tool Version Settings] dialog box if the version 
setting of a tool to be used has been modified.

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Properties] dialog box

This dialog box is used to displays the path information and read attribute of the selected file.  

Figure 6-86   [Properties] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the right mouse button menu -> [Propertes...] with a file/function name selected in the [Project] window.  

Explanation of each area

(1)   Information area

(a)   File Name and Path Name 
Displays the name and the location of the selected file with the full path.  

(b)   Last Update 
Displays the date and time of the last update.  

(c)   Attribute 
This is displayed when the selected file has a read attribute.

(d)   IDL File 
If the selected file is a source file generated from an IDL file, the IDL file name is displayed with the relative path 
starting from the source file.  

Function buttons 

Button  Function

Close Closes this dialog box.  

(1)
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[Add New Memo] dialog box

This dialog box is used to add a new memo.  

Figure 6-87   [Add New Memo] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the right mouse button menu -> [Add New Memo...] on the [Memo] tab in the [Project] window.  

Explanation of each area

(1)   Memo 

Enter a new memo directly.  The date and time of addition is also displayed on the [Project] window.  

Function buttons 

Button  Function

OK Adds the memo newly.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

(1)
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[Startup File] dialog box

This dialog box is used to specify a startup file when an existing file is used as a startup file.  

Figure 6-88   [Startup File] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [Browse...] button on the [New WorkSpace - Step 4/9 [Startup File]] dialog box.  

- Click the [Browse...] button on the [Add New Project - Step 4/9 [Startup File]] dialog box.  

Explanation of each area

(1)   Look in

Select the drive or folder that includes the startup file to be specified from the drop-down list.  

(2)   File name and Files of type

Specify the name of the startup file.  The extension of startup file is ".o" or ".s" by default.  

(1)

(2)
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Function buttons 

Button  Function

Open Sets the specified file as a startup file.  
The specified startup file is registered to the project related files.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Copy Startup File from] dialog box

This dialog box is used to specify a startup file to be a copy source when an existing file is copied and used as a startup 
file.  

Figure 6-89   [Copy Startup File from] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [Browse...] button after selecting Copy and Use the Existing file on the [New WorkSpace - Step 4/9 [Star-
tup File]] dialog box.  

- Click the [Browse...] button after selecting Copy and Use the Existing file on the [Add New Project - Step 4/9 [Star-
tup File]] dialog box.  

Explanation of each area

(1)   Look in 

Select the drive or folder that includes the startup file to be the copy source from the drop-down list.  

(2)   File name and Files of type

Specify the name of the startup file to be the copy source.  The extension of startup file is ".o" or ".s" by default.  

(1)

(2)
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Function buttons 

Button  Function

Open Sets the specified file as a startup file to be the copy source.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Startup File to register] dialog box

This dialog box is used to specify a startup file to register.  The file is to be the copy destination when a sample file or an 
existing file is copied and used as a startup file.  

Figure 6-90   [Startup File to register] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [File Name...] button on the [New WorkSpace - Step 4/9 [Startup File]] dialog box.  

- Click the [File Name...] button on the [Add New Project - Step 4/9 [Startup File]] dialog box.  

Explanation of each area

(1)   Look in 

Select the drive or folder that includes the startup files to register from the drop-down list.  

(2)   File name and Files of type

Specify the name of the startup file to be registered.  The extension of startup file is ".o" or ".s" by default.  

(1)

(2)
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Function buttons 

Button  Function

Open Sets the specified file as a startup file to register.  
The specified startup file is registered to the project-related files.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Link Directive File] dialog box

This dialog box is used to specify a link directive file when an existing file is used as a link directive file.  

Figure 6-91   [Link Directive File] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [Browse...] button after selecting the [Use the Existing file] on the [New WorkSpace - Step 6/9 [LinkDirec-
tive File]] dialog box.  

- Click the [Browse...] button after selecting the [Use the Existing file] on the [Add New Project - Step 6/9 [LinkDirec-
tive File]] dialog box .  

Explanation of each area

(1)   Look in

Select the drive or folder that includes the link directive file to be specified from the drop-down list.  

(2)   File name and Files of type

Specify the name of the link directive file.  

(1)

(2)
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Function buttons 

Button  Function

Open Sets the specified file as a link directive file.  
The specified link directive file is registered to the project related files.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Copy Link Directive File from] dialog box

This dialog box is used to specify a link directive file to be a copy source when an existing file is copied and used as a 
link directive file.  

Figure 6-92   [Copy Link Directive File from] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [Browse...] button after selecting the [Copy and Use the Existing file] on the [New WorkSpace - Step 6/9 
[LinkDirective File]] dialog box.  

- Click the [Browse...] button after selecting the [Copy and Use the Existing file] on the [Add New Project - Step 6/9 
[LinkDirective File]] dialog box.  

Explanation of each area

(1)   Look in 

Select the drive or folder that includes the link directive file to be the copy source from the drop-down list.  

(2)   File name and Files of type

Specify the name of the link directive file to be the copy source.  

(1)

(2)
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Function buttons 

Button  Function

Open Sets the specified file as a link directive file to be the copy source.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Link Directive File to register] dialog box

This dialog box is used to specify a link directive file when an existing file is used as a link directive file.  

Figure 6-93   [Link Directive File to register] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [File Name...] button on the [New WorkSpace - Step 6/9 [LinkDirective File]] dialog box.  

- Click the [File Name...] button on the [Add New Project - Step 6/9 [LinkDirective File]] dialog box.  

Explanation of each area

(1)   Look in 

Select the drive or folder that includes the link directive file to register from the drop-down list.  

(2)   File name and Files of type

Specify the name of the link directive file to be registered.  

(1)

(2)
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Function buttons 

Button  Function

Open Sets the specified file as a link directive file to register.  
The specified link directive file is registered to the project-related files.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Select Project] dialog box

This dialog box is used to specify the project to be added when a source file is dragged to the [Project] window while a 
workspace file or project file is open.  

Figure 6-94   [Select Project] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Drag and drop a new source file to the [Project] window.

Explanation of each area

(1)   Project selection area

Select the project which registers the source file.  
The project group and project names in the currently open project are displayed by default.  

Function buttons 

Button  Function

OK Newly registers the dragged source file in the selected project.  

Open Source File Opens the source file in the Edit window without registering it to a project.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

(1)
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[Edit Batch Build Settings] dialog box

This dialog box is used to select the project for batch build or rebuild and set the build sequence.
The settings in this dialog box are saved in a workspace file when the workspace is saved.

Figure 6-95   [Edit Batch Build Settings] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

- Cautions

Opening

- Select the [Build] menu -> [Batch Build Settings...]. 

Explanation of each area

(1)   Build Project and Build Order 

This area displays the names of the projects registered in the open workspace, with their build modes.  Select the 
check box of the build mode of the project for which build is to be performed. 
The build mode of the currently active project is selected by default.  
Build is executed in order from the top of the list.  To change the order, select the project and use the [Up] or [Down] 
button.  
Multiple projects can be selected.  When multiple projects have been selected, and the check box one of the 
selected projects is manipulated, the check boxes of the other selected projects are manipulated likewise. 

(1)
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Function buttons 

Cautions 

- If the project/build Mode is added after closing the Batch Build dialog box, the next time the Batch Build dialog box is 
opened, the added project/build mode item is added to the Build Project and Build Order to be built. 
If the project/build Mode is deleted after closing the Batch Build dialog box, the next time the Batch Build dialog box 
is opened, the deleted project/build mode item is deleted to the Build Project and Build Order to be built. 

Button  Function

OK Closes this dialog box.

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

Up Moves the selected project up within the list.  
When the project at the top of the list is selected and this button is clicked, the selected 
project moves to the bottom of the list. 
When multiple projects are selected, this button is disabled. 

Down Moves the selected project down within the list.  
When the project at the bottom of the list is selected and this button is clicked, the selected 
project moves to the top of the list. 
When multiple projects are selected, this button is disabled. 
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[Build Mode] dialog box

This dialog box is used to select, add and delete build modes.  

Figure 6-96   [Build Mode] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Build] menu -> [Select Build Mode...]. 

Explanation of each area

(1)   Build Mode 

The currently selected build mode is displayed.  Select the build mode using this combo box as required.  
There are two default build modes.  

- Debug Build: If build is executed in this mode, symbol information is output (default). 

- Release Build: If build is executed in this mode, symbol information is not output. 

Function buttons 

Button  Function

OK Sets the specified build mode.  The set, added, or deleted build mode is saved in a project file.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

Add... Opens the [Add Build Mode] dialog box.  
If a language product that does not support build mode is used, this button is invalid. 

Remove Deletes the currently selected build mode and selects the build mode registered at the top.  Note 
that "Debug Build" and "Release Build" cannot be deleted.  
If a language product that does not support build mode is used, this button is invalid. 

(1)
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[Add Build Mode] dialog box

This dialog box is used to add a new build mode.  
There are two default build modes.  

- Debug Build: If build is executed in this mode, symbol information is output (default). 

- Release Build: If build is executed in this mode, symbol information is not output. 

In this dialog box, options can be added and deleted and any build mode can be defined, based on these build modes.  

Figure 6-97   [Add Build Mode] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Build] menu -> [Select Build Mode...], and click the [Add...] button in the [Build Mode] dialog box. 

Explanation of each area

(1)   Build Mode 

The name of the build mode to be added newly is entered in this area.  Up to 128 characters can be entered.  

(2)   Copy Build Mode from 

The currently set build mode is displayed by default.  Select the build mode using this combo box as required.  

Function buttons 

Button  Function

OK Selects the added build mode and returns to the [Build Mode] dialog box.  
If nothing is entered under [Build Mode], this button cannot be selected.  

Cancel Does not enable the settings, and returns to the [Build Mode] dialog box.

Help Opens the help for this dialog box.  

(1)

(2)



CHAPTER 6  WINDOW REFERENCE

282 User’s Manual  U18416EJ1V0UM

[Build Settings] dialog box

This dialog box is used to set options related to build.  This settings in this dialog box are saved in the registry and 
become valid at the next time the project is opened.  

The following items can be set: 

- Options during build ([Build] tab) 

- Processing to be executed before build ([Pre Build Process] tab)

- Processing to be executed after build ([After Build Process] tab)

Note that the settings in the [Build] tab are saved in the registry, the settings are applied to the use environment (the set-
tings in the [Pre Build Process] or [After Build Process] tab are saved in each project file).

Figure 6-98   [Build Settings] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each tab

- Function buttons

Opening

- Select the [Build] menu -> [Build Settings...]. 

(1) (2) (3)
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Explanation of each tab

(1)   [Build] tab

This tab sets the options for executing build.  

Figure 6-99   [Build Settings] Dialog Box - [Build] Tab

(a)   Open the Log File as Build Failed
When a build error occurs during build, a log file is opened.  If an external editor is set, it is displayed on the exter-
nal editor.  

(b)   Stop the Batch Build as Build Failed
If during batch build/batch rebuild, a build error occurs upon build termination, batch build/batch rebuild stops at 
that instant. 

(c)   Stop the Build on Compile Error
If even one error occurs during build, building stops when compilation of that source file has finished.  
When this box is not selected, even if an error occurs during build, building does not stop until compilation of all 
the target source files has finished.  

(d)   Prompt Message Box as Build Finished  
When build is finished, a message box is displayed (default).  
If this box is not selected, end of build is indicated only by a sound.

(a)

(b)

(c)

(d)
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(2)   [Pre Build Process] tab

If there is any processing required prior to build (conversion processing or backing up of source files), this process-
ing is set here.  The set items are always executed when build is executed. The order of execution is from the top of 
the list.  
Commands can be specified in the [Add Command] dialog box by clicking the [Add...] button.  

Figure 6-100   [Build Settings] Dialog Box - [Pre Build Process] Tab

Button  Function

Add... Opens the [Add Command] dialog box.  
The specified command is inserted to the currently selected position in the command list box. 

Edit... Opens the [Add Command] dialog box.  
Changes the command contents selected in the Command list box to the edited contents.  

Remove Deletes the command selected in the command list box.  

Up Moves the selected command up within the command list.  

Down Moves the selected command down within the command list.  
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(3)   [After Build Process] tab

If there is any processing required after build (copying of output files to another folder, etc), this processing is set 
here.  The set items are always executed after build.  The order of execution is from the top of the list.  
Commands can be specified in the [Add Command] dialog box by clicking the [Add...] button.  

Figure 6-101   [Build Settings] Dialog Box - [After Build Process] Tab

Function buttons 

Button  Function

Add... Opens the [Add Command] dialog box.  
The specified command is inserted to the currently selected position in the com-
mand list box. 

Edit... Opens the [Add Command] dialog box.  
Changes the command contents selected in the Command list box to the edited 
contents.  

Remove Deletes the command selected in the command list box.  

Up Moves the selected command up within the command list.  

Down Moves the selected command down within the command list.  

Button  Function

OK Enables the specified settings. 

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Add Command] dialog box

This dialog box is used to specify the commands used to execute any processing required before or after build (copying 
of output files to another folder, etc.).  

Figure 6-102   [Add Command] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [Add...] button on the [Build] menu -> [Build Settings...] - [Pre Build Process] tab.  

- Click the [Add...] button on the [Build] menu -> [Build Settings...] - [After Build Process] tab.  

Explanation of each area

(1)   Command 

Describe the DOS command to be executed before or after build.  Up to 127 characters can be specified as a com-
mand.  

Function buttons 

Button  Function

OK Adds the specified command to the command list box.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

(1)
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[Edit Command] dialog box

This dialog box is used to edit commands specified as required processing either during build execution, prior to/after 
build processing.  

Figure 6-103   [Edit Command] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [Edit...] button after selecting each command in the command list box on the [Build] menu -> [Build Set-
tings...] - [Pre Build Process] tab.  

- Double-click each command in the command list box on the [Build] menu -> [Build Settings...] - [Pre Build Process] tab.  

- Click the [Edit...] button after selecting each command in the command list box on the [Build] menu -> [Build Set-
tings...] - [After Build Process] tab.  

- Double-click each command in the command list box on the [Build] menu -> [Build Settings...] - [After Build Process] tab.  

Explanation of each area

(1)   Command 

Describe the DOS command to be executed before or after build.  Up to 127 characters can be specified as a com-
mand.  

Function buttons 

Button  Function

OK Edits the command with the specified contents.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

(1)
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[Select RTOS] dialog box

This dialog box is used to select the real-time OS used by the current active project.

Figure 6-104   [Select RTOS] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Tool] menu -> [Select RTOS...].  

Explanation of each area

(1)   Select RTOS

The real-time OS used by the current active project can be selected in this area.
The real-time OS name specified on the [Tool Version Settings] tab in the [Project Settings] dialog box is displayed 
on the drop-down list.  The real-time OS name set by the current active project is displayed by default.

Function buttons

Button  Function

OK Opens the dialog box for setting the real-time OS that has been selected in this dialog box.  
Refer to the user's manual of the real-time OS for setting details. 

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

(1)
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[dump850] dialog box

This dialog box is used to activate the dump command, dump850.  
The analysis results are saved under "project file name.dmp" and displayed in the Edit window.  
The execution of dump850 can be stopped by pressing the [Esc] key.  
This dialog box is available only when a project that uses a V850 microcontroller is active and the CA850 (Ver.3.10 or 

earlier) is selected as the tool to be used. (The dump function is provided in CA850 (Ver. .20 or later)).
Refer to the CA850 compiler package user's manual for details on dump850.  

Figure 6-105   [dump850] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Tool] menu -> [dump850].  

Explanation of each area

(1)   Dump the load module file

This button is selected when a load module file is to be dumped (default).  
The analysis target files are the load module file of the currently active project.  
The file name (.out) to be output by the linker which is the analysis target file is displayed in the edit box.  

(2)   Dump the object file 

This button is selected when an object file is to be dumped .  
The analysis target file is the object file generated by the source file selected in the currently active Edit window or 

[Project] window.  However, if the active Edit window is an IDL file, the object file generated from the source file at 
the caret position is the analysis target file.  
The object file name is displayed in the edit box.  If no source file is specified, nothing will be displayed. 

(1)

(2)
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Function buttons 

Button  Function

OK Activates the dump command, dump850.  
The analysis results are saved under "project file name.dmp" and displayed in the Edit win-
dow.  If a dmp file already exists, the file is renamed as a bak file under "project file 
name.dmp.bak".  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Debugger Settings] dialog box

This dialog box is used to set the details of the debugger to be used.  

Figure 6-106   [Debugger Settings] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Tool] menu -> [Debugger Settings...].  

Explanation of each area

(1)   Select Debugger

(a)   Debugger 
The debugger to be used is selected here.  
The name of the debugger specified for use and its version are displayed on the drop-down list. 
If a debugger is newly selected, the debugger type set in the project opened previously is displayed by default.  

(1)

(2)

(3)
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(b)   File Name 
The path for the selected debugger is displayed here.  
A path for another debugger can also be entered directly.  In this case, if this dialog box is opened after being 
closed by the [OK] button, "User selected debugger" is displayed on the [Debugger] combo box.  

(c)   Option 
Specify the options for when starting up the debugger.  
Nothing will be displayed in the default condition.

(2)   Debugger Target

(a)   Debug Target File
The file to be downloaded to debugger is selected here.  
The load module file names and HEX file names output from the language product are displayed on the drop-
down list.  

(b)   Execute Symbol Reset after Download
Checking this check box executes a symbol reset when a file is downloaded.  

[Caution] 
This check box becomes valid only when a project that uses a V850 Microcontrollers device is active.  

(c)   Execute CPU Reset after Download
Checking this box executes a CPU reset via the debugger when a file is downloaded.  

(3)   Debug Options

(a)   Download the Debug Target Files in the same Project Group
Checking this check box downloads the debug target files of the projects belonging to the same project group as 
the currently active project following the files specified by [Debug Target File].  
This is a function corresponding to the multiple load module files download function of the debugger.  

[Caution] 
This check box becomes valid only when a project that uses a V850 Microcontrollers device is active.  

(b)   Debug Target File List
Select the debug target files to be downloaded in the same group.  
If the [Download the Debug Target Files in the same Project Group] check box is selected, the files selected here 
are downloaded when the debugger starts up, following the files specified by [Debug Target File].  
When the files specified here are downloaded, the symbol and CPU resets are not executed.  
The debug target files set in each project are displayed on the list.  Therefore, to change the debug target files in 
each project, make the project that generates the corresponding debug target files active, and open this dialog 
box.  

Function buttons 

Button  Function

OK Enables the specified settings. 

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Register External Tool] dialog box

This dialog box is used to register (add), change, and delete external tools to be used.  Up to 10 tools can be registered.  
The currently set tools are displayed.  

Figure 6-107   [Register External Tool] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

- Cautions

Opening

- Select the [Tool] menu -> [Register Ex-tool...].  

(1)

(2)
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Explanation of each area

(1)   Menu List 

The menu item names of the currently registered external tools.  The menu item names are the [Menu String] spec-
ified in the [Select External Tool] dialog box using the [Add...] button.  
The menu item names are displayed as a pop-up menu of [Start up EX-tool]. The menu items are displayed in the 
order of [Menu List].  
The icons of the external tools set here are displayed as buttons on the external toolbar.  

(2)   Detail  

The information on the external tool selected in [Menu List] is displayed.  
This information is the contents set by the [Select External Tool] dialog box.

Function buttons 

Cautions

- The external tools are common setting item in PM+.  They cannot be set in project units.  

Button  Function

Add... Opens the [Select External Tool] dialog box for registering external tools.  The added tool is 
displayed at the end of [Menu List].  Up to 10 external tools can be registered.  Therefore, if 10 
external tools are already set, this button is dimmed.  

Edit... Opens the [Select External Tool] dialog box for the selected tool in [Menu List].  

Remove Removes the external tool selected in [Menu List].  

Remove All Removes all of the external tools in [Menu List].  

Up Moves the selected external tool up within [Menu List].  

Down Moves the selected external tool down within [Menu List].  

Button  Function

OK Registers the external tool, and closes this dialog box.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Select External Tool] dialog box

This dialog box is used to specify a external tool to be used.  

Figure 6-108   [Select External Tool] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [Add...] button in the [Register External Tool] dialog box.  

- Click the [Edit...] button in the [Register External Tool] dialog box.  

Explanation of each area

(1)   File Name 

Specify the name of the execution file for the external tool to be registered with the full path.  Up to 260 characters 
can be entered.  
If [Browse...] button is clicked, the [Open] dialog box is opened to select the any file.  

(2)   Parameter 

The arguments used when executing the external tool can be specified here as required.  Up to 260 characters can 
be entered.  

(3)   Tool Folder 

Specify the current folder for starting up the external tool.  Up to 260 characters can be entered.  

(1)

(2)

(3)

(4)

(5)

(6)
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(4)   Menu String 

Specify the menu name to be displayed when the [Start up Ex-tool] menu item is selected.  Up to 32 characters can 
be entered.  If no character string is specified, the name will be the tool execution file name without the path and 
extension.  
Note that the same name cannot be set more than once.  

(5)   Tool tip String 

Specify the character string to be displayed as the tool tip on the toolbar.  Up to 32 characters can be entered.  

(6)   Status bar String 

Specify the character string to be displayed on the status bar when a menu item is selected.  Up to 32 characters 
can be entered.  

Function buttons 

Button  Function

OK Sets the external tool, and closes this dialog box.  
The set tool is displayed on [Menu List] in the [Register External Tool] dialog box.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[File Compare] dialog box

This dialog box is used to compare the contents of two Edit windows.  

Figure 6-109   [File Compare] Dialog Box

Figure 6-110   [File Compare] Dialog Box (Mini)

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Tool] menu -> [File Compare...].  

Explanation of each area

(1)   Original file 

Select the original file to be compared from the drop-down list.  
If there is an active Edit window, the name of the file in that window is selected.  If there is no active Edit window, 
this area is left blank.  
A list of all the files currently being edited is displayed on the drop-down list.  
If the [...] button is clicked, the [Open] dialog box is opened to select the any file.  In the [Open] dialog box, the 
[Apply Layer Rule] and [Gather Files into an Edit Window] check boxes, and the [Layer Rule...] button are invalid.  

(3)

(4)

(1)

(2)
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(2)   Another file 

Select the file to be compared from the drop-down list.  
If the "Original file" is opened first, the name of the file opened second is displayed.  
If the "Another file" is other than the file opened first, the name of the file opened first is displayed.  
A list of all the files currently being edited is displayed on the drop-down list.  If the selected file is the same as the 
"Original file", the file name is not displayed.  
If the [...] button is clicked, the [Open] dialog box is opened to select the any file.  In the [Open] dialog box, the 
[Apply Layer Rule] and [Gather Files into an Edit Window] check boxes, and the [Layer Rule...] button are invalid.  

(3)   Way of comparison setting area

(a)   Compare collapse layer
If this check box is selected, the contents of collapsed layers are also compared (default).  
If it is not selected, the contents of collapsed layers are not compared.  

(b)   Compare layer number
If this check box is selected, differences in the layer positions are also compared (default).  
If it is not selected, differences in the layer positions are not compared.

(c)   Display files side by side
If this check box is selected, the "Original file" and the "Another file" are displayed side by side (default).  
If it is not selected, they are displayed in the status they were in during comparison.  

(4)   Start position

(a)   Top line
If this button is selected, comparison starts from the first line of the file (default).  

(b)   Caret position
If this button is selected, comparison starts from the caret position.  

Function buttons 

Button  Function

Upward Compares files in the upward direction.  This dialog box becomes mini version after the com-
parison.  
If a difference in file contents is found, the caret moves to the line including the difference.  
Note that when the [Top line] button is selected, this button is dimmed.  

Downward Compares files in the downward direction.  This dialog box becomes mini version after the 
comparison.  
If a difference in file contents is found, the caret moves to the line including the difference.  

Details
(only mini version)

Opens the normal File Compare dialog box.

Cancel Does not enable the specified items, and closes this dialog box.  

Help Opens the help for this dialog box.  



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U18416EJ1V0UM 299

[PM+ Settings] dialog box

This dialog box is used to make various environment settings.  The environment settings are performed on the following 
tabs.  

(1)  [Workspace] tab

(2)  [External Editor] tab

(3)  [File] tab

(4)  [Recent] tab

(5)  [Source File by idl File] tab

(6)  [Window] tab

(7)  [Path] tab

(8)  [Edit] tab

(9)  [View] tab

(10)  [Layer] tab

(11)  [Scroll] tab

(12)  [Find/Replace] tab

Figure 6-111   [PM+ Settings] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each tab

- Function buttons

(1) (8) (2) (9) (3) (4) (10) (5) (11)(7) (6)(12)



CHAPTER 6  WINDOW REFERENCE

300 User’s Manual  U18416EJ1V0UM

Opening

- Select the [Tool] menu -> [PM+ Settings...].  

- Select the [PM+ Settings...] from the right mouse click menu on the toolbar in the Main window

Explanation of each tab

(1)   [Workspace] tab

This tab is used to make settings related to the workspace.  

Figure 6-112   [PM+ Settings] Dialog Box - [Workspace] Tab

(a)   Open last workspace at startup
If this check box is selected, the workspace file (project file) when PM+ finished previously is opened when PM+ 
starts up (default).  

(b)   Investigate the files exist at open workspace
If this check box is selected, when a workspace (project) is opened, it is selected whether there are any files reg-
istered in the project (default).  

(c)   Restore window position at each workspace
If this box is selected, a workspace (project) is opened at the same window location as the previous time for 
every workspace.

(a)

(b)

(c)
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(2)   [External Editor] tab

This tab is used to set an external editor.  

Figure 6-113   [PM+ Settings] Dialog Box - [External Editor] Tab

(a)   Use external editor
If this check box is selected, the external editor path setting and the tag jump format can be entered.  By setting 
the path and tag jump here, an external editor can be started up from PM+.  

- Editor 
Specify the external editor.  Clicking the [Browse...] button opens a reference dialog box in which the editor 
can be selected. 

- Format of tag jump 
Specify the tag jump format when an external editor is used.  A tag jump format specific to the external editor 
is specified using the file name specification macro "$F" and line number specification macro "$L".  Refer to 
the manual of each editor for details.  If the format is blank, it is considered as "$F".  
Examples of typical editors are shown below.  

MIFES : $F+$L

(a)
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(3)   [File] tab

This tab is used to make settings related to files.  

Figure 6-114   [PM+ Settings] Dialog Box - [File] Tab

(a)   Watch 
This area specifies the operation when the file being edited is updated by another application.  

- Update The File Automatically, If Changed by Other Process
When a file that is opened in PM+ is changed by another process (such as an editor), the file is read again 
automatically.  

- Don't Update The File, If Changed by Other Process
When a file that is opened in PM+ is changed by another process (such as an editor), the file is not read 
again.  

- Display Message, If Changed by Other Process
When a file that is opened in PM+ is changed by another process (such as an editor), a message is dis-
played to verify whether the file is read again or not (default).  

(b)   File setting area 

- Apply Layer Rule in Opening File(s)
If this check box is selected, files are always read with layer when they are opened (including all the drag-
and-drop operations and file histories).  

- Enable All Layer Rule's Options  
If this check box is selected, all the options of the layer rule used when opening a files are valid. If it is not 
selected, the options accord with the status of the [Set Layer Rule] dialog box.  

- Delete The Spaces and Tabs of The End of Line in Saving a File
If this check box is selected, null characters at the end of a line are deleted when a file is stored.  If it not 
selected, the file is saved with null characters remaining at the end of a line.  

- Make a Backup File
If this check box is selected, a backup file is created when a file is stored (default).  The extension of the 
backup file can be specified freely in the [Extension of Backup File] area.  

(b)

(a)

(c)

(e)

(d)
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- Clear The Undo Buffer in Saving a File

If this check box is selected, the undo buffer is cleared when a file is stored. 
If the [Delete The Spaces and Tabs of The End of Line in Saving a File] check box is selected, this box is 
selected and dimmed (invalid).  

(c)   Extension User Specify
The specified extension is displayed in the drop-down list of the [Files of type] in the [Open] dialog box, [Save As] 
dialog box, and [Insert File] dialog box.  The order in the drop-down list is as displayed in the list of user exten-
sions.  
Up to four extensions can be added.  

- Extension
Enters the extensions to be added.  If multiple file extensions are compiled into one, they are delimited by ";".  
Examples are shown below.  

To display a CPP file:  *.cpp

To display a CPP file and an H file:  *.cpp;*.h

- User Extension List
Displays the added extensions. 

(d)   Extension of Backup File
Specify the extensions for creating backup files.  IDL file and text file extensions can be specified.  Up to 3 char-
acters of extensions can be set.  

- IDL File
Specify the extensions for creating backup IDL files.  The default is "bkl". 

- TEXT File
Specify the extensions for creating backup text files.  The default is "bak". 

(e)   Automatic Backup
This area selects whether a file is automatically saved in the folder specified by the environmental variable Temp 
while it is being edited.  

- Don't Save
Auto backup is not executed (default).

- Save The File
A temporary file is created each set time.  The time can be set in 1-minute units, from 1 to 120.  
If PM+ is exited incorrectly due to an unexpected event at startup, this temporary file is opened when PM+ is 
started up next time.  
The temporary file is automatically deleted when PM+ is exited correctly. 

Button  Function

Add... Adds the extensions to User Extension List.  

Change Changes the extension selected in User Extension List.  

Delete Deletes the extension selected in User Extension List.  

Up Moves the selected extension up within User Extension List.  

Down Moves the selected extension down within User Extension List.  
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(4)   [Recent] tab

This tab is used to make settings related to files.  

Figure 6-115   [PM+ Settings] Dialog Box - [Recent] Tab

(a)   History type selection area
Specifies the type of history to be edited.  

- Recent File 
A list of the file names displayed to [File] menu -> [File History] is displayed in the Recent List (default). 

- Recent Workspace
In the Recent List, display a list of workspace file names displayed in [File] menu -> [File History].

(b)   Recent List
Specifies the history to be edited.  display a list of workspace file names displayed in [File] menu -> [File History] 
in the default condition.
Multiple histories can be added.

(c)   Fixed Recent List
Specifies the number of histories that are not to be changed during file/workspace history updating (when file/
workspace is opened or saved) with drop-down list.   The number of histories that are not to be changed can be 
set from 1 to 5.  The default number is 2.  
When this check box is selected, the specified number of histories from the top history in [Recent List] is not 
changed.  By default, this check box is not selected.  
The background color of unchanged histories in the [Recent List] is displayed in light blue. 

Button  Function

Up Moves the selected history up within the list.  
When the history at the top of the list is selected and this button is clicked, the selected his-
tory moves to the bottom of the list. 
When no history is selected or when multiple histories are selected, this button is disabled. 

Down Moves the selected history down within the list.  
When the history at the top of the list is selected and this button is clicked, the selected his-
tory moves to the bottom of the list. 
When no history is selected or when multiple histories are selected, this button is disabled. 

Delete Deletes the selected history.
When no history is selected, this button is disabled. 

(a)

(b)

(c)



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U18416EJ1V0UM 305

(5)   [Source File by idl File] tab

This tab is used to make settings related to the source files generated by IDL files.  

Figure 6-116   [PM+ Settings] Dialog Box - [Source File by idl File] Tab

(a)   Compare Time Stamp of Source Files as Open idl File
If this check box is selected, the time stamps of the IDL file and source file are compared when the IDL file is 
opened (default).  The operation to be performed if the time stamps are different is also selected here.  

- Always Open New Files
The file with the later time stamp is always read.  

- Display Message, If Source Files Updated
A message is displayed when the source file is newer than the IDL file.  If the [OK] button is clicked in this 
message dialog box, the source file is read instead of the first layer corresponding to the file.  When read, 
the layer option settings is applied to the file at the that time.  If the [No] button is clicked, the IDL file is read.  
The source file is not updated.  
If [Apply to all update files] is selected, all source files found subsequently later are updated without any 
messages being displayed.  

(b)   Layer Option as Update 
This area sets the layer when the source file is read.  

- Not Apply Layers
When a new source file is read, it is read again without layer.  

- Recover Layers
When a new source file is read, the layer set in the previous source file is restored (default).  

- Follow Layer Rule
When a new source file is read, the layer rule is applied to the file.  

(c)   Layer Indent 

- No Replace
When a new source file is saved, the indent of layer is not replaced (default).  

- Replace Tab
The layer indent is replaced by a Tab and the source file is saved. 

(a)

(b)

(c)

(d)
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- Replace Space
The layer indent is replaced by a one-byte space and the source file is saved.  

- Not Replace Layer
A layer indent is not used for a layer higher than the one specified.  

(d)   Convert Tabs to Space in Saving a Source File
If this check box is selected, Tab characters and two-byte spaces are replaced by one-byte spaces when the 
source file is saved.  

(6)   [Window] tab

This tab is used to make settings related to windows.  

Figure 6-117   [PM+ Settings] Dialog Box - [Window] Tab

(a)   Window Size 
This area is used to select the size of the Edit window.  

- Maximize
Opens the Edit window in its maximum size.  

- Default of PM+
Opens the Edit window in the size of the PM+ screen, which is not its maximum size.  

- Default of Windows
Opens the Edit window in cascade to show each caption (default).  However, the Edit window opens in the 
default size selected when the [Project] window or [OutPut] window is displayed.  

- Previous Size
Only files recorded in the file history information are opened in the size they were when closed previously.  
Files not saved in the file history information are opened in the default size of PM+.  

(b)   Memorize of Windows Position
This area is used to select whether the window position is saved during editing.  If the relevant check box is 
selected, the window position is saved when the window is closed.  If it is not selected, the window position is 
not saved.  By default, all check boxes are selected.  

(c)   Always Maximize PM+
If this check box is selected, the previous information is ignored and PM+ starts up in the maximum size.  

(a)

(c)

(b)
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(7)   [Path] tab

This tab is used to make settings related to paths.  

Figure 6-118   [PM+ Settings] Dialog Box - [Path] Tab

(a)   External HELP
This area specifies the paths for the external help files to be referenced during editing.  

- (1) [Shift] + [F1] 
Specify the external help file to open by pressing the [Shift] + [F1] keys.  The file can be entered directly in 
the text box or selected by the [...] button.  

- (2) [Ctrl] + [F1] 
Specify the external help file to open by pressing the [Ctrl] + [F1] keys.  The file can be entered directly in the 
text box or selected by the [...] button.  

- (3) [Shift] + [Ctrl] + [F1]
Specify the external help file to open by pressing the [Shift] + [Ctrl] + [F1] keys.  The file can be entered 
directly in the text box or selected by the [...] button.  

(b)   Make Backup File in Specified Folder
This area specifies the folder in which the backup file is created for the file being edited.  If there is no specifica-
tion, the backup file is created in the same folder as the file being edited.  
Specify the folder by checking the box and entering the folder.  The folder can be entered directly in the text box 
or selected by the [...] button.  

(c)   Open/Save in Specified Folder
This area specifies the folder to be displayed first when a file is manipulated.  If there is no specification, the cur-
rent folder is displayed.  
Specify the folder by checking the box and entering the folder.  The folder can be entered directly in the text box 
or selected by the [...] button.  

(d)   Folder for Macro File 
Specify the folder in which macro files are saved.  If there is no specification, the macro files are saved in the 
same folder as PM+.  
The folder can be entered directly in the text box or selected by the [...] button.  

(c)

(a)

(b)

(d)
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(8)   [Edit] tab

This dialog box is used to make settings related to edits.  

Figure 6-119   [PM+ Settings] Dialog Box - [Edit] Tab

(a)   Setting at the time of edit area

- Don't Delete The Line, If it has Lower Layers
If this check box is selected, lines with lower layers are not deleted when the line delete command is exe-
cuted (default).  If it is not selected, lines are deleted regardless of whether they have lower layers.  

- Select a String between Double(")/Single(') Quotations as Tag Jump
If this check box is selected, if a character string enclosed by '' or "" at the jump origin is at the jump destina-
tion when a tag jump is executed, that character string is range selection (default).  If it is not selected, range 
selection is not executed.  

- Don't Move Caret as Paste
If this check box is selected, the caret position is not moved to the place where character string or line is 
pasted.  If is not selected, the caret position is moved to the paste location.  

- Use Auto Indent
If this check box is selected, the caret is moved to the previous indent line when a linefeed occurs (default).  
If it is not selected, the caret is displayed on the first line when a linefeed occurs.  

- Release Range Selected Before Jump
If this check box is selected, the range selection is cleared before the caret is moved when a menu related to 
jump is executed.  If it is not selected, the caret is moved from the starting position to the destination of the 
caret or the closest position to it while range selection is being executed.  

- Beep Warning Sound
If this check box is selected, an alarm sound is output when warning message is displayed.  

(b)   Double Click 
This area is used to select the double-click operation.  

- Layer Expand/Collapse
Expands or collapses the lower layers.  

- Select a Word
Selects a word including the caret with range selection when the mouse is double-clicked on the Edit window.  

(a)

(c)

(e)

(b)

(d)
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(c)   Image Copy 
This area is used to select whether a layer is replaced by a space or a Tab when an image is copied.  

- Convert Indent to Tab
The layer is replaced be a Tab.  

- Convert Indent to Space
The layer is replaced be a space (default).  

(d)   Object 

- Disable object resize 
If this check box is selected, the size of an object pasted in a document cannot be changed (default).  

- Keep object when execute paste command
If this check box is selected, an object is pasted as an object, even if it can be pasted as text.  To paste it as 
text, use the [Paste Special...] menu item.  

(e)   Smart-Look up Function Use 
If this check box is selected, the smart lookup function can be used.  

- Function List display
If this check box is selected, the candidate function names with the corresponding number of the characters 
are displayed.  

- Display the List at more than xxx character(s)
Sets the number of the characters at which the candidate functions are displayed.  1 to 30 can be selected.  
The default number is 5.  

- User Setup List display
If this check box is selected,  character strings other than function names can be added to the candidate list 
by setting an arbitrary keyword.  The keyword can be set by clicking the [User Setting...] button.  

- [User Setting...] button
Opens the [User Setting] dialog box.
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(9)   [View] tab

This tab is used to make settings related to window display.  

Figure 6-120   [PM+ Settings] Dialog Box - [View] Tab

(a)   Show 

- Under Line with Caret Line
If this check box is selected, an underline is displayed at the caret line on the Edit window.

- CR and EOF
If this check box is selected, a blue "|" is displayed for a linefeed code (CR) and "[EOF]" is displayed for a ter-
minating code (EOF) (default).  

- Tab Characters
If this check box is selected, a Tab code is displayed in a gray.  

(b)   Window 

- Horizontal Scroll Bar
If this check box is selected, a horizontal scroll bar is displayed at the bottom of each Edit window (default). 

- Vertical Scroll Bar
If this check box is selected, a vertical scroll bar is displayed at the right side of each Edit window (default). 

(c)   Indent Tab Characters 
This area sets the number of characters for a Tab indent.  2, 4 or 8 characters can be set.  

(d)   Title
This area is used to select the method to display the title bar on the Edit window.  

- Show Filename
Only file names are displayed on the title bar in the Edit window.  

- Show Filename and Full Path
The title bar on the Edit window is displayed with the full path (default).  

(e)   Put Caret at The Top Line as opened idl File
If this check box is selected, the caret is displayed at the first line when an IDL file is opened.  If it is not selected, 
the caret is displayed at the position saved the previous time.  

(a)

(b)

(c)

(d)

(e)
(f)

(g)

(h)



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U18416EJ1V0UM 311

(f)   Memorize number of Tab Characters each Window
If this check box is selected, the number of Tab character expansions is set for each Edit window.  If it is not 
selected, the setting is executed for the entire PM+.  

(g)   Color 

- Background 
 Sets the background color of the Edit window.  The currently set color is displayed in the text box next to 
"character".  The color can be changed by clicking the [Set Color...] button.  

- Character 
 Sets the underline color of the Edit window.  The currently set color is displayed in the text box next to "char-
acter".  The color can be changed by clicking the [Set Color...] button.  

- Underline 
 Sets the underline color of the Edit window.  The currently set color is displayed in the text box next to 
"underline".  The color can be changed by clicking the [Set Color...] button.  

- CR and EOF
Sets the linefeed code and EOF color of the Edit window.  The currently set color is displayed in the text box 
next to "CR and EOF".  The color can be changed by clicking the [Set Color...] button.  

- ReadOnly Source File
Sets the character color of the source files set as read-only in the IDL files.  The currently set color is dis-
played in the text box next to "ReadOnly Source File".  The color can be changed by clicking the [Set 
Color...] button.  

- Error Line
Specifies the color used to highlight characters in the error indication line in the [OutPut] window.  The cur-
rently set color is displayed in the text box next to "Error Line".  
The color can be changed by clicking the [Set Color...] button. 

- Warning Line
Specifies the color used to highlight characters in the warning indication line in the [OutPut] window.  The 
currently set color is displayed in the text box next to "Warning Line".  
The color can be changed by clicking the [Set Color...] button. 

(h)   Appear Flat Toolbar 
If this check box is selected, the toolbar is displayed flat (default).  
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(10)   [Layer] tab

This tab is used to make settings related to layers.  

Figure 6-121   [PM+ Settings] Dialog Box - [Layer] Tab

(a)   Layer Mark at Top of Line
This area sets the layer mark displayed at the top of a line.  

- Line with Lower Layer 
Sets the layer mark displayed at the top of a line with lower layers.  The default is "+".  

- Line without Lower Layer
Sets the layer mark displayed at the top of a line without lower layers.  The default is "-".  

(b)   Indent Characters
Specify the number of layer indent characters used when a layer is displayed.  0, 2, 4 or 8 characters can be set.  

(c)   Image 
This area displays an image with the set layer mark.  

(d)   Collapse Deeper Layer than Specified Layer as Expand Specified Layer Command
If this check box is selected, all the layers higher than the one specified are collapsed when [Expand the Specific 
Layer...] is selected from the [Layer] menu. If it is not selected, the already expanded layers higher than one 
specified are left as is.  

(e)   Set Indent Character each Edit Window 
If this check box is selected, the number of indent characters is set for each Edit window.  If it is not selected, the 
setting is executed for the entire PM+.  

(a)

(b)

(d)
(e)

(c)
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(11)   [Scroll] tab

This tab is used to make settings related to scrolling in the Edit window.  

Figure 6-122   [PM+ Settings] Dialog Box - [Scroll] Tab

(a)   Way of scrolling setting area

- Move Caret in High Speed by Ctrl + Up/Down arrow Keys
If this check box is selected, the caret is moved quickly (by 5 lines) by pressing the [Ctrl] + [UP/DOWN arrow] 
keys (default).  If it is not selected, the caret is not moved quickly.  

- Move Caret with Page Scroll
If this check box is selected, the caret is also scrolled when the screen is scrolled (default).  If it is not 
selected, the caret does not move when the screen is scrolled.  

- Scroll Half Page as Page UP/Down
If this check box is selected, the screen is scrolled by half a screen by pressing the Page Up/Page Down 
keys.  If it is not selected, the Page Up/Page Down keys perform their normal operation.  

(b)   Mouse Wheel
This area sets the number of lines to be scrolled when using the wheel button of Microsoft's IntelliMouse.  

(b)

(a)
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(12)   [Find/Replace] tab

This tab is used to make settings related to a search and replacement.  

Figure 6-123   [PM+ Settings] Dialog Box - [Find/ Replace] Tab

(a)   Way of search/replacement setting area

- Don't Stop Finding at Top Line/End Line 
If this check box is selected, a message is displayed when the downward search finishes at the final line or 
the upward search finishes at the first line (default).  If the [Enter] key or the key displayed on the message is 
clicked, the search goes on.  If it is not selected, the search finishes at the final or the first line.  

- Memorize Find What in idl File
If this box is selected, the character strings (last 10) or file names (last 10) searched in the [Find String] dia-
log box, [Replace String] dialog box, or [Find in Files] dialog box are saved in an IDL file, and are valid the 
next time the IDL file is opened.  If it is not selected, the information is saved in the registry.  

- Show String You Selected or Word of Caret Position to Find What
If this check box is selected, the character string with range selection for searching is displayed when the 

[Find String] dialog box is opened.  If it is not selected, the previously searched character string is displayed.  

- Show String You Selected or Word of Caret Position to Replace With
If this check box is selected, the character string with range selection for replacement is displayed when the 

[Replace String] dialog box is opened.  If it is not selected, the previously replaced character string is dis-
played.  

- Delete the Top of Underscore('_') Character when Show String Word of Caret Position to Find What/Replace 
With

If this check box is selected, the character string to be searched is displayed ignoring the underscore charac-
ter ('_') at the head of a word.  

- From Top of Structure Member to Member of Caret Position when Show String Word of Caret Position to Find 
What/Replace With

If this check box is selected, when a character string to be searched or replaced is displayed, a words at 
which the caret is placed is considered to be a C language structure, and that structure becomes the target 
character string from the start of the structure.  The structures are recognized by "->" or ".".  
Examples are shown below.  

(b)

(a)
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- Register String for Direct Search as a Candidate of further Finding
If this check box is selected, character strings searched directly are added to the candidate character strings in 
the [Find String] dialog box (default).  If it is not selected, character strings searched directly are not added to 
the candidate character strings. 

(b)   Warning for Find/Replace
This area sets the operation mode when a character string cannot be found.  

- Beep Sound
If this check box is selected, a beep sound is output when the search finishes.  This can be set when the 
[Beep Warning Sound] check box on the [Edit] tab is selected.  

- Display Messages 
If this check box is selected, a message is displayed when the search finishes.  

Function buttons 

Button  Function

OK Enables the specified settings. 

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

pcWork->dwInfo=OLE_BIT

      The character string to be searched is set "pcWork->dwInfo".  

pcWork.dwInfo=OLE_BIT

       The character string to be searched is set "pcWork.dwInfo".  
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[User Setting] dialog box

This dialog box is used to set arbitrary keywords for the smart lookup function.  
The dialog box consists of two pages and up to 64 keywords can be set.  
The keywords set in this dialog box can be saved as a keyword file.  A keyword file is a text file and can be edited easily 

with an arbitrary editor.  

Figure 6-124   [User Setting] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [User Setting...] button on the [Edit] tab in the [PM+ Settings] dialog box.  

Explanation of each area

(1)   Keywords 

Specify keywords directly.  Up to 64 keywords can be set.  
If the keyword file (*.kwd) is read by clicking the [Open] button, the name of the file read is displayed following after 
"Setup File :".

Button Function

<< Displays the previous page. 

>> Displays the next page.  

(1)
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Function buttons 

Button  Function

Initialize Deletes all the set keywords.  If there were any setting files being read, that file name is 
cleared.  

Open Opens the [Open Keyword File] dialog box and reads the keyword file (*.kwd).  At this time, 
the previous keyword is deleted.  If there are over 65 keywords in the setting file, the 65th 
and subsequent keywords are ignored.  

Save Opens the [Save Keyword File] dialog box and saves the keywords in a setting file.  

OK Sets the keywords.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Font] dialog box

This dialog box is used to select the type and size of characters to be displayed in the Edit window.  

Figure 6-125   [Font] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Tool] menu -> [Font...].  

Explanation of each area

(1)   Font 

Specify a desired font.  

(2)   Size 

Specify a desired size.  

(3)   Sample

This area displays the sample characters of the selected font and size.  

(1)

(3)

(2)
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Function buttons 

Button  Function

Default Registers the font specified here as the default font to be used when displaying a new Edit 
window or when loading a file.  

OK Enables the specified items and closes the dialog box.  

Cancel Does not enable the specified items, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Customize] dialog box

This dialog box is used to set the following options.  The option settings are performed on the following tabs.  

(1)  [Keyboard] tab

(2)  [Menu] tab

(3)  [Toolbar] tab

(4)  [User Menu] tab

(5)  [Keyword] tab

Figure 6-126   [Customize] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each tab

- Function buttons

Opening

- Select the [Tool] menu -> [Customize...].  

- Select the [Customize...] from the right mouse click menu on the toolbar in the Main window.  

(1) (3) (4) (5)(2)
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Explanation of each tab

(1)   [Keyboard] tab

This tab sets the options for the keyboard.  

Figure 6-127   [Customize] Dialog Box - [Keyboard] Tab

(a)   Menu 
This area is used to select a menu that includes the menu item to assign keys from the drop-down list.  

(b)   Menu List 
This area lists the menu items included in the menu selected from [Menu].  Select a menu item to which a short-
cut key is assigned.  

(c)   Key 
This area displays the keys that are currently assigned to the menu item selected in [Menu List].  

(d)   Press new shortcut key 
Type the desired key on the keyboard; that key is then displayed in the text box.  To execute a menu item using 
a two-stroke key entry, enter the second key following the first.  However, if a key cannot be used as a shortcut, 
it will not be displayed.
If the entered key has already been assigned to another menu item, the current assignment of the shortcut key is 
displayed as "Currently assigned to:".  If the second key is assigned to the first key, it is displayed as "Prefixed 
Key".  Multiple keys can be assigned to a single command.

[Cautions] 
- The following key allocations are not possible, so allocate different keys. 

[Alt]+[A], [Alt]+[D], [Alt]+[E], [Alt]+[Shift]+[A], [Alt]+[Shift]+[D], [Alt]+[Shift]+[E]

- The shortcut keys for [Help] menu -> [External HELP 1] to [External HELP 3] are fixed.  

Button  Function

Assign Assigns the entered key to the selected menu item.  
If the input shortcut key has already been assigned to another menu item, the assignment 
to the menu is cleared.  

Delete Deletes the shortcut key assigned to the selected menu item.  

Reset Clears all assigned shortcut keys and restores the default state (refer to "APPENDIX C  
SHORTCUT KEYS"). 

(a)

(b)

(c)

(d)
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- The [Delete] key is assigned to the [Edit] menu -> [Delete].  The assignment of the [Delete] key cannot be 
changed.  However, keys other keys than the [Delete] key can also be assigned.  

- If the [Edit]menu [Object] command is allocated to a shortcut key, the shortcut key allocated to the [Object] 
menu item is not displayed. 

(2)   [Menu] tab

This tab sets the options for menus.  

Figure 6-128   [Customize] Dialog Box - [Menu] Tab

(a)   Menu 
This area is used to select a menu that includes the menu item to be added from the drop-down list.  

(b)   Menu List 
This area lists menu items that can be included in the menu selected in [Menu].  Select a menu item to be set.  

(c)   View Menu 
This area displays the menu items currently specified for the menu selected in [Menu].  

Button  Function

Add>> Inserts the menu item selected in [Menu List] at the position selected in [View Menu].  

Remove Deletes the menu item selected in [View Menu].  

Separator Inserts a separating line at the position selected in [View Menu].  

Reset Returns the configuration of the selected menu to the default state. 

Up Moves the menu item selected in [View Menu] up.  

Down Moves the menu item selected in [View Menu] down.  

(a)

(b)
(c)
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(3)   [Toolbar] tab

This tab sets the options for the toolbar.  

Figure 6-129   [Customize] Dialog Box - [Toolbar] Tab

(a)   Menu 
This area is used to select a menu that includes the menu item to be set from the drop-down list.  

(b)   Menu List 
This area lists the buttons and menu items included in the menu selected from [Menu].  Select a button to be 
added.  

(c)   Toolbar 
This area is used to select the toolbar to be customized.  
The standard bar and build bar can be customized.  

(d)   Buttons 
This area displays the buttons and menu items currently specified for the toolbar selected in [Toolbar].  

Button  Function

Add>> Inserts the menu item selected in [Menu List] at the position selected in [Buttons].  

Remove Deletes the menu item selected in [Buttons].  

Separator Inserts a separating line at the position selected in [Buttons].  

Reset Returns the configuration of the toolbar to the default state.  

Up Moves the menu item selected in [Buttons] up.  

Down Moves the menu item selected in [Buttons] down.  

(a)

(b)

(c)

(d)
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(4)   [User Menu] tab

This tab is used to set the menu displayed by the right mouse button or by the assigned shortcut key.  

Figure 6-130   [Customize] Dialog Box - [User Menu] Tab

(a)   Menu 
This area is used to select a menu that includes the menu item to be set from the drop-down list.  

(b)   Menu List 
This area lists menu items included in the menu selected in [Menu].  Select a menu item to be added.  

(c)   Customize Menu 
This area is used to select the menu to be customized.  

(d)   View Menu 
This area displays the menu items currently specified for the menu selected in [Customize Menu].  

Button  Function

Add>> Inserts the menu item selected in [Menu List] at the position selected in [View Menu].  

Remove Deletes the menu item selected in [View Menu].  

Separator Inserts a separating line at the position selected in [View Menu].  

Reset Returns the configuration of the selected menu to the default state.  

Up Moves the menu item selected in [View Menu] up.  

Down Moves the menu item selected in [Buttons] down.  

(a)

(b)

(c)

(d)
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(5)   [Keyword] tab

This tab is used to set the keywords to be highlighted with a color.  

Figure 6-131   [Customize] Dialog Box - [Keyword] Tab

(a)   Accentuate User Keywords
If this check box is selected, the keywords defined by the user are displayed in the set color.  
You can define the keywords with the [Edit User keyword] dialog box opened by clicking the [User Keywords...] 
button, and select the color with the Color dialog box opened by clicking the [Set Color...] button.

(b)   Accentuate Peripheral Register
If this check box is selected, the peripheral register names of the device used in the project are displayed in the 
set color (default).  
You can select the color with the Color dialog box opened by clicking the [Set Color...] button.

(c)   Accentuate RTOS System Calls
If this check box is selected, the real-time OS keywords (system calls) are displayed in the set color.  This check 
box is valid only when a real-time OS of a supported version is installed.  
You can select the color with the Color dialog box opened by clicking the [Set Color...] button.

(d)   Accentuate C Language's Reserved Words
If this check box is selected, the C language keywords are displayed in the set color.  
The C language keywords are set by default, but they can be customized by the user with the [Edit C Language's 
reserve words] dialog box opened by clicking the [Reserve Words] button.  
You can select the color with the Color dialog box opened by clicking the [Set Color...] button.

(e)   Accentuate Comment Lines
If this check box is selected, the comment parts are displayed in the set color. 
In an IDL file, the comments are highlighted by the comment mark set in [Change Source File Name...] on the 
[File] menu.  
You can select the color with the Color dialog box opened by clicking the [Set Color...] button.

Function buttons 

Button  Function

OK Enables the specified items and closes the dialog box.  

Cancel Does not enable the specified items, and closes this dialog box.  

Help Opens the help for this dialog box.  

(a)

(b)

(d)

(e)

(c)
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[Edit User keyword] dialog box

This dialog box is used to edit the keywords defined by the user to highlight arbitrary character strings.  
The dialog box consists of two pages and up to 64 keywords can be set.  
The keywords set in this dialog box can be saved as a keyword file.  A keyword file is a text file and can be edited easily 

with an arbitrary editor.  

Figure 6-132   [Edit User keyword] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [User Keywords...] button on the [Tool] menu -> [Customize...] - [Keyword] tab.  

(1)
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Explanation of each area

(1)   Keywords

Specify keywords directly.  Up to 64 keywords with 32 or fewer one-byte characters can be set. 
If the keyword file (*.kwd) is read by clicking the [Open] button, the name of the file read is displayed following after 
"Keyword File :".

Function buttons 

Button Function

<< Displays the previous page. 

>> Displays the next page.  

Button  Function

Initialize Deletes all the set keywords.  If there were any keyword file being read, that file name is 
cleared from "Keyword File :" area.  

Open Opens the [Open Keyword File] dialog box and reads the keyword file (*.kwd).  At this time, 
the previous keyword is deleted.  If there are over 65 keywords in the setting file, the 65th 
and subsequent keywords are ignored.  

Save Opens the [Save Keyword File] dialog box and saves the keywords to the keyword file 
(*.kwd)

OK Sets the user keywords.  

Cancel Does not enable the specified items, and closes the dialog box. 

Help Opens the help for this dialog box.  
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[Edit C Language's reserve words] dialog box

This dialog box is used to edit the keywords for highlighting of reserved words in C language. 
The dialog box consists of two pages and up to 64 keywords can be set.  

Figure 6-133   [Edit C Language's reserve words] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [Reserve Words] button on the [Tool] menu -> [Customize...] - [Keyword] tab.  

Explanation of each area

(1)   Keywords

Specify keywords directly.  Up to 64 keywords with 32 or fewer one-byte characters can be set. 

Button Function

<< Displays the previous page. 

>> Displays the next page.  

(1)
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Function buttons 

Button  Function

Initialize Erases all specified keywords and displays default reserved words only.  

[Reserved words by default]
__asm, auto, break, case, char, const, continue, default, do, double, else, enum, extern, 
float, for, goto, if, int, long, register, return, short, signed, sizeof, static, struct, switch, type-
def, union, unsigned, void, volatile, while

OK Enables the specified items and closes the dialog box.  

Cancel Does not enable the specified items, and closes the dialog box. 

Help Opens the help for this dialog box.  
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[Save the Key Operation] dialog box

This dialog box is used to save the recorded key operation in a file.  

Figure 6-134   [Save the Key Operation] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Tool] menu -> [Save the Key Operations...].  

Explanation of each area

(1)   Save in

This area displays the folder in which the file is to be saved.  The folder name specified in [Folder for Macro File] on 
the [Tool] menu -> [PM+ Settings...] - [Path] tab, is displayed.  If there is no specification, the folder will be the same 
as the folder when PM+ was started up.  
The folder in which the file is to be saved cannot be changed here.  To change the folder, change the specification 
of [Folder for Macro File] on the [Tool] menu -> [PM+ Settings...] - [Path] tab.  

(2)   File name and Save as type 

Specify the name of the file to be saved.  Only a file name with extension ".imc" can be specified.  
Only "Macro File (*.imc)" is available as [Save as type]. 

(1)

(2)
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Function buttons 

Caution

- The command corresponding to each key operation is described in a macro file (*.imc)
The macro file is text file, and can therefore be referenced or modified.  Addition is also possible, in accordance with 
the prescribed format.  
Refer to "APPENDIX B  COMMANDS FOR KEYBOARD MACROS" for details. 

Button  Function

Save Saves the file with the specified name.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Load the Macro File] dialog box

This dialog box is used to read a saved macro file.  

Figure 6-135   [Load the Macro File] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Tool] menu -> [Load the Macro File...].  

Explanation of each area

(1)   Look in 

This area displays the folder that includes the macro file to be read.  The folder name specified in [Folder for Macro 
File] on the [Tool] menu -> [PM+ Settings...] - [Path] tab, is displayed.  If there is no specification, the folder will be 
the same as the folder when PM+ was started up.  
The folder in which the file is to be saved cannot be changed here.  To change the folder, change the specification 
of [Folder for Macro File] on the [Tool] menu -> [PM+ Settings...] - [Path] tab.  

(2)   File name and Files of type 

Specify the name of the macro file to be loaded.  Only a file name with extension ".imc" can be specified.  

(1)

(2)
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Function buttons 

Button  Function

Open Opens the specified file.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Play back the Macro File] dialog box

This dialog box is used to read the key operation from a saved macro file and execute the macro.  

Figure 6-136   [Play back the Macro File] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Tool] menu -> [Play back the Macro File...].  

Explanation of each area

(1)   Look in 

This area displays the folder containing the macro file to be executed.  The folder name specified in [Folder for 
Macro File] on the [Tool] menu -> [PM+ Settings...] - [Path] tab, is displayed.  If there is no specification, the folder 
will be the same as the folder when PM+ was started up.  
The folder in which the file is to be saved cannot be changed here.  To change the folder, change the specification 
of [Folder for Macro File] on the [Tool] menu -> [PM+ Settings...] - [Path] tab.  

(2)   File name and Files of type 

Specify the name of the macro file to be executed.  Only a file name with extension ".imc" can be specified.  

(1)

(2)
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Function buttons 

Button  Function

Open Loads the specified file and executes the saved key operations.

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Entry Macro Files] dialog box

This dialog box is used to register a macro file to a key.  

Figure 6-137   [Entry Macro Files] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Tool] menu -> [Register the Macro Files...].  

Explanation of each area

(1)   Entry Macro List 

This area displays a list of the macro files that are already registered.  Files are added to the [Play Back the Regis-
ter Macro] menu in order from the top.  
A registered macro is selected by selecting the title.  

(a)   Title
Displays the titles of the macros that are already registered.  The title is set by the [Add...] or [Change...] button.  
The title can also be changed by selecting the character string displayed on the title and clicking it again.  The set 
title becomes the menu character string when a file is added to the [Play Back the Register Macro] menu.  

(b)   Macro File Name
Displays the registered macro file names.  

(1)



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U18416EJ1V0UM 337

(c)   Shortcut: 
Displays the shortcut keys set in the macro file.  The shortcut keys are set on the [Tool] menu -> [Customize...] - 
[Keyword] tab.  

Function buttons 

Button  Function

OK Enables the specified items, and closes the dialog box. 

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  

Up Raises the selected macro to the position directly above.  

Down Lowers the selected macro to the position directly below.  

Add... Opens the [Add the Macro file] dialog box to add a new macro.  Up to 32 macros can be reg-
istered.  

Change... Opens the [Change the Macro file] dialog box to change the contents of the macro selected 
from the entry macro list.  

Delete Deletes the selected macro.  
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[Add the Macro file] dialog box

This dialog box is used to add a macro file for macro registration.  

Figure 6-138   [Add the Macro file] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [Add...] button in the [Tool] menu -> [Register the Macro Files...].  

Explanation of each area

(1)   Look in 

This area displays the folder that includes the macro file to be registered.  The folder name specified in [Folder for 
Macro File] on the [Tool] menu -> [PM+ Settings...] - [Path] tab, is displayed.  If there is no specification, the folder 
will be the same as the folder when PM+ was started up.  
The folder in which the file is to be saved cannot be changed here.  To change the folder, change the specification 
of [Folder for Macro File] on the [Tool] menu -> [PM+ Settings...] - [Path] tab.  

(2)   File name and Files of type 

Specify the name of the macro file to be added.  Only a file name with extension ".imc" can be specified.  

(3)   Title

This area specifies the title of the registered macro.  Up to 32 characters can be set.  The set title becomes the 
menu character string when a file is added to the [Play Back the Register Macro] menu.  

(1)

(2)

(3)
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Function buttons 

Button  Function

Open Adds the specified file.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Change the Macro file] dialog box

This dialog box is used to change the stored contents of a macro file.  

Figure 6-139   [Change the Macro file] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Click the [Change...] button in the [Tool] menu -> [Register the Macro Files...].  

Explanation of each area

(1)   Look in 

This area displays the folder containing the selected macro file.  The folder name specified in [Folder for Macro File] 
on the [Tool] menu -> [PM+ Settings...] - [Path] tab, is displayed.  If there is no specification, the folder will be the 
same as the folder when PM+ was started up.  
The folder in which the file is to be saved cannot be changed here.  To change the folder, change the specification 
of [Folder for Macro File] on the [Tool] menu -> [PM+ Settings...] - [Path] tab.  

(2)   File name and Files of type 

Specify the name of the macro file to be changed.  Only a file name with extension ".imc" can be specified.  

(3)   Title 

This area specifies the title of the registered macro.  Up to 32 characters can be set.  The set title becomes the 
menu character string when a file is added to the [Play Back the Register Macro] menu.  

(1)

(2)

(3)
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Function buttons 

Button  Function

Open Changes the stored contents of the specified macro file.  

Cancel Does not enable the settings, and closes this dialog box.  

Help Opens the help for this dialog box.  
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[Window List] dialog box

This dialog box is used to list the widows that are currently open.  Double-clicking a window in the list makes that win-
dow active.  

Figure 6-140   [Window List] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Window] menu -> [Window List...].  

Explanation of each area

(1)   Select Window 

Displays the names of open windows.  Double-clicking a window name in the list makes the window active.  

Function buttons 

Button  Function

Open Makes the selected window active.  

Cancel Does not enable the specified items, and closes this dialog box.  

Close Window(s) Closes the selected window(s).  Multiple windows can be closed at a time.  

Help Opens the help for this dialog box.  

(1)
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[Shortcut List] dialog box

This dialog box is used to display a list of the shortcut keys set in PM+.  

Figure 6-141   [Shortcut List] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Help] menu -> [Shortcut List...].  

Explanation of each area

(1)   Shortcut List 

This area displays a list of the shortcut keys currently set in PM+.  
If a shortcut key is customized on the [Tool] menu -> [Customize...] - [Keyword] tab, the contents are reflected on 
this list.  
For default shortcut keys, refer to "APPENDIX C  SHORTCUT KEYS".

Function buttons 

Button  Function

Close Closes the dialog box.

Help Opens the help for this dialog box.  

(1)
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[About PM+] dialog box

This dialog box is used to display the version information about PM+.  If a project file is open, the version of the NEC 
Electronics tools corresponding to that project and the device file is also displayed.  

Figure 6-142   [About PM+] Dialog Box

This section describes the following items:  

- Opening

- Explanation of each area

- Function buttons

Opening

- Select the [Help] menu -> [About PM+...].

Explanation of each area

(1)   Tool version 

This area displays the version of the tool to be used among the tools selected in the project file currently opened, in 
the format "product name, version [date]".
If the tree is opened, the file name is displayed with the full path.  

(2)   Device File 

This area displays the device name, file name, and version of the device file used in the currently open project file 
under "device name (device file name), version [date]".  
If the tree is opened, the device file name is displayed with the full path. 

(1)

(2)
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Function buttons 

Button  Function

OK Closes the dialog box.
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CHAPTER 7   MESSAGES

7. 1   Display Format
The messages output by PM+ are displayed in the message dialog box shown in Figure 7-1.  
There are four kinds of messages.  When a message is displayed, a letter indicating the message type is prefixed to the 

message number.  The meaning of each message type is shown in Table 7-1.  

Figure 7-1   Message Dialog Box

Table 7-1   The Meaning of each Message Type 

Prefix Type Explanation

F Fatal Error This message is displayed when a fatal error occurred.  

E Operation Error This message is displayed when an operating error occurred and execution is not 
possible.  

Q Question This message is displayed when some kind of choice is required for the operation.  

I Information This message is displayed to report some kind of information.  
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7. 2   Fatal Error 

The fatal error messages output by PM+ are listed below together the cause and action to take in response to the mes-
sage, in message number order.  All fatal error messages have "F" prefixed to the message number.  

Table 7-2   Fatal Error Message List

Number Description

F0001 Message Memory is not enough. Please terminate other applications. 

Cause Memory could not be secured.  

Action by User Close other applications to free up memory.  

F0002 Message Failed to initialize Object Linking and Embedding.

Cause The object library DLL could not be read at startup.  

Action by User Since the OS is likely to be unstable, restart the machine.  

F0003 Message Failed to executing the command.

Cause The DOS command could not be executed. 

Action by User Check whether the command can be executed correctly at the DOS prompt and set so that 
the command can operate. If this message is displayed prior to build execution, create the 
make file again using [Export Makefile] from the [Project] menu and execute build.

F0004 Message Make file is broken. Make sure that the make file is remade.

Cause An attempt to execute build failed because the make file was damaged. 

Action by User Create the make file again using [Export Makefile] from the [Project] menu and execute build.

F0100 Message Cannot read the file. Make sure that this file has broken.

Cause An error occurred when the file was read. 

Action by User Check if the file is damaged and try again. 

F0101 Message Cannot save this file. This file is used by the other process or specified illegal file name or the 
disk is full.  

Cause A file already specified by another process is being used for storing source files, or the disk 
capacity is smaller than the volume of the files to be written. 

Action by User  If the specified file is being used by another application, close the application.  If the disk is 
full, free up memory.  If the file name is illegal, specify it with usable characters.  

F0102 Message Failed to change(make) the file name of the source file by IDL file.  Make sure the IDL file 
memorized this source file by IDL file.

Cause A source file generated by an IDL file could not be changed or created when being stored.  

Action by User The IDL file is likely to be damaged.  Check if the file is damaged or not.  

F0103 Message Failed to change(make) the file name of the source file by IDL file. Make sure that the correct 
path and filename given or disk space.

Cause The specified path is invalid, the file name is illegal, or the specified disk is full.  

Action by User Check the path and specify a valid one.  If illegal characters have been used for the file name, 
use legal ones.  If the disk is full, free up memory. 

F0104 Message Failed to change(make) the file name of the source file by IDL file.  The original source file by 
IDL file cannot be opened.

Cause When changing the name of a source file generated by IDL, the original source file could not 
be opened.  

Action by User Check the path for the source file and specify the correct path using [Change Source File 
Name...] from the [File] menu.  
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F0105 Message Failed to open the project file. Cannot accentuate the register.

Cause The project file could not be found, or the project file could not be opened because it is dam-
aged.  

Action by User Check the path for the project file, or verify that the project file is not damaged.  

F0106 Message Failed to open the device file. Cannot accentuate the register.

Cause The device file could not found, or the device file could not be opened because it is damaged.  

Action by User Check the path for the device file, or verify that the device file is not damaged.  

F0107 Message Failed to read the device file. Make sure that this file has broken.

Cause A reading error occurred for the device file.  

Action by User Verify that the device file is not damaged.  

F0108 Message Failed to open object. Make sure that this IDL file has broken.

Cause An object could not be read when the file was read.  

Action by User Verify that the IDL file is not damaged.  

F0109 Message Cannot save object. Memory may be not enough.

Cause An object could not be saved when the file was stored.  

Action by User The disk for storing is full, so free up disk space.  

F0110 Message Failed to read the macro file %s. Make sure that the correct path and filename given.

Cause The macro file could not be read.  %s indicates the file name.  

Action by User Check that the specified file exists.  

F0111 Message The macro file %s cannot be created. Make sure that the correct path and filename given or 
disk space.

Cause The macro file could not be saved.  %s indicates the file name.  

Action by User Check whether the characters used in the specified file name are legal, and specify legal 
characters.  If the disk is full, free up memory.  

F0112 Message Cannot load the IDL file of Ver3.X format. Make sure that this IDL file has broken.

Cause The format of the IDL file from an old version (Ver.3.xx) of idea-L is illegal, or the IDL file is 
damaged.  

Action by User Check if the specified file is damaged or not.  

F0113 Message %s  Failed to save this project file.  Make sure that disk space or this file has broken or this file 
using with other application.

Cause The disk space is full, the file is damaged, or the file may be being used by another applica-
tion.  %s indicates the file name.  

Action by User Check the disk capacity, verify that the file is not damaged, and execute again.  If the file is 
being used by another application, close the application and execute again.  

F0114 Message %s  Cannot be found this file.  Please check the NEC Electronics tool is installed correctly.

Cause The tool including the tool DLL displayed in the message could not be found.  %s indicates 
the file name.  

Action by User Check if the tool is installed.  If not, reinstall it.  

F0115 Message Failed to create temporary file. Make sure that work folder exist or the disk is full.

Cause When creating a temporary file, the disk capacity is smaller than the volume of the file to be 
written, or the operating folder specified in the [PM+ Settings] dialog box does not exist.  

Action by User Check the disk capacity or the operating folder, and execute again.  

F0116 Message Failed to open the temporary file.

Cause The temporary file could not be found or the file is damaged.  

Action by User Check if the file exists and is damaged, and execute again.  
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F0117 Message %s  Failed to read the workspace file. Make sure that this file has broken.

Cause The workspace file could not be read.  %s indicates the workspace file name.  

Action by User Verify that the workspace file is not damaged.  

F0118 Message Failed to read the project file. Make sure that a this file has broken.

Cause The project file could not be read.  

Action by User Verify that the file is not damaged, and execute again.  

F0119 Message Same project files cannot be read.

Cause When reading the workspace, some of the registered project files could not be read.  

Action by User Search for the cause of the failure, and execute again. 

F0120 Message All project file cannot be read.

Cause On reading workspace, all the files could not be read among the registered project files.  

Action by User Search for the cause of the failure, and execute again. 

F0121 Message %s  Failed to save this workspace file.  Make sure that disk space or this file has broken or 
this file using with other application.

Cause The disk capacity is full or the file is damaged.  Or, the specified file is being used by another 
application.  %s indicates the file name.  

Action by User Check the disk capacity, verify that the file is not damaged, and execute again.  If the file is 
being used by another application, close the application and execute again.  

F0122 Message Failed to create the backup file. Make sure that the backup file is used by the other process or 
the disk is full.

Cause The backup file being created is already being used by another process, or the disk capacity 
is smaller than the volume of the file to be written.  

Action by User If the backup file is being used by another application, close the application.  Check the disk 
capacity and execute again.  

F0123 Message %s  Failed to delete temporary file. Aborted to create a new workspace.

Cause The displayed temporary file could not be deleted when [New Workspace...] on the [File] 
menu was executed.  %s indicates the name of the file that could not be deleted.  

Action by User When specifying the workspace file name on the [New WorkSpace - Step 1/9 [Workspace 
Information]] dialog box, if overwriting the workspace file is enabled, the original file is left with 
the extension .bak.  Restore this file.

F0124 Message Failed to rename the file name %s1 to %s2. Aborted to create a new workspace.

Cause The displayed temporary file could not be renamed as the original file when [New 
Workspace...] on the [File] menu was executed.  %s1 indicates the name of the temporary file 
and %s2 indicates the name of the original file.  

Action by User When specifying the workspace file name on the [New WorkSpace - Step 1/9 [Workspace 
Information]] dialog box, if overwriting the workspace file is enabled, the temporary file is the 
original file.  Restore this file.  

F0125 Message %s   Failed to create the sample file.  Make sure that disk space or the same name file exists 
that is read only or the other process using.

Cause Failed to create the sample file.  %s indicates the sample file name.  

Action by User Free up disk space.  Check whether or not a file with the same name is read-only or being 
used by another application.  If the file is read-only, clear the attribute and execute again.   If 
the file is being used by another application, close the application and execute again.  
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F0126 Message Cannot found the data file for creating the sample link directive file. Make sure that PM+ has 
installed correctly.

Cause When creating a link directive file sample, the data file to be used could not be found.  

Action by User In the last dialog box of the wizard, click the [Cancel] button, close PM+ and install PM+ 
again.  Or, return to the [New WorkSpace - Step 6/9 [LinkDirective File]] dialog box and select 
other than [Create and Use the sample File].  

F0127 Message Cannot read the data file for creating the sample link directive file. Make sure that PM+ has 
installed correctly.

Cause The data file to be used for creating the link directive file sample is damaged.  

Action by User In the last dialog box of the wizard, click the [Cancel] button, close PM+ and install PM+ 
again.  Or, return to the [New WorkSpace - Step 6/9 [LinkDirective File]] dialog box and select 
other than [Create and Use the sample File].  

F0128 Message %s  The internal RAM area information not found. The sample link directive file cannot be cre-
ated.

Cause The name of a device with no internal RAM was specified.  %s indicates the specified device 
name.  

Action by User Return to the [New WorkSpace - Step 6/9 [LinkDirective File]] dialog box and select other 
than [Create and Use the sample File].  Select any other device with internal RAM in the [New 
WorkSpace - Step 1/9 [Workspace Information]] dialog box. 

F0129 Message %s  Failed to start up NEC Electronics tool.  Please check the NEC Electronics tool is 
installed correctly.

Cause The DLL of the NEC Electronics tool could not be loaded.  %s indicates the name of the file 
that could not be loaded.  

Action by User Verify that the NEC Electronics tool product is installed correctly.  

F0130 Message Failed to copy the file.  Failed to copy the file. The original file cannot be opened or disk space 
may be not enough or the other process may be using the destination file.  
  Copy from: %s1
  Copy to: %s2

Cause Failed to copy the file.  %s1 indicates the name of the file to be the copy source and %s2 indi-
cates the name of the file to be the copy destination.

Action by User Check whether there is a Read attribute in the file to be the copy source. If there is no 
attribute, assign the Read attribute, and execute again.  Free up disk space.  Check if the file 
is being used by another application.   If the file is being used by another application, close 
the application and execute again.

F0131 Message Failed to remove the file.  Make sure that this file is read-only or the other process using this 
file.  

Cause The file could not be deleted when the [Clean] command on the [Build] menu was executed.  
The [OutPut] window indicates the file name that could not be deleted.  

Action by User Check whether the file displayed in the [OutPut] window has the Read-Only attribute or is 
used in another process, and if required, cancel the Read-Only attribute, or close the other 
applications that use this file.  

F0200 Message Failed to make the edit window.  Memory may be not enough. Please terminate other applica-
tion.

Cause The Edit window could not be created because the memory was insufficient or the OS was 
not stable.  

Action by User Close the other applications and free up memory, or restart the OS.  

F0201 Message Cannot open any more window. Please close other window.  

Cause An attempt was made to open more than 64 Edit, Output, and Search result display windows 
in total.  

Action by User Close the other windows and try again.  
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F0202 Message This file is too large size. Please divide this file.

Cause An attempt was made to edit more than the maximum number of lines (2,097,152) on the Edit 
window.  

Action by User Divide the file being edited using the copy or paste function.  

F0203 Message Cannot input more.

Cause More than 5,119 characters were entered in a line.  

Action by User Decrease the number of the characters per line and enter again.  

F0210 Message This file has been used by another process. Please terminate using application. 

Cause A file currently being edited by another application was edited on PM+.  However, this mes-
sage only functions if the application using the same file is an application that has exclusive 
file access control, such as Word.  

Action by User Close the application using this file.  

F0211 Message Failed to create Object.

Cause A new object could not be created.  

Action by User Verify that the specified object is installed correctly.  

F0212 Message Failed to copy clipboard.  Memory may be not enough. Please terminate other application.

Cause The object could not be copied to the clipboard because the memory was insufficient or the 
OS was not stable.  

Action by User Close the other applications and free up memory, or restart the OS.  

F0213 Message Failed to paste from clipboard.  Memory may be not enough. Please terminate other applica-
tion.

Cause Object could not be pasted from the clipboard because the memory was insufficient or the OS 
was not stable.  

Action by User Close the other applications and free up memory, or restart the OS.  

F0214 Message Failed to Undo commands. Cannot undo over there.  Memory may be not enough. Please ter-
minate other application.

Cause The undo operation could not be executed successfully because the memory was insufficient 
or the OS was not stable.  

Action by User Close the other applications and free up memory, or restart the OS.  

F0215 Message Failed to Repeat commands. Cannot repeat over there.  Memory may be not enough. Please 
terminate other application.

Cause The redo operation could not be executed successfully because the memory was insufficient 
or the OS was not stable.  

Action by User Close the other applications and free up memory, or restart the OS.  

F0216 Message This selection is too many characters for copy operation. Please select more small range.

Cause The characters copied to the clipboard exceeded 16 Mbytes.  

Action by User Decrease the selected characters and try again.  

F0217 Message Over the max instructions 64. PM+ has stopped recording. 

Cause When recording key operations, the recorded instructions exceeded 64, which is the maxi-
mum number of recordable instructions.  

Action by User Record key operations within 64 instructions. 

F0218 Message Over the max instructions 64. PM+ has stopped loading the macro file. (%d): %s

Cause When reading a macro file, the recorded instructions exceeded 64, which is the maximum 
number of recordable instructions.  %d indicates the line with the error, and %s indicates the 
character string with the error.  

Action by User Decrease the number of instructions in the macro file and execute again.
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F0219 Message Too big print font, so cannot print any more.

Cause When printing was executed with a large font after text wrap-around, line numbers, and hier-
archy symbols were specified to be printed in the [Print] dialog box, printing was canceled 
because a linefeed occurred between the line numbers and layer marks and the characters.  

Action by User Set a smaller font and try again.  

F0300 Message %s  Failed to delete temporary file. Aborted to add a new project into workspace.

Cause The displayed temporary file could not be deleted when the [Add New Project...] command 
was executed.  %s indicates the file name that could not be deleted.  

Action by User When specifying the project file name on [Add New Project...], if overwriting the project file is 
enabled, the original file is left with the extension .bak.  Restore this file.  

F0301 Message Failed to rename the file name %s1 to %s2. Aborted to add a new project into workspace.

Cause The displayed temporary file could not be renamed as the original file when the [Add New 
Project...] command was executed.  %s1 indicates the name of the temporary file and %s2 
indicates the name of the original file.  

Action by User When specifying the project file name on [Add New Project...], if overwriting the project file is 
enabled, the temporary file is the original file.  Restore this file.  

F0400 Message Syntax error. Please check the make file.

Cause There was a syntax error in the make file.  

Action by User Check the syntax of the make file and correct the error.  

F0401 Message A line has too many characters in make file.

Cause The characters in one line after the macro was expanded in a make file exceeded 5120.  

Action by User Set 5120 or fewer characters per line description.  

F0601 Message %s  The object file was required in order to execute the [dump850] command.  Please exe-
cute build to generate the object file.

Cause The object file could not be found when the [dump850] command on the [Tool] menu was 
executed.  %s indicates the object file name.  

Action by User Execute build, generate an object file, and try again.  

F0602 Message Failed to remove the file.  Make sure that this file is read-only or the other process using this 
file.  

Cause The displayed file could not be deleted when  [dump850] command on the [Tool] menu was 
executed.  %s indicates the name of the file that could not be deleted.  

Action by User Check if the displayed file is read-only or if it is being used by another application.  If it is read-
only, clear it and try again.  If it is being used by another application, close the application and 
try again.  

F0603 Message %s   Failed to rename the filename.  Make sure that other process using this file.

Cause The displayed file could not be renamed when the  [dump850] command on the [Tool] menu 
was executed.  %s indicates the name of the file that could not be renamed.  

Action by User Check if the displayed file is being used by another application.  If it is being used by another 
application, close the application and try again.

F0604 Message %s The load module file was required in order to execute the [dump850] command.  Please 
execute build to generate it.

Cause The load module file could not be found when the [dump850] command on the [Tool] menu 
was executed.  %s indicates the name of the load module file that could not be found.  

Action by User Execute build, generate a load module file, and try again.  

F0700 Message ToolLinkManager is not running.  

Cause During connection to the server, the communication path of ToolLink (TIS/TLM) returned its 
own fatal error.  

Action by User Restart the tool to be used.  
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F0701 Message cannot communicate with %s.

Cause During connection to the server, the server was logged out and the communication path of 
ToolLink (TIS/TLM) returned an error.  %s indicates the name of the logged out tool.  

Action by User Restart the displayed tool.  
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7. 3   Operation Error 

The operation error messages output by PM+ are listed below together the cause and action to take in response to the 
message, in message number order.  All operation error messages have "E" prefixed to the message number.  

Table 7-3   Operation Error Message List

Number Description

E1000 Message %s  This path has not be found. Make sure that the correct path given.

Cause When specifying a path, the specified path did not exist.  %s indicates the specified path.  

Action by User Check the path and try again.  

E1001 Message %s  This file has not be found. Make sure that the correct path and filename given.

Cause When opening a file, the specified file did not exist.  %s indicates the specified file name.  

Action by User Check the file name and try again.  

E1002 Message Cannot change to the using file name.

Cause An attempt was made to save a file under the name of the file currently being edited.  

Action by User Use the name of a file that is not being edited and try again.  

E1003 Message The file %s is read-only, Please input other file name. 

Cause An existing read-only file was specified.  %s indicates the specified file name.  

Action by User Use the name of a file that is not read-only and try again.  

E1004 Message Found the Layer in the Text File. Please save to IDL format file.

Cause The open text file has layers when it was overwritten and saved.  

Action by User Save layer information in an IDL file format.  

E1005 Message The layer state is different when the file opened.  If you save layer information, please save 
to IDL format file.

Cause The user applied layers to a file after reading it with layer and tried to save it in a text file for-
mat.  

Action by User Save layer information in an IDL file format.  

E1006 Message The file name is too long.

Cause The file name set when tag jump is performed is too long for saving the file under another 
name.  

Action by User Change the file name to a shorter name and try again.  

E1007 Message PM+ cannot divide the source files, there were the 1st layers hasn't lower layer.

Cause [Not Divide the Source File] was not selected when saving a source file or changing a source 
file name, but the file could not be divided because there was a first layer without the lower 
layers.  

Action by User Attach lower layers to the first layer line.  

E1008 Message A file name cannot contain any of the characters.  \ /:*?"<>|

Cause An attempt was made to create a file with a file name that includes prohibited characters.

Action by User Set the file name using characters other than the displayed prohibited ones. 

E1009 Message This filename already exists. Please enter other filename.

Cause When changing the source file name, an attempt was made to change the file name to an 
existing source file name.  

Action by User Set a different file name and try again.  
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E1010 Message The filename was not set.

Cause The source file name has not been set in the[Change Source File Names] dialog box.  

Action by User Set the file name and try again.  

E1011 Message %s was not found.

Cause %s used to specify a character string when setting the user comment mark of the source file 
name was not entered.  

Action by User Enter %s in the set user comment and try again.  

E1012 Message Cannot include %s many times.

Cause When setting the comment mark, multiple %s were set.  

Action by User Enter one %s in the set user comment and try again.  

E1013 Message IDL Control Error. Please set the Control Mark to same comment mark of the source file by 
[Change Source File Names]. 

Cause When tag jumping from the [OutPut] window to the first error line in the source file, the com-
ment symbols associated with the IDL file were not set in the first line in the source file.  

Action by User Using [Change Source File Name...], set the same mark for the comment in the source file 
with the build error as the comment line being used in the source file.  

E1014 Message This file was not the source file by IDL file corresponding to the specific IDL file.

Cause When the IDL file that included the specified source file could not be found during tag jump, 
an IDL file that was not corresponding to the source file was specified in the Select IDL File 
dialog box.  

Action by User Specify an IDL file that is corresponding to the source file.  

E1015 Message The selected IDL file cannot be found.

Cause When the IDL file that created the specified source file could not be found during tag jump, 
the IDL file could not be found in the Select IDL File dialog box.  

Action by User Select an existing IDL file.  

E1016 Message The IDL file corresponding to the source file was not be found . Choose the IDL file. Alterna-
tively select Source button to use the source file itself.

Cause During tag jump, the IDL file that was registered in the specified source file could not be 
found.  

Action by User Select the original IDL file or open the source file.  

E1017 Message The Specific drive for the IDL source files cannot be found.  Do you wish to save the IDL 
source files to the same folder of IDL file?

Cause The drive of the source file specified when saving the IDL file could not be found.  

Action by User Change the source file output destination using [Change Source File Name...] or generate a 
source file in the same folder as the IDL file.  

E1018 Message The IDL source file's path cannot be found. Do you wish to change the path? 

Cause The source files save to the same folder of IDL file, if you select [No].  The path specified by 
the source file when saving an IDL file could not be found.  

Action by User Change the source file output destination using [Change Source File Name...] or generate a 
source file in the same folder as the IDL file.  

E1019 Message The path of IDL source file has not be found.  This file will be save to the same IDL file's 
folder.

Cause The path specified by the source file when saving an IDL file or changing the source file 
name could not be found.  

Action by User Change the source file output destination using [Change Source File Name...] or generate a 
source file in the same folder as the IDL file.  
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E1020 Message Cannot convert to new path. Make sure that the path is correct.

Cause The path could not be changed when opening a project file copied from a different folder.  

Action by User Open the project file with an editor and verify the path.  

E1021 Message The file extension was wrong. Please change the file extension.

Cause An unsupported extension was specified.  

Action by User Change the extension and try again.  

E1022 Message %s  This file cannot save settings because of read-only attribute.  Please change read-only 
attribute.  

Cause An attempt was made to write a read-only file.  %s indicates the file name.  

Action by User Clear the Read-Only attribute with Explorer, etc. and set the file again.  

E1023 Message Some files cannot be found.  Please check the files exist.  

Cause The source and include files registered in the workspace file (project file) specified to be 
opened could not be found.  If this massage is displayed, the same contents are also dis-
played in the [OutPut] window.  

Action by User Check that all the source and include files registered in the workspace (project) exist.  

E1024 Message %s  Project file cannot be found.  Make sure that the correct path and filename given.

Cause The specified project file could not be found.  %s indicates the specified project file name.  

Action by User Check that the specified project file exists.  

E1025 Message %s  Cannot create the folder. 

Cause The folder name was illegal or a folder without access rights was specified.  %s indicates the 
specified folder name.  

Action by User Specify the correct folder name or specify a folder with access rights.  

E1026 Message Enter the folder name with absolute path.

Cause The specified folder name has a relative path.  

Action by User Specified the folder name with an absolute path.  

E1027 Message %s  Cannot register the filename with space character.  Please regist the file after rename it.

Cause When adding source file, a file name with one-byte spaces was specified.  %s indicates the 
specified folder name.  

Action by User Rename the file using a file name without one-byte spaces and register it again.  

E1028 Message Please specify the same file extension of copy file.  

Cause The extension of the specified file name to be the copy source and the file name to be regis-
tered differ.  

Action by User Specify the same extension for the file name to be the copy source and the file name to be 
registered.  

E1029 Message The file names of copy file and register file are identical.  Please specify the different file 
name to register.  

Cause Copying is not possible because the specified file name to be the copy source and the file 
name to be registered are the same.  

Action by User Specify the same extension for the file name to be the copy source and the file name to be 
registered.  

E1030 Message %s  Cannot register the file name with space character.  
Please register the file after rename it.  Do you wish to continue to add source files?  

Cause When adding source file, a file name with one-byte spaces was specified.  %s indicates the 
file name.  This message is displayed when multiple source files are selected and added to a 
project.  

Action by User Rename the file using a file name without one-byte spaces and register it again.  
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E1031 Message A file name cannot contain any of the characters.  \/:*?"<>|
Do you wish to continue to add source files?  

Cause An attempt was made to create a file with a file name that includes prohibited characters.  
This message is displayed when multiple source files are selected and added to a project.

Action by User Set the file name using characters other than the displayed prohibited ones.

E1032 Message %s  Cannot use the network path.  

Cause The specified folder was a network path.  %s indicates the specified folder name.  

Action by User Specified the folder other than the network path.  

E1033 Message %s  Cannot use the network path.  Do you wish to continue to add source files?  

Cause The specified folder was a network path.  %s indicates the specified folder name.  This mes-
sage is displayed when multiple source files are selected and added to a project.  

Action by User Specified the folder other than the network path.  

E1035 Message Two or more workspace files or project files cannot be dropped.  

Cause Multiple workspace files and project files were dropped in a main frame or the Edit window.  

Action by User If dropping a workspace or project in a main frame or the Edit window, specify only one such 
item.  

E1036 Message A workspace is not opened during user program execution.  Please open a workspace after 
stopping a program.  

Cause An attempt was made to drop and open a workspace during user program execution.  

Action by User Stop the user program via the debugger and open a workspace again.  

E1037 Message The addition of a project cannot be performed during user program execution.  

Cause An attempt was made to drop and add a project file during user program execution.  

Action by User Stop the user program via the debugger and add a project file again.  

E1100 Message This object cannot edit.

Cause An attempt was made to edit a non-editable object.  

Action by User Edit an editable object.  

E1200 Message Cannot specify the extension IDL and the other extensions.

Cause When setting [Of Type] during global replacement, IDL and another extension were set at the 
same time.  

Action by User When an IDL file the target of replacement, specify only IDL files.  

E1201 Message %s  The file extension was wrong. Please change the file extension.

Cause When setting [Of Type] during global replacement, an extension other than the global 
replacement target extensions was set.  %s indicates the specified extension.  

Action by User Specify a target extension and execute global replacement.  

E1202 Message %s  Cannot specify the wild card for the file without extension.

Cause When setting [Of Type] during global replacement, wildcards ('*', '?') were specified instead 
of extensions.  %s indicates the specified extension.  

Action by User Execute without specifying wildcards.  

E1400 Message The file extension is not PRW/PRJ.

Cause The specified workspace file has an extension other than prw.  

Action by User Specify the file with a prw or prj extension, and execute.  

E1401 Message The workspace file name not specified. Please enter it.

Cause The workspace file name is not specified.  

Action by User Specify a workspace file name, and execute.  
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E1402 Message The project file name not specified. Please enter it.

Cause The project file name is not specified.  

Action by User Specify a project file name, and execute.  

E1403 Message %s  The file already exists. Please enter other file name.

Cause An existing file name was specified.  %s indicates the specified file name.  

Action by User Specify another file name and execute again.

E1404 Message %s  The file was not specified the device. Do you wish to specify it?  You can specify it with 
[Project Settings] command after this time.

Cause No device is specified in the open project file.  %s indicates the specified project file name.  

Action by User Build cannot be executed in this status.  Specified a device here now, or later using the 
[Project Settings...] command.  

E1405 Message %s1 The device file was not found. ( Device:%s2 )
Please install a device file by the device file installer. 

Cause The device file set to the specified project file could not be found.  %s1 indicates the project 
file name and %s2 indicates the device name.

Action by User Check that the device file is installed.  If the device file is not installed, install it by the device 
file installer. 

E1406 Message The file %s already entered.  

Cause The specified file has already been registered in the project.  %s indicates the file name.  

Action by User Rename the file using a different file name, and register it again.  

E1407 Message This project file is not a project file generated with PM+(Project Manager). Please update this 
project.

Cause The specified project file was created by a different NEC Electronics tool (debugger, etc), not 
PM+ or PM.  

Action by User Update the project information to that for PM+.  

E1408 Message This type cannot be selected multiple. Please select one file.

Cause When adding a file related to the project, a file type that could only be specified once was 
specified more than once in the project.  

Action by User Select just one file and execute it.  

E1409 Message Project group name is not specified. Please enter project group name.

Cause An attempt was made to close the [Project Group Name] dialog box with the [OK] button 
without setting a project group name.  

Action by User Set a project group name in the [Project Group Name] dialog box.  

E1410 Message This project group name is using. Please enter other project group names.

Cause A name that had already been used in the workspace was set in the [Project Group Name] 
dialog box and the [OK] button was clicked.  

Action by User Set a character string that is not currently being used as a project group name.  

E1411 Message %s  This file cannot edit.  

Cause The [Open] command was selected for a non-editable project-related file.  %s indicates the 
file name.  

Action by User Select an editable file with the [Open] command.  

E1412 Message The device file information cannot be found in project file.
It does not show the device file version.

Cause The device file information could not be found in the project file.  

Action by User Install a device file to be used.  
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E1413 Message Cannot add the file %s to the project because of the wrong extension.

Cause The extension specified a file name that was not applicable to a source file.  %s indicates the 
specified file name.  

Action by User Change the extension and try again.  

E1414 Message Cannot add the file %s to the project because of the wrong extension.  Do you wish to con-
tinue to add source files? 

Cause The extension specified a file name that was not applicable to a source file.  %s indicates the 
specified file name.  

Action by User Change the extension and try again.  

E1415 Message The file %s has already set.

Cause The specified file has already been set for a source file.  %s indicates the specified file name.  

Action by User Rename the file using a different file name and add the source file again.  

E1416 Message The file %s has already set.  Do you wish to continue to add source files? 

Cause The specified file has already been set for a source file.  %s indicates the specified file name.  

Action by User Rename the file using a different file name and add the source file again.  

E1417 Message %s  Syntax error. Please check the list file.

Cause There was a syntax error in the list file.  %s indicates the specified file name.  

Action by User Check the syntax of the list file and correct the error.  

E1418 Message %s  The project which already supports other devices is registered into this project group. 
Please change the device of a project or change the project group of a registration place.

Cause An attempt was made to add a project supporting a device that was different from the one 
supported by the registered project to the project group.  %s indicates the project file name.  

Action by User Open another project and acquire a device of the same type, or register the project in 
another project group.  

E1419 Message  %s   A project cannot be registered into this project group any more. Please register with 
other project groups.

Cause An attempt was made to register more than the maximum number of projects, 20, in a project 
group.  %s indicates the project file name.  

Action by User Delete the projects in the project group and register them again, or register them in another 
project group.  

E1420 Message %s  This file has already specified as the startup file.

Cause An attempt was made to add a file specified at startup as a linker option.  %s indicates the 
name of the file attempted to be added.  

Action by User Check the linker option.

E1421 Message Cannot register the file any more.

Cause When adding source file or other files, an attempt was made to register more than the maxi-
mum number of files (source files: 2048, other files: 100).  

Action by User Register the file after deleting the unnecessary file.  

E1422 Message %s The file except extension has already set.

Cause The specified file name (without extension) has already been set as a source file.  
%s indicates the specified file name.  

Action by User Rename the file using a different file name and add the source file again.  

E1423 Message The file except extension has already set.  Do you wish to continue to add source files?

Cause The specified file name (without extension) has already been set as a source file.  
%s indicates the specified file name.  

Action by User Rename the file using a different file name and add the source file again.  
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E1424 Message The project %s already entered.  

Cause When adding a new project or inserting a project, a project file name that has already been 
registered was specified.  %s indicates the project file name.  

Action by User Set another file name and register it.  

E1425 Message  A project group cannot be registered into this workspace any more.  Please register the 
project into the existing project group.

Cause When adding a new project or inserting a project, an attempt was made to add more than the 
maximum number of project groups, 128, when a new project group was specified.  

Action by User Register the project in an existing project group.  

E1426 Message %s  This file has already specified as the startup file.  Do you wish to continue to add source 
files?  

Cause An attempt was made to add a file specified at startup as a linker option.  %s indicates the 
name of the file attempted to be added.  

Action by User This message is displayed when multiple source files are selected and added to a project.  

E1427 Message A project cannot be registered into this workspace any more.  Please delete an unnecessary 
project or register the project into the other workspace.  

Cause Registration of a number of projects exceeding the maximum number (128) of projects that 
can be registered to a workspace was attempted.  

Action by User Add the projects after deleting the unnecessary ones.  Or add the projects to a different work-
space.  

E1428 Message %s The specific some tools cannot be found. Please select tools. 

Cause The tool specified in the project file has not been installed in the PC currently operating.  

Action by User Select the tool to be used from the installed tools.

E1429 Message The tool-set name was not set. Please enter it.

Cause An attempt was made to move to another page leaving the tool set name unspecified on the 
[Tool Version Settings] tab in the [Project Settings] dialog box.  

Action by User Select a tool set name.

E1430 Message A Toolset name cannot contain any of the following characters:
\\ / : * ? \"< > |

Cause An attempt was made to use a character which can not be used for the tool set name.

Action by User Specify the tool set name using the character which can be used. 

E1500 Message Cannot exit PM+ while a build is in progress. Select the Stop Build command before exit 
PM+.

Cause An attempt was made to close PM+ during build.   

Action by User Cancel build before closing PM+. 

E1501 Message Cannot exit PM+ while make file creating.

Cause An attempt was made to close PM+ while a make file was being created.  

Action by User Cancel make file creation before closing PM+.  

E1502 Message Failed to execute build. Make sure that compiler and assembler was installed correctly. 

Cause Build could not be started up.  The compiler or assembler is likely to have been installed 
incorrectly. 

Action by User Check that the compiler or the assembler is installed correctly.  
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E1503 Message %s  Failed to start up the editor. Make sure that the correct path and file name given.

Cause The external editor could not be started up.  %s indicates the path of the editor that could not 
be started up.  

Action by User Check whether the set external editor exists.  If not, use another editor or the editing function 
of PM+.  

E1504 Message %s  Failed to start up the debugger. Make sure that the correct path and file name given.

Cause The debugger could not be started up.  %s indicates the path of the debugger that could not 
be started up.  

Action by User Check whether the set debugger exists.  If not, install it or specify another one.  

E1505 Message User program is running. Please stop it to execute the command.

Cause The [New Workspace...], [Add New Project...], [Insert Project...], [Open Workspace], [Build 
and Debug], or [Debug] command was executed while the user program was being exe-
cuted.  

Action by User Stop the user program via the debugger and execute it again.  

E1506 Message Cannot execute this command while the debugger executing.

Cause While the debugger was starting up, an unexecutable command was selected.  

Action by User Close the debugger and execute it again.  

E1507 Message The file %s was not found.  Abort to compile. 

Cause The source file specified when executing compilation could not be found.  The source file 
name for which compile was executed is displayed to %s.  

Action by User Check whether the specified source file exists.  If not, then create it.  

E1508 Message Cannot add the build mode. Please conform using the latest version compiler/assembler.

Cause Build mode was added in a language product that does not support build mode.  

Action by User Verify that the compiler/assembler used is the latest version.  

E1509 Message Cannot remove the build mode. Please conform using the latest version compiler/assembler.

Cause Build mode was added in a language product that does not support build mode.  

Action by User Verify that the compiler/assembler used is the latest version.  

E1510 Message Cannot execute this command while the debugger downloading.  Please execute it after the 
debugger downloading.  

Cause An attempt was made to execute download again during downloading of the debugger. 

Action by User Try again after finishing the download.  

E1511 Message Cannot execute this command without the debugger start up.  Please start up the debugger.

Cause Multiple load module files were downloaded while the debugger was not started up.  

Action by User Start up the debugger and try again.  

E1512 Message The batch build settings is not set up.  Please set up the batch build settings by [Batch Build 
Settings...].

Cause After workspace creation, [Batch Build] or the [Batch Rebuild] menu item was executed 
before the batch build setting was performed. 

Action by User After opening the [Edit Batch Build Settings] dialog box from the [Batch Build Settings...] 
menu item and performing the batch build setting, execute [Batch Build] or the [Batch 
Rebuild] menu item again. 
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E1513 Message The build or rebuild project is not specified.  Please set up the batch build settings by [Batch 
Build Settings].

Cause [Batch Build] or the [Batch Rebuild] menu item was executed with not even one project spec-
ified for building in the batch build setting. 

Action by User After opening the [Edit Batch Build Settings] dialog box from the [Batch Build Settings...] 
menu item and performing the batch build setting, execute [Batch Build] or the [Batch 
Rebuild] menu item again. 

E1600 Message Cannot change to the folder for macro file. 

Cause A macro folder other than the file specified when reading/saving the macro file was set. 

Action by User Specify the set folder for the macro file.  

E1601 Message Over 32 characters.

Cause When registering the macro, an attempt was made to set more than 32 characters for the title 
of the macro.  

Action by User Set a title with fewer than 32 characters.  

E1610 Message Not enough the options. (%d): %s

Cause The options set by the macro instruction are insufficient (such as no specification of the line 
number by the specified line jump).  %d indicates the line number with the error, and %s indi-
cates the line contents.  

Action by User Correct the macro with the correct option setting. 

E1611 Message Wrong the specific number.(%d): %s

Cause A value other than a decimal number was specified for the numeric setting of a macro 
instruction.  %d indicates the line number with the error, and %s indicates the line contents.

Action by User Specify the value with a decimal number.

E1612 Message Cannot specify these options in the same time. (%d): %s

Cause Options that could not be specified simultaneously for a macro instruction were set at the 
same time.  %d indicates the line number with the error, and %s indicates the line contents. 

Action by User Delete one of the options and try again.

E1613 Message Wrong the specific string. (%d): %s

Cause Character strings in a macro instruction were not enclosed by " ".  %d indicates the line num-
ber with the error, and %s indicates the line contents. 

Action by User Enclose character strings by " ".  

E1614 Message Divide by Zero.  (%d): %s

Cause An attempt was made to perform division by 0 while a macro instruction was being executed.  
%d indicates the line with the error, and %s indicates the character string with the error.

Action by User Check the division formula and do not perform 0 division.

E1615 Message Over 255 characters in the line. (%d)  A macro instruction line has more than 255 characters.  
%d indicates the line number with the error.  Set a macro instruction with 255 characters or 
fewer.  

Cause A macro instruction line has more than 255 characters.  %d indicates the line number with 
the error.

Action by User Set a macro instruction with 255 characters or fewer.  

E1616 Message Syntax Error (%d): %s

Cause There was a syntax error in the macro instruction.  %d indicates the line number with the 
error, and %s indicates the character string with the syntax error. 

Action by User Correct the character string syntax and try again.  
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E1617 Message Invalid option. (%d): %s

Cause Invalid options were set for a macro instruction.  %d indicates the line number with the error, 
and %s indicates the line contents. 

Action by User Specify valid options and try again. 

E1618 Message Invalid command. (%d): %s

Cause There was an invalid instruction when executing a macro file.  %d indicates the line number 
with the error, and %s indicates the invalid instruction.

Action by User Set the correct macro instruction and try again. 

E1700 Message %s  Failed to start up the ex-tool. Make sure that the correct path and file name given.

Cause The external tool could not be started up.  %s indicates the full path name for the external tool.  

Action by User Check the set path and verify that the external tool exists.  

E1701 Message The Ex-Editor was not entered.

Cause An external editor is not set.  

Action by User Set an external editor.  

E1702 Message %s  Failed to start up DFINST. Make sure that the correct path and file name given.

Cause DFINST could not be started up.  %s indicates the executed full path name.  

Action by User Check the set path and verify that DFINST exists.  

E1703 Message Cannot register only box or separator.  Please register one or more command buttons.

Cause An attempt was made to register only combo boxes and partition lines when customizing the 
standard bar or build bar.  

Action by User Register more than one command button and then click the [OK] button.

E1704 Message %s  Cannot open this file. Choose the application that open file.

Cause The specified file could not be opened.  %s indicates the specified file name.  

Action by User Make an association with the application to be started up using Explorer.  

E1705 Message Cannot open URL you specified. Choose the application to open URL. 

Cause The specified URL could not be opened.  %s indicates the specified URL.  

Action by User Check if the browser used normally is set.  

E1706 Message %s  Cannot start up this application. Make sure that the correct path and given.

Cause The specified application could not be opened.  %s indicates the full path name of the appli-
cation.  

Action by User Check that the path for the application is correct and try again.  

E1707 Message A reserved word cannot contain any of the characters:
( ) + - / ; = { } < * ?: % ^ ~ | & [ ] < ! > . @ \ \ ' $ \ \ 

Cause Prohibited characters were specified for the keywords of reserved words.

Action by User Specify characters other than prohibited ones for the keywords.

E1708 Message The Title menu string is already in use. 

Cause An attempt was made to set a menu character string that had already been set. 

Action by User Change the menu name to one that has not been set and set again.  

E1709 Message Wrong the tag jump format. It needs '$F' and '$L'. 

Cause There is an error in the tag jump format in the external editor setting.  

Action by User $F and $L need to be specified in the tag jump format.
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E1710 Message Cannot exit PM+ while TW analyzing. 

Cause An attempt was made to close PM+ while TW850 was executing analysis.  

Action by User Close PM+ after TW850 has finished.  

E1711 Message %s  The path or file name is illegal. Enter The correct path or filename. 

Cause An attempt was made to specify an incorrect path or file name.  %s indicates the file name.  

Action by User Specify a correct path or file name.  

E1712 Message %s  The filename is illegal. Enter the correct filename.

Cause An incorrect file name was specified.  This includes the specification of a reserved device 
such as con and com1.  %s indicates the specified file name.  

Action by User Specify a correct file name.  

E1714 Message %s  The file was not the latest object file.  Please execute build command and update the 
object file.

Cause When executing dump850, the .v file, which is a target analysis file, is older than the source 
file.  

Action by User Execute build, update the object, and try the command again.

E1715 Message Failed to start up the Link Directive Generator.  Make sure that it was installed correctly.

Cause The [Open with Link Directive Generator filename] menu was selected with the right mouse 
button on the [Project] window, but LDG could not be started up.  

Action by User This is displayed when tool DLL for LDG is not installed.  Install the LDG and try the com-
mand again.  

E1716 Message Failed to start up the RTOS settings. Make sure that the NEC Electronics RTOS was 
installed correctly.

Cause When creating a new workspace or adding a new project, the [RTOS settings...] button was 
selected, but the OS setting dialog box could not be displayed.  

Action by User Check whether the OS product is installed correctly.  If not, install it.  

E1717 Message The version information not found in the registry.  Make sure that the NEC Electronics tools 
with this function installed correctly.  

Cause On displaying version information, registry information could not acquired.  

Action by User Check if the NEC Electronics tool product that is adapted to the function to display version is 
installed correctly.  If not, install it.  

E1718 Message %s  The file was not the latest load module file.  Please execute build command and update 
the load module file.  

Cause When executing dump850, the .out file, which is a target analysis file, is older than the source 
file.  %s indicates the .out file name, which is a target analysis file.  

Action by User Execute build, update the load module file, and try the command again.  

E1719 Message %s  The folder name is illegal. Enter the correct folder name.

Cause An incorrect folder name was specified.  %s indicates the specified folder name.   

Action by User Specify a correct folder name. 

E1720 Message The Debugger not selected to execute TW.  Please select the debugger with [Debugger Set-
tings].  

Cause When executing TW850, the debugger to be used was not set.  

Action by User Set the debugger to be used from [Debugger Settings...] on the [Tool] menu and try again.
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7. 4   Question 

The question messages output by PM+ are listed below together the cause and action to take in response to the mes-
sage, in message number order.  All question messages have "Q" prefixed to the message number.  

When these messages are displayed, the users must select a button in the message dialog box.  

Table 7-4   Question Message List

Number Description

Q2000 Message Do you wish to save %s ?

Cause When closing PM+ or the Edit window, the windows were not saved.  %s indicates the char-
acter string on the caption of the window.  

Action by User [Yes]: Saves.
[No]: Closes the window without saving.
[Cancel]: Returns to the Edit window.

Q2001 Message Another process has changed %s. Do you wish to reload it?

Cause The contents of the currently open file were changed by another application.  %s indicates 
the updated file name.  

Action by User [Yes]: Reads the new file.
[No]: Displays the Edit window without reading the file.

Q2002 Message %s is already using. It is opened as read-only.

Cause An attempt was made to read a file that has already been read.  %s indicates the specified 
file name. 

Action by User [OK]: Opens the file as Read-Only.
[Cancel]: Cancels reading. 

Q2003 Message %s is already using. Do you wish to open it as read-only? Revert to the original file, if you 
select [No].

Cause An attempt was made to read a file that is already open and being edited.  %s indicates the 
specified file name.  

Action by User [Yes]: Opens the file as Read-Only.
[No]: Discards the edited contents and opens the specified file.
[Cancel]: Cancels reading. 

Q2004 Message %s was not be found. Do you wish to close this window?

Cause A file on the currently open window has been deleted from the disk.  %s indicates the deleted 
file name.  

Action by User [Yes]: Closes the Edit window.
[No]: Dose not close the Edit window.

Q2005 Message %s was not found. Do you wish to save this file?.

Cause The file was deleted from the disk when an attempt was made to close the window being 
edited.  %s indicates the caption of the window

Action by User [Yes]: Displays the [Save As] dialog box.
[No]: Closes the window without saving.
[Cancel]: Returns to the window without doing anything.

Q2006 Message The file %s already exists.  Do you wish to rename to this file name?  

Cause The file already exists.  %s indicates the source file name.  

Action by User [Yes]: Renames the source file.  The existing file will be deleted.  The existing file will be 
deleted.  

[No]: Does not change the name of the file.
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Q2007 Message The file %s is read-only.  Do you wish to rename to this file name?   

Cause The name of source file that was attempted to be changed in the [Change Source File 
Names] dialog box is the same as an existing file name.  Also, the file was read-only.  %s 
indicates the source file name. 

Action by User [Yes]: Renames the source file.  The existing file will be deleted.  The existing file will be 
deleted.  

[No]: Does not change the name of the file.

Q2008 Message Another process has changed %s .  Do you wish to load it?

Cause The source file was changed by another editor after saving the IDL file.  %s indicates the file 
name.  

Action by User [Yes]: Reads the updated source file.
[No]: Reads the IDL file without reading the source file.
[Apply to all update files]:

Reads all the files that are updated without an update message if this check box is 
selected. 

Q2009 Message Do you wish to close all windows?

Cause This is to check whether all the windows are to be closed on when a workspace or project file 
is closed.  

Action by User [Yes]: Closes all the windows.
[No]: Leaves all the windows open.

Q2010 Message %s  The workspace file already exists.  Do you wish to rename old file to %s.bak and replace 
it?

Cause The workspace file name that was specified in the dialog box to create a new workspace file 
is the same as an existing file name.  %s indicates the specified file name.  

Action by User [Yes]: Overwrites the workspace file and save the existing file with the extension .bak.
[No]: Returns to the window without doing anything.

Q2011 Message %s  This folder cannot be found. Do you wish to create it?

Cause The specified folder does not exist.  %s indicates the specified folder name.  

Action by User [Yes]: Creates the folder.
[No]: Does not create the folder.

Q2100 Message Specified to delete in the after grouping. Delete the lines and clear the undo buffer, if you 
select [Yes]. Don't delete, if you select [No].

Cause When grouping by keyword, an operation to delete after grouping was specified.  

Action by User [Yes]: Deletes the grouped lines from the Edit window of the original search document.
[No]: Groups the lines without deleting.

Q2101 Message There were the read-only source file's line in the deleting lines. Do you wish to delete it?

Cause A Read-Only source file is included in the range to be deleted.  

Action by User [Yes]: Deletes the lines that contain a read-only source file also.
[No]: Does not delete.

Q2102 Message Do you wish to update the function prototypes?  The previous prototypes will be deleted as 
update.

Cause An attempt was made to create a prototype declaration more than once.  

Action by User [Yes]: Creates a new prototype declaration.
[No]: Returns to the active Edit window without doing anything.
[This message is not to be shown until restart]:

By checking this check box, this message is not displayed even if the same opera-
tion is performed while PM+ is running.  
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Q2103 Message Do you wish to clear the undo buffer? Do nothing, if you select No.

Cause This is to verify whether the undo buffer is cleared when creating a prototype declaration.  

Action by User [Yes]: Clears undo buffer and create prototype declaration.
[No]: Returns to the active Edit window without doing anything.
[This message is not to be shown until restart]:

By checking this check box, this message is not displayed even if the same opera-
tion is performed while PM+ is running.  

Q2104 Message The read only source file(s) was found. Do you wish to make prototypes for the source file 
but the read-only file(s)?

Cause A read-only source file was discovered while creating a prototype declaration. 

Action by User [Yes]: Creates a prototype declaration for a source file that is not read-only.
[No]: Returns to the active Edit window without doing anything

Q2200 Message PM+ has finished searching this file. Do you wish to continue it from the top of file?  Continue 
it from the top of file, if you select [%s].

Cause Searching finished at the last line.  %s indicates the key assigned to [Down].  

Action by User [Yes]: Searches from the first line.
[No]: Stops searching.

Q2201 Message PM+ has finished searching this file. Do you wish to continue it from the end of file?  Con-
tinue it from the end of file, if you select [%s].

Cause Searching finished at the first line.  %s indicates the key assigned to [Up]. 

Action by User [Yes]: Searches from the last line.
[No]: Stops searching.

Q2202 Message PM+ has finished searching this IDL source file.  Do you wish to continue it from the top of 
IDL source file? Continue it from the top of IDL source file, if you select [%s].

Cause No character string could be discovered during the character string search in the source file.  
%s indicates the key assigned to [Down].  

Action by User [Yes]: Continues searching from the start of the source file.
[No]: Stops searching.

Q2203 Message PM+ has finished searching this IDL source file.  Do you wish to continue it from the end of 
IDL source file?  Continue it from the end of IDL source file, if you select [%s].

Cause No character string could be discovered during the character string search in the source file.  
%s indicates the key assigned to [Up].  

Action by User [Yes]: Continues searching from the start of the source file.
[No]: Stops searching.

Q2204 Message Do you wish to replace all the files?

Cause Replacement of all the files was selected in global replacement.  

Action by User [Yes]: Replaces all the files.
[No]: Returns to the active Edit window without doing anything.

Q2205 Message The search string was found in the IDL source file %s. Do you wish to replace in it?

Cause  During global replacement, the character string to be searched was found in the source files 
of an IDL file.  This message is displayed when the of [Display Message every Source File, in 
the case of IDL file] check box is selected.  %s indicates the source file name.  

Action by User [Yes]: Executes replacement in the displayed source file.
[No]: Skips replacement in the displayed source file and continue searching.
[This message is not to be shown until new searching.]:

If this check box is selected and [Yes] is clicked, global replacement continues 
without a message until the next global replacement is executed.  
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Q2206 Message Do you wish to replace in the using file %s?

Cause An attempt was made to execute global replacement in the file being edited.  %s indicates 
the name of the file being edited.  

Action by User [Yes]: Executes replacement in the file being edited.
[No]: Skips replacement in the file being edited and continue searching.

Q2207 Message %s occurrence(s) have been replaced. Do you wish to continue it from the top of file?

Cause Replacement finished at the last line in character string replacement.  %s indicates the num-
ber of items replaced.  

Action by User [Yes]: Continues replacement from the first line.
[No]: Stops replacement.

Q2208 Message Do you wish to cancel replacement?

Cause The [Esc] key was pressed during replacement of a character string to stop replacement.  

Action by User [Yes]: Stops replacement.
[No]: Continues replacement.

Q2300 Message Do you wish to apply layer rule?

Cause An attempt was made to open a file with layers.  This message is displayed when the [Apply 
Layer Rule in Opening File(s)] check box on the [File] tab under [PM+ Settings...] on the 
[Tool] menu is selected.  The [This message is not to be shown until restart] check box is 
valid only when [Yes] is selected.  

Action by User [Yes]: Opens the file with layers.
[No]: Opens the file without layers.

Q2301 Message Do you wish to clear the undo buffer? Do nothing, if you select [No].

Cause This is to verify whether the undo buffer is cleared when applying layer rule to a file.  

Action by User [Yes]: Clears the undo buffer.
[No]: Returns to the active Edit window without doing anything.
[This message is not to be shown until restart]:

By checking this check box, this message is not displayed even if the same opera-
tion is performed while PM+ is running.  

Q2400 Message %s has already set.  Do you wish to change a setting?  Now: %s2 After: %s3

Cause When adding a project-related file, an attempt was made to add a file type that has already 
been set.  The type of file (startup file, etc.) to be set is displayed to %s1, the currently set file 
name is set to %s2, and the file name to be newly set is set to %s3.  
Select [Yes] button to change the setting, and [No] button to not change the setting.

Action by User [Yes]: Changes the setting and returns to the [Project] window.
[No]: Returns to the [Project] window without changing the setting.

Q2401 Message %s  This project file was generated by a previous version of Project Manager.  PM+ converts 
to the new format.  

Cause An attempt was made to open a project file created in PM V3.xx.  %s indicates the specified 
project file name.  

Action by User [OK]: Changes to a new format.
[Cancel]: Cancels the operation to open the project file.

Q2402 Message %s  The project file already exists.  Do you wish to rename old file to %s.bak and replace it?

Cause The project file name that was specified in the [Add New Project - Step 1/9 [Project Informa-
tion] ]dialog box is the same as an existing file name.  %s indicates the specified file name.  

Action by User [Yes]: Overwrites the project file and save the existing file with the extension .bak.
[No]: Returns to the window without doing anything.

Number Description
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Q2403 Message %s  The file was not found. Do you wish to create it?

Cause The specified file does not exist.  %s indicates the specified file name.  

Action by User [Yes]: Creates a vacant file with the specified file name and continue adding a source file.
[No]: Makes the specified file name invalid and continues adding a source file.
[This message is not be shown until next adding the source files.]:

If this check box is selected, this message is not displayed until the next source file 
addition.

Q2404 Message %s  This file generated by the configurater. Do you wish to add it to the project? 

Cause An attempt was made to register a source file automatically generated by the configurator to 
the project.  %s indicates the specified file name.  

Action by User [Yes]: Registers the specified file to the project.
[No]: Makes the specified file invalid and does not register it to the project.

Q2405 Message The NEC Electronics tool to be used was changed.  When these tools are changed, it is nec-
essary to compile all source files at the time of next build.  Are all object files deleted in order 
to compile all source files at the time of next build?

Cause An attempt was made to change the configuration of the tool to be used in the [Tool Version 
Settings] dialog box.

Action by User [Yes]: Deletes all the object files of the modified project.
[No]: Does nothing and closes the message.

Q2406 Message %s  This Workspace was generated by a previous of Project Manager.  Do you want to con-
vert all projects?  After being converted, they cannot read by a previous version of Project 
Manager.

Cause An attempt was made to open a workspace file generated by the PM plus V5.xx.  %s indi-
cates the workspace file name.  

Action by User [Yes]: Converts all projects and reads the workspace file.
[No]: Does nothing and closes the message.

Q2407 Message %s   An old version has been selected in this project. %s was found. It is newer than the ver-
sion that had been selected. Is a compiler (or assembler) used changed?  The Tools Version 
Setting dialog opens when [YES] button is pushed.

Cause The PM+ found the compiler of the later version than the using compiler.  The first %s indi-
cates the project file name, and the second %s indicates the tool name and its version.  

Action by User [Yes]: Opens the [Tool Version Settings] dialog box.
[No]: Does nothing and closes the message.

Q2500 Message Do you wish to stop building all projects. [No] will stop building project only.

Cause The [Stop Build] command was selected while batch build was being executed.

Action by User [Yes]: Stops all building and return to the active window.
[No]: Stops only the build currently being executed and execute build for the next 

project.
[Cancel]: Cancels stopping build and continues the build.

Q2501 Message %s  The file was not found.  Do you wish to build it?  

Cause The load module file downloaded to the debugger could not be found.  %s indicates the load 
module file name.  Download it after executing build.  

Action by User [Yes]: Downloads after build.
[No]: Starts the debugger without executing build.
[Cancel]: Returns to the active window without doing anything.

Q2600 Message This file already exists. Do you wish to replace it?

Cause The file specified to be overwritten and saved by the macro already exists.

Action by User [Yes]: Overwrites the file.
[No]: Does not overwrite the file.

Number Description
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Q2700 Message PM+ has finished comparing the file %s. Do you wish to continue it from the top of file?

Cause When comparing the files, comparison finished at the last line.  %s indicates the file name.  

Action by User [Yes]: Compares from the start.
[No]: Does nothing.

Q2701 Message PM+ has finished comparing the file %s. Do you wish to continue it from the last of file? 

Cause When comparing the files, comparison finished at the start.  %s indicates the file name. 

Action by User [Yes]: Compares from the last line.
[No]: Does nothing.

Q2702 Message Set the default font. This is applied to create a new file and open an existing text file.

Cause An attempt was made to change the set font value for when a new document is created or a 
text file is read by selecting the [Default] button in the [Font] dialog box.  

Action by User [OK]: Changes the set value of the font.
[Cancel]: Returns to the [Font] dialog box without doing anything.

Q2703 Message The debugger was not selected. Do you wish to select the debugger?

Cause The [Debug] menu item was selected but the debugger was not selected. 

Action by User [OK]: Opens the [Debugger Settings] dialog box.
[Cancel]: Returns to the active window.

Q2704 Message The tag jump format not specified. Cannot jump to the error line, if you don't set this.  Do you 
wish do it?

Cause The tag jump format has not been specified when using an external editor is selected.  

Action by User [Yes]: If another environmental setting page is selected, move to that page.  If the [OK] 
button is clicked, return to the active window.  

[No]: Returns to the external editor page.

Q2705 Message Found key settings of Project Manager standard editor(idea-L).  Do you wish to use this set-
tings?

Cause The key setting of idea-L could be found.  

Action by User [Yes]: Copys the key setting of idea-L so that it can also be used in PM+.
[No]: Does not use the key setting of idea-L, and uses the default key setting of PM+.

Number Description
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7. 5   Information 
The information messages output be PM+ are listed below together the cause and action to take in response to the 

message, in massage number order.  All information messages have "I" prefixed to the message number.  
When these messages are displayed, the users must click the [OK] button as consent.

Table 7-5   Information Message List

Number Description

I3000 Message Another process has changed %s. If you wish to reload it.  Please change read-only attribute.

Cause The source file has been updated but the IDL file is Read-Only, and could not be read again.  
%s indicates the source file name in the IDL file.  

I3001 Message PM+ will open the backup file.

Cause The backup file of the IDL file was specified when the file was read.  

I3002 Message %s  This file is using by the other process.  It is opened as read-only.  

Cause A file opened by another application was specified to be opened.  %s indicates the file name.  

I3003 Message %s  This file is binary file.  It is opened as read-only.  

Cause PM+ judged that the file to be read was a binary file.  %s indicates the file name.  

I3004 Message %s  This file is read-only. It is opened as read-only.

Cause The file specified to be opened was Read-Only.  %s indicates the open file name.  

I3005 Message A workspace %s1 will be opened instead of the specified project %s2.

Cause *A *.prj file was specified but it has a corresponding workspace, so an attempt is being made to 
open that workspace.  %s1 indicates the name of the workspace file to be opened that corre-
sponds with the project, and %s2 indicates the project file name specified by the user.

I3200 Message The search string was not found.

Cause The specified character string could not be found during a character string search.  

I3201 Message The string %s has not be found in the file %s.

Cause The specified character string could not be found during global searching with the [Search 
Active Window Only] check box selected.  The first %s indicates the character string specified to 
be searched and the second %s indicates the file name.  

I3202 Message PM+ has finished searching the files. The string %s has not been found in %d files.

Cause The specified character string could not be found during a global search.  %d indicates the num-
ber of searched files and %s indicates the searched character string.  

I3203 Message %s occurrence(s) have been replaced.

Cause All replacement has finished and the number of replaced character strings is displayed.  %s 
indicates the number of replaced character strings the replacement. 

I3204 Message PM+ has canceled search command.

Cause The [Esc] key was pressed during searching and searching was canceled. 

I3205 Message PM+ has finished replace in files. 

Cause Global searching has finished.  

I3206 Message Function Definition Name cannot be found: %s.

Cause The function definition line could not be found.  %s indicates the specified function name.

I3207 Message %s has been searched.

Cause Global searching is being executed now.  %s indicates the name of the file name currently being 
searched. 

I3400 Message This IDL file has added or deleted the IDL source files. Please add or delete the source file from 
the project file by [Project]-[Project Settings...] Command.

Cause When closing an IDL file, the source files of the IDL file are added or deleted.  
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I3401 Message The version of the device file specified by the project file differs from the version of the device 
file installed.
Make sure that the version of the installed device file is right.
The device file specified by the project file: %s1
The installed device file: %s2

Cause The device version described in the project file and the version of the installed device differ.
%s1 indicates the device version described in the project file.
%s2 indicates the version of the installed device.

I3500 Message Build completed normally.

Cause The build operation finished with 0 errors.  

I3501 Message Error detected on termination.

Cause Building resulted in build errors. 

I3502 Message Stop build.

Cause Build was stopped by selecting [Stop Build] from the [Build] menu. 

I3600 Message Aborted to play back the key operations.

Cause The [Esc] key was pressed while a key operation was being played back. 

I3700 Message The difference was not found.

Cause The compared files were the same. 

I3701 Message This setting will take effect as restart the debugger.

Cause The debugger to be used was changed, but the new debugger is only valid the next time the 
debugger is started up. 

Number Description
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APPENDIX  A   SAMPLE LINK DIRECTIVE FILE

This appendix shows the sample link directive files.
These files are created when the [Create and Use the sample file] check box is selected in the "[New WorkSpace - Step 

6/9 [LinkDirective File]] dialog box" or "[Add New Project - Step 6/9 [LinkDirective File]] dialog box".
The sample link directive file that is created in this process depends on the items specified on each of the wizards.  The 

combinations are shown below.  

- When [Not use RTOS] and [Use Internal memory only] are selected

- When [Not use RTOS] and [Use External memory] are selected

The sample link directive file that was created in this process is saved in the project folder and registered in a project-
related file. 

The name of the sample link directive file is "project file name.dir".  

[Caution] 
The following sample files are all for cases when the start address of the internal RAM is 0xffe000.  
In actual fact, a sample link directive file corresponding to the start address of the internal memory of the specified 
device is created.  
In the space for copyright and other notices, the version information of PM+, device name, device file name, and start 
and end addresses of the internal RAM area are described as well as the copyright notice.  
The link directive file that was created has to be customized by the user according to the specifications of the target or 
the user defined sections.  
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When [Not use RTOS] and [Use Internal memory only] are selected

#   Sample link directive file (not use RTOS/use internal memory only)

#   (copyright and other notices)

SCONST : !LOAD ?R {

       .sconst          = $PROGBITS    ?A .sconst;

};

CONST  : !LOAD ?R {

       .const           = $PROGBITS    ?A .const;

};

TEXT   : !LOAD ?RX {

       .pro_epi_runtime = $PROGBITS    ?AX .pro_epi_runtime;

       .text            = $PROGBITS    ?AX .text;

};

SIDATA : !LOAD ?RW V0xffe000 {

       .tidata.byte     = $PROGBITS    ?AW .tidata.byte;

       .tibss.byte      = $NOBITS      ?AW .tibss.byte;

       .tidata.word     = $PROGBITS    ?AW .tidata.word;

       .tibss.word      = $NOBITS      ?AW .tibss.word;

       .tidata          = $PROGBITS    ?AW .tidata;

       .tibss           = $NOBITS      ?AW .tibss;

       .sidata          = $PROGBIT     ?AW .sidata;

       .sibss           = $NOBITS      ?AW .sibss;

};

DATA   : !LOAD ?RW V0xffe100 {

       .data            = $PROGBITS    ?AW  .data;

       .sdata           = $PROGBITS    ?AWG .sdata;

       .sbss            = $NOBITS      ?AWG .sbss;

       .bss             = $NOBITS      ?AW  .bss;

};

__tp_TEXT @ %TP_SYMBOL;

__gp_DATA @ %GP_SYMBOL &__tp_TEXT{DATA};

__ep_DATA @ %EP_SYMBOL;

[Caution]
The example above is for a case in which the start address of the internal RAM is 0xffe000.
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When [Not use RTOS] and [Use External memory] are selected

#   Sample link directive file (not use RTOS/use external memory)

#   (copyright and other notices)

SCONST : !LOAD ?R {

       .sconst          = $PROGBITS    ?A .sconst;

};

TEXT   : !LOAD ?RX {

       .pro_epi_runtime = $PROGBITS    ?AX .pro_epi_runtime;

       .text            = $PROGBITS    ?AX .text;

};

DATA   : !LOAD ?RW V0x100000 {

       .data            = $PROGBITS    ?AW  .data;

       .sdata           = $PROGBITS    ?AWG .sdata;

       .sbss            = $NOBITS      ?AWG .sbss;

       .bss             = $NOBITS      ?AW  .bss;

};

CONST  : !LOAD ?R {

       .const           = $PROGBITS    ?A .const;

};

SEDATA : !LOAD ?RW V0xff6000 {

       .sedata          = $PROGBITS    ?AW .sedata;

       .sebss           = $NOBITS      ?AW .sebss;

};

SIDATA : !LOAD ?RW V0xffe000 {

       .tidata.byte     = $PROGBITS    ?AW .tidata.byte;

       .tibss.byte      = $NOBITS      ?AW .tibss.byte;

       .tidata.word     = $PROGBITS    ?AW .tidata.word;

       .tibss.word      = $NOBITS      ?AW .tibss.word;

       .tidata          = $PROGBITS    ?AW .tidata;

       .tibss           = $NOBITS      ?AW .tibss;

       .sidata          = $PROGBITS    ?AW .sidata;

       .sibss           = $NOBITS      ?AW .sibss;

};

__tp_TEXT @ %TP_SYMBOL;

__gp_DATA @ %GP_SYMBOL &__tp_TEXT{DATA};

__ep_DATA @ %EP_SYMBOL;

[Caution]
The example above is for a case in which the start address of the internal RAM is 0xffe000.
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APPENDIX  B   COMMANDS FOR KEYBOARD MACROS

This appendix shows the command format that can be used for modifying macro files (*.imc) that have been saved as 
key commands.

[How to read command format]
-  "< >" indicates an argument that cannot be omitted, and "[ ] " indicates an argument that can be omitted.

- "|" indicates selection of either side.  

File Menu

Table B-1   Command Format for Keyboard Macro (File menu)

Contents Command Format 

New newfile  [idl] 
idl: Creates new IDL file.

Open openfile  <"filename"> [readonly] [layer] [autoselect | sjis | euc | jis | unicode] 
filename: Specify the file name with full path.
readonly: Opens the file as a read only file.
layer: Reads the file with layer rule.
autoselect: Detects automatically.
sjis: Reads the files with Shift-JIS codes.
euc: Reads the files with EUC codes.
jis: Reads the files with JIS codes
unicode: Reads the files with Unicode.

Insert file insertfile  <"filename"> 
filename: Specify the file name with full path.

Open workspace openworkspace  <"filename">
filename: Specify the file name with full path.

Close workspace closeworkspace  [nosave]

Close  closefile  [nosave] 
nosave: Closes the edited file without saving.

Save save 

Save As saveas  <"filename"> [makesource [notdevide]] [replace] [crlf|lf|cr] [sjis|euc|jis|unicode] 
filename: Specify the file name with full path.
makesource: Creates a source file.
notdivide: Does not divide the source file.
replace: Overwrites without displaying message to verify.
crlf: Saves a line feed code as CR+LF.
lf: Saves a line feed code as LF.
cr: Saves a line feed code as CR.
sjis: Saves as Shift-JIS code.
euc: Saves as EUC code.
jis: Saves as JIS code.
unicode: Saves as Unicode.

Print print
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Edit Menu

Table B-2   Command Format for Keyboard Macro (Edit menu)

Contents Command Format 

Undo undo

Redo redo

Cut Combination of copy command and delete command

Copy copy

Image Copy imagecopy

Paste paste

Delete delete

Delete the Word deleteword <all>
all: Required to distinguish from "Delete to the End of Word"

Delete to the End of Word deleteword

Delete the Line deleteline

Delete to the Top of Line deletebefore

Delete to the End of Line deleteafter

Select to the Top of Line selectbefore

Select to the End of Line selectafter

Select to the Word selectword

Select to the Top of Word selectleftword

Select to the End of Word selectrightword

Select All selectall

Grouping by Keyword grouping <character string to be searche> [and | or] [color | delete | none | coloronly]  
[undocolor]  [window]

<character string to be searched>:Specify the character string to be searched with " ".
[and]: AND search
[or]: OR search
[matchcase]: Distinguishes a uppercase and lowercase character. 
[zen]: Distinguishes a two-byte and one-byte character.
[paragraph]: Specifies a paragraph (when omitted, no paragraph is 

specified).
[color]: Changes the color after grouping.
[delete]: Deletes after grouping.
[none]: Does nothing after grouping.
[coloronly]: Only changes the color (cannot be specified at same time 

as process after grouping).
[undocolor]: Restores the original color of grouped lines.
[window]: Groups lines in a new Edit window. 

Restore Color of Grouping 
Lines 

undogroupcolor
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Find Menu

Table B-3   Command Format for Keyboard Macro (Find menu)

Contents Command Format 

Find Upward findup <character string to be searched> [word] [matchcase] [zen] [special] [[[loop] [ask-
loop]] | [frombottom]] [source]

<character string to be searched>: Specify the character string to be searched with " "
word: Search word
matchcase: Distinguishes a uppercase and lowercase character.
zen: Distinguishes a two-byte and one-byte character.
special: Regular expression
loop: Does not end the search at the top or bottom line.
askloop: Displays a message to verify when the search does not end at the top 

or bottom line.
frombottom: Searches from the top or bottom line.
source: Searches only source files with caret.

Find Downward finddown <character string to be searched> [word] [matchcase] [zen] [special] [[[loop] [ask-
loop]] | [frombottom]] [source]

<character string to be searched>:Specify the character string to be searched with " ".
word: Search word
matchcase: Distinguishes a uppercase and lowercase character.
zen: Distinguishes a two-byte and one-byte character.
special: Regular expression
loop: Does not end the search at the top or bottom line.
askloop: Displays a message to verify when the search does not end at the top of 

bottom line.
frombottom: Searches from the top or bottom line.
source: Searches only source files with caret.

Replace replace <character string before replacement> <character string after replacement> [word] 
[matchcase] [zen] [special] [[[loop] [askloop]] | [frombottom]] [source] [all]

<character string before replacement>:Specify the character string before replacement 
with " ".
<character string after replacement>: Specify the character string after replacement with " ".
word: Search word
matchcase: Distinguishes a uppercase and lowercase character. 
zen: Distinguishes a two-byte and one-byte character.
special: Regular expression
loop: Does not end the search at the top or bottom line.
askloop: Displays a message to verify when search does not end at the top or 

bottom line. 
frombottom: Searches from the top or bottom line.
source: Searches only source files with caret.
all: Replace all (when omitted, same as the operation of [Replace] button.
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Find in Files 
(When searching 
through multiple files)

grepfile <character string to be searched> <fiel type> <folder> [subfolder] [word] [match-
case] [zen] [special] [source]  [findalllayer | foundlayer | foundnotlayer]  [autoselect | sjis | 
euc | jis | unicode]

<character string to be searched>: Specify the character string to be searched with " ".
<file type>: Specify the file type character string with " ".
<folder>: Specify the folder character string with " ".
subfolder: Also search sub folders. 
word: Search word
matchcase: Distinguishes a uppercase and lowercase character. 
zen: Distinguishes a two-byte and one-byte character.
special: Regular expression
source: Also displays source file name.
findalllayer: Displays all searched files with layers.
foundlayer: Displays files in which character strings are found, with layers.
foundnotlayer: Displays files in which character strings are found, without layers.
autoselect: Detects automatically.
sjis: Reads the files with Shift-JIS codes.
euc: Reads the files with EUC codes.
jis: Reads the files with JIS codes.
unicode: Reads the files with Unicode.

Find in Files 
(When searching 
through the current edit 
window)

grepedit <Character string to be searched> [word] [matchcase] [zen] [special] [source]  [fin-
dalllayer | foundlayer | foundnotlayer]  [autoselect | sjis | euc | jis | unicode]

<character string to be searched>: Specify the character string to be searched with " ".
word: Searches for word.
matchcase: Distinguishes a uppercase and lowercase character. 
zen: Distinguishes a two-byte and one-byte character.
special: Regular expression
source: Displays the source file name as well.
findalllayer: Displays all searched files with layers.
foundlayer: Displays the files in which character strings are found, with layers.
foundnotlayer: Displays the files in which character strings are found, without layers.
autoselect: Detects automatically.
sjis: Reads the files with Shift-JIS codes.
euc: Reads the files with EUC codes.
jis: Reads the files with JIS codes.
unicode: Reads the files with Unicode.

Copy for Append copyforappend

Cut for Append cutforappend

Find in Project findinproject

Contents Command Format 
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Layer Menu

Table B-4   Command Format for Keyboard Macro (Layer menu)

Jump-related

Table B-5   Command Format for Keyboard Macro (jump-related)

Contents Command Format 

Promote onelevelup

Demote oneleveldown

Expand expand

Collapse collapse

Expand All Lower Layers expandalllower

Expand All expandall

Collapse All collapseall

Expand the Specific Layer expandspecified [caret]
caret: Limits the action to those layers below the caret position.

Collapse the Specific Layer collapsespecified [caret]
caret: Limits the action to those layers below the caret position.

Show Index 1 displaylayer1

Show Index 2 displaylayer2

Show Index 3 displaylayer3

Show Index 4 displaylayer4

Show Index 5 displaylayer5

Collapse This Layer collapsethislayer

Contents Command Format 

To the Top of Line topofline

To the End of Line endofline

Mark Jump (Adding the current 
caret position as a marked line)

addmark

Mark Jump (Jumping to a marked 
line)

markjump <mark-number>
<mark-number>: Specifies number of mark beginning with 1

 (in display order of [Mark Jump] dialog box).

To the Specific Line jump <line number>
<line number>: Specify line number appearing on top of file as first line 

(excluding collapsed layers). 

To the Top of File topline

To the Index Line indexline

To the End of File bottomline

Tag Jump tagjump

Next Tag Jump nexttagjump

Next Tag Jump Upward upwardnexttag

One Word Right rightword

One Word Left leftword
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Help Menu

Table B-6   Command Format for Keyboard Macro (Help menu)

To the Matching Brace jumpparent

To the Tag File backtagjump

To the Function Definition fuctiondefinition

To the Top Layer at caret toplayer

One Line Up up [line count]
line count: Specify the number of lines to be jumped (default is 1)

One Line Down down [line count]
line count: Specify the number of lines to be jumped (default is 1)

One Character Left up [character count]
character count: Specify the number of characters to be jumped (default is 1)

One Character Right right [character count]
character count: Specify the number of characters to be jumped (default is 1)

Some Layer Line Up upsamelayer

Same Layer Line Down downsamelayer

Back Jump backjump

Contents Command Format 

External HELP 1 externalhelp1

External HELP 2 externalhelp2

External HELP 3 externalhelp3

Contents Command Format 
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No Menu

Table B-7   Command Format for Keyboard Macro (no menu)

Contents Command Format 

Insert character insert <character string>
<character string>: Specify the character string with " ".
[Caution] 

Inserts characters independently of insert/overwrite mode.

Overwrite character overwrite <character string >
<character string>: Specify the character string with " ".
[Caution] 

Inserts characters independently of insert/overwrite mode.

Enter character input <character string >
<character string>: Specify the character string with " ".
[Caution] 

Inserts characters dependently of insert/overwrite mode.
Input mode can be switched between insertmode, overwritemode, over-
writeswitch, etc.

Enter new line insertreturn [count]
count: Specify an input count (default is 1).

Next Page nextpage

Previous page prevpage

Begin select beginsel
[Caution] 

After executing beginsel, execute a character move command or line move com-
mand to specify a range.

End select endsel
[Caution] 

Releases the range selection mode set by beginsel.

Enter backspace backspace [count] 
count: Specify an input count (default is 1).

Fast caret up upfast [count]
count: Specify a movement count (default is 1).

Fast caret down downfast [count]
count: Specify a movement count (default is 1).

Insert mode insertmode

Overwrite mode overwritemode

Edit window selection window <window name> [readonly [= ReadOnly No] ]
<window name>: 

Specify the file name of the Edit window with full path.
If the file name is not determined, specify the title character string
of the caption.   
This is a character string specification, so enclose with " ".

Readonly = ReadOnly No:
Specifies [readonly] when selecting the Edit window of Read-only.
If ReadOnly number is displayed on the caption, specify the 
numberas [readonly=1], etc.
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Control Command-related

Table B-8   Command Format for Keyboard Macro (control command-related)

Contents Command Format 

Exit PM+ exit

Switch overwrite/insert mode overwriteswitch

Start up external execution mod-
ule

exec <parameter>
<parameter>: Specify the name of the execution module and all the 

execution module arguments with " ".
[Example]

exec "dir"
exec "dir  /od *.txt"
exec "z:\hide\hidemaru.exe" // startup z:\hide\hidemaru.exe

Numeric variable definition #variable name 
#variable name = "initial value"

"initial value": Specify the initial value of the variable. 
[Caution] 

An arbitrary variable name can be set for the variable name.  
When the initial value is omitted, 0 is assumed.  
[Example]

#cnt // initialized to 0 
#cnt2=5 // initialized to 5 

Character string variable definition $character string variable name
$character string variable name = "initial value"

"initial value": Specify the initial value of the variable. 
[Caution] 

An arbitrary character string name can be set for the character string vari-
able name.  
When the initial value is omitted, " " is assumed.  
[Example]

$str // initialized to " " 
$str2="ABC" // initialized to "ABC" 

Operator ++, --, +=, -=, *=, /=, =, +, -
[Example]

#cnt++
#value--
#value += 5
#cnt-=12
#idx *= #cnt
#idx /= #cnt
#idx=#idx+2-#cnt

Conditional expression <, >, ==, <=, >=, !=
[Example]

#a<#b // #a is smaller than #b.
#a>10 // #a is larger than 10.
#a==#b // #a is equal to #b.
#a<=5 // #a is 5 or less. 
#a>=8 // #a is 8 or more. 
#a!=#b // #a is not equal to #b.

while statement while (conditional expression) { process }
[Example]

// routine to insert 1 ten times
#cnt = 0
while ( #cnt < 10 ) {

insert "1" // insert 1
insertreturn // return
#cnt++ // add #cnt

}
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break statement break
[Example]

#cnt = 0
while (1) { // infinite loop

insert "1" // insert 1
insertreturn // return

if ( #cnt == 5 ) {
break // finish after 5 loops

}
#cnt++ // add #cnt

}

continue statement continue
[Example]

#cnt = 0
while ( #cnt < 10 ) { // ten loops

if ( #cnt == 0 ) {
insert "1" // insert 1
insertreturn // return

}
else{

continue // go back to top of while
}
#cnt++ // add #cnt

}

if statement if (conditional expression) { process }
elseif { process }
else { process }

[Example]
#cnt = 0
while ( #cnt < 10 ) { // ten loops

if ( #cnt == 0 ) {
insert "0" // insert 0
insertreturn // return

}
elseif ( #cnt == 1) {

insert "1"
insertreturn // return

}
else{

continue // go back to top of while
}
#cnt++ // add #cnt

}

Display message box msgbox <character string>
<character string>: Specify the character string to be displayed with " ".
[Caution] 

If the [OK] button is selected, the message box closes.

Obtaining the character at the 
caret

$x = getchar
$x: Character string type variable
[Return values]

One character (or character string) returned at the caret

Checking the title line at the caret #x = istitle
#x: Integer type variable
[Return values]

1: Title line
0: Not title line

Contents Command Format 
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Checking the title line at the caret 
(expand/collapse)

#x = istitleopen
#x: Integer type variable
[Return values]

1: The layer of the title line is expanded.
0: The layer of the title line is collapsed.

Checking the first line at the caret #x = istop
#x: Integer type variable
[Return values]

1: Top line
0: Not top line

Checking the last line at the caret #x = isbottom
#x: Integer type variable
[Return values]

1: Bottom line
0: Not bottom line

[Caution] 
Even if the caret line appears to be a bottom line (lower layers collapsed), 1 
is returned.  

Checking the end of line #x = isendofline
#x: Integer type variable
[Return values]

1: The caret is at the end of the line.
0: The caret is not at the end of the line.

Checking the end of file (EOF) #x = iseof
#x: Integer type variable
[Return values]

1: The caret is at the end of the file. 
0: The caret is not at the end of the file.

[Caution] 
Even if the caret line appears to be a bottom line (lower layers collapsed), 1 
is returned.  

Obtaining the column position of 
the caret (tab character = 1 char-
acter)

#x = getcol
#x: Integer type variable
[Return values]

The column number of the caret is returned.  Leftmost column = 1.

Obtaining the column position of 
the caret (tab character = speci-
fied number of space characters)

#x = getdispcol
#x: Integer type variable
[Return values]

The column number of the caret is returned.  Leftmost column = 1.

Obtaining the line position of the 
caret (excluding collapsed layers)

#x = getdispline
#x: Integer type variable
[Return values]

The line number of the caret is returned.  First line = 1.

Obtaining the line position of the 
caret (including collapsed layers)

#x = getabsline
#x: Integer type variable
[Return values]

The line number of the caret is returned.  First line = 1.

Checking the em-size character at 
the caret

#x = isdbcs
#x: Integer type variable
[Return values]

1: Two-byte character
0: one-byte character

Inserting the current time into the 
caret position

time

Inserting the current date into the 
caret position

date

Contents Command Format 
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APPENDIX  C   SHORTCUT KEYS

Table C-9 lists the shortcut keys in the default condition of the PM+.

Table C-9   List of Shortcut Keys (Default Condition)

Menu Item Shortcut Key Note

File New [Ctrl]+ [N]

Open... [Ctrl]+ [O]

Save [Ctrl]+ [S]

Print... [Ctrl]+ [P]

Edit  Undo [Ctrl]+ [Z]

 Redo [Ctrl]+ [Y]

Cut [Ctrl]+[ X]

Copy [Ctrl]+ [C]

Paste [Ctrl]+ [V]

Delete the Word [Ctrl]+ [T]

Delete [Delete]

Delete the Line [Ctrl]+ [G]

Deleting to the Top of Line [Ctrl]+ [U]

[Note 1]
Delete to the End of Line [Ctrl]+ [K]

Select to the Top of Line [Shift] + [Home]

Select to the End of Line [Shift] + [End]

Find Find... [Ctrl]+ [F]

Find Upward [Shift] + [F3]

[Note 1]
Find Downward [F3]

Find the Word Upward [Ctrl]+ [W]

Find the Word Downward [Ctrl]+ [Q]

Replace... [Ctrl]+ [H]

Mark Jump... [Ctrl]+ [J]

To the Top of Line [Home]

To the End of Line [End]

To the Top of File [Ctrl]+ [Home]

To the End of File [Ctrl]+ [End]

To the Index Line [Ctrl]+ [Shift] + [up arrow]

To the Matching Brace [Ctrl]+ [L]

Tag Jump [F10]

To the Tag File [Shift] + [F10]

Next Tag Jump [F9]

Next Tag Jump Upward [Shift] +[F9]

[Note 1]One Word Right [Ctrl]+ [D]

One Line Up [Ctrl]+ [A]

Direct Search [Ctrl]+ [Shift] + [F]
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[Note 1]
This menu item is not displayed by default.
To display this menu item on the toolbar, change the setting by selecting the [Tool] menu -> [Customize...] - [Menu] 
tab.

[Note 2]
The settings of the above shortcut keys, except for some keys, can be changed on the [Keyboard] tab in the 

[Customize] dialog box, which is opened by selecting  the [Tool] menu -> [Customize...].  
The shortcut keys can also be checked in the [Shortcut List] dialog box.  This dialog box lists modified shortcut key 
settings and newly set shortcut keys.

Layer Promote [Ctrl]+ [Shift] + [left arrow]

Demote [Ctrl]+ [Shift] + [right arrow]

Expand [Ctrl]+ [+] Input "+" on the numeric keypad

Collapse [Ctrl]+ [-] Input "-" on the numeric keypad

Expand All Lower Layers [Ctrl]+ [*] Input "*" on the numeric keypad

Show Index 1 [Ctrl]+ [1]

[Note 1]

Show Index 2 [Ctrl]+ [2]

Show Index 3 [Ctrl]+ [3]

Show Index 4 [Ctrl]+ [4]

Show Index 5 [Ctrl]+ [5]

Build Build and Debug [F5]

Compile [Ctrl]+ [F7]

Build [F7]

Help Current Window [F1]

External HELP 1 [Shift] + [F1]

External HELP 2 [Ctrl]+ [F1]

External HELP 3 [Ctrl]+ [Shift] + [F1]

Menu Item Shortcut Key Note
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APPENDIX  D   QUANTITATIVE LIMIT LIST

Table D-10 lists the quantitative limit list of PM+.  

Table D-10   Quantitative Limit List

Item Limit

Workspace-related Length of workspace file name 255 characters

Length of project group name 127 characters

Number of projects that can be registered per workspace 128

Number of projects that can be registered per project group 20

Project-related Length of project file name 255 characters

Length of project title 127 characters

Length of source file name 259 characters

Length of project-related file name 259 characters

Length of other file names 259 characters

Number of source files that can be registered per project 2,048

Number of other files that can be registered per project 100

Build-related Lengths of command character strings that can be set in pre 
build process and past build process 127 characters

Edit window-related Number of characters per line 5,119 characters

Maximum number of lines 2,097,152

Maximum number of layers 127

Number of 1st layers that can be split 128

Number of source files generated in IDL file 128

Mark jump-related Number of marks that can be registered 20

Smart lookup-related Length of function name that can be recognized 1,998 characters

Maximum number of function candidates that user can register 64

External tool-related Number of external tools that can be registered 10

Length of menu that can be set for external tools 32 characters

Length of tool tip that can be set for external tools 32 characters

Length of status bar that can be set for external tools 32 characters

Macro-related Maximum number of macro instructions that can be recorded 64

Maximum number of macro registrations 32

Length of title that can be set for macro registration 32 characters

Keyword-related Maximum number of keywords that can be registered by user 64

Maximum number of C language keywords 64
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INDEX

[A]

About PM+   ... 79, 95

[About PM+] dialog box   ... 344

Active project   ... 33

[Add Build Mode] dialog box   ... 281

[Add Command] dialog box   ... 286

[Add New Memo] dialog box   ... 264

[Add New Project] wizard   ... 141

[Add New Project - Step 1/9] dialog box   ... 143

[Add New Project - Step 2/9] dialog box   ... 145

[Add New Project - Step 3/9] dialog box   ... 147

[Add New Project - Step 4/9] dialog box   ... 149

[Add New Project - Step 5/9] dialog box   ... 151

[Add New Project - Step 6/9] dialog box   ... 153

[Add New Project - Step 7/9] dialog box   ... 155

[Add New Project - Step 8/9] dialog box   ... 157

[Add New Project - Step 9/9] dialog box   ... 159

[Add Other Files] dialog box   ... 255

Add Other Files   ... 92

Add Project Related Files   ... 92

[Add Project Related Files] dialog box   ... 253

Add Source Files   ... 92

[Add Source Files] dialog box   ... 251

[Add the Macro file] dialog box   ... 338

Adding a project-related file   ... 66

Adding a source file   ... 66

Adding other files   ... 66

Apply Layer Rule   ... 61, 91

[B]

Back Jump   ... 50, 90

Batch Build   ... 69, 93

Build

Batch Build Settings   ... 93

Batch Build Settings   ... 71, 93

Batch Rebuild   ... 70, 93

Build   ... 69, 93

Batch Build   ... 69, 93

Batch Build Settings   ... 71

Batch Rebuild   ... 70, 93

Build   ... 69, 93

Build and Debug   ... 68, 93

Build Settings   ... 71, 93

Clean   ... 70, 93

Compile   ... 69, 93

Debug   ... 70, 93

Direct Build Mode Selection   ... 93

Download Some Load Module Files   ... 70, 93

Edit   ... 70, 93

Rebuild   ... 69, 93

Rebuild and Debug   ... 68, 93

Select Build Mode   ... 70, 93

Stop Build   ... 69, 93

Update dependencies   ... 70, 93

Build and Debug   ... 68, 93

Build bar   ... 62, 92, 97

Build Functions   ... 68

Build menu   ... 93

[Build Mode] dialog box   ... 280

Build Settings   ... 71, 93

[Build Settings] dialog box   ... 282

[C]

Cascade   ... 76, 95

[Change Selected Source File Name] dialog box   ... 181

[Change Selected Source File Names] dialog box   ... 183

Change Source File Name   ... 39, 88

[Change Source File Names] dialog box   ... 179

[Change the Macro file] dialog box   ... 340

Character input   ... 113

Clean   ... 70, 93

Close   ... 37, 87

Close All   ... 39, 88

Close Workspace   ... 38, 87

Collapse   ... 59, 91

Collapse All   ... 59, 91

Collapse the Specific Layer   ... 60, 91

Collapse This Layer   ... 61, 91

[Collapse to Specified Layer] dialog box   ... 225

Commands corresponding to key operations   ... 74

Compile   ... 69, 93

Copy   ... 43, 88

Copy for Append   ... 43, 88

[Copy Link Directive File from] dialog box   ... 273

[Copy Startup File from] dialog box   ... 267

Customize   ... 74, 94

[Customize] dialog box   ... 320

Cut   ... 43, 88
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Cut for Append   ... 43, 88

CVS Commit   ... 65, 92

[CVS Commit] dialog box   ... 240

CVS Diff   ... 66, 92

CVS Log   ... 65, 92

[CVS Log] dialog box   ... 242

CVS Status   ... 66, 92

[CVS Status] dialog box   ... 244

CVS Update   ... 65, 92

[CVS Update] dialog box   ... 238

[D]

Debug   ... 70, 93

Debug Build   ... 280, 281

Debugger Settings   ... 73, 94

[Debugger Settings] dialog box   ... 291

Definitions of words   ... 113

Delete   ... 44, 89

Delete the Line   ... 45, 89

Delete the Word   ... 44, 89

Delete to the End of Line   ... 45, 89

Delete to the End of Word   ... 44, 89

Delete to the Top of Line   ... 45, 89

Demote   ... 58, 91

Destroy All   ... 39, 88

Development tools   ... 25

Device File Installer   ... 73, 94

Dialog box

About PM+   ... 344

Add Build Mode   ... 281

Add Command   ... 286

Add New Memo   ... 264

Add New Project - Step 1/9   ... 143

Add New Project - Step 2/9   ... 145

Add New Project - Step 3/9   ... 147

Add New Project - Step 4/9   ... 149

Add New Project - Step 5/9   ... 151

Add New Project - Step 6/9   ... 153

Add New Project - Step 7/9   ... 155

Add New Project - Step 8/9   ... 157

Add New Project - Step 9/9   ... 159

Add Other Files   ... 255

Add Project Related Files   ... 253

Add Source Files   ... 251

Add the Macro file   ... 338

Edit Batch Build Settings   ... 278

Build Mode   ... 280

Build Settings   ... 282

Change Selected Source File Name   ... 181

Change Selected Source File Names   ... 183

Change Source File Names   ... 179

Change the Macro file   ... 340

Collapse to Specified Layer   ... 225

Copy Link Directive File from   ... 273

Copy Startup File from   ... 267

Customize   ... 320

CVS Commit   ... 240

CVS Log   ... 242

CVS Status   ... 244

CVS Update   ... 238

Debugger Settings   ... 291

dump 850   ... 289

Edit C Language’s reserve words   ... 328

Edit Command   ... 287

Edit User keyword   ... 326

Entry Macro Files   ... 336

Expand to Specified Layer   ... 223

File Compare   ... 297

Find in Files   ... 213

Find String   ... 200

Font   ... 318

Font (Print)   ... 189

Function List   ... 229

Grouping by Keyword   ... 194

Insert File   ... 170

Insert Project   ... 236

Jump to Specified Line   ... 208

Jump to Specified Line in the Source file   ... 210

Layer List   ... 234

Link Directive File   ... 271

Link Directive File to register   ... 275

Load the Macro File   ... 332

Mark Jump   ... 211

New WorkSpace - Step 1/9   ... 124

New WorkSpace - Step 2/9   ... 126

New WorkSpace - Step 3/9   ... 128

New WorkSpace - Step 4/9   ... 130

New WorkSpace - Step 5/9   ... 132

New WorkSpace - Step 6/9   ... 134

New WorkSpace - Step 7/9   ... 136

New WorkSpace - Step 8/9   ... 138

New WorkSpace - Step 9/9   ... 140

Open   ... 167

Open Workspace   ... 173

Play Back the Macro File   ... 334

PM+ Settings   ... 299

Print   ... 186
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Project Group Name   ... 256

Project Settings   ... 246

Project Settings - Step 1/3   ... 161

Project Settings - Step 2/3   ... 163

Project Settings - Step 3/3   ... 165

Project Title   ... 257

Properties   ... 263

Register External Tool   ... 293

Replace in Files   ... 217

Replace String   ... 204

Save As   ... 175

Save Source Files Option   ... 177

Save the Function List   ... 232

Save the Key Operation   ... 330

Select Active Project   ... 235

Select External Tool   ... 295

Select RTOS   ... 288

Select the way of Function Prototypes   ... 197

Set Comment Mark   ... 185

Set Header/Footer   ... 191

Set Layer Rule   ... 226

Shortcut List   ... 343

Startup File   ... 265

Startup File to register   ... 269

Tool Version Detail Setting   ... 261

Tool Version Settings   ... 258

User Setting   ... 316

Window List   ... 342

Direct Build Mode Selection   ... 93

Direct Search   ... 56, 90

Direct Select Active Project   ... 67, 92

Display All Object as Content   ... 63, 92

Display All Object as Icon   ... 63, 92

Display Content/Icon   ... 92

Display Functions   ... 62

Display Object as Content/Display Object as Icon   ... 63

DLL   ... 25

Download Some Load Module Files   ... 70, 93

[dump 850] dialog box   ... 289

dump850   ... 72, 94

[E]

Edit   ... 70, 88, 93

Copy   ... 43, 88

Copy for Append   ... 43, 88

Cut   ... 43, 88

Cut for Append   ... 43, 88

Delete   ... 44, 89

Delete the Line   ... 45, 89

Delete the Word   ... 44, 89

Delete to the End of Line   ... 45, 89

Delete to the End of Word   ... 44, 89

Delete to the Top of Line   ... 45, 89

Grouping by Keyword   ... 46, 89

Image Copy   ... 43, 88

Insert New Object   ... 46, 89

Link   ... 46, 89

Make Function Prototypes   ... 46, 89

Object   ... 89

Paste   ... 44, 88

Paste Special   ... 44, 88

Redo   ... 42, 88

Restore Color of Grouping Lines   ... 46, 89

Select All   ... 46, 89

Select to the End of Line   ... 46, 89

Select to the End of Word   ... 45, 89

Select to the Top of Line   ... 45, 89

Select to the Top of Word   ... 45, 89

Select to the Word   ... 45, 89

Undo   ... 42, 88

[Edit Batch Build Settings] dialog box   ... 278

[Edit C Language’s reserve words] dialog box   ... 328

[Edit Command] dialog box   ... 287

Edit Functions   ... 41

Edit menu   ... 88

[Edit User keyword] dialog box   ... 326

Edit window   ... 112

Character input   ... 113

Copying lines/layers   ... 114

Definitions of words   ... 113

Drag-and-drop function   ... 117

Moving lines/layers   ... 114

Opening   ... 112

Operations performed with the right mouse button   
... 114

Operations performed by double-clicking the mouse 
button   ... 114

Range selection   ... 113

Restrictions on the Edit window   ... 117

Scrolling   ... 115

Smart lookup function   ... 115

[Entry Macro Files] dialog box   ... 336

Exit PM+   ... 40, 88

Exiting   ... 29

Expand   ... 58, 91

Expand All   ... 59, 91

Expand All Lower Layers   ... 59, 91

Expand the Specific Layer   ... 60, 91
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[Expand to Specified Layer] dialog box   ... 223

Expand/Collapse   ... 58, 91

Explanation of windows/dialog boxes   ... 85

Export Makefile   ... 66, 92

External tool bar   ... 98

Ex-tool Bar   ... 62, 92

[F]

Features   ... 23

File   ... 36, 87

Change Source File Name   ... 39, 88

Close   ... 37, 87

Close All   ... 39, 88

Close Workspace   ... 38, 87

Destroy All   ... 39, 88

Exit PM+   ... 40, 88

History of files   ... 40
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Insert file   ... 36, 87

New   ... 36, 87

New Workspace   ... 87

Open   ... 36, 87

Open Workspace   ... 37, 87

Print   ... 40, 88

Print Direct   ... 40, 88

Print Preview   ... 40, 88

Recent File   ... 88

Recent Workspace   ... 88

Save   ... 38, 87

Save All   ... 39, 88

Save All Source Files   ... 39, 88

Save and Close All   ... 39, 88

Save As   ... 38, 87

Save Workspace   ... 38, 87

File Compare   ... 73, 94

[File Compare] dialog box   ... 297

File Management   ... 36

File menu   ... 87

Find   ... 47, 89

Back Jump   ... 50, 90

Direct Search   ... 56, 90

Find   ... 47, 89

Find Downward   ... 48, 89

Find in Files   ... 52, 90

Find in Project   ... 53, 90
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Find the Word Upward   ... 48, 89

Find Upward   ... 48, 89

Mark Jump   ... 49, 90

Next Tag Jump   ... 54, 90
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One Character Left   ... 56, 90

One Character Right   ... 56, 90

One Line Down   ... 55, 90

One Line Up   ... 55, 90

One Word Left   ... 55, 90

One Word Right   ... 55, 90

Replace   ... 48, 89
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Find menu   ... 89

[Find String] dialog box   ... 200
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Font   ... 74, 94

[Font] dialog box   ... 318
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[Function List] dialog box   ... 229
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IDL File :   ... 23

Image Copy   ... 43, 88

Insert file   ... 36, 87
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